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ETAS Introduction
1 Introduction

ASCET-DIFF is a program that compares two ASCET models. This allows you to
compare, e.g., two development states, and produces clear results in a short
time. 

The comparison results are displayed in various tabs; different colors are used to
distinguish between identical and changed elements, as well as elements occur-
ring in only one component. Details are given in the ASCET-DIFF online help.

With ASCET-DIFF V6.3, the following types of ASCET components can be com-
pared:

• block diagram classes/modules, 

• AUTOSAR software components, 

• AUTOSAR interfaces 

• AUTOSAR mode groups

• state machines

• ESDL and C code components

• enumerations

• records

• containers 

• projects

1.1 Safety Advice

Please adhere to the Product Liability Disclaimer (ETAS Safety Advice) and to the
following safety instructions to avoid injury to yourself and others as well as dam-
age to the device.

1.1.1 Correct Use

ETAS GmbH cannot be made liable for damage which is caused by incorrect use
and not adhering to the safety instructions.

1.1.2 Labeling of Safety Instructions

The safety instructions contained in this manual are shown with the standard
danger symbol shown below:

The following safety instructions are used. They provide extremely important
information. Read this information carefully.   

WARNING

Indicates a possible medium-risk danger which could lead to serious or even 
fatal injuries if not avoided.
ASCET-DIFF V6.3 - Installation Guide 5
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1.1.3 Demands on the Technical State of the Product

The following special requirements are made to ensure safe operation:

• Take all information on environmental conditions into consideration 
before setup and operation (see the documentation of your computer, 
hardware, etc.).

Further safety advice is given in the ASCET V6.3 safety manual (ASCET Safety
Manual.pdf) available at ETAS upon request. 

1.2 User Profile

ASCET-DIFF users should be familiar with the operating system Microsoft Win-
dows® Vista or Windows® 7. All users should be capable of executing menu
functions, activating buttons etc. Users should also be acquainted with the Win-
dows file storage system, particularly the relations between files and directories.
The user must know about and have mastered the basic functions of the Win-
dows File and Program Manager and Windows Explorer. The user should also be
familiar with "Drag & Drop".

All users who are not familiar with the basic techniques of Microsoft Windows
should familiarize themselves with them before using ASCET-DIFF. Details of
working with Windows are contained in the relevant manuals by Microsoft Cor-
poration.

Knowledge of ASCET is required. 

1.3 Structure of the Documentation

The ASCET-DIFF documentation consists of the following parts:

• this installation guide

• an online help

The ASCET-DIFF Installation Guide consists of the following chapters:

• "Introduction" on page 5 (this chapter) 

This is where you are given an initial overview of the possible field of appli-
cation of ASCET-DIFF. It also contains  general information such as tips 
and system information.

CAUTION

Indicates a low-risk danger which could result in minor or less serious injury or 
damage if not avoided.

NOTICE
Indicates behavior which could result in damage to property.
ASCET-DIFF V6.3 - Installation Guide
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• "Installation" on page 9

This chapter is intended for all users who install, maintain and uninstall 
ASCET-DIFF. It provides important information on the delivery scope, 
hardware and software requirements. The sequence of both the installa-
tion and uninstallation of ASCET-DIFF is also described.

• "Licensing the Software" on page 23

This chapter contains various licensing information.

• "Starting ASCET-DIFF" on page 31

This chapter explains how to start ASCET-DIFF both as standalone tool and 
as ASCET add-on.

• "Starting ASCET-DIFF Model Viewer" on page 36

This chapter explains how to start the ASCET-DIFF Model Viewer via the 
command line or the context menu in the windows file explorer.

• "ETAS Contact Addresses" on page 40

This chapter contains the contact addresses of the ETAS subsidiaries.

1.4 ASCET-DIFF Online Help – Quick Guide

Use the Help → Help Contents menu option to invoke the online help. 

The panes of the help window provide you with the following information:

• The left pane shows the table of content, index, search results, links or 
bookmarks.

• The right pane contains the current help topic. 

The first topic displayed here contains a short description of ASCET-DIFF. 
Click on the TOC entry in the left pane to open the more detailed 
ASCET-DIFF overview topic.
ASCET-DIFF V6.3 - Installation Guide 7
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1.5 Conventions

Documentation Conventions

All activities executed by the user are displayed in a "use case" format, as shown
by the following example. A task in this manual is a sequence of actions which
have to be executed to attain a specific goal. The title of the task  usually specifies
the result of the actions, e.g. "To create a new component" or "To rename an
element". 

To attain a goal:

Any introductory information...

• Execute action 1.

• Explanations are listed under an action.

• Execute action 2.

Any explanation of step 2...

• Execute action 3.

Any explanation of step 3...

Any concluding remarks...

Typographic Conventions

The following typographic conventions are used:

Important notes for the user are shown as follows:

Select File → Open. Menu options are shown in boldface/blue.

Click OK. Buttons are shown in boldface/blue.

Press <ENTER>. Keyboard commands are shown in angled 
brackets, in block capitals.

The "Open File" dialog window 
opens.

Names of program windows, dialog windows,  
fields etc. are shown in quotation marks.

Select the file setup.exe. Text in drop-down lists on the screen, program 
code, as well as path and file names are 
shown in the Courier font.

A distribution is a one-dimen-
sional table of sample points.

Content markings and newly introduced 
terms are shown in italics.

The OSEK group (see 
http://www.osek-vdx.org/) has 
developed certain standards.

Links to internet documents are set in blue, 
underlined font.

Tip

Important note for the user.
ASCET-DIFF V6.3 - Installation Guide
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2 Installation

This chapter is intended for all users who install, maintain and uninstall
ASCET-DIFF on a PC. It provides information on the delivery scope, hardware and
software requirements as well as on how to prepare the installation (section 2.1).
The sequence of both installation (section 2.2) and uninstallation (section 2.5) of
ASCET-DIFF is described; command line installation/uninstallation (section 2.3)
and setting the licensing behavior (section 2.4) are explained as well.

2.1 Preparations

Check the delivery package to make sure it is complete and make sure your sys-
tem corresponds to the system requirements. Make sure that you have the nec-
essary user privileges.

2.1.1 Delivery Scope

The delivery scope of ASCET-DIFF includes:

• ASCET-DIFF program files

• ASCET-DIFF Installation Guide in PDF format (Adobe Reader)

2.1.2 ASCET-DIFF License

You require a valid license for ASCET-DIFF if you want to use the tool. You obtain
the license file required for licensing either from your tool coordinator or through
a self-service portal on the ETAS internet site at http://www.etas.com/support/
licensing. To request the license file you have to enter the activation number
which you received from ETAS during the ordering process. 

For further information on licensing, see "Licensing the Software" on page 23.

2.1.3 System Prerequisites

ASCET-DIFF requires the same system prerequisites as ASCET. 

2.1.4 Required User Privileges for Installation and Operation

User Privileges Required for Installation::

In order to install ASCET-DIFF on a PC, you need the user privileges of an admin-
istrator.

If the user name under which you have registered in Windows does not have
administrator privileges, a warning message is displayed and the ASCET-DIFF
installation is canceled. In that case, please contact your system administrator.

User Privileges Required for operation:

The operation of ASCET-DIFF requires the same user privileges as ASCET.

2.2 Installation

You can install ASCET-DIFF as standalone tool, as add-on to ASCET, or both. You
can, however, only install the add-on variant of ASCET-DIFF if ASCET has already
been installed on your computer.

The installation is independent of whether you install ASCET-DIFF from installa-
tion disk or a network drive. 
ASCET-DIFF V6.3 - Installation Guide 9
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Windows® Vista + SP1 (32 bit) or Windows® 7 (32 bit or 64 bit) or Windows® 8
(64 bit in 32 bit compatibility mode) is required to install ASCET-DIFF.

To start the ASCET-DIFF installation:

• Insert the installation disk in the respective drive on 
your PC. 

• Select the drive in the Windows Explorer and run 
the Setup.exe file.

The ETAS Installer is launched. 

• Click Next to continue.

The installer checks if your computer meets the sys-
tem requirements for ASCET-DIFF installation. The 
result is displayed in the "System Check" window.

• If your system meets the system requirements, click 
Next to continue.

• If your system does not meet the system require-
ments, follow the instructions in the "System 
Check" window and re-start the installation.
ASCET-DIFF V6.3 - Installation Guide
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To accept the license agreement:

The following window shows the license agreement. 

• Read the license agreement, then activate the I read 
and accept the license agreement option.

If you do not accept the license agreement, you 
cannot continue the installation.

• Click Next to continue.

Or

• Click Proceed to Install to go to the "Ready to 
install" window immediately, with default settings 
for components to be installed, installation and 
workspace paths, etc.

Continue reading in section "To install 
ASCET-DIFF:" on page 16.
ASCET-DIFF V6.3 - Installation Guide 11
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To select components:

The "Installation" window lists the necessary prerequisites and the components
of ASCET-DIFF. Prerequisites and components already present on your PC are
marked accordingly.

The text field on the right displays information on the highlighted component.

For ASCET-DIFF, all components are mandatory, you cannot select them.

• Click Next to continue.

Or

• Click Proceed to Install to go to the "Ready to 
install" window immediately, with default settings 
for installation type, installation and workspace 
paths, etc.

Continue reading in section "To install 
ASCET-DIFF:" on page 16.

To select the installation type:

The "Installation Type" window allows you to select either a standard installation
or a side-by-side installation. The following installation type options are available:

• Standard Installation: ASCET-DIFF V6.3.x is installed as ASCET-DIFF V6.3. 
Previous installations of ASCET-DIFF V6.3.* are uninstalled automatically.
ASCET-DIFF V6.3 - Installation Guide
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• Side-by-Side Installation: ASCET-DIFF V6.3.x is installed as ASCET-DIFF 
V6.3.x. Previous installations of ASCET-DIFF V6.3.y are kept, except for 
y = x.

• Read the explanations in the "Installation Type" 
window.

• Activate the option for the installation type you 
want to use.

• Click Next to continue.

Or

• Click Proceed to Install to go to the "Ready to 
install" window immediately, with default settings 
for installation and workspace paths, etc.

Continue reading in section "To install 
ASCET-DIFF:" on page 16.
ASCET-DIFF V6.3 - Installation Guide 13
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To define path settings:

In the "Installation directory" window, you are prompted to enter a destination
directory for the installation (referred to as <installation>).

• To change a preset directory, enter or select (via the 
Browse button) the new path.

If you entered an invalid path, the Next and Proceed 
to Install buttons are disabled.

• If you used the Browse button, proceed as follows.

– In the "Browse For Folder" window, select an 
existing directory.

Or

– Use the tree structure and the Make New Folder 
button to create a new folder.

– Click OK to close the "Browse for Folder" win-
dow and accept your selection.
ASCET-DIFF V6.3 - Installation Guide
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• Click Next to continue.

Or

• Click Proceed to Install to go to the "Ready to 
install" window immediately, with default settings 
for workspace path, etc.

Continue reading in section "To install 
ASCET-DIFF:" on page 16.

• In the "Workspace Path" window, enter or select a 
path for the ASCET-DIFF workspace.

• Click Next to continue.

Or

• Click Proceed to Install to go to the "Ready to 
install" window immediately, with default settings.

Continue reading in section "To install 
ASCET-DIFF:" on page 16.

To associate with ASCET:

The "Associate ASCET-DIFF with ASCET version(s)" window lists all installations
lower than ASCET V6.1.0 on your PC.

Tip

This instruction is only relevant if one or more ASCET versions lower than 
V6.1.0 are installed on your PC.
ASCET-DIFF V6.3 - Installation Guide 15
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• Select the ASCET installation(s) you want to use 
with ASCET-DIFF.

ASCET-DIFF cannot be started from within ASCET 
installations not selected.

• Click Next or Proceed to Install to continue.

To install ASCET-DIFF:

The "Ready to install" window lists the components selected for installation. You
cannot change the selection here; to do so, you must go back to the "Installa-
tion" window (cf. page 12). 

• In the "Ready to install" window, click Install.

The selected components (cf. page 12) are installed. 
Components already present on your PC are 
skipped. A progress indicator shows how the instal-
lation is progressing.

To complete the installation:

Once all components have been installed successfully, you are prompted to end
the installation. 

• Click on Finish to end the installation.

Tip

The next step will start the installation. You cannot 
cancel the installation once it is running; the Cancel 
button is deactivated.
ASCET-DIFF V6.3 - Installation Guide
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An icon is placed on the desktop of your PC, and the ASCET-DIFF folder with the
following entries is created in the Windows Start menu:

The version number shown in desktop icon and start menu entries depends on
the installation type (standard: Vx.y or side-by-side: Vx.y.z) you selected (see
page 12).

• ASCET-DIFF Vx.y[.z]

The ASCET-DIFF program is started.

• ReadMe

Opens the Readme file.

The ETAS License Manager has its own folder, License Management, in the ETAS
program group of the Windows Start menu. This folder contains a single entry,
ETAS License Manager.

2.3 Command Line Installation / Uninstallation

When you start the ASCET-DIFF installation from a command line, you can use
several command-line parameters to customize the installation.

Each execution of Setup.exe writes a log file %appdata%1\ETAS\SETUP\
<date_time> Setup.log.

/silent

Silent installation mode. With this installation mode, no dialog windows 
requiring user information open. 

Default values are used for all information normally requested in installa-
tion windows. Error messages are hidden, too.

/EULAAccepted

Accepts the license agreement. 

The text of the license agreement is provided on the installation disk, in 
the EULA subfolders. 

1. %appdata% = 
C:\Users\<username>\AppData\Roaming (Windows 7)

Tip

To accept EULA (cf. page 11) during silent installation, you must use the 
command-line parameter /EULAAccepted.
To deal with a possible request for a computer restart, you must use 
either the /NoRestart or the /AllowRestart command line 
parameter.
ASCET-DIFF V6.3 - Installation Guide 17
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/NoRestart

Suppresses a computer restart that may be required at the end of the 
installation. If a reboot is suppressed, a log message is issued.

/AllowRestart

Allows a computer reboot restart that may be required at the end of the 
installation. A restart is performed without further notice.

/Debug

Writes additional log files for *.msi packages. 

These files are stored in the %appdata%1\ETAS\SETUP folder.

/DefaultSettings

Allows to specify an own XML file with default settings (instead of using 
InstallationDefaultSettings.xml). 

You can specify a relative path if the file is relative to Setup.exe, other-
wise you have to specify a absolute path.

Syntax: /DefaultSettings:"<path>\<filename>.xml"

/uninstall

Uninstalls ASCET-DIFF. Can be combined with /silent for uninstallation 
without user interaction.

Examples:

Setup.exe /silent /EULAAccepted 

Triggers a silent installation. 

Setup.exe /uninstall /Debug

Triggers an uninstallation and writes additional logs.

Setup.exe /DefaultSettings:"D:\myOwnSettings.xml"

Triggers a non-silent installation that uses your own default settings for 
the installation.

By default, silent installation uses the standard installation type (see page 12). To
select side-by-side installation, proceed as follows:

To select Side-by-Side for command-line installation:

• Copy the InstallationDefaultSet-
tings.xml file to a location where you can edit it.

• Open InstallationDefaultSettings.xml 
in a suitable editor.

1. %appdata% = 
C:\Users\<username>\AppData\Roaming (Windows 7)

Tip

For command-line uninstallation, you must run setup.exe from the follow-
ing location:

ETAS\GENericSetup\ASCET_DIFF ASCET-DIFF\<a>.<b>.<c>.<d> 
in your program directory
ASCET-DIFF V6.3 - Installation Guide



ETAS Installation
• In the editor, go to the package with 
ID="ASCET_DIFF ASCET-DIFFInstall-
Pack_<a>.<b>.<c>.<d>".

• In that package, edit the variable 
PRODUCT_FOLDER_VERSION as follows:

<Variable
name="PRODUCT_FOLDER_VERSION"
defaultValue="[packagevar:xyzversion]"
validation="none" />

packagevar:xyzversion is required for side-
by-side installation.
packagevar:xyversion is required for stan-
dard installation.

• Save the XML file.

• Use /DefaultSettings (cf. page 18) to pass 
the changed InstallationDefaultSet-
tings.xml file to the command-line installation. 

2.4 Setting the Licensing Behavior

The ASCET-DIFF installation includes an installation of the ETAS license manager.
You can define the way in which ASCET-DIFF (and other ETAS software pro-
grams) access the required licenses in the [Licensing] section of an *.ini
file.

Such an *.ini file is available on your installation disk, in the ...\Packages\
ASCET-DIFF LicensingASCET-DIFFInstallPack_6.3.<x>.<y>
folder. You can copy this file to a local directory and adapt it according to your
needs.

To define the access to the required licenses:

• Open the *.ini file with a text editor.

• Modify the settings in the [Licensing] section 
as desired. 

The parameters and their settings are described 
below.

• Save your changes.

The following parameters may be used:

• LicenseFileName

Defines the absolute path to the location of the license file which is to be 
added.

• LicensesToBorrow

You can use this setting if licenses can be borrowed from a license server. 
To enable the borrow mechanism, you must enter the name of the prod-
uct or features license (e.g. ASCET-DIFF). If you enter more than one 
license, the license names must be separated by blanks.
ASCET-DIFF V6.3 - Installation Guide 19
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• BorrowExpiryMode

Defines the way in which the expiration of the borrow status is given. 
Possible values are:

– Date

If the BorrowExpiryMode is set to Date, the borrow period will 
expire at a certain date which is specified under BorrowExpiry-
Date.

– Interval

If the BorrowExpiryMode is set to Interval, the borrow period 
will expire after a certain number of days which is specified under 
BorrowExpiryInterval.

• BorrowExpiryDate

If the BorrowExpiryMode is set to Date, this parameter specifies the 
date when the borrow period expires. The format is yyyy-mm-dd.

• BorrowExpiryInterval

If the BorrowExpiryMode is set to Interval, this parameter specifies 
the length of the borrow period in days.

• ExecuteBorrowAutomaticExtensionInterval

Defines at what point of time the borrow period will be automatically 
extended. This parameter specifies the number of days before the expira-
tion of the current borrow period. When this time is reached, the borrow 
period is automatically extended to the interval specified under 
BorrowAutomaticExtensionInterval.

• BorrowAutomaticExtensionInterval

This parameter specifies the borrow interval in days that is applied when 
an automatic extension of the borrow period is executed (as defined 
under ExecuteBorrowAutomaticExtensionInterval).

• ImmediateBorrow

You can define that a license is automatically borrowed. Possible values 
are:

– True

The license is borrowed automatically at installation time.

– False

The license will be borrowed at the first time when the program con-
nects to the license server.

Tip

ImmediateBorrow=’True’ works only for the user who per-
forms the installation. Other users who work on the same computer 
do not own the borrowed license.
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• CustomLicenseFolder

Due to the fact that the default location for added license files (e.g., 
C:\ProgramData\ETAS\FlexNet for Windows 7) is only writeable 
for users with admin rights, a different path for the license file folder may 
be specified with this parameter.

The following example defines that borrowing is enabled for ASCET-DIFF. The
license will be borrowed when ASCET-DIFF is started for the first time; by default
the license expires after 100 days.

[Licensing]

LicenseFileName = ’d:\licenses\MyLicense.lic’

LicensesToBorrow = ’ASCET-DIFF’

BorrowExpiryMode = ’Interval’

BorrowExpiryInterval = ’100’

ImmediateBorrow = ’false’

2.5 Uninstallation

If you uninstall ASCET-DIFF, all installed variants are uninstalled automatically. 

To uninstall ASCET-DIFF:

• Start the uninstall procedure via the Programs and 
Features icon in the Windows Control Panel.

The ETAS installer is launched.

You can use the Next button to get to the next 
uninstallation window; Back to get to the previous 
window, and Cancel to cancel uninstallation.
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• Click Next to check if your computer meets the sys-
tem requirements for ASCET-DIFF uninstallation.

The result is shown in the "System Check" window.

• Click Next to continue.

The "Ready to uninstall" window opens. It lists the 
components that will be uninstalled. You cannot 
change the selection. 

• Click Uninstall to actually uninstall ASCET-DIFF.

A progress indicator shows how the uninstallation 
is progressing.

Once all components have been uninstalled, a suc-
cess window opens.

• Click Finish to end the uninstallation.

Tip

The next step will start the uninstallation. You cannot cancel uninstallation 
once it is running; the Cancel button is deactivated.
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3 Licensing the Software

To be able to work with an ETAS software product, you require a license. This
section contains basic details on this subject.

• "ETAS License Models" on page 23

• "How to get a License" on page 24

• "The License File" on page 25

• "Grace Mode" on page 27

• "The "Expiration Warning" Window" on page 27

• "Borrowing a License" on page 28

Details concerning the scope of the licenses and other legal aspects can be found
in "Terms and Conditions".

3.1 ETAS License Models

There are three different license models available for licensing your ETAS soft-
ware: 

Machine-Named License, Local

• A license of this type is managed by the user him/herself.

• As it is linked to a particular PC (better: to the MAC address of the Ether-
net adapter), it is valid wherever the PC is used.

• When you change your PC, you require a new license.

User-Named License, Server-Based

• The licenses (of a department or company) are managed centrally on a 
server by a designated person.

• The license is linked to the user name with which the user is registered in 
the network and is available on every PC in the network.

• If the relevant PC is disconnected from the network, the license can be 
"borrowed."

Concurrent (or Floating) License, Server-Based

Most of what is true of the user-named license applies to this type of license. The
difference is that here several users share a limited number of licenses.
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3.2 How to get a License

If your company has a tool coordinator and server-based license management for
ETAS software, contact this person. Otherwise (in the case of a machine-named
license) you obtain your license from the ETAS license portal (the URL is shown
on your Entitlement Certificate).

There are three ways of logging in on the welcome page:

• Activation ID 

Once you have logged in, a specific activation1 is visible and can be man-
aged – the activation ID is shown on your Entitlement Certificate.

• Entitlement ID 

All activations of the entitlement2 are visible and can be managed (e.g. for 
a company with just one entitlement).

• E-mail and password 

All activations of the entitlements assigned to the user account are visible 
and can be managed (e.g. for a tool coordinator responsible for several 
entitlements).

If you need help in the portal, click the Help link.

3.2.1 What Information is Required?

Information on the hosts must be entered to activate licenses:

• Machine-named license

The MAC address of the Ethernet adapter to which the license is to be 
bound is required here

• User-named license

Here, you need a server host or a server triad as well as a user name

• Concurrent (floating) license

Here, you need a server host or a server triad.

3.2.2 License File

The result of your activities is the provision of a file <name>.lic with which you
can license your software in the ETAS License Manager.

1. The activations refer to a specific product, its license conditions, the available 
number of licenses and other details required for generating a license. Activa-
tions are identified uniquely with activation IDs. 

2. An entitlement shows the authorizations you have as a user; it stands for the 
right to own one or more licenses for a product. It is a kind of account of rights 
of use for software from which you can take licenses as you need to. 

Tip

If this data changes (e.g. due to changes in the hardware or a change of user), 
the license must be given a "rehost". This procedure is also described in the 
portal help file.
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3.3 The License File

To check to license status

• In the Windows Start menu, select Programs → 
ETAS → License Management → ETAS License 
Manager.

The ETAS License Manager opens. It contains one 
entry for each installed product. The symbol at the 
beginning of the entry and the "Status" column 
entry indicate whether a valid license has already 
been obtained or not.

To add a license file:

• Open the ETAS License Manager (cf. page 25) and 
select File → Add Licensing File.

The "Install License" dialog window opens.

• Next to the "Select License File" field click the ... 
button.
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• In the file selection window, select the license file 
and click Open.

The "Install License" dialog window shows infor-
mation on the selected license.

• Confirm with OK.

The license just added is now listed in the ETAS 
License Manager. A green symbol before the entry 
shows that the license is valid.

• Close the ETAS License Manager.

Tip

The "Version" column shows the version number of 
the license, not the version number of the software.

Tip

If the green symbol is not displayed, there might be a 
problem with the license file or the license relates to 
another product. Additional information on the ETAS 
License Manager can be found in the online help of 
the ETAS License Manager.
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3.4 Grace Mode

If you have not yet installed a license, you can still operate the software for a
limited amount of time – it then runs in what is referred to as grace mode. The
window shows you how long you can continue to operate the software in this
mode.

3.5 The "Expiration Warning" Window

If your installed license runs out in the next 30 days, a warning is shown when
you open the ETAS software. 

The "Expiration Warning" window contains a list of licenses that expire in the
next 30 days. The expiration date is shown for each license; in the case of bor-
rowed licenses (see "Borrowing a License" on page 28) it shows when the bor-
rowing period expires (i.e. the date when borrow mode runs out).

Click Manage Licenses to open the ETAS License Manager and install a valid
license file. As soon as you have installed a valid license, you can continue to
operate the ETAS software in normal operating mode.

Click Ignore to close the dialog box and start the ETAS software. This is only
possible during the grace period; as soon as the grace period has expired, you
can only continue to use the ETAS software once you have installed a valid
license file.

Tip

Note that no Grace Mode is available for the ASCET-DIFF Model Viewer. You 
can only start the ASCET-DIFF Model Viewer if you have the required "ASCET-
VIEW" license. For more information on existing licenses, see chapter "Licens-
ing the Software" on page 23 or contact your system administrator. 
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As soon as the expiration date has been reached, you can continue to use the
ETAS software for a further 14 days in what is referred to as limited mode (see
"Grace Mode" on page 27). Once this phase is over, the ETAS software can only
be used when a new or updated license file has been installed.

3.6 Borrowing a License

The borrowing mechanism makes it possible to work offline even when using a
server-based license (i.e. without being connected to the license server).

To borrow a license, proceed as follows:

To borrow a license

• Make sure that the ETAS software whose license 
you want to borrow is not running.

• Select the license you want to borrow in the 
"License Listing" table of the ETAS License 
Manager.

• Select License → Borrow license.

The "Select Borrow end date" dialog box opens.

Tip

You can only borrow a license if a server-based license is being used!
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• Select the date until which you want to borrow the 
license from the calendar displayed and click OK.

The text in the "Source" column of the ETAS 
License Manager changes from "SERVER" to "BOR-
ROW", and the expiration date of the borrowed 
license is displayed.

You can now use the relevant ETAS software offline until the expiration date of
the borrowed license has been reached. 

If you want to use the ETAS software longer than you had originally planned, you
can borrow the license again. If you stop using the ETAS software earlier than
planned, you can return the license to the license server early (License → Return
License Early). A borrowed license can only be returned by the person that bor-
rowed it; it cannot be returned by another person.
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3.7 Customizing the Network Installation

You can change certain default settings before conducting the network installa-
tion; this also includes the access to the required licenses. The customization of
the installation is done by adjusting the configuration file install.ini, which
is located in the installation directory of the product to be installed. 
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4 Starting ASCET-DIFF

Depending on the way ASCET-DIFF is installed, you can start it individually or as
add-on from within ASCET.

4.1 Starting the Standalone Variant

To start the standalone variant:

• In the Windows Start menu, go to the ETAS pro-
gram group and select ASCET-DIFF 6.3 → 
ASCET-DIFF V6.3.

Or

• Double-click the ASCET-DIFF desktop icon.

ASCET-DIFF starts. 

If no valid license file is detected, a grace mode is 
activated. That is a limited period of time during 
which the tool is fully operational, but a license file 
is searched regularly, and a warning is issued when 
the search fails. See also chapter 3 "Licensing the 
Software".

If you start ASCET-DIFF for the first time, the "Wel-
come to ASCET-DIFF" window opens.

• Click on the Start ASCET-DIFF link.

ASCET-DIFF opens.
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4.2 Starting the Add-On Variant

Add-On to ASCET V6.0 or Lower

If ASCET-DIFF is installed as add-on to ASCET V6.0 or lower, the Compare menu
with the following menu items is added to the ASCET component manager.

• Open ASCET-DIFF 

Opens ASCET-DIFF.

• Compare selected components 

Compares two selected components.

• Compare selected components recursively 

Compares two selected components and their included components.

If ASCET-DIFF is installed as add-on to ASCET V6.0 or lower, and if ASCET-SCM
is installed on your PC, ASCET-DIFF is made known to ASCET-SCM during instal-
lation.

Add-On to ASCET V6.1 or Higher

If ASCET-DIFF is installed as add-on to ASCET V6.1 or higher, you have to per-
form the following steps before you can use ASCET-DIFF within ASCET and—if
installed—ASCET-SCM.

To set up ASCET-DIFF usage in ASCET V6.1 or higher:

• Open the ASCET component manager.

• In the component manager, select Tools → 
Options.

The ASCET options window opens.

• In the options window, go to the "ASCET-DIFF" 
node.

The nodes have been re-structured in ASCET V6.2.

V6.1
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• Select the ASCET-DIFF version you want to use with 
ASCET V6.1 or higher.

• Click Ok to close the ASCET options window.

With that, the ASCET-DIFF submenu is added to the Tools menu in the ASCET
component manager.

The Compare submenu is also available as context menu in the "1 Database" or
"1 Workspace" list.

Add-On to any ASCET Version

To start ASCET-DIFF from within ASCET: 

If the add-on variant of ASCET-DIFF is installed, you can access ASCET-DIFF via
the ASCET component manager.

• Open the ASCET component manager.

Tip

With ASCET V6.1 or later, you have to set up ASCET-DIFF usage first, see 
page 32

V6.2
V6.3
ASCET-DIFF V6.3 - Installation Guide 33



34

Starting ASCET-DIFF ETAS 
• In the "1 Database" or "1 Workspace" field, select 
two components you want to compare.

1. ASCET V6.1 or later

• Do one of the following:

– Select Tools → ASCET-DIFF → Open 
ASCET-DIFF to start the tool without comparing 
the components.

– Open the components’ context menu and 
select Compare → Selected Components or 
Selected Components Recursively.

– Select Tools → ASCET-DIFF → Compare → 
Selected Components or Selected Components 
Recursively.

2. ASCET V6.0 or earlier

• Do one of the following:

– Select Compare → Open ASCET-DIFF to start 
the tool without comparing the components.

– Select Compare → Selected Components or 
Selected Components Recursively.

3. all

Selected Components compares only the selected 
components.

Selected Components Recursively compares the 
selected components and the referenced compo-
nents.

The comparison is executed. ASCET-DIFF opens and 
displays the results.

4.3 Starting ASCET-DIFF via the Command Line

You can start ASCET-DIFF via the command line, too. Use the following syntax:

ASCET-DIFF "<left main file>" "<right main file>"

<left main file> and <right main file> are path and file name
(including extensions) of the *.main.amd files of the components you want to
compare.

ASCET-DIFF can be invoked from the command line in two different configura-
tions:

• With switches

• Without switches

With switches: ASCET-DIFF can be invoked from the command line with
switches using the following syntax:

ASCET-DIFF -lf <left file path> -rf <right file path> 
-lc <left component name> -rc <right component name> 
-lv <left version string> -rv <right version string> 

where
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• -lf is the left file path switch

• -rf is the right file path switch

• -lc is the left component name switch (optional)

• -rc is the right component name switch (optional)

• -lv is the left version string switch (optional)

• -rv is the right version string switch (optional)

The switches -lf and -rf are mandatory.

The same command line switches can also be used to specify compressed files
(originally in AXL or ZIP format) having renamed file names. The file extensions
can also be arbitrary, however, the component names have to be specified as
arguments.

Without switches: ASCET-DIFF can also be invoked from the command line
without switches. In that case, the first argument is assumed to be absolute path
of the left component and the second argument is assumed to be absolute path
of the right component. The following command line syntaxes are supported:

1. ASCET-DIFF <left file path> <right file path> 

2. ASCET-DIFF <left file path> <right file path> 
<relative path of left component> <relative path of 
right component> 

3. ASCET-DIFF <left file path> <right file path> <rela-
tive path of left component> <relative path of right 
component> <timestamp> 

This syntax is used for interfacing ASCET-DIFF to ASCET.

4. ASCET-DIFF <left file path> <right file path> <left 
component name> <right component name> 

This syntax can be used when left and right archive files have been 
renamed or have multiple components and the component names are 
passed as argument.
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5 Starting ASCET-DIFF Model Viewer

The following chapters will describe how to start ASCET-DIFF in the model viewer
mode using a command line prompt or the Windows context menu. It can be
invoked from the command line with relative or absolute path specification.

• "Starting the Command Prompt" on page 36

• "Command Line arguments for invoking the Model Viewer" on page 37

• "Starting ASCET-DIFF Model Viewer via context menu" on page 39

5.1 Starting the Command Prompt 

The installation directory of ASCET-DIFF is the starting point within the Com-
mand Prompt window. Usually this is the following path:

C:\Program Files (x86)\ETAS\ASCET-DIFF6.3.0

Then a distinction is made between the argument for relative and absolute path.
How to invoke the Model Viewer using an absolut path specification is described
in the following chapter. First, you must start the command prompt.

To start the command prompt and change directory to installation directory

• In the Windows Start menu, go to the Accessories 
program group and select Command Prompt.

Or

• In the Windows Start menu, enter "cmd" in the 
"Search programs and files" field and press 
<ENTER>.

The "Command Prompt" window opens.

Tip

You can only start the ASCET-DIFF Model Viewer if you have the required 
"ASCET-VIEW" license. Note that no Grace Mode is available for the ASCET-
DIFF Model Viewer. For more information on existing licenses, see chapter 
"Licensing the Software" on page 23 or contact your system administrator. 
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• In the "Command Prompt" window, enter the syn-
tax for changing to the installation directory. 

If you used the default path for the 32-bit installa-
tion, use the following exemplified syntax:

cd C:\Program Files 
(x86)\ETAS\ASCET-DIFF6.3.0

If you used the default path for the 64-bit installa-
tion, use the following exemplified syntax:

cd C:\Program Files\ETAS\ASCET-
DIFF6.3.0

You are now in the installation directory of 
ASCET-DIFF V6.3.

5.2 Command Line arguments for invoking the Model Viewer

This chapter describes how to invoke the ASCET-DIFF Model Viewer using an
absolute path specification for a component within the command line prompt.
Prerequisite is that you have already changed in the ASCET-DIFF installation
directory (see chapter 5.1 on page 36).

To specify the command line argument 

• In the "Command Prompt" window, enter the fol-
lowing syntax:

ASCET-DIFF.exe -f "<path>\<file 
name>.<format>" -c <component name> 
-v <version>

where

– ASCET-DIFF.exe is the argument to start 
ASCET-DIFF.

Tip

Specifying the syntax for changing to the installation 
directory may vary and depends on where you 
installed the system. For more information on how to 
install ASCET-DIFF V6.3, see chapter 2.2.

Tip

Only files with the file extension *.main.amd or *.axl will be displayed in the 
ASCET-DIFF Model Viewer.
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– -f "<path>\<file name>.<format>" is 
the file path switch. The path of the component 
can be specified absolute or relative to the 
installation directory.

Relative:

(-f)"..\ASCET-DIFF 6.3\Sam-
ples\<file name>.<format>"

Absolute:

(-f)"C:\Program Files 
(x86)\ETAS\ASCET-DIFF 6.3\Sam-
ples\<file name>.<format>"

– -c <component name> is the component 
name switch (optional).

– -v <version> is the version string switch 
(optional).

The following graphic shows the command prompt 
window including an exemplary command line 
argument:

• Press <ENTER>.

The command will be executed and ASCET-DIFF will 
be invoked in the Model Viewer mode displaying 
the specified component.

Tip

The specification of the key "-f" prior the path is 
optional only if no other key is used in the command 
line argument.

Tip

The specification of the component name key "-c" is 
not necessary for axl files (*.axl) if the file contains 
only one component with the same name.
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5.3 Starting ASCET-DIFF Model Viewer via context menu

This chapter describes how to invoke the ASCET-DIFF Model Viewer using the
Windows context menu.

To start the Model Viewer via context menu

• In the Windows file explorer, right-click on the file 
(e.g. *.axl) you want to view.

The respective context menu opens.

• Click on Open with.

The "Open with" window opens.

• Select ASCET-DIFF.exe to open this file.

• Click OK.

ASCET-DIFF V6.3 starts in the model viewer mode. 

Tip

With the checkbox "Always use the selected pro-
gram to open this kind of file" you can set the 
selected program as default. Once you have set the 
default program, you can start the ASCET-DIFF 
Model Viewer directly over the entry "View in 
ASCET-DIFF V6.3.0" in the windows context menu.
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6 ETAS Contact Addresses

ETAS HQ

ETAS GmbH

ETAS Subsidiaries and Technical Support

For details of your local sales office as well as your local technical support team
and product hotlines, take a look at the ETAS website:

Borsigstraße 14 Phone: +49 711 3423-0

70469 Stuttgart Fax: +49 711 3423-2106

Germany WWW: www.etas.com

ETAS subsidiaries WWW: www.etas.com/en/contact.php

ETAS technical support WWW: www.etas.com/en/hotlines.php

http://www.etasgroup.com
http://www.etasgroup.com
http://www.etasgroup.com
http://www.etas.com
http://www.etas.com/en/contact.php
http://www.etas.com/en/hotlines.php
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