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1 はじめに

ASCET は、組み込みソフトウェアシステムのファンクション開発とソフトウェア
開発のための革新的なソリューションを提供します。ASCET は、新しい独自のア
プローチによって、モデリング、コード生成、シミュレーション実験、といった
開発工程の各段階を強力にサポートするので、品質向上や開発サイクルの短縮、
さらにコスト低減を実現できます。

本書は、読者の方が ASCET について理解し、速やかに成果を得られるように支援
するものです。システムについて順を追って紹介すると同時に、すべての情報を
参考資料として利用しやすい形にまとめてあります。

1.1 ASCET ファミリ

ASCET 製品ファミリに含まれる各製品には、それぞれシミュレーションプロセッ
サとのインターフェース、サードパーティのソフトウェアパッケージとのイン
ターフェース、さらに ASCET のリモートアクセスを行うためのインターフェー
ス、といった機能が盛り込まれています。 新バージョンにおいては、ASCET 製
品ファミリは以下の製品で構成されています。

• ASCET-MD
モデルの開発とオフラインシミュレーションに使用します。

• ASCET-RP
実験ターゲット（マイクロコントローラを搭載した ETAS シミュレーショ
ンボード）を使用した HiL（Hardware-in-the-Loop）シミュレーションや
ラピッドプロトタイピングをサポートします。また INTECRIO との接続機
能も含まれます。

• ASCET-SE
ECU の各種マイクロコントローラターゲットへのコード実装をサポートし
ます。ターゲットとなるマイクロコントローラ用に 適化された実行コー
ド（任意に設定されたオペレーティングシステムを含む）が生成されま
す。さまざまなタイプのコントローラをサポートし、2 種類の OS を統合
できます。

また、以下のオプションモジュールも利用できます。

• ASCET-DIFF
ASCET モデルの比較ツールです。

• ASCET-SCM
外部のコンフィギュレーション管理ツールとのインターフェースを提供し
ます。

これらの他にも、ご要望に応じてユーザー固有の製品を ASCET に組み込むことも
可能です。詳しくは ETAS までお問い合わせください。
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1.2 マニュアルについて

1.2.1 ユーザープロファイル

このマニュアルは、ECU（自動車制御ユニット）の開発や適合作業の経験がある
方を対象としています。 このマニュアルをお読みいただくには、信号測定や ECU
に関する技術についての専門的な知識が必要です。 

また、Windows（2000、XP、Vista のいずれか）の操作についての知識も必要で
す。 メニューコマンドの実行、ボタン操作、さらには Windows のファイルシステ
ム、特にファイルとディレクトリの関係についての知識が必要です。また
Windows のファイルマネージャやエクスプローラ等の基本的な使い方を理解され
ていて、「ドラグアンドドロップ」操作に慣れていることも必要です。

Microsoft Windows の基本テクニックに慣れていない方は、まずそれらについて
学習してから、ASCET をご使用ください。 Windows オペレーティングシステム
についての詳しい説明は、マイクロソフト社発行のマニュアルを参照してくださ
い。

またさらに ANSI C や JAVA 等のプログラミング言語に関する知識があれば、
ASCET をより効率的にお使いいただくことができます。

1.2.2 マニュアルの構成

ASCET マニュアルは、以下の 3 つのドキュメントで構成されています。

1. 『ASCET V6.0 入門ガイド』

ASCET で作業する際に必要な基本的な情報がまとめられています。

2. 『ASCET V6.0 インストールガイド』

ASCET 製品のシステム要件やインストール方法についての情報がまとめ
られています。

3. ASCET オンラインヘルプ

ASCET 製品の機能や操作方法が詳しく説明されています。

本ドキュメント『ASCET V6.0 入門ガイド』は、以下の章で構成されています。

• 第 1 章 「はじめに」（本章）

ASCET 製品とマニュアルについての概要、および操作時に役立つ一般情
報がまとめられています。

• 第 2 章 「ASCET による自動車用組み込み制御ソフトウェアの開発」

ASCET 製品ファミリと、それによってサポートされる開発プロセスにつ
いての概要です。ASCET を使用する前に必ずお読みください。

• 第 3 章 「ASCET と AUTOSAR」

ASCET の AUTOSAR 対応についての概要を説明します。
はじめに



• 「チュートリアル」

この章は、ASCET を初めて使うユーザーを対象としています。例題につ
いて実際に作業を進めながら、ASCET の使用方法を学習できます。
チュートリアルは各工程ごとにいくつかのセクションに分かれていて、各
セクションは互いに関連し合っています。なお、チュートリアルの演習を
行う際は、あらかじめ「ASCET による自動車用組み込み制御ソフトウェ
アの開発」（13 ページ）をお読みください。

• 「用語集」

マニュアルで使用されている技術用語について解説されています。

• 「付録 A： ASCET に関するトラブルシューティング」

ASCET 使用時に ASCET 固有の問題が発生した際の対処法とエラーレポー
トの作成方法について説明されています。

• 「付録 B： 一般的なトラブルシューティング」

ETAS ソフトウェア製品使用時に発生する可能性のある一般的な問題点と
その解決方法がまとめられています。

• 「付録 C：AUTOSAR」

ASCET の AUTOSAR 対応機能についての詳しい情報がまとめられていま
す。

ASCET の機能や操作方法についての詳しい情報は、オンラインヘルプに記載され
ています。オンラインヘルプの使用方法については 1.3.3 項を参照してください。

1.2.3 本書の使用法

表現について

ユーザーが実行するすべてのアクションは、いわゆる“Use-Case”形式で記述さ
れています。つまり以下に示すように、操作を行う目標がタイトルとして 初に
簡潔に定義され（例：「新しいコンポーネントを作成する」、「エレメントの名前を
変更する」）、その下に、その目標を実現するために必要な操作手順が列挙され、
必要に応じて ASCET のウィンドウやダイアログボックスのスクリーンショットが
添付されています。

注記

ETAS では、ASCET のユーザートレーニングを実施しています。トレーニング
にご参加いただくことにより、ASCET の基本的な機能と使用方法のほか、より
詳しい知識を短時間で習得していただくことができます。
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目標の定義：

前置き ...

• 手順 1

手順 1 についての説明 ...

• 手順 2

手順 2 についての説明 ...

• 手順 3

手順 3 についての説明 ...

まとめ ...

具体例：

新しいファイルを作成する：

新しいファイルを作成する際は、他のファイルをすべて閉じておきます。

• File → New を選択します。

“Create file”ダイアログボックスが開きます。

• 新しいファイルの名前を、“File name”フィール
ドに入力します。

ファイル名は 8 文字以内でなければなりません。

• OK をクリックします。

新しいファイルが作成され、ユーザーが指定した名前で保存されます。このファ
イルを使用して以降の操作を行います。

表記上の規則

本書は以下の規則に従って表記されています。

表記例 説明

File → Exit を選択して、... メニューコマンドは、青の太字で表記
します。

OK をクリックして、... ユーザーインターフェース上のボタン
名は、青の太字で表記します。

<Ctrl> を押して、... キーボードの各キーは、< > で囲んで表
記します。

“Open File”ダイアログボックスが
開きます。

プログラムウィンドウ、ダイアログ
ボックス、入力フィールド等のタイト
ルは、“ ”で囲んで表記します。
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特に重要な注意事項は、以下のように表記されています。

また PDF 文書において、索引、および他の部分を参照する個所（例：「xx を参照
してください」の中の「xx」の部分）については、その参照先へのリンクが設け
られているので、必要な参照個所を素早く見つけることができます。

1.3 ユーザーサポート機能

1.3.1 モニタウィンドウ

ASCET によって実行された処理に関する履歴は、モニタウィンドウ（詳しくは
ASCET オンラインヘルプを参照してください）に出力されます。履歴データに
は、エラーや通知メッセージなども含まれます。何らかの情報が出力されると、
直ちにモニタウィンドウが 前面に表示されます。

setup.exeファイルを選択しま
す。

リストボックス、プログラムコード、
ファイル名、パス名等のテキスト文字
列は、Courierフォントで表記しま
す。

論理型のデータから算術型のデータ
への変換はできません。

注意すべき個所、または新出の用語は
太字 、あるいは「 」で囲んで表記され
ます。

OSEK グループ（http://www.osek-
vdx.org/ を参照してください）はさま
ざまな標準規格を策定しています。

インターネットへのリンクは、青い下
線で表記されています。

注記

ユーザー向けの重要な注意事項

表記例 説明
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モニタウィンドウは、情報を表示するだけでなく、エディタ機能も持っています。

• モニタウィンドウの“Monitor”タブに出力された履歴データは、自由に
編集できます。これによって、ユーザーのメモやコメントを ASCET の出
力メッセージに付加できます。

• ASCET のメッセージを、付加したコメントと共にテキストファイルとして
保存できます。

• 既に保存されている他の履歴データをロードして、記録された処理値内容
を比較できます。

1.3.2 キーボードコマンドの一覧

<Ctrl> + <F1> を押すと、現在有効なキーボードコマンドの概要が表示されます。

1.3.3 マニュアルとオンラインヘルプ

デフォルト設定で ASCET をインストールすると、ASCET の入門ガイド（ASCET 
V6.0 Getting Started.pdf）とインストールガイド（ASCET V6.0 
Installation.pdf）がマニュアルフォルダ（ETAS¥ETASManuals）にイ
ンストールされます。また日本語版マニュアルも用意されています。

Windows スタートメニューの ASCET 6.0 フォルダから Online Manuals を選択
すると、このフォルダにアクセスできます。

PDF ファイルでは、索引やテキスト検索、または随所に設定されているハイパー
リンクを使用して、必要な情報に素早くアクセスすることができます。

また、ASCET 使用中に <F1> キーを押すと、ETAS¥ASCET6.0¥Helpディレク
トリにインストールされているオンラインヘルプから関連するトピックが開きま
す。
はじめに



2 ASCET による自動車用組み込み制御ソフトウェアの開発

「自動車組み込みソフトウェア」の開発は、自動車の領域（インフォテイメント、
シャシー、ボディ、パワートレイン）間や会社（自動車メーカーとサプライヤ）
間の協力が要求される総合的な事業です。しかも、自動車組み込みソフトウェア
は、個々のメカニカルサブシステムにおいて非常に重要な部分を占めています。
その特徴は以下のような点です。

• センサからデータを読み取り、アクチュエータに送る制御値を計算する制
御アルゴリズムを実現します。

• 一般的に、ECU（Electric Control Unit: 電子制御ユニット）内で、1 つ
または複数のマイクロコントローラとその他の電気部品や電子部品を用
いて稼働します。

• 通常、自動車のライフタイム全体にわたって変更されることはありません。

• メカニカルサブシステムの安全性と信頼性に関するすべての要件に適合し
ている必要があります。

このため、ソフトウェアで実装すべき機能についての「共通の理解」が、シーム
レスな統合、さらには機能自体には直接関係のない 適化（リソース消費など）
のための基盤となります。特に後者は、ECU の大量生産を考えた場合、顕著な結
果を生み出します。1 台の ECU について少しでもコストを減らすことができれ
ば、製品ライン全体の莫大なコスト節減につながります。たとえば、メモリ使用
量を削減することによって廉価なマイクロコントローラを使用できるようになれ
ば、たとえ ECU1 台当たりのコストの違いはわずかでも全体のコスト削減は非常
に大きなものとなります。

多くの場合、ECU ソフトウェアのファンクションをグラフィカルにモデリングす
ることが、上述の「共通理解」を実現するための要因となります。グラフィカル
モデルは、組み込み C コードより抽象的である一方、テキスト記述に比べて解釈
の余地がなく一義的であることから、より「形式的」であると言えます。グラ
フィカルモデルは PC 上でシミュレーション実行でき、また「ラピッドプロトタ
イピング」の手法により、開発工程内の早い段階から実車を用いた動作検証を行
うこともできます。このようにファンクションのグラフィカルモデルは、「デジタ
ル仕様書」としてさまざまな局面で利用できます。

ファンクションのグラフィカルモデルは、コード自動生成機能により自動車組み
込みソフトウェアに変換することができます。この際には、機能性に直接関係の
ない製品特性（安全性、リソース消費など）を含む、各ターゲットに固有の設計
情報をファンクションモデルに加味します。

ECU の動作環境は Hardware-in-the-Loop システム（HiL）によりシミュレートす
ることが可能であるため、ECU のテストを早期に実験室内で容易に行うことがで
きます。ECU の HiL テストにおいては、実車テストの場合と比べて非常に柔軟な
テストを実行することができます。

一般的に、自動車組み込みソフトウェアの「適合」は、開発工程の終わり近くに
ならないと完了させることができません。適合は多くの場合、実車においてシス
テム全体（つまりソフトウェアを組み込んだすべてのメカニカルシステム）を稼
働させた状態で実行されるため、専用のツールやメソッドが必要となります。ソ
フトウェア生成時にはこのような条件についても考慮が必要です。
ASCET による自動車用組み込み制御ソフトウェアの開発 13
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2.1 項では「モデルベース設計」の諸段階について詳しく説明し、ファンクショ
ンのグラフィカルモデル作成のために ASCET で採用している「抽象化メカニズ
ム」についても説明します。2.2 項では ECU 製品開発環境における ASCET モ
デルの使用方法を紹介し、2.3 項で主要トピックについてまとめます。

2.1 モデルベース設計

自動車組み込み制御ソフトウェアの開発は、V モデルの形で表すことのできる複
数の開発ステップからなります。 初に論理システムアーキテクチャの分析と設
計、つまり、制御ファンクションの定義を行い、続いて物理的アーキテクチャ

（ECU ネットワーク）を定義し、その後、ECU にソフトウェアを実装します。さ
らに各ソフトウェアコンポーネントの統合とテストを行ってから ECU を車両ネッ
トワークに統合し、 後の仕上げの工程として、実装されたファンクションを実
行するシステム全体を「適合」により微調整します。これは「トップダウン」式
開発手法とは異なり、シミュレーションとラピッドプロトタイピングによる早期
フィードバックが重要な要素となります。
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図 2-1 ソフトウェアファンクションのモデルベース開発

2.1.1 制御アルゴリズム開発

初の工程は制御アルゴリズムの開発で、これは主に制御工学的な作業となりま
す。まずは制御対象システム（「プラントモデル」と呼ばれます）を動的に分析す
ることから始めます。プラントモデルは、車両（センサやアクチュエータなど）
とその環境（道路状態など）、およびドライバーで構成されます。一般的には、パ
ワートレインを含むエンジンとドライバー、あるいはシャシーと道路状態、と
いったさまざまなパターンに応じて、車両の各サブシステム（コンポーネント）
について考察します。これらのモデルは、分析的に解決される微分方程式などを
用いた「分析的モデル」と、数値的に解決される積分方程式による「シミュレー
ションモデル」のいずれかですが、実際には、大抵のプラントモデルは両者の混
合したものとなります。

ソフトウェアファンクションのモデルベース開発の手法

ソフトウェアファンクションのモデル ドライバ、車両、環境のモデル

論理システム
アーキテクチャ

物理システム
アーキテクチャ

ソフトウェアファンクションの実装 ドライバ、車両、環境

1. ソフトウェアファンクション、およびドライバ／車両／環境のモデリング

2. 実車を用いたソフトウェアファンクションのラピッドプロトタイピング

3. ソフトウェアファンクションの設計と実装

4. 実験車両やテストベンチを用いたソフトウェアファンクションの統合と検証

5. 実車を用いたソフトウェアファンクションの検証と適合
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次に、一定の品質基準に基づいた「制御規則」が適用されます。制御規則はプラ
ントのダイナミクスを補うものであり、数多くの法則に基づく優れた制御規則を
利用することができます。自動車制御アルゴリズムは「閉ループ」の制御規則と

「開ループ」の制御方針を一体化して実現されることが多く、後者は多くの場合
オートマトンまたはスイッチング構造を採用したものです。このような制御アル
ゴリズムは、システム理論の観点から見ると「ハイブリッド」なシステムである
と言えます。一般的に、制御規則は「制御機能」と「監視機能」を併せ持つ

「セットポイント生成」ファンクションであり、それらの機能はすべてソフトウェ
アにより実現されます（「ソフトウェアによる制御アルゴリズムの実現」という項
を参照してください）。ここでの第 1 ステップは、シミュレーションモデルにより
表現される車両サブシステムを対象とする制御アルゴリズムを設計することです。
ここでは制御アルゴリズムとプラントモデルはどちらもコンピュータ上で実行さ
れます。一般にプラントは疑似連続系モデルとして設計され、制御アルゴリズム
は離散系モデルとして設計されます。どちらのモデルも値の範囲は連続的なので、
制御アルゴリズムとプラントが使用する状態変数とパラメータは、シミュレー
ションコード内では浮動小数点変数として実現されます。このモデルは 15 ペー
ジの図 2-1 の上の部分に示されています。ここに示される「論理システムアーキ
テクチャ」は、ドライバー、車両、および環境のモデルに結合される制御アルゴ
リズムを表すものです。1 の矢印は制御アルゴリズム設計の段階を表し、制御ア
ルゴリズムのモデリングは「共有信号の使用」という観点において行われます。
つまり、あるコンポーネントが信号の提供役となり、他のコンポーネントが同じ
信号の要求役となることにより、信号を共有します。

ソフトウェアによる制御アルゴリズムの実現

制御アルゴリズムは「ハイブリッドシステム」、つまり、閉ループシステムと開
ループシステムの混成体で、ほとんどの場合、開ループ部は有限ステートマシン
のような非線形の離散システムです。制御アルゴリズムをマイクロコントローラ
上で実行するには順次プログラミング言語（C 言語など）に変換する必要があり
ますが、これを も容易に実現する方法は、割込みによりトリガされるメイン
ループを作り、そのループの中で順次プログラムを内包する複数のサブルーチン
を呼び出すというものです。サブルーチン間のデータ交換はグローバル変数によ
り行います。割込みがメインループをトリガするたびに順次プログラムが繰り返
し実行されるので、「タイミング割込み」を使用すれば、メインループで「サンプ
ル値システム」を実現することができます。

しかしこのように制御アルゴリズムをソフトウェアでストレートに表現する方法
は、「マルチレートシステム」（複数のサンプルレートを必要とするシステム）を
実現するには限界があり、そのようなシステムは、1 つのメインループの代わり
に複数のタスクを使用して実現する必要があります。このような「マルチタスキ
ングシステム」においては、信号データがタスク間で適切に交換されなければな
りませんが、状態変数、パラメータ、入力／出力信号などを C コードレベルで確
実に扱うことは容易ではありません。そこで、制御アルゴリズムを ASCET で作成
することにより、このような制御アルゴリズムの「制御工学的視点」と「実装的
視点」のギャップを埋めることが可能となります。ASCET においては、C コード
のように変数とサブルーチンを単純に使用するのではなく、以下のような「構造」
を用いて制御アルゴリズムをモデリングします。

• モジュール
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• クラス

• プロジェクト

これらの構造を組み合わせることにより、さまざまなターゲット上で複雑な制御
アルゴリズムを構築し実行することができます。「ターゲット」とは制御アルゴリ
ズムが実行されるシステム、つまり PC やラピッドプロトタイピングシステム、
または ECU のマイクロコントローラを指します。実行する際は、まず ASCET モ
デルを汎用的な C コードに変換し、その C コードを各ターゲット上で実行可能な
コードに変換します。その際に使用されるすべての「モデリング構造」は、デー
タベース内で維持管理されます。

モジュール

「モジュール」は、（状態）変数、パラメータ、入力／出力信号に対する順次ス
テートメント（つまりそれらのアイテムに対して順に実行される命令文）を定義
するためのものです。「順次ステートメント」は、ブロックダイアグラムエディタ

（BDE）において、変数に割り当てられた「シーケンスコール」によって定義され
ます。つまり、順番が定義された各シーケンスコールにより式の結果が変数に代
入されます。また複数の順次ステートメントを 1 つの「プロセス」（サブルーチン
に相当します）にまとめることができます。なお ASCET では、ステートメントの
記述方法として BDE の代わりに「ESDL プログラミング言語」を使用することも
できます。

入力信号は「受信メッセージ」としてモデリングされ、受信メッセージの値を式
に読み込んで計算することができます。出力信号は「送信メッセージ」としてモ
デリングされ、式の結果を送信メッセージに代入する（書き込む）ことができま
す。ブロックダイアグラムエディタでは、メッセージへの代入は、変数の場合と
同様にシーケンスコールにより表されます。

「パラメータ」は独特な表現形式を持っています。パラメータの値を式に読み込む
ことはできますが、パラメータに値を代入することはできません。

以上をまとめると、モジュールは送信メッセージと受信メッセージを使用して他
のモジュールとデータ交換を行います。また、モジュールは複数のプロセスを持
ち、プロセスには任意の数の順次ステートメントが含まれます。モジュールには
メッセージ以外に変数やパラメータも内包されます。受信メッセージから読み込
んだ値はモジュール内のプロセス間で共有できますが、送信メッセージへの書き
込みには各プロセス間の排他的アクセスが必要です。1 つのモジュール内のプロ
セス間でしか交換されないメッセージが存在する可能性もあり、そのような専用
メッセージは「送受信メッセージ」と呼ばれます。

クラス

プロセスが実行される際、内部変数（制御アルゴリズムの状態など）を処理する
ためにデータを保存する必要が生じる場合があります。コンピュータサイエンス
の観点から、内部変数はいくつかの型に分類され、複数の型を組み合わせて「複
合型」を作成することもできます。複合型のエレメントについてはステートメン
トを定義することができ、各処理を合わせて複数のサブファンクションまたはメ
ソッドを形成することができます。このうち「メソッド」は引数を取ることがで
き、通常のデータ操作で複合型のデータエレメントにアクセスすることができま
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す。このようなメソッドを伴う複合型を「クラス」と呼びます。クラスは「型」
のひとつであるため、変数を定義する場合と同様に「インスタンス化」が可能で
す。ASCET では、変数およびクラスのインスタンスをクラスまたはモジュールの
中に定義することができます。

あるクラスを別の（= 外側の）クラスのスコープ内のインスタンスとして定義す
ることにより、インスタンス化されたクラスのメソッドを外側のクラスのメソッ
ドから呼び出すことができます。このようにしてメソッド（たとえばフィルタリ
ングアルゴリズムなどの計算を実現するメソッド）をインスタンス化することに
より、その計算結果を呼び出し側のメソッドの計算の中で利用することができま
す。このメカニズムを利用すれば、制御アルゴリズムを「型定義されたオブジェ
クト階層」として表現することができます。トップレベルのクラス、つまり他の
クラス内でインスタンス化されていない も外側のクラスのメソッドを呼び出す
と、「メソッドの出力値」という結果が得られますが、その結果を算出する際は、
組み込まれているメソッドインスタンスが順次呼び出され、後続の計算に利用さ
れます。このことから、「トップレベルメソッドの実行」はオブジェクト指向プロ
グラムの「順次実行」に相当することがわかります。

パラメータ

「パラメータ」を情報工学的に説明すれば、「プログラムからは読み込みのみ可能
で、書き込みできない特殊な変数」ですが、自動車制御工学の見地から説明する
と「制御アルゴリズムを特定の車両に合わせて調整するために使用されるデータ」
となります。パラメータの値は制御アルゴリズムの実行開始前に設定され、その
値は制御アルゴリズムの実行中には変化しません1。しかしそれでもパラメータは

「変数」の特殊な形であるため、変数と同様の方法で分類することができます。

クラスにはパラメータを定義することができ、その際、パラメータは複合型（ク
ラス）に含まれる 1 つの要素として表現されます。クラスは複数回インスタンス
化できるので、そこに定義されたパラメータも複数回存在することができます。
しかし原則として、パラメータは読み取り専用メモリ内に存在し、起動時に専用
メソッド（コンストラクタなど）により初期化されることはありません。値の初
期設定は実行に先立って（設計時などに）行われ、その際に設定されたパラメー
タ値のセットを「データセット」と呼びます。設計時にパラメータ値を挙動クラ
スのインスタンスに割り当てる場合、データセットを特定のインスタンスに関連
付けて設定する必要がありますが、ASCET では、クラス設計時に仮インスタンス
用のデータセットを定義しておき、特定のインスタンスへのデータセットの関連
付けは、各インスタンスの作成時に行います。

モジュール内でのクラスの使用

上述のように、制御アルゴリズムの順次実行はトップレベルクラスのメソッドを
呼び出すことから始まります。この「メソッド呼び出し」はプロセスの実行によ
り開始されます。一般に、メソッドの引数はプロセスの受信メッセージにより供給
され、メソッドの戻り値は送信メッセージに供給されます（さらにこれらのメソッ
ドにもモジュールの内部変数から値が供給される場合があります）。

1. 「アダプティブパラメータ」についてはここでは考慮しません。
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リアルタイム処理の観点から見ると、トップレベルクラスのメソッドを呼び出す
プロセスは、カプセル化されたインスタンスに属するメソッドの「呼び出しス
タック」を形成します。「リーブインスタンス」（“leave instance”）のメソッド
も、そのプロセスがマッピングされているタスクのコンテキストで実行されます。
メソッドの呼び出しスタックを深くするとイベントの反応性が低下してしまうた
め、クラスを設計してリアルタイムコンポーネントに組み込む際には、オブジェ
クト指向の再利用性とタスクスケジュールの反応性のバランスを調整する必要が
あります。

プラントモデリングのための連続系ブロック

ASCET には連続系モデルのための専用ブロックが用意されています。これらの
「連続系ブロック」（CT ブロック）には以下の 2 種類があります。

• エレメンタリブロックをグループ化した「構造ブロック」

• エレメンタリシステムのダイナミクスを定義した「基本ブロック」

基本ブロックは下に示す標準形の非線形システムを想定し、動的挙動をオブジェ
クト指向形式で定義したものです。

 

メソッドには、初期化メソッドと終了メソッド、f を実現するための入力／更新／
デリバティブメソッド、さらに g を実現するための直接的／間接的な出力メソッ
ドと間接出力メソッドがあります。さらに、状態イベント検知メソッドや、状態
イベント発生時に実行する処理を記述するイベントメソッドもあります。それ以
外にも重要なものとして、従属パラメータを解決するためのメソッドがあります。
式は ESDL と C のどちらの構文でも記述できます。

x· f x y,( )=
y g x u,( )=
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閉ループシミュレーション用プロジェクト

ECU ソフトウェアは、相互通信を行う一連のモジュールとオペレーティングシス
テムとで構成されます。オペレーティングシステムの「コンフィギュレーション」
にタスクとそのスケジュールを定義し、オペレーティングシステム自体はタスク
とメッセージを実現します。「タスクスケジュール」にはプロセスのタスクへの割
り当て情報が含まれます。PC で閉ループシミュレーションを実行する場合は、制
御アルゴリズムのリアルタイムコンポーネントに CT ブロック（19 ページの「プ
ラントモデリングのための連続系ブロック」という項を参照してください。）がア
タッチされます。リアルタイムコンポーネントと CT ブロックのメッセージ間の
バインディングは、「名前」によるものではなく明示的に、つまりポートをグラ
フィカルに接続することにより行われます。CT ブロックのメソッドは数値的な積
分アルゴリズムから呼び出されます。積分アルゴリズムは、 終的なオペレー
ティングシステムコンフィギュレーション内の独立したタスクとして実行されま
す。

プロセスがタスクに割り当てられて適切な CT ブロックタスクの作成が終わると、
OS コンフィギュレーションが実行形式のコードに変換されます。PC 上での閉
ループシミュレーションの場合、適切なイベントキューと数値ソルバを備えたシ
ミュレーション環境が生成されます。ただしこのシミュレーション環境は「リア
ルタイム実行環境」ではありません。

2.1.2 ラピッドプロトタイピング

一般的に、設計時に使用されるプラントモデルは、設計工程全体にわたって一環
して参照できるほど詳細には定義されていないため、モデルではなく実車を使用
しての制御アルゴリズムの検証は欠かせません。この検証工程において、制御ア
ルゴリズムは初めて「リアルタイム」で実行されることになります。ソフトウェ
アコンポーネントのエントリ（実行開始）ポイントはオペレーティングシステム
タスク内にマッピングされますが、それ以外に、ハードウェアアクセス専用のソ
フトウェアコンポーネントを作成して制御アルゴリズムのソフトウェアコンポー
ネントに接続する必要があります。この工程は、15 ページの図 2-1 では、実際の
環境でドライバーが運転する自動車と論理システムアーキテクチャの結び付け

（図の矢印 2）として表されていて、ここではさまざまな方法が考えられます。1
つめは、自動車とのインターフェース専用の I/O ボードを備えた専用の「ラピッ
ドプロトタイピングシステム」を使用する方法です。ラピッドプロトタイピング
システム（「RP システム」とも呼ばれます）は高性能のプロセッサボードと I/O
ボードとで構成され、各ボード間は内部バスシステム（VME など）により接続さ
れています。一般に、これらのプロセッサボードは製品用 ECU とは異なり、浮動
小数点演算ユニットを備え、ROM や RAM の容量も大きく、高性能なものです。
バス接続された I/O ボードを介してセンサやアクチュエータとインターフェース
を取るので、さまざまなユースケースに柔軟に対応できます。この工程において
は、「ECU の生産コスト」よりも「制御アルゴリズムのラピッドプロトタイピン
グ」に重点が置かれます。

上記のようなラピッドプロトタイピングシステムにおいては、インターフェース
要件は、多くの場合、ボード上の専用回路で実現されます。しかしこれには柔軟
性に限界があるため、代わりに従来の ECU とそのマイクロコントローラペリフェ
ラル、およびその他の ECU エレクトロニクスを使用してセンサ／アクチュエータ
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とのインターフェースを実現するという方法も考えられます。それにより、I/O
ハードウェア抽象化レイヤのソフトウェアコンポーネントを後のシリーズ生産で
再利用できるという副次的効果が得られます。図 2-2 は制御／監視ファンクショ
ンがバイパスシステム上で稼働し、そのバイパスシステムがセンサとアクチュ
エータを介して自動車に接続されているようすを示しています。

図 2-2 典型的なラピッドプロトタイピングシステム

図 2-2 に示すようなバイパス構成におけるラピッドプロトタイピングでは、ECU
のマイクロコントローラのペリフェラルを使用してセンサとアクチュエータを駆
動します。つまり、I/O ドライバは製品用 ECU 上で稼働し、制御アルゴリズムは
ラピッドプロトタイピングハードウェア上で実行されます。3 つの信号 W、R、U
はデジタル値で、それぞれセットポイント、プラントの反応をサンプリングした
値、デジタルアクチュエータ信号を表します。アクチュエータ信号は、ドライ
バーの希望 W* に合った状態で車両を動作させるための電気的または機械的信号
Y に変換されます。W はサンプリングされたデジタル信号です。機械的または電
気的信号 X で表される車両の状態がサンプリングされ、デジタル信号 R として制
御アルゴリズムに供給されます。さらに、道路条件などのノイズ信号 Z が存在し、
これは測定される入力信号とは異なり、制御アルゴリズム内で直接考慮されるも
のではありませんが、車両の挙動に影響を与えます。RP システムは、プロセッサ
ボードと専用の通信ボードのみを使用し、その他の車両信号を直接使用すること
はありません。センサ値 R、セットポイント値 W、アクチュエータ値 U はハイス
ピードリンクで送信されますが、一般的な ECU ハードウェアにはハイスピード
通信リンクに対応する専用回路が装備されています。

ソフトウェア開発の観点から見ると、製品 ECU 上で稼働する既存のソフトウェア
と、新たに開発された制御アルゴリズムにおける「構造化されたインターフェー
ス」により、ラピッドプロトタイピングの効率は大幅に向上します。

車両

ドライバー 環境

セットポイント アクチュエータ
制御対象

センサ
システムジェネレータ

コントローラ
／モニタ

ECU 実験システム
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リアルタイム I/O モジュール

「ラピッドプロトタイピング実験」には、高性能マイクロプロセッサに加えて通信
と I/O のための専用のハードウェアが必要です。ETAS の ES1000 ファミリの場
合、さまざまな機能を実現するための VME ボードを使用でき、システム内通信
は VME バスにより行われます。

このようなラピッドプロトタイピングシステムは、構成を柔軟に変更できる「組
み込みシステム」であるといえます。通信と I/O ハードウェアの機能を実現する
にはハードウェアと制御アルゴリズムを結びつける「基本ソフトウェアモジュー
ル」が必要ですが、ASCET においては、これらすべての基本ソフトモジュールは

「リアルタイム I/O」と呼ばれる 1 つの ASCET モジュールで表現されます。たと
えば、CAN バッファから信号を読み込んでそれを送信メッセージとして提供する
プロセスがある場合、このプロセスはオペレーティングシステムタスクの中で

「スケジュール」されますが、その際に使用する信号名と CAN フレーム ID を事
前に専用エディタで設定しておくことができます。

制御アルゴリズムを ETAS ラピッドプロトタイピングシステム上でテストする際
は、コンフィギュレーションパラメータに基づいてこの「リアルタイム I/O モ
ジュール」を生成する必要があります。このモジュールは汎用的な ASCET の C
モジュールとして表現されるのので、これが他のリアルタイムコンポーネント、
つまり、一般的な ASCET モジュールにアタッチされることにより、実行可能なラ
ピッドプロトタイピング制御アルゴリズムができあがります。

ラピッドプロトタイピング用のプロジェクト

ラピッドプロトタイピング用のプロジェクトには連続系ブロックで表現されるプ
ラントモデルは内包されません。その代わりにリアルタイム I/O モジュールが内
包され、ラピッドプロトタイピングプロジェクト用に設定されます。このモ
ジュールは、モデルレベルにおいてはメッセージにより制御アルゴリズムモ
ジュールと通信を行います。そのため、リアルタイム I/O モジュールのコンフィ
ギュレーションに応じた複数のプロセスがオペレーティングシステムタスクに
フックされます。

2.1.3 制御アルゴリズムの実装と ECU への統合

ラピッドプロトタイピングの工程を経た制御アルゴリズムは、実車 に対しても有
効なものとなります。ただしラピッドプロトタイピングシステム用に生成された
コードは、RAM リソースや浮動小数点ユニットなど、専用プロセッサボードの強
力な機能を使用することを前提としています。それをメモリ容量や演算能力が限
られた条件下で実行できる制御アルゴリズムにするためには、制御アルゴリズム
のモデルの再設計が必要となります。たとえば、計算式を浮動小数点から固定小
数点の制御アルゴリズムに変換し、効率、スケーラビリティ、モジュール性と
いったさまざまな制限事項に対処する必要があります。このようにして再設計さ
れたデザインを用いて、適切な製品用コードが自動生成されます。
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浮動小数点から固定小数点への変換

自動車などの「物理プラントモデル」においては、車速と加速度、冷却液温度、
ヨーレート、バッテリ電圧などの「物理量」が扱われますが、シミュレーション
モデルにおいてこれらの物理量は 64 ビットまたは 32 ビットの float 型変数で表
現されます。シミュレーションモデルは閉ループ制御システムであるため、車両
モデルと制御アルゴリズムモデルはどちらも浮動小数点で表現される必要があり
ます。しかし、実際には浮動小数点ユニットは高価であるため、一般の車載マイ
クロコントローラには使用されません。つまり、制御アルゴリズムを車載マイク
ロコントローラに実装するためには、浮動小数点から固定小数点への変換が必要
となります。

例 : 冷却液温度の範囲を -50 ℃～ 150 ℃とします。これらの値を直接 16 ビッ
ト整数に実装するのでは極めて非効率的です。これでは図 2-3(a) に示すように
16 ビットで表現できる範囲の 0.3％しか使用されず、温度の分解能は 1 ビット
=1 ℃となってしまい、測定された温度が 83.4 ℃であっても制御ソフトウェア内
では 80 ℃として表現されてしまいます。

これを、図 2-3(b) に示すように測定値に 217.78 を掛けることにより、分解能を
1 ビット当たり約 0.0046 ℃に変えることができます。しかしこの変換は単なる

「浮動小数点の乗算」であるため、適切なものとはいえません。

別の方法として、分解能を 1 ビット当たり 0.0078125 ℃に設定する方法があり
ます。この乗算は 7 ビットの左シフト演算により表現できます。この演算を温度
範囲に当てはめると、-6400 から 19200 までのビットパターンが得られるので、
16 ビット整数型の値の範囲の 39％が使用されることになります。このスケーリ
ングを図 2-3(c) に示します。

またさらに、符号なし 16 ビット整数値を使用し、1 ビット当たり 0.00390625
℃という分解能に加えて「オフセット」を併用することにより、使用率をさらに
高めることができます。オフセットを -12800 に設定した場合、温度範囲は -
12800 ～ 38400 となり、51200 個の値の範囲を使用できることになり、使用率
は図 2-3(d) に示すように 78％を超えます。ただしここではオフセット計算のた
めの減算処理が必要になります。
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図 2-3 スケーリングなしのマッピング (a)、任意マッピング (b)、27 スケーリン
グ (c)、28 スケーリングとオフセット (d)

この関係は下の線形関係で表現できます。

Impl_value = f_impl(phys_value) = 
phys_value*256+12800

または、以下のように一般的な形で表現することもできます。

impl=scal * phys_value + x

上の式の scalがスケーリングファクタで、xがオフセットです。分解能はス
ケーリングファクタの逆数になるので、物理値は以下の式の実装値で表されます。

phys_value = impl_value / scal - ofs

固定小数点数の演算

変数に実装変換式（“implmentation formula”）を定義すると、その変数を扱う
メソッドやプロセスのステートメント、つまり式や代入文に影響を与えます。以
下のような、物理値を表す 2 つの変数を用いた単純な代入文でさえも、実装情報

（“implementation"）、つまり割り当てられた実装変換式が異ると、単純な演算で
はなくなってしまいます。

a = b

a と b を符号なし 8 ビット変数（値の範囲 : 0 ～ 255）として、それぞれに以下
の実装変換式を適用してみましょう。

a = 2 * a_impl, b = 3 * b_impl
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すると、a の物理値の分解能は 2 になり、b の物理値の分解能は 3 になります。
この実装情報に基づいて代入 a=b を表すと、以下のようになります。

2* a_impl = 3* b_impl

これを以下のように単純に移項してみます。

a_impl = (3 / 2)* b_impl

このように、元のステートメント a=bから、a_impl = (3/2) * b_implと
いうステートメントが得られました。実装変換式1 は、定数を用いた単純な算術演
算です。しかし、 大精度を実現するための一連の演算においては注意が必要で
す。もし上の式のとおりに 初に除算を行ってしまうと、除算は整数で行われる
ため、結果に約 50％の誤差が生じ、変換式が効果的でなくなってしまいます。こ
の変換には、以下のようなステートメントの方が適しています。

a_impl = 3 * b_impl / 2

物理変数を扱うステートメントにおいて、このように調整された実装変換式を
使用する場合でも、一般的に、さらにいくつかの要素を考慮する必要がありま
す。

まずは「オーバーフロー」の問題です。上の式において 初に 3 をかけると、
b_implが 255/3=85 より大きい場合はオーバーフローが発生します。同様に、
アンダーフローと丸め誤差についても注意が必要です。先に 2 で割ると、右シフ
ト演算が行われ、 小桁のビットが失われてしまいます。これでは b_implの値
が 1 または 0 である場合には値の区別がなくなり、どちらの場合も a_impl（つ
まり a）には 0 が代入されてしまいます。また事実上、a=bという代入は物理範
囲が同じ（ここでは 0 ～ 510）である場合に限り意味をなすことから、b_impl
には 510/3=170 という 大値が想定されますが、これではオーバーフローが発
生する可能性があるため、それを回避しなければなりません。この対策として、
コード生成時にケースごとに処理を選択するという方法が考えられます。つまり、
b_implが 170 以下の場合は先に乗算を行い、b_implが 170 より大きい場合
は先に除算を行うようにするのです。しかし、そのためには余分なコードが必要
になってしまいます。そのためここでは、値の範囲全体において 大精度 1.5 の
許容誤差を受け入れる、ということが必要になってしまいます。一般的に、複雑
な結合や式を用いる場合は言うまでもなく、オペランドの少ない通常の算術演算
の場合でもこれ以上に困難な状況となる可能性は十分にあります。

C コードのクラスとモジュール

レガシーコードの再利用やマイクロコントローラのペリフェラルアクセスを行う
ような場合、内部挙動が C コードで記述されたメソッド（またはプロセス）を含
むクラス（またはモジュール）を定義する必要が生じる場合があります。C コー
ドクラスと C コードモジュールのコードには実装情報が含まれ、このコードを
ターゲット用実行プログラムに順に組み込んでいきます。つまり C コードクラス
と C コードモジュールはターゲットに依存しているので、プロジェクトのター
ゲットを変更する場合は、変更後のターゲットに合った C コードを作成しなおす
必要があります。

1. 少なくとも ASCET がサポートする変換式の場合
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組み込みマイクロコントローラ用プロジェクト

上述のように、C コードクラスと C コードモジュールはマイクロコントローラの
ペリフェラルにアクセスすることができます。ASCET プロジェクトエディタでは
オペレーティングシステムの設定と生成を行えるため、制御アルゴリズムを記述
したモジュールを含む組み込みマイクロコントローラ用プロジェクトを「統合プ
ラットフォーム」として使用することができます。この際、コードジェネレータ
は、OS スケジュールやモジュール間メッセージ通信を調べてタスクやメッセージ
を生成し、さらにプロセスからメッセージへのアクセスコード1 を生成します。
こうしてでき上がったプロジェクトとそのすべての内包モジュールの C コード
は、マイクロコントローラに書き込むための .hexファイルに変換され、その際、
すべての測定変数と適合変数（パラメータ）が定義された ASAP2 ファイルも生
成されます。

ただし製品 ECU 用の生成時には専用のビルド環境と基本ソフトウェアモジュール
が使用される場合も多く、そのような場合は、アプリケーションソフトウェア、
つまり制御アルゴリズムのモデリングのみを ASCET2 で行います。この場合は、
プロセスのアクセスコードを含むメッセージとタスクボディ、つまり OS エディ
タで定義されたプロセスのシーケンスが生成されるので、このタスクボディを外
部の OS コンフィギュレーションエディタにコピーします。

2.1.4 各種プロジェクトにおける制御アルゴリズムの再利用

ASCET のモデリングエレメントはすべてデータベース内で管理されますが、同じ
制御アルゴリズムを使用するプロジェクトでも、ターゲットが異なればモジュー
ルの数や種類が異なります。

• 閉ループシミュレーション用プロジェクト : 制御アルゴリズム用のモ
ジュールと CT ブロックを参照します。

• ラピッドプロトタイピング用プロジェクト : 制御アルゴリズム用のモ
ジュール（閉ループシミュレーションの場合と同じモジュール）とリアル
タイム I/O モジュールを参照します。リアルタイム I/O モジュール用のコ
ンフィギュレーションデータはプロジェクトに保存されます。

• 組み込みマイクロコントローラ用プロジェクト : 制御アルゴリズム用のモ
ジュールとペリフェラルアクセス用のモジュール（C コード）を参照しま
す。固定小数点コードが必要な場合、モジュール、クラス、プロジェクト
に実装変換式を定義する必要があります。またコードを生成する前に、プ
ロジェクトに適した実装情報を選択する必要があります。

ASCET プロジェクトは PC、ラピッドプロトタイピングシステム、プロダクショ
ン ECU3 などさまざまなターゲット上で実行できますが、PC またはラピッドプロ
トタイピングシステム上で実行される際は、ASCET の統合実験環境（EE）を使用
して実験を行います。また ECU を使用した実験の場合は、実車で行う制御アルゴ
リズムの適合作業（ファインチューニング） 4 と同様、測定／適合システム INCA5

を用いて行います。

1. 一般的にはマクロで実現されます。
2. このユースケースは「additional programmer」と呼ばれます。
3. または評価ボード
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ソフトウェアの面から見ると、実験には以下の 4 種類のタイプがあります。

1. 物理実験

2. 量子化実験

3. 実装実験

4. オブジェクトベースのコントローラ実装実験

「物理実験」には実装情報は必要ありません。「量子化実験」には量子化が必要で、
「実装実験」と「オブジェクトベースの実装実験」にはさらに整数の基本型と限界
値についての情報が必要です。ASCET の制御アルゴリズムモデルを構成するス
テートメントから生成されるコードは、ターゲットと実験のタイプに応じて異な
ります。「物理実験」においては、物理ステートメントが real64 の変数で表現さ
れるので、量子化の影響はありません。「量子化実験」でも real64 の変数が基礎
に使用されますが、物理ステートメントに量子化の影響が付加されます。「実装実
験」では実装情報が使用され、整数型がベースとなります。つまり実装実験用に
生成されるコードの変数には、実装情報として指定されている基本型が使用され、
物理ステートメントは実装変換式に基づく実装ステートメントに変換されます。

「オブジェクトベースのコントローラ実装実験」では、実装実験の型と実装ステー
トメントが使用されますが、モジュールとクラスの構造は別の形で表現されます。
ASCET 内の各変数には基本型、限界値、実装変換式だけでなく、マイクロコント
ローラのメモリレイアウトが反映された「メモリクラス」も定義できます。しか
し前述のように、オブジェクトベースのコントローラ実装実験は製品 ECU 用でし
か行えないうえ、オンライン実験は INCA などの測定／適合ツールでしか行えま
せん。

PC またはラピッドプロトタイピングターゲットを使用し、かつ基本型、限界値、
オフセット、量子化に関するすべての実装情報がすべてのエレメントに定義され
ている場合は、実験のタイプを切り替えるだけで、物理環境における実装変換式
や整数基本型の作用を観察することができます。

2.1.5 実験室における技術システムアーキテクチャのテスト

実装／統合工程の結果として、物理的システムアーキテクチャ、つまり「ECU
ネットワーク」ができあがります。これらの ECU のテストはプラントモデルを使
用してリアルタイムに行われます。プラントモデルは、センサ／アクチュエータ
のモデルや専用ボードを使用することにより、本来は ECU の電装部品から取得さ
れる電気信号をシミュレートできます。このようなシステムは Hardware-in-the-
Loop システム（HiL）と呼ばれ、プロセッサボードと I/O ボードとで構成されま
す。プラントモデルには典型的な運転操作をシミュレートするさまざまな値が初
期設定されていて、HiL 上で運転操作がシミュレートされることによって ECU に

4. 実験用の ECU リソースには限りがあるので、特別な対応が必要になります。これに

ついては本書では説明しません。
5. ASCET プロジェクトが CT ブロックだけを含み、そのプロジェクトが PC またはラ

ピッドプロトタイピングシステム上で実行される場合、LABCAR OPERATOR の EE
を使用します。
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対するセンサデータが出力され、さらに ECU からアクチュエータデータが入力さ
れます。このようにして ECU が正しく統合されたかどうかを調べることができま
す。HiL テストは 15 ページの図 2-1 の矢印 4 で示されている部分です。

2.1.6 実車における技術システムアーキテクチャのテストと仕上げ

前述のように、一般的なプラントモデルは車両のダイナミクスを完全に表せるほ
ど詳細化されていません。今日では適合作業の多くを HiL システムで行えますが、
車両の制御アルゴリズムの 終仕上げは実車の製品 ECU に組み込まれた製品ソフ
トウェアで行う必要があります。このためには、物理システムアーキテクチャを
実車に組み込み、性能試験場でテストを行う必要があります。この 終工程にお
いては制御アルゴリズムのパラメータ値の微調整のみを行います。

2.2 生産環境における ASCET の利用

図 2-4 高度なソフトウェア生産環境

典型的な「ハンドコーディング環境」においては、複数のソフトウェア開発者に
よって、制御アルゴリズム用、およびオペレーティングシステムを含む基本ソフ
トウェアモジュール用の C コードが作成されます。さらに、「ECU インテグレー
タ」の役割を持つ担当者がすべてのソースコードファイルを集め、コンパイラと
リンカを起動する「Make ツールチェーン」を実行します。C コードはソフト
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ウェア開発者間でファイルシステムやソースコード管理（SCM）システム1 を介
して受け渡されます。「SCM」はさまざまなバージョンのソースコードファイル
を保持しながらコンフィギュレーションの作成と維持管理を行うことのできる
データベースです。これは ECU ソフトウェアの生成／統合のベースラインとして
使用されます。C コードファイルの 2 つのバージョン間の相違を調べる際は、

「ディファレンスブラウザ」を用いてプログラムテキスト内の相違点を強調表示さ
せることができます。この 10 年程の間に SCM システムとディファレンスブラウ
ザは広く使用されるようになり、それによって自動車組み込みソフトウェアの品
質が大幅に向上しました。

高度なソフトウェア生産環境においては、一部の制御アルゴリズム用 C ファイル
は制御アルゴリズムモデル（実装情報が設定された ASCET モデルなど）から生成
されますが、多くの基本ソフトウェアモジュール用 C ファイル（OS や COM ス
タックなど）はいわゆる「コンフィギュレータ」により生成されます。このよう
な高度な生産環境の例（ASAM-MCD-2MC ファイルの生成工程を除く）を
28 ページの図 2-4 に示します。ここには C コード生成環境と、SCM データベー
スおよび Make システムが示されています。このような高度な生産環境をさらに
詳しく検討し、ASCET による制御アルゴリズム用 C コードのモデルベース生成に
注目すると、モデルは、ソースコードの基礎となるものでありながら、一方では
制御アルゴリズム開発の過程でラピッドプロトタイピングの結果を反映して進化
していくものであることがわかります。したがって、モデルも SCM データベー
スで維持管理することが必要となります。

ASCET コンポーネントはローカルデータベースに保存され、1 つのローカルデー
タベースにはモデルの 1 つのバージョンだけが保存されますが、「ASCET-SCM イ
ンターフェース」はローカルデータベースから SCM レポジトリ（= 貯蔵庫）への
リンクを確立し、バージョン間のモデルの交換を可能にします。このモデル交換は
30 ページの図 2-5 の (a) に示されています。ソースコード開発ではバージョン間
のディファレンスブラウジングが不可欠ですが、モデルベース開発においてもそ
れは同じです。ASCET-SCM インターフェースを「Model-Diff-Browser」で強化
すれば、たとえばモジュールのブロックダイアグラムエディタ内に追加された
メッセージなどが強調表示されるようにすることができます。

2.2.1 モデル変換

組み込みリアルタイムソフトウェアの開発は制御エンジニアとコンピュータエン
ジニアの両者により進められます。開発工程においては、制御ソフトウェアの開
発を「挙動ドリブン」の観点から始める場合と、「構造ドリブン」の観点から始め
る場合があり、さらには両方の観点から始める場合もあります。ASCET（および
AUTOSAR）の垂直アプローチにはこの両方のアプローチが統合されていますが、
純粋に挙動的または構造的なアプローチによるモデルを使用する必要がある場合
も考えられます。

「挙動的」な方法をとる場合、閉ループ制御アルゴリズムのモデリングには 
MATLAB®/Simulink® を使用するのが一般的です。それは、少なくとも PC シミュ
レーションを行う際に問題となる多くの構造体関連の詳細事項に煩わされること

1. 一般的な SCM システムとして、CVS や SubVersion があります。
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がないためです。そして PC シミュレーションを実行した後は、制御アルゴリズ
ム部はブロックダイアグラムの形式で ASCET のモジュールまたはクラスに引き継
がれ、プラント部は ASCET CT ブロックとして表現されます。

図 2-5 ASCET-SCM インターフェース。ディファレンスブラウジング機能があ
る場合（b）とない場合（a）

「構造的」な方法をとる場合は、UML の 1.4 または 2.0 が一般的に広く使用され
ています。非常にシンプルなクラスとオブジェクトのダイアグラムに加えて、イ
ンタラクションおよびコラボレーションのダイアグラムを使用して車両アクセス
システムや診断などの複雑なインタラクションを表記できます。ただしクラス、
オブジェクト、およびそれらのインタラクションについては、ASCET モデルの中
で改良されています。ASCET では、シーケンスコールによって、UML に相当す
るもの（つまりクラスとオブジェクト）にオブジェクトインタラクションが反映
されます。これらのオブジェクトを ASCET リアルタイムオブジェクトの中に組み
込めば、UML モデルにリアルタイム的側面が加わるだけでなく、モデルをそのま
ま実行することが可能になります。
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ETAS のパートナーである Aquintos 社のモデルツーモデルコンバータ（M2M）
を使用すると、このような挙動的モデルや構造的モデルを ASCET 用に変換するこ
とができます。このコンバータは UML 1.4 製品および MATLAB/Simulink に対応
しています。

2.3 まとめ

ASCET は自動車組み込みソフトウェア開発のさまざまな段階において、制御アル
ゴリズムのモデルベース設計および実装をサポートします。抽象化の採用により、
物理的な制御アルゴリズムモデルを後続の開発工程全体におけるすべての実装情
報の基盤として使用でき、ターゲットを変更する際にブロックの交換などを行う
必要がありません。さらにディファレンスブラウジング機能付きの SCM イン
ターフェースを使用すれば、ECU 生産開発環境への ASCET の統合をさらにシー
ムレスに実現できます。
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3 ASCET と AUTOSAR

本章では ASCET の AUTOSAR 対応について説明します。3.1 項では AUTOSAR
の趣旨を概説し、続いて 3.2 項では AUTOSAR のランタイム環境（RTE）につい
て説明し、3.3 項で ASCET がサポートする AUTOSAR エレメントを紹介します。

本章は AUTOSAR 対応の概論についてのみ説明するもので、詳細については「付
録 C：AUTOSAR」をご参照ください。AUTOSAR から発行されているドキュメン
トは、AUTOSAR のホームページ（http://www.autosar.org/）からダウンロードで
きます。

3.1 概要

一般的に、自動車組み込みソフトウェアの開発工程において、複数のベンダーから
提供されるソフトウェアコンポーネントを複数のネットワークや ECU（電子制御
ユニット）、各種ソフトウェアアーキテクチャで構成される車両プロジェクトに統
合するには、非常な手間がかかります。また、ソフトウェアの「再利用性」に制限
があれば、高機能を持った検証済みの高品質なソフトウェア を提供するためには
多大な工数が必要となります。

このような状況の中で、車両メーカーとベンダーとのパートナーシップにより組
織された「AUTOSAR」では、主に基本的なシステムファンクションとファンク
ションインターフェースを標準化することにより、車両エレクトロニクス用ソフ
トウェアの共同開発の簡素化、費用低減、工期短縮、品質向上などを図り、さら
には安全関連システムの設計に必要なメカニズムの提供も目指しています。

これらの目標を達成するため、AUTOSAR では自動車組み込みソフトウェア用の
アーキテクチャを定義しています。このアーキテクチャには、各アプリケーショ
ンの機能を実装する「ソフトウェアコンポーネント」（SWC： AUTOSAR 
Software Component）が含まれていますが、この SWC は ECU に依存しないも
のであるため、再利用、交換、スケールの変更、統合が容易に行えます。

このように抽象化された SWC 環境は、「仮想ファンクションバス」（VFB： 
Virtual Function Bus）と呼ばれています。実際の AUTOSAR 対応の ECU 内にお
いてこの VFB は、各 ECU に依存するプラットフォームソフトウェアにマッピン
グされます。AUTOSAR「プラットフォームソフトウェア」の機能は、「ランタイ
ム環境」（RTE： Run Time Environment）と基本ソフトウェア（BSW： Basic 
Software）とに分けられます。BSW に含まれるものは、通信や I/O の機能のほ
か、各種ソフトウェアコンポーネントに必要な諸機能（診断やエラー報告、不揮
発メモリ管理など）です。
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3.1.1 RTA-RTE と RTA-OS

「ランタイム環境」は、ソフトウェアコンポーネント、BSW モジュール、オペ
レーティングシステム（OS）の間のインターフェースとなるものです。SWC の
相互接続においては、RTE は通信の「スイッチボード」のような役割を果たしま
す。この役割は、コンポーネントが単体の ECU に常駐する場合でも、車載バスに
よりネットワーク化された複数の ECU に常駐する場合でも同じです。

図 3-1 AUTOSAR ソフトウェアコンポーネント（SWC）の通信は、「ランタイ
ム環境（RTE）および基本ソフトウェア（BSW）」によって実現される

「仮想ファンクションバス（VFB）」経由で行われます。
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AUTOSAR では、OS は RTE を通じて SWC のランナブルエンティティを呼び出し
ます。アプリケーションソフトウェアの実行制御に関しては、基本ソフトウェア
の中でも RTE と OS がキーモジュールとなります。

ETAS は十余年にわたり、「ERCOSEK」、および現在の「RTA-OSEK」という 2 つの
車両用オペレーティングシステムを自動車業界に供給してきました。AUTOSAR
ランタイム環境「RTA-RTE」 、および AUTOSAR オペレーティングシステム

「RTA-OS」（2008 年第 3 四半期発売予定）は、AUTOSAR の主要ソフトウェアモ
ジュールをサポートし、RTA の機能範囲を拡張します。現行の RTA-OSEK は、
AUTOSAR OS Scalability Class 1 をサポートしています。

AUTOSAR インターフェースに準拠する RTA-RTE および RTA-OSEK は、サード
パーティベンダーの基本ソフトウェアモジュールをシームレスに統合することが
可能です。

3.1.2 AUTOSAR ソフトウェアコンポーネントの作成 

システムアーキテクチャや AUTOSAR インターフェースのディスクリプションを
作成するための AUTOSAR オーサリングツールに加え、ETAS のモデリングツー
ル「ASCET」を活用することにより、AUTOSAR に適合する制御機能の挙動を記
述し、実装することが可能となります。

ASCET モデルは、容易に AUTOSAR に適応させることができます。これは、
AUTOSAR コンセプトの多くの部分を ASCET のインターフェース記述と同じよう
な形式で定義することができるためです。実際に行う作業としては、各アプリ
ケーションのインターフェースを AUTOSAR に適合するように修正するだけで
す。従来のモデルを実際に適合させた事例からわかるように、現行バージョンの
ASCET バージョンでこの作業を行っても、それほど多くの所要時間は要しませ
ん。

なお ASCET V6.0 においては、AUTOSAR V2.1 に準拠する AUTOSAR SWC の記
述、および AUTOSAR 準拠 SWC の量産コード生成がサポートされます。

3.2  ランタイム環境とは

VFB（仮想ファンクションバス）は、ソフトウェアコンポーネントの再利用化の
ための抽象概念です。RTE（ランタイム環境）は、この VFB の機能を実行するた
めに必要なメカニズムを提供します。 もシンプルな RTE は、VFB を実装するだ
けでできあがりますが、実際には、各種インターフェースやインフラストラク
チャを用意して、ソフトウェアコンポーネントを以下のように扱えるようにする
必要があります。

1. ECU（VFB モデル）に依存せずに SWC を RTE に実装できること

2. アプリケーションソフトウェア自体を修正することなく、ECU および大規
模な車両ネットワークに SWC を統合できること（Systems Integration モ
デル）。

具体的には、RTE には以下のような機能が必要となります。
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• ソフトウェアコンポーネント用通信インフラストラクチャ

ここでいう「通信」には、同一 ECU 上のソフトウェアコンポーネント間
の通信（「ECU 内通信」）と、異なる ECU 上のソフトウェアコンポーネン
ト間の通信（「ECU 間通信」）との両方が含まれます。

• ソフトウェアコンポーネントのリアルタイムスケジューリング

AUTOSAR におけるリアルタイムスケジューリングとは、SWC のランナ
ブルエンティティを、設計時に定義された時間的条件に基き、オペレー
ティングシステムが提供するタスクにマッピングすることを指します。

BSW（基本ソフトウェア）は、RTE により実装される「抽象概念」の下層に位置
するため、アプリケーションソフトウェアコンポーネントから直接アクセスする
ことはできません。つまり、SWC がオペレーティングシステムや通信サービスな
どに直接アクセスすることはできません。そのため RTE は、それらのサービスを
カバーする「抽象概念」を提供する必要があります。この抽象概念は、ソフト
ウェアコンポーネントがどこに配置されていても常に不変でなければなりません。
この条件に基づき、ソフトウェアコンポーネント間のすべての通信は、標準化さ
れた RTE インターフェースの呼出しにより行われることになります。

さらに RTE は、1 つまたは複数の ECU に配置された SWC で構成される既存の
「アーキテクチャ」を実際に利用する際にも使用されます。RTE を効果的に実装す
るために、アーキテクチャに必要な RTE のコードはビルド時において各 ECU ご
とに決定されます。標準化された RTE インターフェースの実装は、RTE 生成ツー
ルにより自動的に行われますが、その際、指定されたコンポーネントインタラク
ションとコンポーネントアロケーションを実現するための適切なインターフェース
が生成されます。

同じ ECU 上に配置された 2 つのソフトウェアコンポーネント間の通信には「ECU
内通信」を使用できますが、どちらか一方を別の ECU に移した場合、両者間の通
信には「車両ネットワーク」が必要となります。

このようにして生成される RTE により、各 ECU 用の基本ソフトウェアの差異は、
以下のようにアプリケーションソフトウェアコンポーネントから隠蔽されること
になります。

• 一貫したインターフェースをソフトウェアコンポーネントに提供すること
により、ソフトウェアコンポーネントの再利用が可能となります。つま
り、一度設計して作成されたソフトウェアコンポーネントを複数の ECU
に再利用できます。

• このインターフェースは、VFB 内に「抽象概念」としてに実装された
AUTOSAR 基本ソフトウェアにバインドされます。

3.3 ASCET がサポートする AUTOSAR エレメント 

ASCET は以下の AUTOSAR エレメントをサポートしています。
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3.3.1 AUTOSAR ソフトウェアコンポーネント

AUTOSAR ソフトウェアコンポーネント（SWC: AUTOSAR Software 
Component）はアプリケーションレベルの汎用コンポーネントで、CPU 内、お
よび車両ネットワーク内の配置に依存しません。システム設計者が定義した制約
条件に従い、システム設定時において任意の ECU 上に配置することができます。

ただし SWC は AUTOSAR システムを分散化する際の 小単位であるため、1 つ
のコンポーネントは必ずその全体を 1 つの ECU 上に配置する必要があります。

SWC を作成する際は、そのコンポーネントタイプ（「SWC タイプ」）を定義しま
す。この「SWC タイプ」は、SWC の固定的特性（ポート名や、ポートがイン
ターフェースによりどのように使用されるか、SWC の挙動、などの情報） を定義
するものです。SWC タイプには、システム内で一意の名前を付ける必要がありま
す。これらの点をふまえ、各 SWC は以下のもので構成されます。

• 形式に従って定義された SWC ディスクリプション － コンポーネントのイ
ンフラストラクチャの設定方法を定義するもの

• SWC の実装コード － C コードによる SWC の機能記述

SWC は、システム設定時において「インスタンス化」することにより、使用可能
となります。ここでの「タイプ」と「インスタンス」は、従来のプログラミング
言語における「型」と「変数」の関係と似ています。つまり、従来のアプリケー
ション内で一意の型名（つまり SWC タイプ）を定義し、その型を用いて、一意
の名前を持つ変数（1 つまたは複数の SWC インスタンス）を宣言するのと同じ要
領です。

3.3.2 ポートとインターフェース

VFB モデルにおいて SWC は、インターフェースによってアクセスされる「ポー
ト」を通じて他のコンポーネントとの通信を行います。「インターフェース」は、
通信によって伝達される情報や通信のセマンティックスを制御します。SWC は
ポートを通じてインターフェースにアクセスし、この「ポート」と「ポートイン
ターフェース」を組み合わせたものを「AUTOSAR インターフェース」と呼びま
す。

ポートには以下の 2 つのクラスがあります。

• 提供ポート（P ポート： Provided port） － SWC はこのタイプのポートを
使用してデータやサービスを他の SWC に提供します。P ポートには「セ
ンダポート」と「サーバーポート」とがあります。

• 要求ポート（R ポート： Required port） － SWC はこのタイプのポートを
使用して他の SWC にデータやサービスを要求します。R ポートには「レ
シーバポート」と「クライアントポート」とがあります。

ASCET V6.0 は以下のタイプのインターフェースのみサポートしています。

注記

本書では、非 AUTOSAR ポートとの混同を避けるため、AUTOSAR ポート
を「R ポート」および「P ポート」と呼びます。
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• センダ - レシーバ（シグナル渡し）

SWC の各 P ポートおよび R ポートには、その SWC が提供または要求するイン
ターフェースタイプを定義します。

1 つのシステムが複数の SWC インスタンスにより構築されている場合、それらの
インスタンスの R ポートと P ポートを接続します。 この際、必ず 1 つのセンダを
1 つにレシーバに接続する必要があります。

センダ - レシーバ通信

センダ - レシーバ通信においては、 小単位のデータエレメントで構成されるシ
グナルを 1 つの SWC が送信し、1 つまたは複数の SWC がそのシグナルを受信し
ます。

1 つの SWC タイプに複数の「センダ - レシーバポート」を持たせることができま
す。

各センダ - レシーバポートには、個別に送受信できる複数のデータエレメントを定
義することができます。インターフェース内のデータエレメントとしては、単純
データ型（integer や float など）や複合データ型（array や matrix など）を使用で
きます。

センダ - レシーバ通信は単方向通信なので、レシーバからの応答が必要な場合は、
その応答を別のセンダ - レシーバ通信としてモデリングする必要があります。

センダ - レシーバインターフェースを要求する SWC の R ポートはインター
フェースのデータエレメントを読み取ることができます。一方、センダ - レシー
バインターフェースを提供する P ポートはデータエレメントを書き込むことがで
きます。

センダ - レシーバ通信においては“1:n”（1 つのセンダ、複数のレシーバ）また
は“n:1”（n 個のセンダ、1 つのレシーバ）の形が可能です。後者の場合、セン
ダ側での同期は行われません。

3.3.3 ランナブルエンティティとタスク

ランナブルエンティティ（「ランナブル」とも呼ばれます）は SWC に含まれる一
連のコードを指し、ランタイムおいて RTE によりトリガされます（3.2 項参照）。
これは ASCET における「プロセス」にほぼ相当します。

各ソフトウェアコンポーネントは 1 つまたは複数のランナブルエンティティで構
成され、RTE は、ランタイムにおいて各ランナブルエンティティにアクセスしま
す。ランナブルエンティティは、以下のイベントによりトリガされます。

• タイミングイベント － 周期的スケジューリングイベント（周期的タイマ
ティックなど）です。ランナブルエンティティは通常実行用のエントリポ
イントを提供します。

• R ポートのデータ受信によりトリガされるイベント（DataReceive イベン
ト）。

AUTOSAR ランナブルエンティティはいくつかのカテゴリに分類されますが、
ASCET はカテゴリ 1 のランナブルエンティティをサポートしています。
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ランナブルエンティティを実行するためには、そのランナブルエンティティを
AUTOSAR オペレーティングシステムのタスクに割り当てます。

3.3.4 ランタイム環境

RTE（ランタイム環境）については 3.2 項で説明しています。
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4 チュートリアル

このチュートリアルは、主に、ASCET を初めて使うユーザーを対象として、実際
のモデル記述作業を例に ASCET の基本的な使い方を説明するものです。チュート
リアルは、互いに関連しあうコンポーネントを扱う複数のレッスンに分かれてい
ます。なお、チュートリアルを始める前に、あらかじめ「ASCET を理解する」

（15 ページ）を読んで ASCET の基本概念を理解しておいてください。

4.1 単純なブロックダイアグラムを作成する

ASCET では、アプリケーションを構成するメインブロックとしてクラスやモ
ジュール等のコンポーネントを使用します。製品に含まれている既成のコンポー
ネントを使ったり、独自のコンポーネントを新たに作成することもできます。

ASCET では、コンポーネントは、通常グラフィックを使用して記述します。すべ
てのコンポーネントの定義が終わったらそれらを組み合わせ、ASCET ソフトウェ
アシステムの基礎となるプロジェクトを構築します。 終的なソフトウェアシス
テムは、グラフィカルなモデル記述から生成された C コードで構成され、マイク
ロコントローラや実験ターゲットコンピュータ上で実行することができます。

4.1.1 準備

初に、まずチュートリアルのデータベースを開きます。このチュートリアルで
作業するコンポーネントはすべてこのデータベースに格納されるので、すべての
作業はこのデータベースを開いた状態で行います。

このチュートリアルで作成するコンポーネントとプロジェクトは、データベース
Tutorial内の ETAS_Tutorial_Solutionsというフォルダ内にあらかじ
め格納されているので、ここで説明するコンポーネントをすべてユーザー自分で
定義する必要はありません。

ただし、少なくともレッスン 1、3、および 4 のコンポーネントだけは、練習のた
めにご自分で作成することをお勧めします。
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ASCET を起動すると、以下のようなコンポーネントマネージャが開き、前回の
セッションで開いていたデータベースがロードされます。

Tutorialデータベースがない場合は、以下のようにして新しいデータベースを
作成します。

新しいデータベースを作成する：

• コンポーネントマネージャから、File → New 
Database を選択します。

または

• New ボタンをクリックします。

または

• <Ctrl> + <N> を押します。

“New database”ダイアログボックスが開きま
す。

• Tutorialという名前を入力します。
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• OK をクリックします。

新しいデータベースが作成されます。ここには、
データベース名と Rootというフォルダのみが含
まれます。

Tutorialデータベースすでに存在している場合は、以下のようにしてそのデー
タベースを開きます。

データベースを開く：

• コンポーネントマネージャから、File → Open 
Database を選択します。

または

• Open ボタンをクリックします。

または

• <Ctrl> + <O> を押します。

“Open database”ダイアログボックスが開き、
現在設定されているデータベースパスに存在する
データベースの一覧が表示されます。

• 一覧の中に Tutorialデータベースがある場合
は、それを選択して OK をクリックします。

コンポーネントマネージャに Tutorialデータ
ベースの内容が表示されます。

• Tutorialデータベースが他のパスに格納されて
いる場合には、<select path>オプションを
選択して OK をクリックします。

• “Select database path”ダイアログボックスが開
くので、データベースを指定して OK をクリック
します。

新しいコンポーネントを作成するために、まず Tutorialという名前の新しい
トップレベルのフォルダと LessonNという各レッスン用のサブフォルダを作成
します。
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新しいトップレベルフォルダを作成する：

• “1 Database”ペインでデータベース名を選択し
ます。

• メニューアイテム Insert → Folderを選択します。

または

• Insert Folder ボタンをクリックします。

または

• <Insert> を押します。

“1 Database”ペインに Rootという名前の新し
いトップレベルのフォルダが表示されます。

• トップレベルフォルダの名前をTutorialに変更
します。強調表示されている名前に上書き入力し
てから <Enter> を押します。

• フォルダ Tutorialを選択します。

• もう一度 Insert → Folder を選択します。

“1 Database”ペインに Folderという名前の新
しいフォルダが表示されます。

• 新しいフォルダの名前をLesson1に変更します。

このチュートリアルで作成するコンポーネントはすべて、いずれかの LessonN
フォルダに格納します。各レッスンごとに新しいフォルダを作成してください。
データベースにはトップレベルフォルダが必ず 1 つ以上あり、その中に任意の数
のサブフォルダを作成することができます。

次に、 初のコンポーネントを Lesson1フォルダに作成します。

コンポーネントを作成する：

• “1 Database”ペインのフォルダ Lesson1をク
リックします。

• Insert → Class → Block Diagram を選択しま
す。

“1 Database”ペインの Lesson1フォルダの下
に、Class_Blockdiagramという新しいコン
ポーネントが表示されます。このコンポーネント
は class タイプです。class タイプは ASCET で頻
繁に使用されます。

注記

すべてのフォルダ名やアイテム名、およびそれらの中の変数やメソッドの名前
は、ANSI C 標準に準拠している必要があります。
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• このコンポーネントの名前をAdditionに変更し
ます。

4.1.2 クラスを定義する

Tutorial/Lesson1フォルダに新しいコンポーネントを作成したので、次に
その機能を定義します。まず 初にコンポーネントのインターフェース、つまり、
メソッド、引数、および戻り値を定義し、次にそのコンポーネントの機能を定義
するブロックダイアグラムを作成します。

コンポーネントの機能を定義する：

• “1 Database”ペインでコンポーネント
Additionを選択します。

• メニューアイテム Edit → Open Component を
選択します。

または

• コンポーネントをダブルクリックします。

または

• <Enter> を押します。

ブロックダイアグラムエディタが開きます。これ
は、コンポーネントの機能を定義するためのメイ
ンウィンドウです。
チュートリアル 45



46
• “Outline”タブに表示されているメソッド calc
を選択します。このメソッドは、デフォルトメ
ソッドとして自動的に作成されたものです。

• Edit → Rename を選択します。

または

• <F2> を押します。

メソッド名 calcが強調表示されます。

• このメソッドの名前を DoAdditionに変更しま
す。

• Edit → Properties を選択します。

または

“Outline”タブを含む

“Components”ペイン

描画エリア

パレット
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• メソッド名をダブルクリックします。

このメソッドのシグネチャエディタが開きます。

クラスには、少なくとも 1 つのメソッドを定義する必要があります。ASCET にお
けるメソッドは、オブジェクト指向プログラミング言語で用いられる「メソッド」
や、手続き型プログラミング言語で用いられる「関数」に似ています。メソッド
は任意の数の引数を入力し、1 つの戻り値を出力することができます（これらは
すべて任意指定です）。引数は、コンポーネントにデータを渡すために使用され、
戻り値はコンポーネント内で行われた計算の結果を「外側」に返すために使用さ
れます。

これらの「メソッドシグネチャ」は、シグネチャエディタを使用して定義します。
ここでは continuous型の引数を 2 つと戻り値を 1 つ定義します。

メソッドシグネチャを定義する：

• シグネチャエディタで Argument → Add を選
択します。

“Arguments”ペインに、argという新しい引数
が表示されます。

• この引数の名前を input1にします。

• もう 1 つの引数を作成し、input2という名前を
付けます。

デフォルトでは引数の型は continuous（または
略して cont ）になっています。ここでは、この
型のまま使用します。

• シグネチャエディタの "Return" タブを選択しま
す。
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• Return Value オプションをオンにします。

戻り値の型も、デフォルトで cont になります。

• OK をクリックして、シグネチャエディタを閉じ
ます。

メソッド DoAdditionの引数と戻り値の名前が、ブロックダイアグラムエディ
タ左側の“Outline”タブ内のメソッドの下に表示されます。これで、ブロックダ
イアグラムを作成してこのコンポーネントの機能を定義する準備が整いました。

コンポーネント Addition の機能を定義する：

• “Outline”タブの第 1 引数をドラッグして、ブ
ロックダイアグラムエディタの描画エリアにド
ロップします。

この引数のシンボルが、描画エリアに表示されま
す。

• 同じドラッグアンドドロップ操作により、もう 1
つの引数と戻り値を追加します。

• “Basic Blocks”パレット内の Addition ボタンを
クリックします。

マウスカーソルに加算演算子がロードされまし
た。

• 描画エリア内の、引数のシンボルと戻り値のシン
ボルの間をクリックします。

加算シンボルが挿入されます。デフォルトでは、
これには 2 つの入力ピン（矢印で示されます）
と、1 つの出力ピンが付いています。出力ピンは
右側に付きます。
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エレメントと演算子は、描画エリアの任意の位置にドラッグして配置することが
できます。

次に、エレメント同士を接続して、情報の流れを定義します。

ダイアグラムエレメントを接続する：

• “General”ツールバー内の Connect ボタンをク
リックします。

• または、描画エリア内の、エレメントが配置され
ていない部分を右クリックします。

カーソルは、描画エリア内で十字カーソルに変わ
ります。

• 第 1 引数を表すシンボルの出力ピンをクリックし
て、接続を開始します。

マウスカーソルを動かすと、それに従って線が引
かれます。描画エリア内でクリックするたびに、
その時点で引かれていた線が固定されます。この
ようにして、接続線の道筋を確定していきます。

• 加算シンボルの左側にある入力をクリックしま
す。

これで、第 1 引数のシンボルが加算シンボルの入
力に接続されます。

• 第2引数のシンボルを、加算シンボルのもう1つの
入力に接続します。
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• 戻り値のシンボルを、加算シンボルの出力に接続
します。

加算演算子と戻り値との接続が、緑色の線で表示
されます。緑色の線は、この演算のシーケンスが
まだ決定されていないときうことを表わしていま
す。

• Tools → Sequence Calls → Sequencing - 
Ignore Current を選択して、加算のシーケンス
を自動的に決定します。

加算演算子と戻り値の間の接続が黒色の線で表示
されます。

これで、 初のコンポーネントの定義、つまり機能記述は完了です。

後に、コンポーネントのレイアウト、つまり、このコンポーネントが他のコン
ポーネント内で使用される際にどのように表示されるようにするかを定義します。

レイアウトの編集方法は 2 通りあります。

コンポーネントのレイアウトを編集する：

• ウィンドウ右端の“Browse”タブをクリックし
て“Browse”ビューに切り替えます。
チュートリアル



• “Layout”タブを選択し、レイアウトが表示され
たエリアをダブルクリックしてレイアウトエディ
タを開きます。

• または、Edit → Component → Layout を選択
します。

レイアウトエディタ（“Layout Editor”ダイアロ
グ）が開きます。

• ブロックをクリックするとそのブロックのハンド
ルが表示されるので、そのハンドルをドラッグし
てブロックを任意のサイズに変更します。

• 引数と戻り値のピンをドラッグして、配置を調整
します。

• OK をクリックします。

これで、コンポーネントは完成しました。このレッスンの 後の作業として、コ
ンポーネントをデータベースに保存します。
チュートリアル 51



52
コンポーネント Additionを保存する：

• File → Save を選択し、ブロックダイアグラムエ
ディタを閉じます。

• コンポーネントマネージャで Save ボタンをク
リックします。

作業内容は、この操作をするまではディスクに書
き込まれません。

ブロックダイアグラムエディタ内で Save を選択
した際は、変更部分はキャッシュメモリに格納さ
れるだけです。そこで、作業中は定期的にコン
ポーネントマネージャの Save ボタンで保存を行
うことをお勧めします。

ユーザーオプションを設定して、変更内容が自動
的に保存されるようにすることもできます（オン
ラインヘルプを参照してください）。

ここで、練習のため、同じ機能を ESDL（Embedded Software Description 
Language）でモデリングしてみましょう。そうすれば、ESDL エディタや、外部
ソースコードエディタの使用法を習得することができます。

まず初めに、モジュールインターフェースを ESDL タイプの新しいモジュールに
コピーしてから、そのモジュールの名前を変更します。それから、そのモジュー
ルで実現したい機能を、ASCET の ESDL エディタ、または外部テキストエディタ
を使用して記述します。

コンポーネント Additionをコピーして定義する：

• コンポーネントマネージャの“1 Database”ペイ
ンでコンポーネント Additionを選択します。

• ショートカットメニューから Edit → Reproduce 
As → ESDL を選択します。

コンポーネントのコピーが作成され、
Addition1という名前が自動的に付けられま
す。

• 新しいコンポーネントの名前を AdditionESDL
に変更します。
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• “1 Database”ペインで、新しいコンポーネント
の名前をダブルクリックします。

AdditionESDL用のエディタが開きます。この
エディタにもさまざまな編集機能が備わっていま
す。

• 内部テキストエディタの“Edit”ペインに、以下
のような機能を入力します。

return input1 + input2;

• 今度は Activate External Editor ボタンをク
リックして、外部エディタモードに切り替えま
す。

変更内容を保存するかどうか、尋ねられます。

“Edit”ペイン

（内部テキストエディタ）

パレット
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• Yes をクリックして確定します。

変更内容が保存され、ESDL エディタは外部エ
ディタモードに切り替わります。

外部エディタモードに切り替わると、以下のよう
な画面になります。

• プロセス／メソッドのペインから、定義したいメ
ソッドまたはプロセスを選択します。

すでに入力されている機能が定義フィールドに表
示され、Start Edit ボタンが有効になります。

• Start Edit をクリックして外部エディタを起動し
ます。

Start Edit ボタンが無効になり、End Edit およ
び Update ボタンが有効になります。

• 外部エディタで機能を記述します。

• 記述した機能を保存します。

• ESDL エディタで Update をクリックし、外部エ
ディタからデータを転送します。

注記

外部エディタが起動されると、Windows に登録されている、*.cと *.hとい
うファイルに割り当てられたアプリケーションが呼び出されます。この外部エ
ディタと ASCET 間のデータ転送は一時ファイルを介して行われるので、外部
エディタを閉じる前や ESDL エディタにデータを転送する前には、ファイルが
保存されていることを確認してください。

プロセス／メソッドの
ペイン

プロセスやメソッドの
記述内容が表示されるペイン
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• 後に End Edit をクリックして、外部エディタと
の連結を解除します。

End Edit をクリックしても外部エディタは開い
たままですが、それ以降、外部エディタで変更し
た内容を ESDL エディタに転送することはできま
せん。

• 再度 Activate External Editor をクリックして、
外部エディタモードを終了します。

• Build → Analyze Diagram を選択して、入力し
たコードを検証します。

エラーがあった場合は、ASCET モニタウィンド
ウに表示されます。

4.1.3 まとめ

このレッスンでは、ASCET で以下の作業を行いました。

• データベースを開く

• フォルダを作成して名前を付ける

• コンポーネントを作成して名前を付ける

• メソッドのインターフェースを定義する

• 描画エリアにダイアグラムエレメントを配置する

• ダイアグラムエレメントを接続する

• コンポーネントのレイアウトを編集する

• 機能記述用のビュー（“Specification”ビュー）とブラウザビュー
（“Browse”ビュー）とを切り替える

• コンポーネントを保存する

• コンポーネントのインターフェースをコピーする

• ESDL エディタを使用する

• 外部エディタを使用する
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4.2 コンポーネントの実験を行う

Addition および AdditionESDL というコンポーネントができあがったので、
それを用いて実験を行います。実験環境では、コンポーネントがどのように機能
するかを、シミュレーションによって運用時と同様に見ることができます。実験
環境には各種ツールが用意されていて、コンポーネント内の入力、出力、パラ
メータ（適合変数）、および変数（測定変数）の値をモニタすることが可能です。

4.2.1 実験環境（Experiment Environment）を起動する

実験環境を、ブロックダイアグラムエディタまたは ESDL エディタから起動しま
す。起動するには、実験したいコンポーネントを指定して実験環境を開きます。

実験環境を起動する：

• ASCET コンポーネントマネージャから、
¥Tutorial¥Lesson1フォルダに入っている
Additionのブロックダイアグラムを開きます。

• ブロックダイアグラムエディタで Build → 
Experiment を選択します。

実験用のコード生成が行われます。ASCET は
ユーザーが定義したモデルを分析し、そのモデル
で記述されている機能を実現する C コードを生成
します。さまざまなプラットフォーム用のコード
を生成することができます。

このレッスンでは、デフォルト設定を使用して
PC 用のコードを生成します。
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コードの生成とコンパイルが終わると、実験環境
が開きます。

4.2.2 実験をセットアップする

実際に実験を開始する前に、環境の設定が必要です。つまり、実験用に生成する
入力値を指定し、さらに実験結果をどのように表示するかを指定します。このた
めに、イベントジェネレータ、データジェネレータ、そして 後に測定システム
を順にセットアップしていきます。

イベントジェネレータをセットアップする：

• Open Event Generator ボタンをクリックしま
す。

“Event Generator”ウィンドウが開きます。シ
ミュレートする各メソッドごとに、イベントを 1
つと generateDataイベントを作成する必要
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があります。運用時にはオペレーティングシステ
ムが行うスケジューリングが、これらのイベント
によってシミュレートされます。

• DoAdditionイベントを選択します。

• Channels → Enable を選択します。

• もう一度、イベント DoAdditionを選択します。

• Channels → Edit を選択します。

これら 2 つの操作は、"Elements" フィールドの
ショートカットメニューからも行えます。

“Event”ダイアログボックスが開きます。

• dTの値を 0.001 にします。

• OK をクリックします。

• イベントジェネレータ内で generateDataイベ
ントを選択し、その dT値を 0.001 にします。

• “Event Generator”ウィンドウを閉じます。
チュートリアル



データジェネレータをセットアップする：

• Open Data Generator ボタンをクリックしま
す。

“Data Generator”ウィンドウが開きます。

• Channels → Create を選択します。

“Create Data Generator Channel”ダイアログ
ボックスが開きます。

• エレメントの一覧から、input1/DoAddition 
および input2/DoAdditionという変数を選
択します。

• OK をクリックします。

2 つの変数が“Data Generator”ウィンドウの
“Data Elements”ペインにリストアップされま
す。

• “Data Elements”ペインの input1/
DoAddition を選択します。
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• Channels → Edit を選択します。

“Stimulus”ダイアログボックスが開きます。

• 以下の値を設定します。

• OK をクリックして“Stimulus”ダイアログボッ
クスを閉じます。

• 同様にして input2の値を以下のように設定しま
す。

• “Data Generator”ウィンドウを閉じます。

上記のように設定すると、周波数と振幅が異なる 2 つの正弦波が得られます。
Additionコンポーネントはこの 2 つの正弦波を合成し、その結果として得られ
るカーブを出力します。

これらのカーブをオシロスコープに表示して波形を確認できるようにするため、
測定システムをセットアップします。

Mode： sine

Frequency： 1.0Hz

Phase： 0.0s

Offset： 0.0

Amplitude： 1.0

Mode： sine

Frequency： 2.0Hz

Phase： 0.0s

Offset： 0.0

Amplitude： 2.0
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測定システムをセットアップする：

• “Physical Experiment”ウィンドウの“Measure 
View”コンボボックスで、データ表示タイプとし
て <2. New Oscilloscope>を選択します。

• “Outline”タブ内のエレメントリストを開きま
す。

• input1/DoAdditionを選択します。

• Extras → Measure を選択します。

input1という測定チャンネルが割り当てられた
オシロスコープウィンドウが開きます。実験環境
の“Measure View”リストが更新され、そこに
この測定ウィンドウのタイトルが追加されます。

• “Physical Experiment”ウィンドウの“Outline”
タブ内の input2/DoAdditionを選択します。

• Extras → Measure を選択します。

input2という測定チャンネルがオシロスコープ
に追加されます。
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• 同様にしてreturn/DoAdditionを測定ウィン
ドウに追加します。

• 実験環境で、File → Save Environment を選択
します。

これで実験のセットアップが終わり、実験を開始することができるようになりま
した。環境設定を保存したので、次回、このコンポーネント用の実験環境を起動
すると、同じ環境が再びロードされます。

4.2.3 実験環境を使用する

実験環境には、コンポーネント内の変数の値を表示したり、実験実行中にセット
アップ内容を変更するための機能が用意されています。また、値の表示方法を選
択したり調整することもできます。

実験を開始する：

• “Physical Experiment”ウィンドウの Start 
Offline Experiment ボタンをクリックして実験
を開始します。

シミュレーションが実行され、その結果がオシロ
スコープに表示されます。

• Stop Offline Experiment ボタンをクリックし
て、実験を停止します。

この時点では、オシロスコープには、カーブのごく一部しか表示されていません。
オシロスコープにカーブの他の部分を表示するには、値軸（信号値を示す Y 座標
軸）のスケールを変更する必要があります。

オシロスコープのスケールを変更する：

• オシロスコープウィンドウの“Measure 
Channels”リストから、3 つのチャンネルをすべ
て選択します。

複数のチャンネルを選択するには、<Ctrl> キー
を押し下げたまま個々のチャンネルをクリックし
ます。

すべてのデータエレメントが強調表示され、これ
から行う変更は 3 つのチャンネルすべてに反映さ
れます。

• Extras → Setup を選択します。
チュートリアル



“Display Setup”ダイアログボックスが開きます。

• “Value Axis”の範囲を -3 ～ 3 に変更します。

• “Time Axis Extent”を 3 にします。

• “Backgroud color”リストから背景色を選択しま
す。

• <Enter> を押します。

これで、値が適切なスケーリングで表示されるようになりました。入力された 2
つの正弦波と、その 2 つを合成した出力波形が表示されます。入力値を調整して、
出力がどのように影響を受けるかを調べてみましょう。
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実験の入力値を変更する：

• “Physical Experiment”ウィンドウで Tools → 
Data Generator を選択して、“Data 
Generator”ウィンドウを開きます。

• データジェネレータ上で、変更したい変数を選択
します。

• Channels → Edit を選択します。

“Stimulus”ダイアログボックスが開きます。

• 値を適宜調整します。

• Apply をクリックします。

オシロスコープのカーブが、新しい設定に応じて変化します。実験の実行中に、
すべての設定を変更することができます。

4.2.4 まとめ

このレッスンでは、ASCET で以下の作業を行いました。

• 実験環境を呼び出す

• イベントジェネレータをセットアップする

• データジェネレータをセットアップする

• 測定システムをセットアップする

• 実験を開始し、停止する

• 実験の環境設定を保存する

• 実験実行中にスティミュレーションの内容を変更する
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4.3 再利用可能なコンポーネントを定義する

このレッスンでは、マイクロコントローラソフトウェアでよく用いられる機能単
位である「積分器」のクラスを作成します。このダイアグラムはやや複雑ですが、
ここまでに学習した方法で作成し、実験することができます。

この例では、与えられる時間と速度から走行距離を算出する積分器を定義します。
速度はメートル／秒の単位で与えられ、それを dT（秒）の周期で積算します。各
周期ごとに値がアキュムレータに累算され、アキュムレータの値は、所定の時間
経過後の走行距離（メートル）となります。

ASCET では、アキュムレータなどの標準ブロックは、シンプルに図示されます。

4.3.1 ダイアグラムを作成する

ダイアグラムを記述する前に、additionコンポーネントの場合と同様の準備作
業が必要です。まず Tutorialフォルダ内に新しいフォルダを作成してから、
新しいクラスを追加します。これで、メソッドのインターフェース、さらにブ
ロックダイアグラムとレイアウトを定義することができます。

まず、フォルダと新しいクラスを作成することから始めます。

積分器のクラスを作成する：

• コンポーネントマネージャで、Tutorialフォル
ダを開きます。

• 新しいフォルダを作成し、その名前を Lesson3
にします。

• Lesson3フォルダ内に新しいクラスを作成し、
その名前を Integratorにします。

積分器のインターフェースを定義する：

• “1 Database”ペインで、エレメント
Integratorを選択します。

• エレメントをダブルクリックするか、または Edit 
→ Open Component を選択します。

ブロックダイアグラムエディタが開きます。

• メソッド calcの名前を integrateに変更しま
す。
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• メソッド integrateを編集して、1 つの引数
（cont型）と戻り値（cont型）を追加します。

• integrateの引数と戻り値を描画エリアに配置
します。

この積分器は、ここまでのレッスンでは使用されなかった「変数」および「パラ
メータ」という 2 つのタイプのエレメントを使用します。

「変数」は、プログラミング言語の変数と同じように用いられます。変数には値を
格納することができ、以降の計算ではその値を読みとることができます。これと
は対照的に、「パラメータ」は読みとり専用です。パラメータの値は、たとえば新
しい実験環境での適合作業によってなど、コンポーネントの外部でしか変更でき
ず、コンポーネント内での計算で上書きすることはできません。なお ETAS の測
定・適合ツールでは、「変数」は「測定変数」、「パラメータ」は「適合変数」と呼
ばれています。

さらにこの例では、「依存パラメータ 」を定義します。しかし、これは積分器の
機能とは無関係です。依存パラメータ は 1 つまたは複数のパラメータに依存する
もので、その値は別のパラメータの値から算出されます。この計算は値が定義さ
れた時や適合された時にだけ行われます。依存パラメータは、ターゲットコード
内においては通常のパラメータと全く同じように機能します。
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変数を作成する：

• “Elements”パレット内の Continuous 
Variables ボタンをクリックします。

プロパティエディタが開きます。

• “Name”フィールドに bufferという名前を入力
します。

• OK をクリックします。

変数の名前が bufferになりました。マウス
カーソルにこの continuous 型の変数がロードさ
れ、カーソルが十字カーソルに変わります。

• 描画エリア内をクリックして、変数を配置しま
す。

変数が描画エリア内に配置され、“Outline”タブ
内にその変数の名前が反転表示の状態で追加され
ます。

上記の操作でプロパティエディタが自動的に開かない場合は、そのまま変数を描
画エリアに配置し、その後、“Outline”タブ内のその変数をダブルクリックして
プロパティエディタを開いてください。プロパティエディタの Always show 
dialog for new elements オプションをオンにしておけば、次回のエレメント作成
時から、自動的にプロパティエディタが開くようになります。
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パラメータを作成する：

• Continuous Parameter ボタンをクリックしま
す。

プロパティエディタが開きます。

• “Name”フィールドに Kiという名前を入力しま
す。

• OK をクリックします。

• 描画エリア内をクリックして、パラメータを配置
します。

• “Outline”タブでこのパラメータを右クリック
し、ショートカットメニューから Data を選択し
ます。

データコンフィギュレーションウィンドウ（数値
エディタ）が開きます。

• 入力フィールドに 4.0と入力してから <Enter> 
を押します。

この値がパラメータのデフォルト値になります。
ダイアグラム内のすべてのパラメータや変数につ
いて、このようにしてデフォルト値を割り当てる
ことができます。

依存パラメータを作成する：

• Continuous Parameter ボタンをクリックしま
す。

プロパティエディタが開きます。

• “Name”フィールドに WurzelKiという名前を
入力します。

• “Attribute”フィールドの Dependent オプショ
ンを選択します。
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• Formulaボタンでフォーミュラエディタを開きま
す。

• “Identifier”フィールドを右クリックしてショー
トカットメニューを開き、Add を選択します。

仮パラメータが作成されます。

• “Identifier”フィールドに新しいパラメータの名
前 xを入力します。

• “Formula”フィールドに変換規則を定義します。

“Operator”コンボボックスから演算子を選択し
て、複雑な式を定義することができます。演算子
は、“Operator”フィールドのとなりの >> ボタン
を押すたびに 1 つずつ“Formula”フィールドに
挿入されます。

同様に、“Function”コンボボックスで関数を選
択し、“Function”コンボボックスの隣の >> ボタ
ンを押して“Formula”フィールドに挿入するこ
ともできます。

• ここでは例として、仮パラメータの平方根を求め
る計算を定義します。

Identifier：x
Formula：sqrt(x)

• OK でプロパティエディタを閉じます。

カーソルが十字カーソルに変わります。

• 描画エリア内をクリックして、パラメータを配置
します。
チュートリアル 69



70
• ブロックダイアグラムエディタで、“Outline”タ
ブの WurzelKiを右クリックしてショートカッ
トメニューを開き、Data を選択します。

• “Dependency Editor”ウィンドウで、コンボボッ
クス内のモデルパラメータ（この例では Ki）を
仮パラメータに割り当てます。

• OK をクリックして、データ入力を完了します。

これで、パラメータ Kiに依存し、適合時に Ki
に基づいて自動的に算出される依存パラメータが
定義されました。後で実験を行う時に、この依存
関係を確認することができます。

すべてのエレメントを作成したので、次に積分器を定義します。ダイアグラムの
残りの部分を以下のようにして完成させてください。
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ダイアグラムを作成する：

• “Basic Blocks”パレット内“No. of arguments"
コンボボックスの値を 3 にし、乗算演算子の入力
の数を指定します。

• 乗算演算子を作成し、描画エリアに配置します。

• dT ボタンをクリックして dT エレメントを作成し
ます。

プロパティエディタが開きます。この演算子を作
成する前に、“Argument Size”の値を 2 に戻し
てください。

• dT エレメントを描画エリアに配置します。

• 2 つの入力を持つ加算演算子を作成し、描画エリ
アに配置します。

この演算子を作成する前に、“Argument Size”の
値を 2 に戻してください。

• エレメントを下図のように接続します。

バッファと戻り値の入力を示す線は、緑色で表示
されます。

ここまでで、ダイアグラムのすべてのエレメントの設定が終わりました。次に、
シーケンスコールを定義して、計算の順序を決定します。
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シーケンスコールに値を割り当てる：

• 変数 bufferの上に表示されているシーケンス
コールを右クリックします。

• ショートカットメニューから Edit を選択します。

シーケンスエディタが開きます。

• OK をクリックして、デフォルト設定を確定しま
す。

この設定により、この代入処理は、積分器のアル
ゴリズムの冒頭部分で行われます。

シーケンスコール内のシーケンス番号を調整する：

• integrateの戻り値の上に表示されているシー
ケンスコールを右クリックします。

• ショートカットメニューから Edit を選択します。

• シーケンスエディタで、“Sequence Number”の
値を 2 にします。

• OK をクリックします。

この設定により、変数 bufferが更新された後
に戻り値への代入が行われます。

シーケンスコール
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レイアウトを調整する：

• Edit → Component → Layout を選択します。

レイアウトエディタが開きます。

• または、“Information/Browse”ビューから
“Layout”タブ内のレイアウトをダブルクリック
して、レイアウトエディタを開くこともできま
す。

• 引数を integrateからブロックの左側の中程に
ドラッグします。

• 戻り値をブロックの右側の中程にドラッグしま
す。

• OK をクリックします。

これで、積分器クラスのダイアグラムは完成です。今度は File → Save を選択し
て、ダイアグラムの変更内容を保存します。ダイアグラム自体に影響を与えない
部分の変更内容は、自動的に保存されます。次に、コンポーネントマネージャ
ウィンドウで File → Save Database を選択して、変更内容をデータベースに保
存します。

4.3.2 積分器の実験を行う

ここでも、初めにイベントジェネレータ、次にデータジェネレータ、 後に測定
システムをセットアップします。

積分器用の実験をセットアップする：

• Build → Experiment を選択して、実験環境を開
きます。
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• Event Generator ボタンをクリックします。

• イベント integrateをアクティブにして、dTは
デフォルト値 0.01 のままにします。

• “Event generator”ウィンドウを閉じます。

• Data Generator ボタンをクリックします。

• Channels → Create を選択して integrateか
ら引数を選択し、integrateメソッド用のデー
タチャンネルを作成します。

• 以下の値を設定します。

• データジェネレータを閉じます。

• integrateメソッドのargとreturnをオシロ
スコープウィンドウに割り当てます。

• 値軸の範囲を -10～10にし、時間軸の範囲を10秒
にします。

• Start Offline Experiment をクリックして、実
験を開始します。

integrateメソッドの出力値は、引数が正なら増加し、負なら減少します。入
力カーブの正と負の部分の時間は等しいので、安定範囲内の値が出力され続けま
す。

Mode： pulse

Frequency： 0.2Hz

Phase： 0.0s

Offset： -1.0

Amplitude： 2.0
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実験を停止してから再開する際、すべての変数の値は停止された時に保存された
値で続行されますが、場合によっては変数を初期値にリセットする必要が生じる
場合もあります。

実験をリセットする：

• Extras → Reinitialize → Variables（または
Parameters 、Both）を選択します。

選択したコマンドに応じて、すべての変数または
すべてのパラメータ、またはその両方が初期値に
リセットされます。

次に、実験の条件を変更して、積分器ファンクションのカーブを表示してみま
しょう。Kiパラメータを調整、つまり「適合」し、入力値を変更します。

積分器の実験を行う：

• “Outline”タブの Integratorエレメントを展
開します。

• パラメータ Kiを選択します。

• Extras → Calibrate を選択します。

このパラメータ用の数値エディタが開きます。

• 5を入力します。

オシロスコープの出力カーブの勾配が急になりま
す。

• 値を 3にします。

出力カーブの傾斜が緩くなります。

• パラメータの値を 4に戻してから数値エディタを
閉じます。

• “Data Generator”ウィンドウを開きます。

• 入力パルスのオフセットを -0.5にします。

• OK をクリックします。

これで正の部分の方が大きくなるので、出力値が増加し、ある時点でオシロス
コープの表示範囲を超えてしまいます。このような場合、個々の値について、オ
シロスコープのスケールを変更することができます。また、以下のようにして数
値表示ウィンドウを開いて出力値を表示することもできます。

値を数値で表示する：

• 実験環境の“Measure View”コンボボックスか
ら <1. Numeric Display>を選択します。

• “Outline”タブで、integrateメソッドの戻り
値 (return) を選択します。
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• Extras → Measure を選択します。

“Numeric display”ウィンドウに、現在の戻り値
が表示されます。

• 依存パラメータ WurzelKiも表示します。

• Kiの値を変え、Update Dependent 
Paramters ボタンで WurzelKiを更新し、実験
を行います。

4.3.3 まとめ

このレッスンでは、ASCET で以下の作業を行いました。

• パラメータを作成する

• 依存パラメータを作成し定義する

• 変数を作成する

• 複数の入力を伴う演算子を作成する

• シーケンスコールのシーケンス番号を設定する

• デフォルト値を割り当てる

• 実験中に値を適合する

• “Numeric display”ウィンドウに値を表示する

4.4 実際的な例

このレッスンでは、標準の PI フィルタを若干拡張したものをベースにして、コン
トローラを作成します。このコントローラは、自動車のアイドリング時のエンジ
ン回転速度を一定に保つために用いられます。

エンジンのアイドリング速度をコントロールする場合、実際の回転数 nがアイド
リング時の目標値 n_nominalに近い状態を確実に維持する必要があります。
n_nominalから値 nを引いて、コントロールする偏差を決定します。

この実際の回転数の偏差が、air_nominalの値を算出するための基礎になりま
す。air_nominalはスロットル位置、つまりエンジンの吸気量を決定します。

4.4.1 コントローラを定義する

コントローラのダイアグラムを作成する手順は、これまでのレッスンで用いた手
順と同じです。

• コンポーネントマネージャで新しいフォルダを追加し、コンポーネントを
作成します。
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• インターフェースを定義し、ブロックダイアグラムを作成します。

これまでのレッスンと大きく異なるのは、コントローラをモジュールとして実装
する点です。モジュールはプロジェクトの 上レベルのコンポーネントとして用
いられます。モジュール内では、プロジェクトを構成する「プロセス」が定義さ
れます。

コントローラコンポーネントを作成する：

• コンポーネントマネージャで、新しいサブフォル
ダを Tutorialフォルダに追加し、その名前を
Lesson4にします。

• Lesson4フォルダを選択し、Insert → Module 
→ Block diagram を選択して新しいモジュール
を追加します。

• 新しいモジュールの名前を IdleConにし、ブ
ロックダイアグラムエディタを開きます。

• “Outline”タブで、ダイアグラム processの名
前を p_idleに変更します。

モジュールの機能は「プロセス」という単位で定義されます。モジュールにおけ
るプロセスは、クラスにおけるメソッドに相当します。プロセスはメソッドとは
異なり、引数や戻り値を伴いません。ASCET におけるプロセス間の通信、つまり
データ交換は、「受信メッセージ」（入力）および「送信メッセージ」（出力）と呼
ばれる方向性のあるメッセージを使用して行われます。

ここで作成するコントローラは、実際の回転数を受信メッセージ nとして受け取
り、それを使用して算出されたスロットル位置を air_nominalという送信
メッセージに代入して出力します。

コントローラのインターフェースを定義する：

• Receive Message ボタンをクリックして受信
メッセージを作成し、その名前を nにします。

• メッセージ nのプロパティエディタを開き、Set() 
Method オプションをオンにします。

• Send Messageボタンをクリックしてから描画エ
リア内をクリックして、送信メッセージを作成し
ます。
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• 送信メッセージの名前を air_nominalにしま
す。

• メッセージair_nominalのプロパティエディタ
を開き、Get() Method オプションをオンにしま
す。

このコントローラには、レッスン 3 で作成した積分器 Integrator を使用します。

コントローラに Integrator を追加する：

• Insert → Component を選択して、“Select 
item”ダイアログボックスを開きます。

• “1 Database”ペインの Tutorial¥Lesson3
フォルダから Integratorを選択し、OK をク
リックします。

• 積分器がコンポーネント IdleConに内包されま
す。コンポーネントは参照により内包されるた
め、この積分器の元の定義を変更すると、他のコ
ンポーネントに内包されるこの積分器のコンポー
ネントにも、その変更が反映されます。

これまでに追加したエレメント以外に、以下のエレメントをコントローラに追加
する必要があります。

• ndiffと pi_valueという、continuous 型の 2 つの変数

• n_nominal、Kp、および air_lowという、continuous 型の 3 つのパラ
メータ
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コントローラの残りの部分を定義する：

• 必要な演算子や他のエレメントを作成してから、
それらを下のブロックダイアグラムのように接続
します。

• “Outline”タブから、n_nominalパラメータを
選択して、Edit → Data を選択します。

• n_nominalの値を 900 にします。

• Kpの値を 0.5 にします。

• ダイアグラム内の定義を保存し、変更をデータ
ベースに適用します。
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4.4.2 コントローラの実験を行う

モジュールの実験は、コンポーネントの実験と同様の手順で行います。まず、
データジェネレータとイベントジェネレータをセットアップし、次に測定システ
ムをセットアップします。

実験をセットアップする：

• Build → Experiment を選択して、実験環境を開
きます。

• “Event Generator”ウィンドウを開き、プロセス
p_idle用のイベントをイネーブルにして、dT
はデフォルト値の 0.01 のままにしておきます。

プロセス用のイベントも、メソッド用のイベント
と同じように機能します。

• “Data Generator”ウィンドウを開き、受信メッ
セージ n用のチャンネルに以下の値を設定しま
す。

Mode： pulse

Frequency： 1.0Hz

Phase： 0.0

Offset： 800.0

Amplitude： 200.0
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• 変数 n_diffおよび air_nominalをオシロス
コープに割り当てます。

• オシロスコープの値軸の範囲を -500 ～ 500 に、時
間軸の範囲を 2 にします。

• Save Environment ボタンをクリックします。

これで実験のセットアップが終わり、回転数の偏差とスロットル位置の関係を表
示できるようになりました。

コントローラの実験を行う：

• Start Offline Experiment ボタンをクリックし
て、実験を開始します。

• 変数KiおよびKp用の適合ウィンドウを開きます。
そこから、値 Kiおよび Kpを調整し、その出力
に対する影響を調べることができます。

有意義な値に戻すために、実験中にモデルを再初
期化する必要があるかもしれません。

4.4.3 プロジェクト

プロジェクトは、完結したソフトウェアシステムとして機能する ASCET ソフト
ウェアの単位です。プロジェクトは、実験ターゲットやマイクロコントローラ
ターゲットを使用して、オンラインでリアルタイムな実験を行うことができます。
個々のコンポーネントの実験はオフライン（PC ベース）でしか行えません。

実験はプロジェクト単位で実行されます。プロジェクト用のコードが生成される
と、オペレーティングシステムコードも必ず生成されます。ASCET で作成された
ソフトウェアシステムをリアルタイムに実行するには、オペレーティングシステ
ムのセットアップが必要です。ソフトウェアシステムをリアルタイムに実行する
実験を「オンライン実験」と呼びます。これまでのレッスンで行った実験はすべ
てオフライン実験であり、リアルタイムなシミュレーションは行われませんでし
た。

注記

オンライン／オフラインにかかわらず、ASCET の実験は実際にはすべてプロ
ジェクトの単位で行われます。このことはオフライン実験でデフォルトプロ
ジェクトを使用する（このプロジェクトはユーザーからは見えない場合もあり
ます）ことでも明らかです。オペレーティングシステムを定義する目ために明
示的にプロジェクトを作成してセットアップしなければならないのは、オンラ
イン実験の場合だけです。ただし、ユーザー独自のアプリケーション用にデ
フォルトプロジェクトを設定することもできます。
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4.4.4 プロジェクトをセットアップする

コンポーネントマネージャで、IdleConモジュールと同じフォルダにプロジェ
クトを作成します。

プロジェクトを作成する：

• コンポーネントマネージャで、Insert → Project
を選択するか、または Insert Project ボタンをク
リックして、新しいプロジェクトを追加します。

• プロジェクトの名前をControllerTestにしま
す。

• Edit → Open Component を選択するか、また
はプロジェクトエレメントをダブルクリックしま
す。

プロジェクト用のプロジェクトエディタが開きま
す。

次に、プロジェクトの“Outline”タブに IdleConコントローラを追加します。

プロジェクトにコンポーネントを追加する：

• プロジェクトエディタで Insert → Component 
を選択して、“Select Item”ダイアログボックス
を開きます。

• “1 Database”リストから、 Tutorial/
Lesson4 フォルダのコンポーネント、
IdleConを選択します。

• OK をクリックして、このコンポーネントを追加
します。

コンポーネントの名前が、プロジェクトエディタ
の“Outline”タブに表示されます。
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参照されるコンポーネントは、非参照コンポーネントに内包されます。つまり、
内包されたコンポーネントのダイアグラムを変更すると、その変更がプロジェク
ト全体に反映されます。

プロジェクトに含まれるタスクとプロセスのスケジューリングは、オペレーティ
ングシステムによって行われます。プロジェクト用のコードを生成する前に、タ
スクをいくつか作成してそれらにプロセスを割り当てておく必要があります。

オペレーティングシステムのスケジューリング条件は、プロジェクトエディタの
“OS”タブに定義します。ここで、p_idleプロセスが 10ms ごとに起動される
ように、オペレーティングシステムのスケジュールを定義しましょう。

プロジェクト用のオペレーティングシステムのスケジュールをセットアップす
る：

• “OS”タブをクリックします。

• Task → Add を選択して、新しいタスクを作成し
ます。

• 作成したタスクの名前を Task10msにします。

作成されるタスクは、デフォルトでは Alarm タス
ク、つまり、オペレーティングシステムにより周
期的に起動されるタスクです。

• “Period”フィールドで、このタスクの周期を
0.01 秒にします。

この周期は、タスクが起動される頻度を規定しま
す。この例では、10ms ごとに起動されます。
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• “Processes”リストの IdleControlというアイ
テムを展開します。

• プロセス p_idleを選択し、Process → Assign
を選択します。

このプロセスが Task10msタスクに割り当てら
れ、“Tasks”リストのこのタスク名の下に表示さ
れます。

プロジェクト内においては、インポートエレメントやエクスポートエレメントを
用いてプロセス間通信を行います。これらのエレメントはグローバルエレメント
で、モジュール間通信の送信メッセージと受信メッセージに相当します。グロー
バルエレメントはプロジェクト単位で宣言され、プロジェクト内の各モジュール
に含まれる同名のエレメントに結び付けられていなくてはなりません。

グローバルエレメントを定義する：

• プロジェクトエディタで、Extras → Global 
Elements → Resolve Globals を選択します。

グローバルエレメントが作成され、それぞれ対応
するエレメントに結び付けられます。同じ名前の
エレメント同士が自動的に結び付けられます。

4.4.5 プロジェクトの実験を行う

まず、このプロジェクトのオフライン実験を行います。オフライン実験は、ハー
ドウェアを接続せずに PC 上で行うことができます。プロジェクトのデフォルト
設定では PC 上で稼働するようになっているので、この設定を変更する必要はあ
りません。プロジェクトのオフライン実験は、コンポーネントのオフライン実験
と同様の手順で行います。

実験をセットアップする：

• コンポーネントマネージャで、File → Save 
Database を選択します。

実験環境を起動する前に、変更内容を必ずデータ
ベースに保存することをお勧めします。

• プロジェクトエディタで Build → Experiment 
を選択します。
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プロジェクトのコードが生成され、オフライン実
験が開きます。

• Open Event Generator ボタンをクリックしま
す。

プロジェクト用のイベントジェネレータには、コ
ンポーネントの実験の場合のように各メソッドや
各プロセス用のイベントではなく、実験で使用す
る各タスク用のイベントが表示されます。

• ダイアログボックスからタスク generateData
をイネーブルにし、dT値にはデフォルトの 0.01
秒を採用します。

タスク Task10msはデフォルト状態ですでにイ
ネーブルになっているので、これでタスク
generateData および 10ms のイベントの dT値
はともに 0.01 秒になります。これ以上変更の必
要はありません。

• イベントジェネレータを閉じます。

• データジェネレータと測定システムを、前回の実
験と同じ値でセットアップします（80 ページの

「コントローラの実験を行う」を参照してくださ
い）。

• File → Save Environment を選択して、環境設
定を保存します。

実験を行う：

• Start Offline Experiment ボタンをクリックし
ます。
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• 前項と同様にKiおよびKpパラメータを調整して、
出力への影響を確認します。

4.4.6 まとめ

このレッスンでは、ASCET で以下の作業を行いました。

• モジュールを作成する

• モジュール内のメッセージを作成する

• コンポーネントマネージャで作成したコンポーネントをブロックダイアグ
ラムに組み込む

• プロジェクトを作成する

• プロジェクトにコンポーネントを内包する

• タスクを作成し、それらにプロセスを割り当てる

• プロジェクトの実験を行う

4.5 プロジェクトを拡張する

このレッスンでは、コントローラを少し改良して一層実用的なものにします。セ
ンサで読みとった値を実際の値に変換する、シグナルコンバータを作成します。
たとえば自動車制御アプリケーションで用いられるような多くのセンサは、温度、
位置、毎分の回転数などの測定値に対応する電圧を返します。この電圧と測定値
の関係は、必ずしも一次関数で表せるとは限らないので、ASCET では、この種の
対応関係を効率的にモデリングできる特性テーブルを使用できます。

4.5.1 シグナルコンバータを定義する

シグナルコンバータをモデリングするために、まずフォルダとモジュールを作成
して、機能を定義します。シグナルコンバータは 2 つの特性カーブを使用して、
入力値に対する出力値を求めます。

モジュールを作成する：

• コンポーネントマネージャで、新しいフォルダ
Tutorial¥Lesson5を作成します。

• 新しいモジュールを作成し、その名前を
SignalConvにします。

• エレメントをダブルクリックしてブロックダイア
グラムエディタを開きます。

• ブロックダイアグラムエディタで Insert → 
Process を選択して 2 つめのプロセスを作成しま
す。

• 2 つのプロセスの名前を n_samplingおよび
t_samplingにします。
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• “Outline”タブに、2 つの受信メッセージ U_nお
よび U_tと、2 つの送信メッセージ tおよび n
を作成します。

• One-D Table ボタンをクリックして、特性カー
ブエレメントを作成します。

プロパティエディタが開きます。

• t_sensorという名前を入力します。

• “Dimension”フィールドの“x”の部分に値 13 を
入力します。

これにより、この特性カーブを 大 13 列まで広
げることができるようになりました。

特性カーブは 1 次元なので、“Dimension”
フィールドの“ｙ”の部分は無効になっていま
す。

• OK をクリックしてプロパティエディタを閉じま
す。

• 描画エリア内をクリックして、テーブルを配置し
ます。

このテーブルが“Outline”タブに追加されます。

• 大 2 列の第 2 のテーブルを作成し、n_sensor
という名前にします。

• 下図のようにエレメントを接続し、シーケンシン
グを編集して、この処理を行うプロセスを割り当
てます。

次に、2 つの特性カーブのデータを編集します。ASCET ではテーブルエディタを
使用して各種テーブルデータ（配列、特性カーブ、および特性マップ）を編集し
ます。

テーブルを編集する：

• テーブル t_sensorを右クリックし、ショート
カットメニューから Data を選択します。

テーブルエディタが開きます。
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• テーブルのサイズを以下のように調整します。

テーブルが 13 列に拡張され、z 値はすべてデ
フォルトで 0 になります。

• 以下の値を入力します。上の行が X 行、下の行が Z
行の値です。

まずサンプルポイント（X 値）を左から右の順に
入力して、テーブルを編集します。

• 編集しようとする X 値をクリックしてから、ダイ
アログボックスに新しい値を入力します。

新しい値は両隣のサンプルポイントの間の値でな
ければなりません。

• 次に、Ｚ 値（出力値）をクリックし、強調表示さ
れた値の上に適切な値を入力します。

• 同じ方法で、以下のデータを使用して、第 2 の
テーブルを編集します。

• ブロックダイアグラムエディタで、File → Save 
を選択します。

• コンポーネントマネージャで、Save ボタンをク
リックして、変更内容を保存します。

この例では、第 2 のテーブルは出力が入力の変化に従って直線的に変化する関係
を表せばよいので、必要なサンプルポイントは 2 つだけです。値の補間モードと
して線形補間を指定したので、これで充分に機能します。

線形補間では、2 つのサンプルポイント間の入力値に対応する出力値は、直線か
ら求められます。この場合、入力値が 0 なら 0 が返され、10 なら 6000 が返され
ます。入力値が 5 の場合、戻り値は補間により 3000 になります。

4.5.2 シグナルコンバータの実験を行う

新しいコンポーネントの実験を行い、テーブルによる変換処理の結果を調べてみ
ましょう。2 つのテーブルの値の範囲は互いに異なるので、それぞれに専用のオ
シロスコープウィンドウを使用します。

0.00 0.08 0.30 0.67 1.17 2.50 5.00 7.50 8.83 9.33 9.70 9.92 10.00

-40.0 -26.0 -13.0 0.0 13.0 40.0 80.0 120.0 146.0 160.0 173.0 186.0 200.0

0.0 10.0

0.0 6000.0
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実験をセットアップする：

• コンポーネントマネージャから Build → 
Experiment を選択して、実験環境を開きます。

• コンポーネント内の各プロセス（n_sampling、
t_sampling、generateData）用にイベン
トを作成し、各イベントの dT値を 4ms にしま
す。

• データジェネレータで、メッセージ U_n用と U_t
用にチャンネルを 1 つずつ作成し、両チャンネル
に以下の値を設定します。

• メッセージnおよびU_nのオシロスコープウィン
ドウと、メッセージ tおよび U_tのオシロス
コープウィンドウを作成します。

後者のオシロスコープを作成する際には、“Select 
Measure View”コンボボックスで必ず <2. New 
Oscilloscope>を選択しておいてください。

Mode： sine

Frequency： 2.0Hz

Phase： 0.0

Offset： 5.0

Amplitude： 5.0
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2 つのテーブルのサンプリングポイントの分解能とそれに対応する補間値は大き
く異なるので、各チャンネルの表示設定は、それぞれのオシロスコープ内で個別
に行う必要があります。

オシロスコープを測定値にあわせて調整する：

• プロセス n_sampling用のオシロスコープ
（チャンネル U_nおよび n）を選択します。

• “Measure Channels”リストから、メッセージ n
を選択し、Extras → Setup を選択します。

メッセージ n用の“Display Setup”ダイアログ
ボックスが開きます。

• 値軸の範囲を 0 ～ 6000 にし、時間軸の範囲を 0.5
にします。

• メッセージ U_n用の“Display Setup”ダイアログ
ボックスを開きます。

• その値軸の範囲を -1 ～ 11 にします。

時間軸の範囲は、1 つのオシロスコープウィンド
ウ内のすべての変数について同じでなければなら
ないので、時間軸の範囲を変更する必要はありま
せん。

• プロセス t_sampling（チャンネル U_tおよび
t）用のオシロスコープを選択し、そのチャンネ
ルを以下のようにセットアップします。

• File → Save Environment ボタンをクリックし
て、環境設定を保存します。

これで、実験を実行してシグナルコンバータの機能を調べることができるように
なりました。2 つの変換処理の相違を調べてみましょう。

U_t t

Min -1 -40

Max 11 200

Extent 0.5 0.5
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実験を行う：

• Start Offline Experiment ボタンをクリックし
ます。

n_sensorテーブルでは、入力される正弦波の
振幅だけが変化します。ここでの入力は 0 ～ 10
ボルトの電圧信号です。これが 0 ～ 6000rpm の
回転速度にマッピングされます。

テーブル t_sensorでは、入力される電圧と出
力される温度との関係は一次関数では表せませ
ん。この関係は自動車制御用に一般に用いられて
いる温度センサの応答特性カーブと同じです。

• データジェネレータからの入力をさまざまな波形
に変更して、両方の出力カーブに表れる影響を調
べます。

4.5.3 シグナルコンバータをプロジェクトに統合する

シグナルコンバータの定義が終わったので、これを、レッスン 4 で作成したプロ
ジェクトに統合します。シグナルコンバータからの出力信号が、エンジンコント
ローラへの入力信号として使用されます。

プロジェクトにシグナルコンバータを統合するために、新しいプロセス用のタス
クをセットアップし、プロセス間通信に必要なグローバルエレメントを宣言して
その結び付けを行います。

シグナルコンバータをプロジェクトに追加する：

• プロジェクトControllerTestをプロジェクト
エディタで開きます。

• モジュール SignalConvを、コンポーネントマ
ネージャの“1 Database”リストからプロジェク
トの“Outline”タブにドラッグします。
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• “OS”タブをクリックして、オペレーティングシ
ステムエディタを開きます。

• 新しいタスク n_samplingを作成します。

• 新しいタスクの周期を 0.004 秒にします。

• プロセスn_samplingをタスクn_samplingに
割り当てます。

これで、プロジェクトに 2 つのタスクが定義されました。第 1 のタスクは 10 ミ
リ秒ごと、第 2 のタスクは 4 ミリ秒ごとに起動されます。1 つのタスクに割り当
てられているすべてのプロセスは、そのタスクに定義されているインターバルで
実行されます。この例ではそれぞれのタスクにプロセスが 1 つずつしかありませ
んが、必要に応じて任意の数のプロセスを割り当てることができます。

シグナルコンバータを統合するためには、次にモジュール間の通信を解決します。
プロセス間通信はグローバルエレメントを介して行われます。プロジェクト内で
用いられるすべてのグローバルエレメントは、対応するモジュール内でメッセー
ジとして定義されていなければなりません。

デフォルトでは、送信メッセージはモジュール内に定義されますが、受信メッ
セージは、通常モジュールにインポートされるものであるため、プロジェクト内
で受信メッセージを定義する必要があります。

グローバルエレメントをセットアップする：

• Extras → Global Elements → Resolve 
Globals を選択して、結び付けを自動で行いま
す。

• Extras → Global Elements → Delete Unused 
Globals を選択して、前のレッスンで使用した結
び付けを削除します。

必要なグローバルエレメントはすべて、自動的に作成され、同じ名前のエレメン
トに結び付けられます。たとえばグローバルメッセージ U_nは、SignalConv
内のメッセージ U_nに自動的に結び付けられます。
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レッスン 4 ではメッセージ nをプロジェクトのグローバルメッセージとして定義
しましたが、このレッスンではメッセージ nをモジュール SignalConvに定義
し、モジュールのプロセス間通信に使用します。そのため、使用しないグローバ
ルメッセージ nを削除する必要があります。

プロジェクトの実験を行う：

• Build → Experiment ボタンをクリックして実験
環境を開きます。

• イベントジェネレータを開き、タスク
n_samplingをイネーブルにします。

• このタスクの dT値を 4 ミリ秒にします。

プロジェクトのオフライン実験では、オンライン
実験時にはオペレーティングシステムが行うスケ
ジューリングを、イベントジェネレータがシミュ
レートします。

• データジェネレータを開き、既存のデータチャン
ネルを削除します。

• メッセージU_n用に新しいチャンネルを設定しま
す。

• チャンネル U_nを以下のように設定します。

• 回転速度センサの出力電圧U_nをアクティブにし
ます。

シグナルコンバータは、特性テーブル
n_sensorを使用してこの電圧値を回転数 nに
変換します。

上記の値により、nが前の実験（信号処理なし）
と同じ範囲で出力されます。

• Save Environment ボタンをクリックします。

• 実験を開始します。

出力されるカーブは、信号処理を行わない例で出力されたカーブと同じはずです。
データジェネレータによりスティミュレートされる値は異なりますが、テーブル
で処理され、前の実験と同じ出力値になります。

Mode： pulse

Frequency： 1.0Hz

Phase： 0.0

Offset： 4/3

Amplitude： 1/3
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4.5.4 まとめ

このレッスンでは、ASCET で以下の作業を行いました。

• 特性カーブエレメントを作成して使用する

• コンポーネントをプロジェクトに追加する

• プロジェクト内のコンポーネント間の通信を定義する

4.6 連続系をモデリングする

物理、機械、電子、およびメカトロニクスに関する処理を現実的にモデリングす
るには微分方程式を用いることが多く、連続系メソッドが要求されます。このよ
うなメソッドをこれまでの章で作成したプロジェクトに統合する前に、本章では
詳しい例を用いて、連続系のモデリングについて説明します。

ASCET は、いわゆる「CT ブロック」による連続系のモデリングとシミュレー
ションをサポートしています。CT は“Continuous Time”（連続時間）の略で、
疑似連続的な時間ステップで計算処理が行われることを意味します。ASCET にお
ける連続系モデリングは、連続系の設計に用いられる標準的な記述形式である、
状態空間表現をベースとしています。この形式では、CT 基本ブロックを非線形 1
次常微分方程式と非線形出力方程式で定義することができます。ASCET は、これ
らの微分方程式の 適な解を見つけるための、いくつかのリアルタイム積分メ
ソッドを提供します（詳細は ASCET オンラインヘルプを参照してください）。

以下に、ばね－質量系の、地球の重力による減衰を伴う動きを例にして、連続系
のモデリングの手順を説明します。

4.6.1 運動方程式

上図の質量 mには、以下の力が働いています。

• 重力：Fg = -mg
（g = 重力の加速度）

m

x

c

d
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• ばねの力：FF = -c (x + l0)
（c = ばね定数、l0 = 静止時のばねの長さ、x = 質量 mの位置）

• 減衰 FD = - d x’
（d = 減衰定数、x’ = 質量の速度）

これにより、以下の運動方程式が得られます。

mx’’ = -mg + F あるいは x’’ = -g + F/m (ただし F = FF + FD)

この 2 次微分方程式を（x = x、v = x’により）2 つの 1 次微分方程式にする
と、以下のようになります。

x’ = v
v’ = -g + F/m

以下のモデル設計では、これらの微分方程式を使用します。

4.6.2 モデル設計

ばね－質量系のモデルは、CT ブロックを 1 つだけ用いてシンプルに設計すること
もできますが、ここでは 2 つの CT ブロックを用いてこのモデルをモデリングし
ます。その過程で「直接通過」や「間接通過」のプロパティについて説明し、こ
れらのプロパティを適切に設定して算術ループを避ける方法を紹介します。

• Forceブロックでは、質量 mの位置と、速度 x’から求められる摩擦力に基
づいて、ばねの力 Fを算出します。

• Massブロックでは、ばねの力 Fから加速度x’’を算出します。x’’を積分
して、速度 x’と位置 xを算出します。

一見して、このシステムでは、どちらのブロックも相手のブロックから要求され
る出力を算出するために相手のブロックからの入力が必要なので、算術ループに
なってしまうように見えます。

このループは、「直接通過 」または「間接通過」のプロパティを適切に設定する
ことによって回避することができます。

• Forceブロックでは、下の方程式により算出される出力変数 Fは、入力変
数 xおよび x’に直接依存しています。したがって、このブロックは直接
通過として定義されます。

F = -c(x + l0) - dx’

• 一方、Massブロックでは、出力変数xおよびx’は入力変数Fに直接依存し
ているわけではなく、ブロックの内部ステート変数に依存しています。こ
れらは、少なくとも初めは初期値になっているので、入力変数 Fの値がわ

Mass
x, x'

F
Force
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からなくても、初期値に基づいて出力変数 xおよび x’を算出することが
できます。Fの値がわかっている場合には、出力変数は微分方程式を用い
て算出されます。

x’ = v
v’ = -g + F/m 

したがって、このブロックは、間接通過として定義します。

モデルを作成する：

• コンポーネントマネージャでフォルダを作成し、
その名前を Lesson6にします。

• このフォルダ内で Insert → Continuous Time 
Block → ESDL を選択して、Forceおよび
Massというブロックを作成します。

• Forceブロックをダブルクリックして、ESDL エ
ディタを開きます。

• Input ボタンをクリックして、x および v とい
う 2 つの入力（continuous型）を作成しま
す。

• Output ボタンをクリックして、出力 F
（continuous型）を作成します。
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• Parameter ボタンをクリックして、定数 c（ばね
定数）、d（減衰定数）、l0（静止時のばねの長
さ）を作成します。

“Outline”タブ内のメソッドは自動的に作成され
ます。

• “Outline”タブ内の各定数を右クリックして、
ショートカットメニューから Data を選択しま
す。

“Numeric Editor”ダイアログボックスが開きま
す。

• 定数に現実的な値を割り当てます（例、ばね定数
cには 5.0、減衰定数 dには 1.0、静止時のばね
の長さ l0 には 2.0）。

• “Outline”タブ内のメソッド
directOutputs[]をクリックします。

• “Edit”フィールドに、力を算出する以下の式を定
義します。

F = -c * (x + l0) - d*v;
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• Generate Code ボタンをクリックします。

CT ブロック Forceがコンパイルされます。

• Massブロックをダブルクリックして、ESDL エ
ディタを開きます。

• Force ブロックの場合と同様にして、入力 F、2 つ
の出力 xおよび v、パラメータ m（質量）、およ
び定数 g（重力加速度）を作成します。

• Force ブロックの場合と同様にして、gおよび mに
値を割り当てます（gは 9.81、質量 mはたとえ
ば 2.0）。

• Continuous State ボタンをクリックして、出力
を内部で計算するためのステート変数 x_local
および v_localを作成します。

• derivatives[]メソッドに、計算に必要な微
分方程式を定義します。

x_local.ddt(v_local)

v_local.ddt(-g + F/m)

• nondirectOutputs[]で、ステート変数
x_localおよび v_localを出力 xおよび vに
渡します。

x=x_local;
v=v_local;
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• init[]メソッドでは、ユーザーが
resetContinuousState()関数を使用して、
xと vに現実的な初期値を与えることができま
す。

resetContinuousState(x_local,0.0);
resetContinuousState(v_local,0.0);

• Generate Code ボタンをクリックします。

CT ブロック Massがコンパイルされます。

ブロックダイアグラムエディタ（BDE： Block Diagram Editor）を使用して、2 つ
の基本 CT ブロックを結合して 1 つの CT 構造ブロックにします。

2 つの基本 CT ブロックを結合する：

• コンポーネントマネージャの Lesson6 フォルダ
を選択し、Insert → Continuous Time Block → 
Block Diagram を選択して新しいブロック
Mass_Springを作成します。

• 新しいブロックをダブルクリックしてブロックダ
イアグラムエディタ（BDE）を開きます。

• コンポーネントマネージャから Massおよび
Forceブロックを 1 つずつドラッグして BDE
ウィンドウにドロップし、Mass_Spring内に
組み込みます。
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• 対応する入力と出力とを接続します。

• Build → Experiment を選択します。

CT ブロックがコンパイルされ、実験環境が起動
されます。

注記

CT 基本ブロックの 1 つをダブルクリックすると、そのブロックを編集できるよ
うになります。ブロックに修正を加えるとライブラリ全体、つまり、その基本
ブロックを使用するすべての構造ブロックに影響します。
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• 以下のように数値エディタとオシロスコープを設
定します。

• オシロスコープ内のチャンネルのスケールを、x
は -10 ～ 0、vは -8 ～ +8 に調整します。

4.6.3 まとめ

このレッスンでは、ASCET で以下の作業を行いました。

• モデルを作成してプロセスをシミュレートする

• ESDL エディタを使用して、直接および間接通過の CT ブロックを作成する

• ブロックダイアグラムエディタを使用して、複数の CT ブロックを結合する

• 物理実験を行う
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4.7 プロセスモデル

前のレッスンでの CT ブロックの紹介に続いて、それらの CT ブロックを使用した
コントローラのテストを行います。ASCET では、制御対象となる物理プロセスの
モデルを開発し、閉制御ループによってコントローラモデルの実験を行うことが
できます。これにより、実際の車両を使用する前にコントローラのテストを入念
に行っておくことができます。

ここでは、モータの物理プロセスを扱います。この物理プロセスモデルはエンジ
ン回転速度センサの値 U_nを返します。そしてコントローラはこの値を処理し、
値 air_nominalを返します。コントローラの出力値によりエンジンのスロッ
トル位置が決まり、さらにこのスロットル位置が回転速度に影響します。

図 4-1 閉ループ実験

このプロセスモデルには CT ブロックを使用します。連続系コンポーネントはプ
ロセスモデルに特に適していて、モデルのベースとなるのは、PT2 系をモデリン
グする以下の微分方程式です。

T2 s’’ + 2DTs’ + s = Ku

式 4-1 PT2 系

この方程式においては、パラメータ T、D、および K に適切な値を設定する必要
があります。

4.7.1 プロセスモデルを定義する

連続系コンポーネントの作成方法は、他のコンポーネントの作成方法とは異なり
ます。連続系コンポーネントには入力と出力があり、これらは引数と戻り値に相
当します。主な違いは、連続系ブロックは複数の入力と出力を伴うことができ、
それらが特定のメソッドと結びついていないことです。各連続系ブロック内には、
あらかじめ一連のメソッドが固定的に定義されていて、これをユーザーが変更す
ることはできません。
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ここでは、ESDL コードを使用します。ESDL コードの構文は C++ や Java に似て
います。オブジェクトのメソッドは、「オブジェクト名 . メソッド名 ( 引数 ); 」の
形式で呼び出されます。微分に用いるメソッドは ddt()と呼ばれます。たとえ
ば、方程式  は、ESDL では s.ddt(sp);という文で表記されます。

連続系コンポーネントを作成する：

• コンポーネントマネージャでフォルダ
Tutorial¥Lesson7を作成します。

• 連続系ブロックを追加するために、Insert → 
Continuous Time Block → ESDL を選択しま
す。

• 新しいコンポーネントの名前を ProcModelにし
ます。

• Edit → Open Component を選択して、ESDL エ
ディタを開きます。

ここではもちろん外部テキストエディタも使用で
きます。使用方法は、チュートリアルの 初の部
分に説明されています。

プロセスモデルを編集するには、まず必要なエレメントを追加してから、メソッ
ド derivatives()および nondirectOutputs()を編集します。

プロセスモデルを編集する：

• ESDLエディタのContinuous Stateボタンを使用
して、2 つの連続ステートを作成します。

• これらのステートの名前を sおよび spにします。

• 入力 uを作成します。

• 出力 yを作成します。

どのエレメントも cont型です。

• パラメータ Dを作成します。

• パラメータ Kおよび Tを作成します。

このプロセスモデルの“Outline”タブは、以下
のようになります。

sp s·=
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• 各パラメータを以下のように設定します。

D = 0.4
K = 0.002
T = 0.05

• “Online”タブで derivativesメソッドを選択
し、そのコードを以下のように編集します。

s.ddt(sp);
sp.ddt((K*u-2*D*T*sp-s)/(T*T));

この図は内部テキストエディタを使用した例で
す。

• “Outline”タブから nondirectOutputsメ
ソッドを選択し、以下のテキストを入力します。

y = s;

• レイアウトエディタでレイアウトを調整します。

プロセスモデルの場合、出力を左側、入力を右側
に配置するのがよいでしょう。

• Edit → Save を選択します。

• コンポーネントマネージャの Save ボタンをク
リックして、プロセスモデルを保存します。

これで、新しいモデルを用いて実験を開始する準備ができました。

モデルの実験を行う：

• ESDL エディタで Build → Experiment を選択し
て、実験環境を開きます。

注記

微分方程式の解法については、ASCET オンライン
ヘルプの連続系ブロックの記述法についてのト
ピックを参照してください。
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• Open CT Solver ボタンをクリックして、“Solver 
Configuration”ダイアログボックスを開きます。

現在のコンフィギュレーションが表示されます。

• OK をクリックしてデフォルト設定を有効にしま
す。

• データジェネレータを開き、入力 u のチャンネル
を作成します。

• 以下の値をチャンネル u に設定します。

• チャンネル u および y のオシロスコープウィンド
ウを開きます。

• オシロスコープの各測定チャンネルを、以下のよ
うに設定します。

• Save Environment ボタンをクリックします。

Mode： pulse

Frequency： 0.5Hz

Phase： 0.0s

Offset： -0.5

Amplitude： 1.0

u y

Min -1 -0.002

Max 2 0.004

Extent 3.0 3.0
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• 実験を開始します。

出力は下図のようになるはずです。

4.7.2 プロセスモデルを統合する

閉制御ループを作成するために、前に作成したコントローラプロジェクトにプロ
セスモデルを統合します。これまでのレッスンと同様に、モジュールを内包させ、
オペレーティングシステムをセットアップしてグローバルエレメントを結び付け
るという作業が必要です。

プロセスモデルを内包させる：

• コンポーネントマネージャから
ControllerTest用のプロジェクトエディタ
を開きます。

プロジェクトエディタで、コンポーネント
ProcModelを“Outline”タブに追加します。

• プロジェクトエディタの“OS”タブを選択し、
CT タスクのスケジューリングを定義します。

注記

作業を単純にするために、プロセスモデルを同じプロジェクトに追加します。
この方法は、閉ループシミュレーションの早い段階でのテストにしばしば役立
ちますが、プロセスモデルは組み込みシステムの構成要素ではないため、通常
は、ネットワーク経由で各プロジェクト向けに配布されます。
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• タスク simulate_CT1を選択し、“Period”
フィールドの値を 0.01（秒）に設定します。

コントローラとプロセスモデルが、共に同じ時間
間隔で実行されます。

連続系ブロックとモジュールの結び付けを自動的に行うことはできないので、ブ
ロックダイアグラムで明示的に接続する必要があります。

モジュールと連続系ブロックの結び付きを調整する：

• “Graphics”タブをクリックします。

• “Outline”タブから、3 つのコンポーネントをド
ラッグし、描画エリアにドロップします。

• モジュールのメッセージを、CT ブロックの対応す
る入出力に接続します。

この例では、ProcModelの出力 yにグローバル
メッセージ U_nを接続し、ProcModelの入力
uにグローバルメッセージ air_nominalをそ
れぞれ接続します。

• 各コンポーネントを右クリックして
Unconnected Ports を選択し、未接続のポート
がダイアグラムに表示されないようにします。

モジュール間通信のためのメッセージの結び付けは、自動的に行われます。同じ
名前のメッセージ同士が結びつきます。
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これでプロジェクトが完成し、実験を行えるようになりました。今度はオンライ
ン実験を行うので、ASCET-RP がインストールされていることと、リアルタイム
ターゲット（ES1000 など）が接続されていることが必要となります。これらの
条件が揃っていない場合は、これまでどおりオフライン実験を行ってください。

プロジェクトをオンライン実験用にセットアップする：

• Project Properties ボタンをクリックします。

• “Project Properties”ダイアログボックスの
“Build”ページで、ターゲットに ES1130、コン
パイラに GNU-C V3.4.4 (PowerPC) を選択
します。

これらのオプション設定により、ハードウェアと
それに対応するコード生成用コンパイラが指定さ
れます。

• OK をクリックして、ダイアログボックスを閉じ
ます。

Reconnect to Experiment of selected 
Experiment Target および Select Hardware 
ボタンが有効になります。

• “OS”タブをクリックして、オペレーティングシ
ステムエディタを開きます。

注記

オフライン実験を行う場合には、グローバルメッセージ U_nをデータジェネ
レータから必ず削除してください。
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• 前に作成したスケジューリング設定をコピーする
ために、Operating System → Copy From 
Target を選択します。

• “Selection Required”ダイアログから PCを選択
して OK をクリックします。

これで、新しいターゲット用のプロジェクトに、
以前の PC でのオフラインシミュレーション用に
定義したものと同じスケジューリング設定が定義
されました。

オンライン実験には、オフライン実験とは異なる点がいくつかあります。オンラ
イン実験ではイベントジェネレータやデータジェネレータは用いません。イベン
トジェネレータは、オンライン実験用に生成されるオペレーティングシステムタ
スクのスケジューリングをオフライン実験でシミュレートするためのものです。

オンライン実験では、実験コードの実行（つまり OS の起動）と測定とを別々に
開始します。このためツールバーにもそれぞれ専用のボタンが用意されています。
これは、測定によって実験のリアルタイム動作が影響を受ける場合があるので、
場合によっては測定を行わずに実験を行う必要があるためです。

プロジェクトの実験をオンラインで行う：

• “Experiment Target”コンボボックスから 
Online (RP) を選択します。

Offline (RP) はターゲット上でオフライン実
験を行うためのものです。
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• Build → Experiment ボタンをクリックします。

実験用のコードが生成され、前に定義した環境と
同じ環境で実験が開きます。

プロジェクトに複数のタスクが含まれている場
合、各測定変数の値をどのタスクで取得するかを
尋ねるダイアログボックスが開きます。

• “Selection Required”ダイアログボックスで、#3 
simulate_CT1 というタスクを選択して OK をク
リックします。

• n および n_nominal を既存のオシロスコープ
に設定し、それらの値の範囲を 0 ～ 2000 にしま
す。

• 変数 n_nominal、 Ki Kp 用の数値エディタを
開きます。
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• Start OS ボタンをクリックしてから、Start 
Measurement ボタンをクリックします。

実験が開始され、結果がオシロスコープに表示さ
れます。n の値が急速に n_nominal に近づ
き、その状態が維持されます。

• n_nominalを数値エディタで修正します。

n_nominalの値を変えると、それに応じて n 
の値が変わるはずです。

• パラメータ Ki および Kp を調整して、制御ルー
プの動作を 適化することができます。

4.7.3 まとめ

このレッスンでは、ASCET で以下の作業を行いました。

• 連続系ブロックを作成し、定義する

• 連続系ブロックの実験を行う

• 連続系ブロックをプロジェクトに統合する

• 変数の結びつきを定義する

• 異なるターゲットに切り替える

• プロジェクトの実験をオンラインで行う

4.8 ステートマシン

ステートマシンは、有限数の明確なステート間を遷移するシステムをモデリング
する際に有効な手段です。ASCET は、コンポーネントをステートマシンとして定
義するための強力な機能を備えています。このレッスンでは、温度によるアイド
リングエンジンの目標回転数の変化を表す、単純なステートマシンを定義しテス
トします。それから、そのステートマシンをプロジェクトに統合します。そして
次のレッスンで階層ステートマシンを構築します。

エンジンが冷えている時には、高速アイドリングさせて回転を維持する必要があ
ります。エンジンが暖まったら、燃料消費を減らすためにアイドリングの回転速
度を下げます。このためのステートマシンは「エンジンが冷えている」および

「エンジンが暖まっている」という 2 つのステートを持つ 2 段階制御を行います。

4.8.1 ステートマシンを定義する

ステートマシンはステート図と、アクションやコンディションの定義から構成さ
れます。アクションやコンディションの定義により、さまざまなステートで、お
よびステートからステートへの遷移時に何を行うかを指定できます。これらはブ
ロックダイアグラムと ESDL コードのどちらででも定義できます。

測定開始OS 起動
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ステートマシンはブロックダイアグラムエディタで定義します。これ以外の方法
としては、それぞれのステートやトランジションごとに開くテキストエディタに
ESDL コードを直接書き込む方法があります（注記：ここでは ESDL エディタは開
きません）。ステートマシンには、他のコンポーネントとのデータ交換に使用され
る入力と出力があります。

ステートマシンを作成する：

• コンポーネントマネージャで、フォルダ
Tutorial¥Lesson8を作成します。

• Insert → State Machine を選択するか、または 
Statemachine ボタンをクリックして新しいス
テートマシンを作成します。

• 作成したステートマシンの名前を WarmUpにしま
す。

• “1_Database”リスト内の新しいステートマシン
の名前をダブルクリックして、ステートマシンエ
ディタを開きます。

ステートマシンを作成する場合には、まずステートダイアグラムを定義してから、
ステートやステートトランジションに関連付けるさまざまなアクションやコン
ディションを定義します。

エンジンをコントロールするこのステートマシンには、「エンジンが冷えている」
および「エンジンが暖まっている」という 2 つのステートがあります。

ステートダイアグラムを定義する：

• State ボタンをクリックして、カーソルにステー
トアイテムをロードします。
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• 描画エリア内の、ステートを配置したい位置をク
リックします。

クリックした位置にステートシンボルが表示され
ます。

• ステートシンボルをもう 1 つ作成し、描画エリア
内の 初のステートの下に配置します。

• 先に作成したステートシンボルを右クリックし、
ショートカットメニューから Edit State を選択
して、ステートエディタを開きます。

• “State”フィールドに coldEngineというス
テート名を入力します。

• Start State オプションをオンにして、このス
テートを、 初にステートマシンが起動されたと
きのステート（「開始ステート」）にします。

ステートマシンには必ず開始ステートを 1 つ定義
する必要があります。
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• OK をクリックして、ステートエディタを閉じま
す。

ステートの名前が、ステートシンボル内に表示さ
れます。

• もう 1 つのステートシンボルの名前を
warmEngineにします。

• 描画エリア内のシンボルが表示されていない位置
を右クリックして、接続モードに切り替えます。

• coldEngineステートシンボルの右半分をク
リックして接続を開始し、次に warmEngineス
テートシンボルの右半分をクリックして、両ス
テートを接続します。

両ステートシンボルを結ぶ線が引かれます。この
線は下向きの矢印になっていて、ステート間で起
こり得るトランジションを表します。

• 下のステートシンボルの左半分から上のステート
シンボルの左半分に向けて、もう 1 つのトランジ
ションを作成します。

• File → Save を選択し、作成したステートマシン
を保存します。

• コンポーネントマネージャで File → Save 
Database を選択してデータベースを保存しま
す。

ステートマシン構築の際に次に行うのは、そのインターフェースの定義です。温
度値用の入力と、回転数用の出力が必要です。さらに、高温と低温、および回転
数（rpm）を定義するパラメータが必要です。
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ステートマシンのインターフェースを定義する：

• Input ボタンをクリックして、入力を作成します。

• その入力の名前を tにします。

• Output ボタンをクリックして、出力を作成しま
す。

• その出力の名前を n_nominalにします。

• Continuous Parameter ボタンで4つのパラメー
タを作成します。

• 各パラメータの名前と値を以下のように設定しま
す。

t_up = 70
t_down = 60
n_cold = 900
n_warm = 600

次に、両ステートと、その間のトランジションについて、アクションとコンディ
ションを定義します。各ステートに定義できるアクションは以下の 3 種類です。

• そのステートに入るたびに実行される Entry アクション

• そのステートを離れるたびに実行される Exit アクション

• そのステート内に留まって、状態が変化しない時に実行される Static アク
ション

同様に、各トランジションには、トリガイベント、コンディション、優先度およ
びアクションを定義することができます。トリガ名とコンディション名は、トラ
ンジションの隣に表示されます。ステートマシンが作成されるとトリガが 1 つ、
自動的に作成されます。

アクションとコンディションは、普通のダイアグラムか ESDL コードで定義され
ます。この例では、ESDL コードを使用します。

トリガのアクションとコンディションを定義する：

• coldEngineステートから warmEngineに向
かって接続されているトランジションを右クリッ
クします。

• ショートカットメニューから Edit Transition を
選択して、トランジションエディタを開きます。

coldEngine から warmEngine へ遷移するための
条件は、「実際の温度値 t が t_up より大きい」
ということです。
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• “Condition”タブのコンボボックスから <ESDL> 
を選択します。

このコンボボックスではあらかじめ定義されてい
るオプション設定を変更することができます。

• コンディションのコードペインに、下図のコード
を入力します。

このコンディションの評価結果が trueなら、エ
ンジンのアイドリング速度が n_warmになりま
す。

このコードはステートマシンダイアグラムに表示
されます。この例では、トランジションのコン
ディションに別名（1 行目のコメント）を付けた
ので、それがダイアグラムに表示されます。

• アクション用にも <ESDL> を選択し、以下のコー
ドを入力します。

n_nominal = n_warm;

• OK をクリックして、トランジションエディタを
閉じます。

ダイアグラムには、ステートマシンのコンディ
ションとアクションが表示されます。

注記

トランジションエディタでは、コンディションの
終わりにセミコロンを付けません。これは、通常
の ESDL コードにおいてコンディションを括弧で囲
んで記述する場合も同じです。
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• warmEngine から coldEngine へのトランジ
ションを編集するために、別のエディタを開きま
す。

• コンディションに <ESDL> を選択し、以下のコー
ドを入力します。

t < t_down

このコンディションには別名（コメント）を付け
なかったので、ダイアグラムにはこのコンディ
ションのコード全体が表示されます。

• アクションに <ESDL> を選択し、下図のコードを
入力します。

n_nominal = n_cold;

• エディタを閉じ、File → Save を選択します。

アクションとコンディションは、ESDL の代わりに BDE で定義することもできま
す。ただしその際は、先にアクションとコンディション用のブロックダイアグラ
ムを作成しておく必要があります。

アクションとコンディションのブロックダイアグラムを作成する：

• ステートマシンエディタで Insert → Diagram → 
Actions/Conditions BDE を選択します。

“Outline”タブに ActionCondition_BDEと
いう名前のブロックダイアグラムが作成されま
す。

• このデフォルト名を確定します。

これでアクションとコンディションを定義することができるようになりました。

アクションとコンディションをブロックダイアグラムで定義する：

• “Diagrams”フィールドの ActionCondition 
ダイアグラムをクリックします。

• Insert → Action と Insert → Condition で、新
しいアクションとコンディションを作成します。
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作成したアクションとコンディションは、トラン
ジションエディタ内の各タブのコンボボックスで
選択することができます。Edit ボタンをクリック
すれば、直接 BDE を開いてグラフィック編集を
行えます。

この時点で、出力 n_nominalの初期値はまだ定義されていません。パラメータ
とは異なり、この値を設定することはできないので、代わりに開始ステートであ
る coldEngineのアクションを定義します。ただし開始ステートの Entry アク
ションは 初にステートマシンが起動された時には実行されないため、初期値の
定義は Static アクション内で行う必要があります。

Entry アクションを定義する：

• 開始ステートcoldEngineを右クリックします。

• ショートカットメニューから Edit State を選択し
て、ステートエディタを開きます。

• “Entry”タブのコンボボックスから <ESDL> を
選択して、Entry アクションを定義します。

ここでの設定は、ASCET オプションダイアログ
ボックスの“Defaults”ページで設定されている
デフォルトの記述形式よりも優先されます。

• コードペインにn_nominal = n_cold;と入力
して、n_nominalの初期値を 900 にします。
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• OK をクリックして、ステートエディタを閉じま
す。

これで、ステートマシンの定義が終わりました。この実験を開始する前に、ここ
であらかじめステートマシンの動作を理解しておいてください。

4.8.2 ステートマシンの動作

一般的に、標準コンポーネントの動作（機能）はそのグラフィック記述を見れば
簡単に理解できますが、ステートマシンの場合はその動作が一見ではわかりにく
い場合があります。本項では、前項の例を用いて、ステートマシンの原理につい
て説明します。ステートマシンとその機能についての詳細は、ASCET オンライン
ヘルプのステートマシンエディタに関するトピックを参照してください。

ステートマシンの各ステートにはステート名、Entry アクション、Static アクショ
ン、および Exit アクションが定義されています。さらに、各ステートは他のス
テートからとの間にトランジション（状態遷移を表す接続線）を持ち、各トラン
ジションには優先度、トリガ、アクションおよびコンディションが定義されてい
ます。

各ステートマシンにはそれぞれ 1 つの開始ステートが必要です。ステートマシン
が初めて起動されると、開始ステートが有効になり、開始ステートのアクション

（つまりステートマシンの初期処理）が実行された後、開始ステートから他のス
テートへのトランジションを発生させるコンディションが調べられます。この例
では、このようなトランジションは 1 つしかなく、そのコンディションは t > 
t_upです。ここでは、入力値が t_upパラメータの値より大きいかどうかが調
べられます。もしそうならコンディションは真（true）なので、トランジション
が発生します。

パラメータ t_up および t_down は温度を規定します。エンジンがこれらの温度
にならないと、目標回転速度を変更することができません。今の例では、エンジ
ン温度が 70 度を超えたら、回転速度を 600rpm に下げることができます。その
後、エンジン温度が 60 度を下回ると、目標速度を 900rpm にリセットしなけれ
ばなりません。

トランジションが発生すると必ず、そのトランジションに定義されているトラン
ジションアクションが実行されます。今の例では、coldEngineから
warmEngineへのトランジションが発生すると実行されるトランジションアク
ション n_nominal = n_warmにより、変数 n_nominalの値が 600 になり
ます。反対に、トランジションアクション n_nominal = n_coldは
n_nominalの値を 900 にします。トランジションが発生すると、離れようとす
るステートの Exit アクションと、入ろうとするステートの Entry アクションも実
行されます。この例では、これらのアクションは定義されていないので、何も行
われません。

ステートマシンが第 2 のステートに入ると、第 2 のステートから第 1 のステート
へのコンディションが満たされるまでは、第 2 のステートに留まります。ステー
トマシンが 1 つのステートに留まっている間は、ステートマシンが起動されるた
びに Static アクションが実行されます。ステートマシンを起動させるのは必ず外
部のイベントで、1 回の起動によりステートマシンの 1 回のパスが開始されます。
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ステートマシンの 1 回のパスは、まず現在のステートから他のステートへのトラ
ンジションについてのすべてのコンディションを調べることから始まります。コ
ンディションは、その優先度の順に調べられます。あるコンディションが true な
ら、それに対応するトランジションが発生し、Exit アクション、トランジション
アクションおよび Entry アクションが実行されます。 初に調べたコンディショ
ンが true だった場合、同じステートから他のステートへの他のトランジション

（ 初に調べたコンディションよりも優先度が低いコンディション）は調べられま
せん。どのコンディションも true でない場合には、現在のステートのままにな
り、そのステートに留まるパスが実行されるたびに Static アクションが 1 回実行
されます。

第 2 のトランジションのコンディションが true になると、つまり、入力値がしき
い値よりも小さくなると、ステートマシンは第 1 のステートに戻ります。それか
ら、入力値が再びしきい値より大きくなるまでは、そのステートのままになりま
す（第 1 のステートには Static アクションが定義されていないので、何も行われ
ません）。

4.8.3 ステートマシンの実験を行う

実験には、ステートマシンの場合も他のタイプのコンポーネントの場合と同様の
機能がありますが、それ以外に、ステートマシンの実験を行う場合にだけ使用で
きるアニメーションという機能があります。これは、実験実行中にステートマシ
ンダイアグラム内のカレントステート（現在アクティブになっているステート）
を強調表示する機能です。

ステートマシンの実験を行う：

• ステートマシンエディタで Build → Experiment 
を選択して、実験環境を開きます。
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• ステートの 1 つを右クリックし、ショートカット
メニューから Animate States を選択します。

• triggerイベントをイネーブルにします。

• データジェネレータで、変数 tのチャンネルを作
成します。

• このチャンネルに周波数 1Hz、オフセット 70、振
幅 20 の正弦波を割り当てます。

• t および n_nominal用のオシロスコープウィン
ドウを開きます。

• Start Offline Experiment ボタンをクリックし
て、ステートマシンの実験を行います。

• 個々のステートの色を変えて表示を見やすくする
ために、Exit to Component ボタンで実験環境
を終了し、ステートエディタを開きます。

• “Color”コンボボックスで色を選択します。

• 再度実験を行います。

実験が実行されると、n_nominalの値は、正弦波が対応する温度しきい値を上
回ったり下回ったりするたびに変化します。適合システムを使用してしきい値を
変更し、それによる出力の変化を調べることができます。また、ステートダイア
グラムにおいては、カレントステートが強調表示されます。

4.8.4 ステートマシンをコントローラに統合する

ASCET の他のすべてのコンポーネントと同様に、ステートマシンもやはり、別の
任意のタイプのコンポーネントを構成する要素として用いることができます。で
は、ステートマシンをコントローラモジュールに統合し、回転速度をエンジン温
度に合わせて調整できるようにしましょう。

ステートマシンを統合する：

• コンポーネントマネージャから、ブロックダイア
グラムエディタでモジュール
Lesson4¥IdleConを開きます。
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• ダイアグラムと“Outline”タブから、パラメー
タ n_nominalを削除します。

ブロックダイアグラムにおいて、このパラメータ
の代わりにステートマシンを使用します。

• Insert → Component を選択し、コントローラ
の“Outline”タブにステートマシンを追加しま
す。

• 受信メッセージを作成し、その名前を tにします。

• 削除した変数の代わりにコンポーネント WarmUp
の出力を減算の演算子に接続し、同コンポーネン
トの入力を受信メッセージ tに接続します。

• ダイアグラムを下図のように調整します。すべて
のアイテムが正しい順序で接続されるように、
シーケンシングを調整します。

• ダイアグラムを保存し、コンポーネントマネー
ジャで Save ボタンをクリックします。

修正後のコントローラをプロジェクト内で機能させるために、プロジェクトにも
変更を加える必要があります。今度は、まだ使用されていなかった温度センサも
統合します。

プロジェクトを変更する：

• プロジェクトControllerTest用のプロジェク
トエディタを開きます。

• “OS”タブに切り替えます。

• プロセスt_samplingをタスクTask10msに割
り当てます。

• Task → Move Up を使用して、プロセス
t_samplingをタスクの先頭に配置します。

• Build → Experiment を選択します。
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• 値 U_t用に、もう 1 つのスカラ適合ウィンドウを
開きます。

• 変数 tをオシロスコープに追加します。

• Start OS ボタンをクリックします。

• Start Measurement ボタンをクリックします。

• 値 U_tを調整し、その影響を調べます。

t の値が限界値（70 度）を超えると、ステート
マシンは n の目標値を低い方の値 600 に切り替
えます。温度が 60 度を下回ると（U_tを調整す
ることによりシミュレートされます）、n の目標
値は元の値 900 に戻ります。

4.8.5 まとめ

このレッスンでは、ASCET で以下の作業を行いました。

• ステートダイアグラムを作成する

• コンディション、アクション、およびトリガを作成し、ステートマシンに
割り当てる

• ステートマシンの実験を行う

• ステートマシンを他のコンポーネントに統合する

4.9 階層ステートマシン

前のレッスンでステートマシンの機能について理解できたので、今度はやや複雑
なシステムを構築してみます。このレッスンでは階層ステートマシンについて集
中的に学習し、また、タイマなど ASCET に付属しているシステムライブラリとコ
ンポーネントの使用法を学びます。

ASCET では、閉階層と開階層を用いてステートマシンを構築することができま
す。開階層の場合はその中に含まれるサブステートも図示され、閉階層の場合そ
れらは省略されます。

交通信号制御システムを構築して、パラメータで指定できるタイミングを使用し
て交通信号の各フェーズへの移り変わりを実現してみましょう。この交通信号に
はエラーステータスもあり、そのときには信号が点滅します。

4.9.1 ステートマシンを定義する

まず、必要なライブラリをインポートして準備します。

システムライブラリをインポートする：

• コンポーネントマネージャで Import ボタンをク
リックします。

“Select Import File”ダイアログボックスが開き
ます。

測定開始OS 起動
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• “Import”フィールドの  ボタンで、 ASCET の
インストールディレクトリ下のエクスポートディ
レクトリ（例：C:¥etas¥ASCET6.0¥
export）に格納されている
SystemLibETAS.exp というファイルを選択
します。

OK ボタンが有効になります。

• OK をクリックしてインポートを開始します。

“Import”ダイアログボックスが開き、選択され
たファイルに含まれるすべてのオブジェクトが一
覧表示されます。

• OK ボタンをクリックします。

ファイルがインポートされます。この処理には数
分かかります。インポートが終了すると、イン
ポートされたアイテムの一覧が“Import Items”
ウィンドウに表示されます。

次に、交通信号を制御するために必要な 2 つのメインステート（NormalMode
と ErrorMode）を定義します。

ステートマシンを作成する：

• コンポーネントマネージャで、フォルダ
Tutorial¥Lesson9を作成します。

• Insert → State Machine を選択して、新しいス
テートマシンを作成し、その名前を Lightにし
ます。

• Edit → Open Component ボタンをクリックし
て、ステートマシンエディタを開きます。

ここから、交通信号を制御するステートマシンを
定義します。

• 2 つの主要ステート ErrorModeおよび
NormalModeを作成します。

次に、システムライブラリのタイマをプロジェクトに追加します。

タイマオブジェクトを追加する：

• Insert → Component を選択します。

• “Select item”ダイアログボックスで、
SystemLib_ETASライブラリの
Counter_Timerフォルダにあるタイマオブ
ジェクト、Timerを選択します。
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• OK で確定します。

ステートマシンの“Outline”タブにオブジェク
ト Timerが追加されます。

ステートダイアグラムを定義する：

• 必要なデータエレメントを以下のように定義しま
す。

－ Logic型の入力 error

－ 信号の 3 色を表す、Logic型の 3 つの出力
（yellow、green、red）

－ 信号のさまざまなフェーズを表す、
Continuous 型の 4 つのパラメータ

（BlinkTime、YellowTime、
GreenTime、RedTime）

依存パラメータについて理解を深めるために、緑
色のフェーズの値だけを定義し、他のパラメータ
には緑色のフェーズの値に依存する値が設定され
るようにします。

RedTime = 2 * GreenTime
YellowTime = GreenTime/3
BlinkTime = YellowTime/10

• 次に、個々のパラメータの計算式と依存関係を定
義します。

• このためには、パラメータ RedTime、
YellowTimeおよび BlinkTimeについて、プ
ロパティエディタの“Dependency”の下にある 
Dependent オプションをオンを選択します。

プロパティエディタを起動するには、パラメータ
をダブルクリックするか、または Edit ショート
カットメニューを使用します。

• Formula ボタンをクリックしてフォーミュラエ
ディタを開きます。

• フォーミュラエディタを使用して、それぞれの依
存パラメータについての計算式を定義します。
初に仮パラメータ x を作成し、それからフォー
ミュラペインに計算式を入力します。

Redtime : 2*x
YellowTime : x/3
BlinkTime : x/10

• フォーミュラエディタとプロパティエディタを閉
じます。
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• ショートカットメニュー Edit Data でディペンデ
ンシーエディタを開きます。

• それぞれの依存パラメータの仮パラメータ xに対
応するモデルパラメータを割り当てます。 

RedTime : x = GreenTime
YellowTime : x = GreenTime
BlinkTime : x = YellowTime

• データエレメントに有意義な値を与えます（例、
GreenTime = 5）。

• ステート ErrorModeステートエディタで開きま
す。

ステートエディタを開くには、編集するステート
をダブルクリックするか、Edit State ショート
カットメニューを使用します。

• このステートを開始ステートとして定義し、色を
赤にします。

• 両方のステートを拡大表示し、階層を挿入できる
ようにします。

• 2 つのステートの間にトランジションを作成しま
す。

• ショートカットメニュー Edit Transition で、ま
たはトランジションを示す曲線をダブルクリック
して、トランジションエディタを開きます。

• トランジションダイアログボックスにコンディ
ションを入力して、2 つのステートの間のトラン
ジションを定義します。入力 errorが false

（つまり、エラーが発生していない）なら正常ス
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テート NormalModeになり、エラーの場合には
ErrorMode になるように、ESDL でコンディ
ションを記述します。

• File → Save を選択し、作業内容を保存します。

• コンポーネントマネージャで File → Save 
Database を選択し、データベースを保存しま
す。

• これらのメインステートについて、実験を行って
みてください。

次に、交通信号制御システムに必要なサブステートを定義します。ここではまず
エラーモード（ErrorModeステート）における処理を定義します。このステー
トでは、黄色の点滅光が出力されます。このためには、YellowOffおよび
YellowOnという 2 つのサブステートを定義し、この両者間の切り替えをタイマ
で行うようにします。YellowOnステートでは出力 Yellowが trueになり、
YellowOffステートでは falseになります。

エラーモード用のサブステートを定義する：

• YellowOffおよびYellowOnというステートを
作成し、それらをステート ErrorMode内に配
置します。

• YellowOffを開始ステートとして定義し、
YellowOnの色を黄色にします。
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• ステート YellowOffの対応をステートエディタ
で定義します。

ステートエディタを開くには、Edit State ショー
トカットメニューを使用するか、このステートを
ダブルクリックします。

• Entry アクションを入力します。“Entry”タブのコ
ンボボックスで ESDLを選択し、以下ののコード
を入力します。

green = false;
red = false;
yellow = false;
Timer.start(BlinkTime);

• Static アクションを入力します。“Static”タブに
以下のコードを入力します。

Timer.compute();

• 次に、同じ方法で、YellowOnステートについて
定義します。

Entry アクション：
yellow = true;
Timer.start (BlinkTime);

Static アクション：
Timer.compute();

• 今度は、2 つのサブステートの間のトランジショ
ンを定義します。

状態遷移の条件は、タイマがタイムアウトするこ
と（Timer.out() == false）です。
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つまり、ErrorModeステートは YellowOffステートで開始されます。このス
テートの Entry アクションで、黄色の点灯信号をオフにし、パラメータで指定さ
れる点滅時間を計測するタイマを起動します。このステートの Static アクション
ではタイマ関数 compute()が毎回起動され、タイマカウンタをデクリメントし
ます。このカウンタ値が 0 になると、タイマ関数 out()がコード falseを返
し、トランジションのコンディションが真になります。そして、ステート
YellowOnでは、Entry アクションにより、黄色の点灯信号 Yellowがオンにな
ります。

次に、正常動作時の動作を定義します。このためには、開始ステート AllOffを
作成して NormalModeステート内に配置します。そしてその Exit アクションで
各色の点灯信号を定義されたステートに設定します。では、交通信号制御システ
ムとして、どのように処理すればよいかを考えてみましょう。

この例では、各色の点灯信号のオン／オフ切り替えを、今までのようにステート
の Entry アクションにではなく、トランジションアクションに定義します。

正常動作時のサブステートを定義する：

• ステート AllOff（開始ステート）、Yellow、
Red、RedYellow、Greenを作成して、
NormalModeステート内に配置します。

• これらのステートの動作を定義します。これに
は、Entry アクションで各色用のタイマを起動し、
Static アクションでタイマ処理

（Timer.compute()）を行うようにします。
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• ステートトランジションを定義し、トランジショ
ンアクション内にステートの動作を定義します。

正常時は AllOffステートから Yellowステー
トに遷移し、他のトランジションは、対応するタ
イマのカウントダウンが終了した時に発生しま
す。

• 各色の点灯信号用のアクションを、トランジショ
ンエディタの“Action”タブに入力します。

• トランジションエディタを閉じて、File → Save 
を選択します。

これで、交通信号制御システムの定義が終わりました。この実験を始めるには、
各色用タイマのパラメータに適切な値を入力する必要があります。

4.9.2 階層ステートマシンの実験を行う

階層ステートマシンの実験も、基本的なステートマシンの実験と同じ方法で行う
ことができます。実験では、アニメーション機能を起動することを忘れないでく
ださい。

ステートマシンの実験を行う：

• ステートマシンエディタで Build → Experiment 
を選択して、実験環境を開きます。
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• ステートの 1 つを右クリックし、ショートカット
メニューから Animate States を選択します。

• triggerイベントをイネーブルにします。

• Start Offline Experiment ボタンをクリックし
て、ステートマシンの実験を行います。

• GreenTimeパラメータの値を変更し、さらに
Update Dependent Parameterを使用して依存
パラメータの値を更新して、実験を行ってくださ
い。

• error入力を trueにして、動作の変化を確認し
てください。

4.9.3 階層ステートマシンの動作

階層ステートマシンは、通常のステートマシンと同じように機能します。基本的
に、階層ステートマシンはさまざまな動作すべてをグラフィック構造で表してい
るにすぎません。余裕のある方は、階層ステートマシンで定義した動作を、どの
ようにすれば階層なしで実現できるか考えてみましょう。

この交通信号の例では、2 つの階層ステートを使いました。システムは論理入力
変数 errorの値に応じて、2 つのステート ErrorModeと NormalModeを切
り替えます。それぞれの動作は、これらのステートの中で定義されています。

これを理解するために、ErrorModeステート内の処理に注目してみましょう。
トリガが起動されるたびに、階層ステート ErrorMode から NormalModeへの
コンディション（コンディション：!error）が調べられます。主要ステートの
トランジションが必要ない場合には、サブステートのトランジション
YellowOffから YellowOnへ、またはその逆のトランジションのコンディ
ションが調べられ、必要なアクションが行われます。

NormalModeについて考えてみると、トリガが呼び出されるたびに、まず
error入力が trueかどうか、つまり遷移が必要かどうかが調べられ、この条件
に該当しなかった場合にのみ、各サブステート（AllOff、Yellow、Red、
RedYellow、Green）間のコンディションが調べられます。交通信号の例で
は、タイマがタイムアウトしたかどうかも調べられます。

以上の処理を明らかにするために、ステートダイアグラムから生成されるコード
を見てみましょう。
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生成されたコードを表示する：

• ステートマシンエディタで Build → View 
Generated Code を選択して、生成されたコー
ドを表示します。

コンポーネントのコードはテンポラリファイルに
書き込まれ、Windows に登録されているアプリ
ケーションで開かれます。

4.9.4 まとめ

このレッスンでは、ASCET で以下の作業を行いました。

• 階層ステートダイアグラムを作成する

• ステートアクションとトランジションアクションの動作を定義する

• モジュール、クラス、コンポーネントをインポートする

• ASCET ライブラリのシステムコンポーネントをインポートする

• 既存の Timer コンポーネントを使用する

• 依存パラメータを使用する

• 生成されたコードを表示する

注記

生成されたコードを表示する際、拡張子 *.cおよ
び *.hのファイルに関連付けられているアプリ
ケーションが、Windows のレジストリ内から検索
されて開きます。
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5 用語集

この用語集では、ASCET のドキュメントで使用されている用語について解説しま
す。各用語の一般的な意味よりも、ここでは、ASCET について使用される場合の
意味について説明します。

用語はアルファベット順、あいうえお順に並んでいます。

5.1 略語集

ASAM-MCD

Assosiation for the Standardization of Automation and Measurement 
systems（オートメーションおよび測定システム標準化委員会）の、測定

（Measurement）、適合（Calibration）および診断（Diagnosis）について
のワークグループ

ASCET

ECU ソフトウェア開発ツール

ASCET-MD

ASCET Modeling and Design - ASCET モデリング／デザインツール

ASCET-RP

ASCET Rapid Prototyping - ASCET ラピッドプロトタイピングツール

ASCET-SE

ASCET Software Engineering - ASCET ソフトウェアエンジニアリング
ツール

AUTOSAR

Automotive Open System Architecture（http://www.autosar.org/ 参照）

BDE

Block Diagram Editor（ブロックダイアグラムエディタ）

CPU

Central Procesing Unit（中央演算処理装置）

ECU

Embedded Control Unit（組み込み制御ユニット）

ERCOSEK

OSEK 準拠の ETAS リアルタイムオペレーティングシステム

ESDL

Embedded Softare Description Language（組み込みソフトウェア記述言
語）
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ETK

独語： Emulatortastkopf（Emulator Test Probe：エミュレータ・テスト
プローブ）

FPU

Floating Point Unit（浮動小数点演算ユニット）

HTML

Hypertext Markup Language（ハイパーテキストマークアップ言語）

INCA

Integrated Calibration and Acquisition Systems（統合計測・適合システ
ム）

INTECRIO

ETAS の新しい製品ファミリ。さまざまなビヘイビアモデリングツールで
作成されたコードを統合してコンフィギュレーション設定や実行コードの
生成を行い、ラピッドプロトタイピング実験を行うための実験環境を提供
します。

OS

Operating System（オペレーティングシステム）

OSEK

独語：Arbeitskreis Offene Systeme fur die Elektronik im Kraftfahrzeug
（Open Systems and the Corresponding Interfaces for Automotive 
Electronics：自動車エレクトロニクス用オープンシステムおよびインター
フェース）

RAM

Random Access Memory（ランダムアクセスメモリ）

RE

Runnable entity（ランナブルエンティティ： 実行時に RTE によってトリ
ガされる、SWC 内の一連のコードで、ASCET の「プロセス」にほぼ相当
するもの）

ROM

Read Only Memory（読み取り専用メモリ）

RTA-RTE

ETAS の AUTOSAR runtime environment（ETAS の AUTOSAR 実行環境）

RTE

AUTOSAR runtime environment（AUTOSAR 実行環境： ソフトウェアコ
ンポーネント、基本ソフトウェア、オペレーティングシステム間のイン
ターフェースを提供するもの）
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SWC

Atomic AUTOSAR software component（アトミックな AUTOSAR ソフ
トウェアコンポーネント： AUTOSAR における分割不可能な 小単位のソ
フトウェアコンポーネント）

UML

Unified Modeling Language（統一モデリング言語）

XML

Extensible Markup Language（拡張マークアップ言語）

5.2 その他の用語

ASAM-MCD-2MC ファイル

プロジェクト用のデータ交換に使用される ASCII 形式の標準フォーマット
ファイルで、測定および適合に必要なディスクリプションが含まれていま
す。*.a2lという拡張子が付きます。

C コード

コンポーネントを記述する形式の 1 つで、内容はインプリメンテーション
に依存します。

HEX ファイル

プログラムの 1 つのバージョンをハードウェア間で交換するためのファイ
ル形式です。フォーマットは Intel HEX と Motorola S Record のいずれか
です。

Intel Hex

プログラムの 1 つのバージョンをハードウェア間で交換するためのファイ
ル形式です。

L1

ホストと、実験が行われているターゲットとの間でデータ転送を行うため
のメッセージフォーマットです。データ転送は、たとえば測定ウィンドウ
での値の表示のために行われます

Motorola-S-Record

プログラムの 1 つのバージョンをハードウェア間で交換するためのファイ
ル形式です。

OSEK オペレーティングシステム

OSEK 準拠のオペレーティングシステムです。

アイコン

ASCET コンポーネントの機能を視覚的に表すために使用されます。
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アクション

ステートマシンの構成要素で、ステートマシンのステートまたはトランジ
ションに関連付けて定義されます。一連の機能からなり、その実行はス
テートマシンによりトリガされます。

アプリケーションモード

ASCET のオペレーティングシステムの動作モードです。EEPROM プログ
ラミングや暖機運転モード、通常モードなどシステムに想定されるさまざ
まな状態を表します。

イベント

オペレーティングシステムのアクション（タスクの起動など）の外部トリ
ガとなるものです。

イベントジェネレータ

実験環境の一部を成すもので、オフライン実験において、タスク（メソッ
ド／プロセス／タイムフレーム）起動のためのイベント生成の順序とタイ
ミングを定義するために使用されます。

インターフェース

コンポーネントのインターフェースは、そのコンポーネントが他のコン
ポーネントとどのようにデータ交換を行うかを定義します。これは C 言語
環境における .h ファイルにたとえられるものです。

インプリメンテーション

物理記述（モデル）から実行形式の固定小数点コードへの変換方法を定義
するものです。モデルデータの変換に使用される線形変換式と上下限値と
で構成されます。

インプリメンテーションキャスト

このエレメントを使用すると、連続する算術演算の中間値のインプリメン
テーションを、そのエレメントの物理表記を変えることなく任意に変更す
ることができます。

インプリメンテーション型

プロジェクト全体で使用できる複数のインプリメンテーションを「インプ
リメンテーション型」として定義しておき、それを必要に応じて各エレメ
ントに個別に割り当てることができます。

ウィンドウエレメント

実験で使用される適合エレメントと測定エレメントを指す一般的な用語で
す。

エディタ

→「適合ウィンドウ」参照
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エレメント

コンポーネントを構成する要素で、データ（変数やパラメータ、またはコ
ンポーネント内で使用される他のコンポーネント）の読み取りや書き込み
を行います。

エレメントタイプ

エレメントのタイプには、変数、パラメータ、定数の 3 種類があります。
変数の値は読み取りも書き込みも可能です。パラメータの値は読み取るこ
としかできませんが、実験中に適合（書き込みによる値の調整）を行うこ
とができます。定数の値は常に読み取ることしかできず、実験中でも書き
込みは行えません。

オシロスコープ

測定ウィンドウの一種で、実験中にデータの値をグラフ表示します。

オフライン実験

ASCET で生成されたコードが PC または実験ターゲット上で実行される環
境ですが、リアルタイムな実行はサポートされません。ここでは主にシス
テムの機能記述についてのテストに重点が置かれます。

オペレーティングシステム

ASCET ソフトウェアシステムの起動や実行をスケジューリングするもの
です。また内部通信のためのサービス（メッセージ）やハードウェアの予
約部分（リソース）へのアクセスもサポートします。ASCET のオペレー
ティングシステムは、ERCOSEK というリアルタイムオペレーティングシ
ステムをベースとしています。

オンライン実験

ASCET で生成されたコードが実験ターゲット上で、リアルタイムオペ
レーションシステムに設定された挙動に基づいてリアルタイムに実行され
ます。ここでは、スケジューリング等のリアルタイムな挙動 すが、リアル
タイムな実行はサポートされません。ここでは主にシステムの機能記述に
ついてのテストに重点が置かれます。

階層

階層ブロックは、ブロックダイアグラムによるグラフィック定義を階層化
（構造化）するために使用します。

型 （またはモデルデータ型）

ASCET モデルでは、cont (continuous)、udisc (unsigned 
discrete)、sdisc (signed discrete)、log (logic)といっ
たさまざまな型の変数やパラメータを使用できます。contは任意の値を
持つことのできる物理量に使用され、udiscは正の整数値、sdiscは負
の整数値に使用されます。また logは論理値（trueまたは false）に
使用されます。これらの型は、生成されるコードで使用される実装データ
型とは異なります。加算や比較などさまざまな基本演算がそれぞれの型用
に用意されています。実装情報によって、モデルデータ型が実装データ型
に変換されます。
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クラス

ASCET のコンポーネントの 1 つで、オブジェクト指向言語におけるクラ
スと同じものです。クラスの機能はメソッドにより定義されます。

グループ適合カーブ／マップ

1 つの座標ポイントディストリビューションを共有する複数の特性カーブ
／マップを指し、総称して「グループテーブル」とも呼ばれます。各グ
ループテーブルの出力値はそれぞれ異なります。座標ポイントのディスト
リビューションと個々のグループテーブルは、それぞれ独立したエレメン
トとして定義されます。

コード

コード（実行形式のコード）は、実際のアルゴリズムを含むプログラム
で、データは含まれません。コードは、CPU によって実行されるプログラ
ムの部分です。

コード生成

物理モデルから実行形式コードへの変換の第 1 ステップです。物理モデル
が ANSI C コードに変換されます。C コードはコンパイラ（つまりター
ゲット）に依存するので、ターゲットごとに異なるコードが生成されま
す。

固定小数点コード

物理記述から生成されるコードの一種で、浮動小数点演算ユニットを持た
ないマイクロプロセッサ上で実行するためのものです。

コンディション

ステートマシンの制御フローを定義するためのものです。あるステートか
ら別のステートへのトランジションを発生させるかどうかを決める論理値
を返します。

コンテナ

プロジェクト、クラス、またはモジュールを保管しておくためのもので
す。モデルやデータベースの構築や、異なるデータベースアイテムを共通
のバージョン管理下に置くために使用されます。

コンフィギュレーションダイアログボックス

測定／適合ウィンドウ、または各ウィンドウに表示される変数のコンフィ
ギュレーションを行うために使用されるダイアログボックスです。

コンポーネント

ASCET における再利用可能な機能の基本単位です。コンポーネントはク
ラス、モジュール、またはステートマシンによって定義されます。各コン
ポーネントは、演算子で接続されて機能を形成する数々のエレメントで構
成されます。
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コンポーネントマネージャ

ASCET の作業環境設定を行ったり、ユーザーによって作成されデータ
ベースに格納されたデータの管理を行うためのユーザーインターフェース
です。

算術演算サービス

オンライン実験の環境設定が格納されます。測定／適合ウィンドウに関す
る情報（ウィンドウのサイズや位置、およびウィンドウに含まれるデータ
チャンネルの割り当てやサンプリングレート、表示形式等）や、イベント
ジェネレータ、データジェネレータ、データロガー等の設定が含まれま
す。

実験

コンポーネントやプロジェクトの機能をテストするために使用される実験
環境の設定が定義されたものです。ここには、測定ウィンドウや適合ウィ
ンドウに関する情報（ウィンドウのサイズや位置、およびその内容）や、
イベントジェネレータ、データジェネレータ、データロガーについての設
定が含まれます。実験は、オフライン（非リアルタイム）またはオンライ
ン（リアルタイム）で行われ、バイパスまたはフルパス環境において物理
プロセスを制御するシミュレーションが行われます。どの条件において
も、ASCET で記述されたモデルから生成されたコードが使用されます。

実験環境

測定／適合作業を行うための操作環境です。

実装データ型

C 言語の基礎であるデータ型（unsigned byte (uint8)、signed 
word (sint16)、float）を指します。

スケジューリング設定

プロセスへのタスクの割り当て、およびオペレーティングシステムによる
タスク起動に関する定義です。

スコープ

各エレメントは、ローカル（コンポーネント内でのみ使用可能）またはグ
ローバル（プロジェクト内で定義されている）のスコープを持ちます。

ステート

ステートマシンを構成する要素です。ステートマシンは常にそのステート
のうちの 1 つの状態（つまり、いずれか 1 つのステートがアクティブな状
態）になっています。いずれか 1 つのステートが開始ステートとしてマー
クされていて、これがステートマシンの初期ステートになります。ステー
ト同士はトランジション（遷移）を示す曲線で接続されています。各ス
テートには Entry アクション（そのステートに入ったときに実行されるア
クション）、Static アクション（そのステートのまま変わらないときに実行
されるアクション）、および Exit アクション（そのステートから出るとき
に実行されるアクション）が定義されます。
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ステートマシン

ASCET のコンポーネントの 1 つです。その挙動は、トランジションで接
続される複数のステートによって構成されるステートダイアグラムで記述
されます。

測定値

実験中に画面上に表示される変数やパラメータの値です。値は、さまざま
な測定ウィンドウ（オシロスコープや数値ディスプレイ）に表示すること
ができます。

測定ウィンドウ

実験中に測定信号を表示する、ASCET の作業ウィンドウです。

測定チャンネルパラメータ

測定モジュールの個々のチャンネル用に設定されるパラメータです。

ターゲット

実験の対象となるハードウェアを指します。ターゲットには実験ターゲッ
ト（PC、トランスピュータ、PowerPC）とマイクロコントローラター
ゲット（ECU）があります。

ダイアグラム

コンポーネントをブロックダイアグラムまたはステートマシンによって定
義するために使用される記述形式です。

タスク

オペレーティングシステムから起動される単位で、その中に複数のプロセ
スとその実行順が割り当てられます。タスクは、アプリケーションモー
ド、起動用のトリガ、優先度、スケジューリングモード等の属性を持ちま
す。タスクが起動されて実行されると、そのタスクに割り当てられたプロ
セスが指定された順序で実行されます。

定数

ASCET モデルの実行中に値を変更することのできないエレメントです。

ディスクリプションファイル

ECU 内の特性値と測定変数の物理情報（名前、アドレス、変換式、ファン
クション割り当てなど）を記述するファイルです。

ディストリビューション

1 つまたは複数の特性カーブ／マップのブレイクポイント（「サンプルポ
イント」ととも呼ばれます）が定義されたものです。

ディメンション

基本エレメントのサイズを定義するものです。ディメンションの型は、ス
カラ（0 次元）、配列（1 次元）、特性カーブ／テーブルのいずれかです。

データ

プログラム用の変数の集合で、適合時に使用されます。
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データジェネレータ

実験環境の一部を成すものです。実験対象のモデルの入力または変数をス
ティミュレートするために使用されます。

データセット

コンポーネントまたはプロジェクトのすべてのエレメントの初期データ、
あるいはその参照が設定されています。

データベース

ASCET で生成されるすべての情報が格納されます。フォルダによる階層
構造になっています。

コンポーネントマネージャ

データベースを作成し、格納されるデータを管理するための作業環境で
す。

データロガー

実験環境で測定されるデータを読み取り、後で分析できるようにディスク
に保存する機能を持ちます。

適合

ASCET モデルの実行（実験）中に、パラメータの値（物理／インプリメ
ンテーション）を調整することです。

適合ウィンドウ

パラメータの修正に使用する ASCET の作業ウィンドウです。

特性カーブ

2 次元のパラメータ（適合変数）です。

特性データ

マップ、カーブ、および特性値を表す一般的な用語です。（「パラメータ」
も参照してください。）

特性値

1 次元のパラメータ（適合変数）です。

特性マップ

3 次元のパラメータ（適合変数）です。

トランジション

ステート間の遷移を表し、起こり得るステートの遷移について記述された
ものです。各トランジションにはステートマシンのトリガの 1 つが割り当
てられ、優先度、コンディション、アクションを持ちます。

コンディション

ステートマシンのフロー制御を定義するために使用されます。あるステー
トから別のステートへのトランジションを起こすかどうかを決める論理値
を返します。
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トリガ

タスクの実行、またはステートマシンの実行をトリガ（起動）するもので
す。

バイパス実験

ASCET がマイクロコントローラに直接接続され、マイクロコントローラ
ソフトウェアの一部をシミュレートする実験です。

配列

基本スカラ型 continuousまたは discreteの静的な 1 次元リスト
で、基本スカラ型 discreteのインデックスを持ちます。

パラメータ

ASCET のモデル内での計算では値を変更できないエレメント（特性値、
特性カーブ、および特性マップ）です。ただし実験中に適合させることが
できます。

引数

クラスメソッドへの入力です。その引数が属するメソッドの記述において
のみ使用でき、クラス内の他のメソッドでは使用できません。

フォルダ

ASCET データベースの階層構造を形成する単位で、この中に各アイテム
が格納されます。

フルパス実験

ASCET が実験用マイクロコントローラに直接接続され、アプリケーショ
ン全体が ASCET によってシミュレートされる環境です。

プログラム

コードとデータから構成され、ECU の CPU により実行される 1 つの単位
です。

プログラムバージョン

ECU プログラムが格納された HEX ファイルを指します。プログラムバー
ジョンの一部が、データバージョンと共に 1 つのファイルとなります。

プロジェクト

組み込みソフトウェアシステム全体についての記述です。機能を定義する
コンポーネント、オペレーティングシステムに関連した設定、および内部
通信を定義するバインディングのしくみが記述されます。

プロセス

並行して実行される機能の単位で、オペレーティングシステムにより起動
されます。プロセスはモジュール内に記述され、引数／入力や戻り値／出
力を持ちません。
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ブロックダイアグラム

コンポーネントをグラフィカルに記述するものです。さまざまなエレメン
ト、演算子、および入力／引数や出力／戻り値が、方向性のある線で接続
されます。1 つのブロックダイアグラムは複数のダイアグラムで構成され
ます。ブロックダイアグラムによる記述は、C コードによる記述とは異な
り、物理記述です。

変換式

インプリメンテーション（実装情報）の一部で、データのモデルデータ型
から実装データ型への変換方法を定義するものです。

変数

ASCET のモデルの実行中にモデルから値の読み取りや書き込みができる
エレメントです。また適合作業において値を変更することもできます。

また広義では、パラメータ（特性データ）と測定信号を示す一般的な用語
としても使用されます。

メソッド

オブジェクト指向プログラミングで使用されるクラスにおいて、そのクラ
スの機能の一部を記述するものです。メソッドは任意の数の引数と 1 つの
戻り値を持ちます。

メッセージ

並行して実行されるプロセス間のデータ交換の整合性を保証するための、
ASCET のリアルタイム言語構造体です。

モジュール

ASCET のコンポーネントの 1 つです。オペレーティングシステムによっ
て起動される複数のプロセスが記述されています。モジュールを他のコン
ポーネント内のサブコンポーネントとして使用することはできません。

モニタ

実験中にエレメントの値をダイアグラム上に表示する機能です。

ユーザープロファイル

ユーザー固有のオプション設定です。

優先度

各タスクに対して数値で与えられる優先度で、この数値が大きいほど優先
度が高くなり、優先的にスケジューリングされます。

ランナブルエンティティ

→ 「RE」 参照

ランタイム環境

→ 「RTE」 参照
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リソース

組み込みシステムにおいて、排他的に使用される部分（タイマなど）をモ
デリングする際に使用されます。このような部分をアクセスするには、使
用前にそれを予約（確保）して使用後に解放する、という処理が必要です
が、この一連の処理がリソースの概念によって行われます。

リテラル

コンポーネントの記述に使用されるもので、連続値や論理値として解釈さ
れる文字列を定義します。

レイアウト

コンポーネントは、入力／引数や出力／戻り値を表すピンや、タイムフ
レーム、メソッド、プロセスを表すグラフィック表現（レイアウト）を持
ち、さらにそのレイアウトには、そのコンポーネントが他のコンポーネン
ト内で使用される時のグラフィック表示に用いられるアイコンも含まれて
います。
用語集



6 付録 A： ASCET に関するトラブルシューティング

この章では、ASCET 使用時に ASCET 固有の問題（ネットワーク等に関する一般
的な問題以外）が発生した際の対処方法を説明します。

6.1 トラブルシューティングと ETAS へのお問い合わせ

ASCET の製品開発においては、プログラムの機能上の安全性が も重要視されて
います。しかし万一ご使用中にエラーが発生した場合には、以下の情報を ETAS
までお送りください。

• エラーが発生したときにどのような作業をしていましたか ?

• 発生したエラーはどのようなものでしたか ?（関数エラー、システムエ
ラー、システムのクラッシュなど）

• エラーが発生した時に、どのようなモデル（またはモデルエレメント）を
編集していましたか？

サポート機能を使用すると、ASCET は自動的にログディレクトリの内容（すべて
の *.logファイル）とテキスト情報を、...¥ETAS¥LogFiles¥サブディレク
トリの EtasLogFiles00.zip というファイルに圧縮します。2 回目以降の
ZIP ファイルには番号が付き、この番号は 1 から順に 19 までインクリメントされ
ます。

重大なシステムエラーが発生すると、以下のようなウィンドウが開きます。

注記

ASCET の品質をより高めるためには、ASCET の操作中にエラーが発生した際
にユーザーの皆様からお送りいただくレポートは、非常に重要です。お手数で
すが、できる限り以下の手順でレポートをお送りください。
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エラー発生時の操作：

1. Problem Report ボタン

• Problem Report ボタンをクリックします。

サポート機能が起動されます。

• エラー内容を記述し、作成された ZIP ファイルを使
用していたモデルと共に ETAS の LabCar ホット
ラインに送信してください。

1. Exit ボタン

• Exit ボタンをクリックします。

ASCET が終了します。保存されていなかった変
更はすべて失われます。

データを保存することを勧めるメッセージボック
スが開いた場合、データの保存は行わずにメッ
セージボックを閉じてください。

• ASCET を再起動します。

2. Continue ボタン

• Continue ボタンをクリックします。

ASCET は稼働し続け、エラー発生直前の状態に
戻ります。

• データを保存します。

• ASCET を終了します。

• ASCET を再起動します。

一般には、エラーが発生したらデータの保存を行わずにプログラムを終了し、再
起動することをお勧めします。それにより、引き続いてより重大なエラーが発生
することを回避できます。

注記

Continue ボタンは、重要なコンフィギュレーションを保存する必要があ
るような場合に限り使用してください。そのまま作業を続行すると、さら
にエラーが発生したり、不正なコンフィギュレーション設定が行われてし
まう可能性があります。
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7 付録 B： 一般的なトラブルシューティング

この章では、個々のソフトウェアやハードウェアに依存しない一般的な問題が発
生した場合の対処法について説明します。

7.1 問題と解決法

7.1.1 ETAS ネットワーク用のネットワークアダプタを選択できない

原因： APIPA が無効になっている

IP アドレッシングの代替メカニズムである APIPA は、Windows 2000 ／ XP ／
Vista 環境では、通常は有効に設定されていますが、時にはネットワークセキュリ
ティポリシーによって無効となっている場合もあります。そのような場合、
DHCP 設定のネットワークアダプタ（ネットワークカード）を ETAS ハードウェ
アのアクセスに使用することはできず、そのアダプタを選択すると ETAS ネット
ワークマネージャは警告メッセージを表示します。

無効になっている APIPA メカニズムを有効にするには、Windows のレジストリ
を編集する必要がありますが、これを行うには管理者の権限が必要です。ネット
ワーク管理者の方にご相談のうえ行ってください。

APIPA メカニズムを有効にする：

• Windows の スタート メニューから ファイル名を
指定して実行 を選択します。

• regedit と入力して OK をクリックします。

レジストリエディタが開きます。

• 以下のフォルダを開きます。

HKEY_LOCAL_MACHINE/SYSTEM/
CurrentControlSet/Services/Topic/
Parameters/

• 編集 → 検索 を選択して以下のキーを検索します。

IPAutoconfigurationEnabled

• APIPA メカニズムが有効になるように、見つかっ
たキーの値をすべて 1 に変更します。

Windows のレジストリ内には、この名前のキー
がいくつか含まれている場合があります。これら
は一般的な TCIP/IP サービス用のものと、個別の
ネットワークアダプタ用のものです。ETAS ネッ
トワーク用に使用するアダプタについてのみ値を
変更してください。

• レジストリエディタを閉じます。
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• 変更されたレジストリの内容を有効にするため、
PC を再起動します。

APIPA メカニズムが無効になっていない場合、レジストリ内にこのキーは存在し
ません。

7.1.2 PC に接続されたイーサネットハードウェアが検索されない

原因： パーソナルファイアウォールによる通信のブロック

パーソナルファイアウォールによって発生する可能性のある問題とその解決法は、
151 ページの「パーソナルファイアウォールによる通信のブロック」を参照して
ください。

原因： リモートアクセス用クライアントソフトウェアによる通信のブロック

ETAS ハードウェアネットワーク外で使用されている PC には、リモートアクセス
用クライアントソフトウェアがインストールされているものがあり、それによっ
て ETAS ハードウェアへのアクセスが妨害される場合があります。それには以下
のような状況が考えられます。

• イーサネットメッセージをブロックするファイアウォールが使用されてい
る（148 ページの「原因： パーソナルファイアウォールによる通信のブ
ロック」を参照してください）

• トンネリングに使用されている VPN クライアントソフトウェアが誤って
メッセージをフィルタリングしてしまうことがあります。たとえば Cisco 
VPN クライアントの V4.0.x より前のバージョンでは、特定の UDP ブロー
ドキャストを不正にフィルタしてしまう、というケースがありました。

このケースに該当する場合は、VPN クライアントソフトウェアのバージョ
ンをアップデートしてください。

原因： ETAS ハードウェアのフリーズ

ETAS ハードウェアが何らかの理由でフリーズしてしまった可能性もあります。こ
の場合は、ハードウェアの電源を切ってから再投入してください。これによって
ハードウェアは再初期化されるので、多くの場合、正常に戻ります。

原因： ネットワークアダプタへの IP アドレス割り当てが一時的に失われた

PC の接続を、DHCP が使用されている社内 LAN から ETAS ハードウェアに切り
替える際、PC が ETAS ハードウェアを検知できるようになるまでに約 60 秒かか
ります。これはオペレーティングシステムが DHCP プロトコルから ETAS ハード
ウェア用の APIPA に切り替わる処理に要する時間です。
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原因： ETAS ハードウェアが他の論理ネットワークに接続されている

1 つの ETAS ハードウェアに対して複数の PC からアクセスする場合、各 PC で使
用されるネットワークアダプタは、同じ論理ネットワークを使用するように設定
しておく必要があります。このように設定することが不可能である場合、他の PC
を切り替える前に ETAS ハードウェアの電源を切って再投入してください。

原因： ネットワークカード用のデバイスドライバが起動していない

ネットワークカード用のデバイスドライバが起動していない可能性があります。
その場合は、ネットワークカードを一旦無効にしてから再度有効にしてください。

ネットワークカードを無効にして、再度有効にする：

• ネットワークカードを無効にするには、
Windows の スタート メニューから以下のように
操作します。

－ Windows 2000 の場合： 設定 → ネットワー
クとダイアルアップ接続 を選択します。

－ Windows XP の場合： 設定 → ネットワーク
接続 を選択します。

－ Windows Vista の場合： 設定 → コントロー
ルパネル（クラシックビューの場合） → ネッ
トワークと共有センター → ネットワーク接
続の管理 を選択します。

• ETASネットワーク用に使用されているデバイスを
右クリックし、ショートカットメニューから 無
効にする を選択します。

• 続いて同じショートカットメニューから 有効に
する を選択し、カードを有効にします。

原因： ラップトップ PC の電源管理システムによってネットワークカードが
無効になっている

ラップトップ PC の電源管理システムにより、ネットワークカードが無効になっ
ている場合があります。この場合、ラップトップ PC の電源管理を無効にしてく
ださい。

ラップトップ PC の電源管理を無効にする：

• Windows の スタート メニュー以下のように操作
します。

－ Windows 2000 の場合： 設定 → コントロー
ルパネル → システム を選択します。

－ Windows XP の場合： 設定 → コントロール
パネル → システム を選択します。
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－ Windows Vista の場合： 設定 → コントロー
ルパネル（クラシックビューの場合） → シス
テム → 詳細な電源設定の変更（メニューコ
マンド） を選択します。

• ハードウェア タブを選択し、デバイスマネー
ジャ ボタンをクリックします。

• デバイスマネージャ ウィンドウで ネットワーク
アダプタ のツリーを展開します。

• 使用するネットワークアダプタを右クリックし、
ショートカットメニューから プロパティ を選択
します。

• 以下のようにして電源管理を無効にします。

－ Windows 2000 の場合： 電源の管理 タブを
選択し、コンピュータでこのデバイスの電源
をオフできるようにする オプションをオフに
します。

－ Windows XP の場合： 電源の管理 タブを選
択し、コンピュータでこのデバイスの電源を
オフできるようにする オプションをオフにし
ます。

－ Windows Vista の場合： 電源マネージャ タ
ブを選択し、コンピュータでこのデバイスの
電源をオフできるようにする オプションをオ
フにします。

• 詳細設定 タブを選択し、プロパティ に 
Autosense が含まれている場合、これを無効に
します。

• OK をクリックして設定を有効にします。

原因： ネットワークの自動切断

ネットワークカードのデータトラフィックが一定の時間途絶えると、ネットワー
クカードが自動的にイーサネット接続を切断する場合があります。これは、レジ
ストリの autodisconnectキーを設定することによって避けることができま
す。

レジストリキー autodisconnectを設定する：

• レジストリエディタを開きます。

• HKEY_LOCAL_MACHINE/SYSTEM/
ControlSet001/Services/
lanmanserver/parameters というフォル
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ダに含まれるレジストリキー 
autodisconnect の値を 0xffffffff に
変更します。

7.1.3 パーソナルファイアウォールによる通信のブロック

パーソナルファイアウォールは、ETAS のイーサネットハードウェアへのアクセス
を妨害する場合があります。そのような場合、ハードウェアの自動検索時に、コ
ンフィギュレーションが正しく設定されているのにもかかわらずイーサネット
ハードウェアがまったく検出されない、という状態が発生する可能性があります。

また、ファイアウォールが適切に設定されていないと、ETAS ソフトウェアにおけ
る特定の操作（例： ASCET で実験を開く、INCA や HSP でハードウェアを検索す
る、など）を実行する際に不具合が発生する場合があります。

ファイアウォールによって ETAS ハードウェアとの通信がブロックされる場合は、
ETAS ソフトウェア使用中はファイアウォールソフトウェアを無効にするか、また
はファイアウォールの詳細設定を行って以下のアクセスを許可するようにしてく
ださい。

• UDP を経由する、デスティネーションアドレス 255.255.255.255 への出
力方向の IP ブロードキャスト（デスティネーションポート： 17099 また
は 18001）

• UDPを経由する、ソース IPアドレス0.0.0.0からデスティネーション IPアド
レス 255.255.255.255 への入力方向の IP ブロードキャスト（デスティ
ネーションポート： 18001）

• UDP を経由する、ETAS ネットワークへの直接 IP ブロードキャスト（デス
ティネーションポート： 17099 または 18001）

• UDP を経由する、ETAS ネットワーク内のすてべの IP アドレスへの出力方向
の IP ユニキャスト（デスティネーションポート： 17099 ～ 18001）

• UDP を経由する、ETAS ネットワーク内のすてべの IP アドレスからの入力方
向の IP ユニキャスト（ソースポート： 17099 ～ 18020、デスティネー
ションポート： 17099 ～ 18020）

• ETAS ネットワーク内への出力方向の TCP/IP 接続（デスティネーションポー
ト： 18001 ～ 18020）

Windows XP および Windows Vista に組み込まれているパーソナルファイア
ウォール以外に、サードパーティ（Symantec、McAfee、Blackice）の各種パー
ソナルファイアウォールも一般的によく使用されています。これらの各ファイア
ウォールではそれぞれ対処方法も異なる場合がありますので、お使いのパーソナ
ルファイアウォールの説明書をよくお読みください。

注記

実際のポート番号は、使用するハードウェアに応じて異なります。ポート番号
についての詳しい情報は、ハードウェアのドキュメントを参照してください。
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以下に一例として、一般的に使用されている Windows XP（SP2） ／ Vista のファ
イアウォールの設定方法をご紹介します。

Windows XP ／ Vista ファイアウォールの設定： 管理者権限を持つユーザー
の場合

PC の管理者権限を持っているユーザーの場合、ETAS ソフトウェアがファイア
ウォールによってブロックされると、以下のようなダイアログボックスが開きま
す。

製品のブロックを解除する：

• “Windows セキュリティの重要な警告”ダイアロ
グボックスで、ブロックを解除する をクリックし
ます。

以降、該当する ETAS ソフトウェアはファイア
ウォールによってブロックされなくなります。こ
の設定は、プログラムや PC の再起動後も維持さ
れます。

上記の“Windows セキュリティの重要な警告”ダイアログボックスが開く前に、
前もって ETAS ソフトウェアのブロックを解除しておくこともできます。

ファイアウォールの設定を変更して製品のブロックを解除する：

1. Windows XP

• Windows のスタートメニューから 設定 → コント
ロールパネル を選択します。

• コントロールパネルから Windows ファイア
ウォール を選択します。

2. Windows Vista
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• Windows のスタートメニューから コントロール
パネル → Windows ファイアウォール を選択し
ます。

• “Windows ファイアウォール”ダイアログボック
スで、Windows ファイアウォールによるプログ
ラムの許可 をクリックします。

3. XP ／ Vista 共通

“Windows ファイアウォール”ダイアログボック
ス（XP の場合）または“Windows ファイア
ウォールの設定”ダイアログボックス（Vista の
場合）が開きます。

• “例外”タブを選択します（下図は XP の場合で
す）。

このタブには、ファイアウォールによるブロック
から除外されているプログラムが一覧表示されま
す。

• プログラムの追加 または 編集 ボタンをクリック
して、新しいアイテム（プログラム）を追加する
か、既存のアイテムを編集します。

• 以下のようにして、使用する ETAS ソフトウェアと
それに関連するサービスについて、正しく例外設
定されていることを確認します。
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－ 例外リストから該当するアイテムを選択して 
編集 （Vista の場合は プロパティ）をクリッ
クし、“プログラムの編集”ダイアログボッ
クスを開きます。

－ スコープの変更 をクリックし、“スコープの
変更”ダイアログボックスを開きます。

－ ETAS ハードウェアへのアクセスが行えるよ
うに、192.168.40.xxxという IP アドレ
スがブロック解除されていることを確認して
ください。

－ OK をクリックして“スコープの変更”ダイ
アログボックスを閉じ、さらにプログラムの
編集”ダイアログボックスも OK をクリック
して閉じます。

• OK をクリックして“Windows ファイアウォー
ル”ダイアログボックスを閉じます。

以降、該当する ETAS ソフトウェアはファイア
ウォールによってブロックされなくなります。こ
の設定は、プログラムや PC の再起動後も維持さ
れます。

Windows XP ／ Vista ファイアウォールの設定： 管理者権限を持たないユー
ザーの場合

権限（システム変更、書き込み、ローカルログオンなど）が制限されているユー
ザーの場合は、以下のように操作してください。

ETAS ソフトウェアを使用するユーザーは、所定のディレクトリ（ETAS、
ETASData、ETAS の一時ディレクトリ）への“書き込み”の権利が必要です。
それらの権利がない場合状態で ETAS ソフトウェアを起動すると、エラーメッ
セージが表示され、その後データベースが開きますが、正しい操作は行えません。
これは、ETAS ソフトウェアの操作時にはデータベースファイルや *.iniファイ
ルの書き換えが必要なためです。
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ETAS ソフトウェアは、必ず管理者権限のあるユーザーがインストールを行い、そ
の後、Windows XP ／ Vista ファイアウォールの例外リストにそのプログラムを
正しく登録してください。これが行われていないと、以下の事柄が生じます。

• ファイアウォールにより制限されているアクションを実行すると、
“Windows セキュリティの重要な警告”ダイアログボックスが開きます。

製品のブロックを解除する（管理者権限のないユーザーの場合）：

• “Windows セキュリティの重要な警告”ダイアロ
グボックスで、このプログラムについてはこの
メッセージを表示しない をオンにします。

• OK をクリックしてダイアログボックスを閉じま
す。

この後、管理者権限のあるユーザーが
“Windows ファイアウォール”ダイアログボック
ス（XP の場合）または“Windows ファイア
ウォール設定”ダイアログボックス（Vista の場
合）の“例外”タブで適切な設定を行い、ETAS
ソフトウェアがハードウェアアクセスを行えるよ
うにする必要があります。
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8 付録 C：AUTOSAR

8.1 基本原理

AUTOSAR における SWC、つまり「アトミックソフトウェアコンポーネント」
（実行されるソフトウェアの 小単位）の作成は、2 つのステップに分かれます。
第 1 ステップでは、コンポーネントの「インターフェース」を定義します。イン
ターフェースの定義は「オーサリングツール」を用いて行い、XML フォーマット
で交換されます。XML ファイルはコンポーネント API ジェネレータに渡され、そ
こでインターフェース定義がヘッダファイルに変換されます。このヘッダファイ
ルには、アトミックソフトウェアコンポーネントの内部挙動が使用するすべての
アクセスマクロが含まれます。一般に、コンポーネント API ジェネレータは RTE1

ジェネレータの「コントラクトフェーズ部」に相当します。

第 2 ステップでは、アプリケーションソフトウェアコンポーネント開発者が C
ファイルで内部挙動を記述しますが、その際、前出のヘッダファイル内に定義さ
れているインターフェースを遵守する必要があります。このようにしてアトミッ
クソフトウェアコンポーネントの *.hファイルと *.cファイルが作成され、コ
ンパイルチェックが行える状態になります。アクセスマクロの解決は、RTE ジェ
ネレータが、OS スケジュール、および RTE の作成対象となる ECU にマッピング
されるすべてのコンポーネント（インスタンス）を認識できる「RTE 生成フェー
ズ」においてのみ行われます。

ASCET は、この「アトミックソフトウェアコンポーネントのオーサリングツー
ル」および「挙動モデリングツール」の両方の機能を備えています。

「オーサリングツール」として使用される際は、ASCET 6.0 でサポートされている
AUTOSAR モデリングエレメント（「モードグループ」、「インターフェース」、「ア
トミックソフトウェアコンポーネント」）が ASCET データベース内に作成され、
維持管理されます。これらのエレメントは ASCET の OID（オブジェクト ID）を
持ち、さまざまなインプリメンテーションを割り当てることができるため、複数
のプロジェクトで再利用することができます。

AUTOSAR エレメントは XML ファイル内で互いに参照し合います。たとえば、
「データエレメントプロトタイプ」は型を持ち、「センダ - レシーバ」インター
フェース型内で使用されます。同様に、「インターフェース型」は「アトミックソ
フトウェアコンポーネント型」内で「ポートプロトタイプ」として使用されます。
ASCET 6.0 では「アトミックソフトウェアコンポーネント型」を作成しますが、
アトミックソフトウェアコンポーネントにはいわゆる「内部挙動」が定義され、
内部挙動は「ランナブルエンティティ」で構成されます。「ランナブルエンティ
ティ」は、AUTOSAR ECU の統合においてはオペレーティングシステムタスクに
マッピングされ、コンポーネントの「部分的」挙動を表します。これは ASCET の

「プロセス」とよく似ています。

1. Run Time Environment： ランタイム環境
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また ASCET は「挙動モデリングツール」としても使用できます。ASCET 6.0 に
おいて、アトミックソフトウェアコンポーネントの内部挙動はブロックダイアグ
ラムエディタで定義されます。内部挙動は「変数」、「クラスインスタンス」、「パ
ラメータ」、「シーケンスコール」で構成されます。マイグレーションの目的で

「メッセージ」と「モジュール」もサポートされています。

AUTOSAR の XML およびコードの生成は ASCET プロジェクトにより行われま
す。つまり、AUTOSAR ユースケースにおける ASCET プロジェクトには 1 つのア
トミックソフトウェアコンポーネント型が内包されます。AUTOSAR コード生成
は、製品コードのターゲットである RTE-AUTOSAR ターゲット専用に機能しま
す。コード生成時、アクセスマクロを含む C コードは ASCET の cgen フォルダに
格納されます。生成された *.cと *.arxmlの両方のファイルを取得するには、
ASCET の「生成コードのエクスポート」機能を使用します。

8.2 ASCET における AUTOSAR モデリングエレメント

8.2.1 モード

ASCET は、AUTOSAR リリース 2.1 の「モード管理」をサポートしています。各
モード型には「モード宣言」と呼ばれるものが必要で、これは ASCET の列挙型に
似ています。典型的なモード宣言は init、run、diagnostics などです。ただし列
挙型とは異なり、モードを表す整数値を明示的に設定することはできません。
モードはデータベース内で維持管理され、エディタ内の 初のモード宣言が init
モードになります。

8.2.2 インターフェース

ASCET 6.0 でサポートされているインターフェースは「センダ - レシーバ」イン
ターフェースのみで、これをエディタで見ると、メソッドを持たないレイアウトク
ラスによく似ています。センダ - レシーバインターフェース内には「データエレメ
ントプロトタイプ」が含まれます。データエレメントプロトタイプは ASCET のモ
デル型のひとつであるため、1 つのインターフェース型に複数の「ASCET インプリ
メンテーション」（実装情報）を持たせることができます。センダ - レシーバイン
ターフェースの ASCET インプリメンテーションは、そのデータエレメントプロト
タイプのインプリメンテーションにより定義されます。データエレメントプロトタ
イプの ASCET インプリメンテーションは、ASCET のモデル型（contなど）に
ASCET の実装型（uint16など）を割り当てるもので、ASCET 実装型の範囲は、
モデル型 cont の物理範囲と実装変換式により定義されます。この ASCET 実装型の
範囲によってデータエレメントプロトタイプのプリミティブな AUTOSAR の型が決
定されます。AUTOSAR リリース 2.1 では、RTE が AUTOSAR の型を C のデータ型
に変換し、この変換については RTE 仕様書1 の 5.2.4.2 項に記載されています。こ
れらのデータ型は ASCET の実装型と一致します。

1. AUTOSAR_SWS_RTE リリース 2.1（www.autosar.org を参照してください）
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データエレメントプロトタイプ用のデータ型は、すべての ASCET ビルトインモデ
ル型、およびユーザー定義の列挙型およびレコード型から選択することができま
す。「配列」は直接使用することはできないので、レコード内にカプセル化する必
要があります。「モード」は、モード以外の型のデータエレメントプロトタイプが
他にない場合に限りセンダ - レシーバインターフェース内で使用できます。つま
り、センダ - レシーバインターフェースにモードがデータエレメントプロトタイ
プとして含まれている場合は、すべてのデータエレメントプロトタイプは「モー
ド型」でなければなりません。このような「モードインターフェース」の場合、
データエレメントプロトタイプは「モード宣言グループプロトタイプ」と呼ばれ
ます。

8.2.3 アトミックソフトウェアコンポーネント型

「アトミックソフトウェアコンポーネント」は階層的な ASCET クラスとモジュー
ルの混成体です。アトミックソフトウェアコンポーネント（SWC）は、インター
フェース型を「ポートプロトタイプ」としてインスタンス化することができます。
つまり、1 つの SWC の中に同じインターフェース型のポートプロトタイプが複数
存在する可能性があります。ポートプロトタイプはそれを提供したり要求したり
することによってその機能が実現されます。センダ - レシーバインターフェースを
持つポートプロトタイプは、そのデータエレメントプロトタイプがコンポーネント
により受信される場合は「要求ポート」となり、データエレメントがコンポーネン
トにより送信される場合は「提供ポート」になります。

ポートプロトタイプは SWC のエレメント（部品）であり、その役割はプロパ
ティエディタで選択できます。役割が適切に設定されたデータエレメントプロト
タイプは ASCET のメッセージに似ています。ASCET モジュール内のメッセージ
送受信は「メッセージ」により行われますが、AUTOSAR SWC はランナブルエン
ティティを使用してポートプロトタイプのデータエレメントプロトタイプにアク
セスします。

したがって、SWC の内部挙動は一連のランナブルエンティティにより定義される
ことになります。ランナブルエンティティはデータエレメントプロトタイプを読
み取るたびに、データ読み取りアクセスを実行します。データエレメントプロト
タイプの送信も同様で、ランナブルエンティティはデータ書き込みアクセスを行
います。ここでは ASCET のメッセージとは異なり、各種のデータエレメントアク
セスが用意されています。 も一般的な種類は implicit（暗黙的）と explicit（明
示的）です。

ASCET 内の SWC のエレメントリストにおいて「ポートプロトタイプ」は、変数、
パラメータ、クラスインスタンス、モジュール、メッセージなど他のすべての内
包エレメントと同様に表示されます。SWC にもダイアグラムがあり、ランナブル
エンティティはダイアグラム内に定義されます。ASCET SWC はランナブルエン
ティティだけでなくメソッドもサポートしています。

ランナブルエンティティにおいては、シーケンスコールを使用してグラフィカル
に「代入」をモデリングします。たとえば、データエレメントプロトタイプを暗
黙的に読み取るためには、ポートプロトタイプをダイアグラムに引き込みます。
そうすると、データエレメントプロトタイプのピンが式の演算に接続され、これ
が変数、または提供ポート内のデータエレメントプロトタイプへの書き込みアク
セスになります。この代入はシーケンスコールにより行われ、シーケンスコール
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はランナブルエンティティ（またはメソッド）によりトリガされます。「明示的
データ読み取りアクセス」（「データ受信ポイント」とも呼ばれます）には専用の
アクセス演算子と、データを格納するための変数またはメッセージが必要です。
その変数またはメッセージのシーケンスコールには、トリガとしてランナブルエ
ンティティまたはメソッドが割り当てられます。

8.3 ASCET インプリメンテーションの AUTOSAR への適用

前述のように、ASCET のセンダ - レシーバインターフェースのデータエレメント
プロトタイプは ASCET のモデル型をサポートしていますが、AUTOSAR の型は、
ASCET モデル型にインプリメンテーションが定義されてからでないと決定できま
せん。つまり、ASCET データベース内の 1 つのセンダ - レシーバインターフェー
スエントリは、その ASCET インターフェースのインプリメンテーションの数と同
じ数の AUTOSAR インターフェース型を表すことになります。ASCET 内の SWC
はポートプロトタイプ内で ASCET センダ - レシーバインターフェースを使用する
ので、異なる複数のインプリメンテーションを持つことができます。その結果、1
つの ASCET アトミックソフトウェアコンポーネントタイプには、定義されている
ASCET インプリメンテーションの数と同じ数の AUTOSAR アトミックソフトウェ
アコンポーネントタイプが定義されることになります。

8.3.1 サブパッケージ

AUTOSAR のリリース 2.1 においては、XML ディスクリプション内では 32 文字ま
でのショート名しか使用できません。そのため生成されたコード内の異なるインプ
リメンテーションを区別するためにインプリメンテーション名を ASCET モデル名に
連結する、という ASCET の古典的なアプローチを適用するには限界がありますが、
これは XML ファイル内にサブパッケージを使用することにより解決できます。XML
ファイル内にはアトミックソフトウェアコンポーネントとそのインターフェースの
ために 1 つのパッケージが生成されますが、エレメントを処理する前に各インプリ
メンテーション用のサブパッケージが生成されます。ASCET 6.0 はアトミックソフ
トウェアコンポーネントの 1 つのインプリメンテーション用の C コードと XML
ディスクリプションしか生成しないので、サブパッケージの数は 1 つだけです。イ
ンプリメンテーションは、プロジェクトのコード生成時に前もって選択され、
ASCET XML ジェネレータは、すべての参照（サブパッケージ impl-1内のポート
プロトタイプからサブパッケージ impl-2内のインターフェースへの型参照など）
を適切に設定します。ここで、アトミック SWC とインターフェースは異なる
AUTOSAR パッケージであることに注意してください。

8.4 例

ここで非常に単純な例を紹介します（以下の説明には ASCET 6.0 の AUTOSAR 
Tutorialというサンプルデータベースを使用しています）。このアトミックソ
フトウェアコンポーネントをアトミックソフトウェアコンポーネントエディタで
開くと、コンポーネントに含まれるエレメントが図 8-1 のように表示されます。
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ここには非常に単純なアトミックソフトウェアコンポーネント
（AR_VerySimpleExample）が含まれていて、そこにデータ通信用の 2 つの
ポートプロトタイプ（インターフェース型 IF_aの port2 とインターフェース型
IF_ABの port4）が含まれています。また各ポートの上にはモードポートが表
示されています。このソフトウェアコンポーネントには 2 つのランナブルエン
ティティ（runnable_explおよび runnable_impl）が含まれています。ま
た AUTOSAR エレメントの他に、ランナブルエンティティが明示的データアクセ
スを行って調べる errorという変数と、RTE アクセス用に作成されている戻り
値型 enumerationとがあります。

図 8-1 単純なアトミックソフトウェアコンポーネントのエレメント

インターフェース IF_aおよび IF_abは、ASCET の contモデル型であるデー
タエレメントプロトタイプをまとめたものです。インターフェース型 aの内容は
図 8-2 のとおりで、左側のエレメントリストにデータエレメントプロトタイプが
表示されています。

ここで“Implementation”タブを開いて AR_16bitというインプリメンテー
ションを選択してください。するとそのインプリメンテーションに定義されてい
る変換式により、実装型が符号付き 16 ビット整数に変わります（図 8-3）。この
設定に従ってコードと AUTOSAR XML ファイルが生成されます。

生成された XML ファイルの抜粋を図 8-4 に紹介します。これを見ると、ASCET 
interfacesという AR パッケージの下に AR_16bitというサブパッケージが
生成されています。データエレメントプロトタイプ a は AR_16bitサブパッ
ケージ内に組み込まれていて、autosar_types.arxmlファイル内の
sint16という実装型を参照（「型参照」）しています。

図 8-2 インターフェース IF_a
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図 8-3 インターフェース IF_a（整数インプリメンテーション）

図 8-4 AR_16bitサブパッケージ内に生成されたインターフェース

前述のとおり（また図 8-1 にも示すとおり）、port2というポートプロトタイプ
のインターフェース型は IF_aです。すべての ASCET モデリングエレメントと
同様、製品コード生成に使用されるアトミックソフトウェアコンポーネントには
複数のインプリメンテーションが定義されています。この例の
AR_VerySimpleExampleコンポーネントには 2 つのインプリメンテーション
があり、その 1 つは連続モデル用の 64 ビット real のデフォルトインプリメン
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テーションである implで、もう 1 つは符号付き int16型を使用する
AR_16bitです。ここでは図 8-5 に示すように、上記の操作によって整数インプ
リメンテーションが選択されているため、整数コードが生成されます。

図 8-5 16 ビット整数インプリメンテーションの選択

生成された AUTOSAR XML ファイルの抜粋を図 8-6 に紹介します。アトミックソ
フトウェアコンポーネント AR_VerySimpleExampleは、ASCET インプリメ
ンテーションと同じ名前のサブパッケージに組み込まれています。

図 8-6 AR_16bitサブパッケージ内に生成されたアトミックソフトウェアコ
ンポーネント
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AUTOSAR パッケージの観点から見ると、この種の ASCET インプリメンテーショ
ン表現を使用するためには、すべての集合エレメント用の型参照にそれぞれ適切
なパッケージが必要です。この種の「サブパッケージ参照」の例を図 8-7 に示し
ます。インプリメンテーション AR_16bitのインターフェース IF_aを見つけ
るために、アトミックソフトウェアコンポーネント AR_VerySimpleExample
内の port2の型参照は ASCET_interfacesパッケージだけでなく、そのサ
ブパッケージである AR_16bitも参照します。

このためオーサリングツールと ECU 統合ツールは、サブパッケージを扱えること
が必須条件となります。このサブパッケージ構造はコード生成や RTE アクセスに
はまったく影響しません。

このようなサブパッケージ表現が使用されているのは、AUTOSAR リリース 2.1
に 32 文字制限があり、「エレメント名とインプリメンテーション名を連結する」
という ASCET の古典的な方法は非常に限られた状況でしか使用できないためで
す。

図 8-7 AUTOSAR XML ファイル内のサブパッケージ参照

ASCET ソフトウェアコンポーネントの内部挙動は、ブロックダイアグラムエディ
タで記述されます。この例では、それぞれ 1 つのランナブルエンティティを持つ
2 つのダイアグラムが使用されています。第 1 のダイアグラム内のランナブルエ
ンティティはポートプロトタイプ port2および port4への暗黙的アクセスのみ
を実現しています。このブロックダイアグラムを図 8-8 に示します。要求ポート
プロトタイプ port2は左側に位置し、そのデータエレメントプロトタイプ a は
ランナブルエンティティ runnable_implのシーケンスコール 5 番によりアク
セスされ、グラフィカルな式の中で使用されます。この式の結果はシーケンス
コール 5 番によりポートプロトタイプ port4のデータエレメントプロトタイプ
a に書き込まれます。ポートプロトタイプ port2のデータエレメントプロトタイ
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プ a は、さらにシーケンスコール 10 番によってもアクセスされます。シーケン
スコール 10 番の式は a に 1（物理モデル）を加算し、その結果をポートプロトタ
イプ port4のデータエレメントプロトタイプ b に暗黙的に書き込みます。 

図 8-8 「暗黙的」ランナブルエンティティの内部挙動

生成されたコードとその暗黙的 RTE アクセスマクロを図 8-9 に紹介します。暗黙
的通信の場合、RTE_IREADアクセスマクロを式の中に使用でき、式は整数演算
で実現されることがわかります。グラフィカルに見ると、暗黙的データエレメン
トアクセスはポートプロトタイプへの直接接続により示され、これがデフォルト
アクセスと見なされます。

図 8-9 暗黙的ランナブルエンティティについて生成されたコード

明示的データアクセスは、図 8-10 に示すようにダイアグラム
Example_Explicitで実現されています。このダイアグラムでは「RTE アク
セスブロック」が使用されています。このブロック内で、ポートプロトタイプの
データエレメントプロトタイプに対するアクセスを、「暗黙的」（implicit）、「明示
的」（explicit）、および「ステータス付き明示的」(explicit-with-status) アクセス
のうちから選択することができます。このアクセスブロックがない場合はデフォ
ルトとして暗黙的通信が行われますが、明示的通信を行う場合は必ずこのアクセ
スブロックが必要です。こうして、RTE アクセスブロック内においては explicit メ
ソッドがデフォルトアクセスメソッドになります。このアクセスメソッドは
port2および port4のデータエレメント aに使用され、port4のデータエレ
メント bには explicit-with-status アクセスメソッドが使用されます。この場合、
さらに、ASCET BDE 言語の if-then-elseブロックの else部と同じ意味を
持つ出力ピンを使用できます。この else部を使用して、エラーフラグのセット
やエラーファンクションの呼び出しを行うなどのデータフローをトリガできます。
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明示的なデータ読み取りアクセスを使用するランナブルエンティティは、RTE か
らフェッチしたデータを格納するメモリを備えている必要があり、この例ではそ
のために「ランナブルローカル変数」が使用されています。他の方法としては、
アトミックソフトウェアコンポーネント型、クラス、あるいはメッセージ内の変
数を使用することもできます。メッセージはマイグレーションプロジェクト、つ
まり、モジュールがアトミックソフトウェアコンポーネントにインポートされる
場合に使用できますが、OSEK プロジェクトの場合とは意味が少し異なります。

図 8-10 明示的ランナブルエンティティの内部挙動

生成されるコードを図 8-11 に示します。データエレメント a が RTE_Readマク
ロにより port2から読み取られ、ランナブルエンティティのローカル変数
locvarのメモリロケーションに書き込まれています。また、169 ページの図 8-
9 の暗黙的ランナブルエンティティの例では 2 つのアクセスが必要であったのに
対し、明示的ランナブルエンティティでは必要な RTE アクセスは 1 つだけです。
式への「データ配布」は runnable_explの例では RTE ではなくローカル変数
により行われています。

図 8-11 暗黙的ランナブルエンティティのコード
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明示的通信の場合、RTE 仕様書1 の 5.4.1 項の規定に従い、RTE アクセスマクロの
戻り値を表す列挙型を作成する必要があります。このような列挙型を図 8-12 に
紹介します。

図 8-12 RTE の標準的な戻り値

RTE にランナブルエンティティを実行させるためには、そのランナブルエンティ
ティをイベントによりトリガする必要があります。各ランナブルエンティティに
ついて 1 つ以上のイベントを指定する必要があり、RTE ジェネレータはこの情報
を取得して適切なタスクにランナブルエンティティを割り当てます。ASCET で
は、イベントはアトミックソフトウェアコンポーネントの“Event Specification”
タブに指定されます。この例では、下の 2 つのタイミングイベントが指定されて
います。

• Ev_Timing_Explicit_10ms

• Ev_Timing_Implict_10ms

イベント名は AUTOSAR の命名規則に従う必要があります。ランナブルエンティ
ティもイベントもパッケージの内部挙動の一環であり、1 つのパッケージ内のエ
レメント名はすべて一意でなければなりません。たとえば、ランナブルランナブ
ル Aに対応するイベントの名前は、Aではなく ev_Aという名前にする必要があ
ります。

1. AUTOSAR_SWS_RTE リリース 2.1（www.autosar.org を参照してください）

注記

ASCET V6.0 では、イベント名とランナブルエンティティ名が異なるかどうか
のチェックは行われません。
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明示的タイミングイベントと明示的ランナブルエンティティの関連付けを図 8-13
に示します。 

図 8-13 イベントをランナブルエンティティにマッピングする

AUTOSAR のランタイム実行のコンセプトには「モード」という表記法がありま
す。アプリケーションソフトウェアコンポーネントの場合、ランナブルエンティ
ティの実行を「モード無効化に関する依存性」（"mode-disabling dependency"）
によって制御することができます。これは、所定のモードの時に RTE が所定のラ
ンナブルエンティティを実行しないように定義するものです。現在のモードは
ポートプロトタイプによりアトミックソフトウェアコンポーネントに伝えられま
す。

この例では、2 つのモードが定義されています。モードの定義は OnOffModeと
いう名前のモード宣言グループ（または略して「モードグループ」）を作成するこ
とにより行われます。図 8-14（コンポーネントマネージャ）を参照してくださ
い。

図 8-14 モード宣言グループ

図 8-15 に示すように、このモードグループは ModeInterfaceという名前の
センダ - レシーバインターフェース内にモード宣言グループプロトタイプとして
インスタンス化されています。そしてこの ModeInterfaceはこの例のアト
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ミックソフトウェアコンポーネント AR_VerySimpleExample内の
ModePortというポートプロトタイプ内にインスタンス化されています。これは
165 ページの図 8-1 のエレメントリストに含まれています。

図 8-15 センダ - レシーバインターフェース内のモード宣言グループプロトタイ
プ

モードと RTE イベントの関連付けは自動的に行われるので、アトミックソフト
ウェアコンポーネント型によって「モードインターフェース」が 1 つのポートプ
ロトタイプに統合されると、このコンポーネントのすべてのランナブルエンティ
ティはモード無効化依存性に関連付けられていると想定されることになります。
図 8-16 を見ると、イベント ev_timingExpl_10msは OnModeの時に有効に
なり、イベント ev_timingImpl_10msは OffModeの時に有効になることが
わかります。

図 8-16 イベント定義エディタ

8.5 レガシープロジェクトの移植

ASCET の古典的なモデリング手法では「モジュール」と「クラス」が用いられま
すが、アトミックソフトウェアコンポーネント内でこれらのものを使用すること
ができます。図 8-17 は、AR_VerySimpleMigrationというアトミックソフ
トウェアコンポーネント内においてモジュールが再利用されているようすを示し
ています。このモジュールは SimpleMigrationModuleという名前で、その
メッセージ receive_aは set メソッドが有効になっていて、メッセージ
send_aおよび send_bは get メソッドが有効になっているため、各メッセージ
はアトミックソフトウェアコンポーネント内で受信メッセージまたは送信メッ
セージとして「表示」されます。その結果、モジュール内の受信メッセージを使
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用して、ランナブルエンティティ migration_runnable_module_10msの
データ受信ポイントから port2のデータエレメントプロトタイプ a にデータを
格納することができます。このモジュールの送信メッセージは、データ送信ポイ
ントの引数として使用できます。

図 8-17 モジュールをアトミックソフトウェアコンポーネントに組み込む

シーケンスコール 5 番からわかるように、アトミックソフトウェアコンポーネン
トのブロックダイアグラムエディタでは、プロセスをメソッドのように呼び出す
ことができます。生成されたコードを図 8-18 に示します。モジュールについて
見てみると、すべての受信メッセージが RTE から読み取られてからプロセスが呼
び出され、送信メッセージが RTE に書き込まれます。

図 8-18 アトミックソフトウェアコンポーネント内のモジュールについて生成さ
れたコード

図 8-19 からわかるように、プロセス内のアルゴリズムはアトミックソフトウェ
アコンポーネント型の中で使用されていることを認識していません。つまり、既
存のモジュール、さらにはプロジェクトでさえも、1 つのアトミックソフトウェ
アコンポーネント型に容易に移植することができます。2 つのランナブルエン
ティティが共通メッセージを共有する 2 つのプロセスを呼び出す場合、ASCET
コードジェネレータはそのメッセージの回りに排他領域を生成してメッセージを
保護します。「ランナブルエンティティ間の相互変数」という概念は ASCET 6.0
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ではサポートされていないので、モジュールをまったく使用しないアトミックソ
フトウェアコンポーネント型の中でもメッセージを使用できるようになっていま
す。また、代わりに ASCET リソースを使用する方法もあります。

図 8-19 ASCET モジュール内のシンプルなアルゴリズム

アトミックソフトウェアコンポーネント型の内部挙動を階層構造にするために、
モジュールだけでなくクラスも使用できます。これを図 8-20 に示します。シン
プルなアルゴリズムは、図 8-21 に示すように、戻り値を返さない 1 つのメソッ
ド calc と戻り値 aおよび bを返す 2 つのメソッドを使用して、ASCET クラスと
してモデリングされます。SimpleMigrationClassには入力引数を格納する
ためのメンバ変数が必要で、そこに格納された入力引数はそれぞれ 1 つの戻り値
を提供するメソッドのステートメントの中で使用されます。ランナブルエンティ
ティ内で暗黙的アクセスを使用する場合、データ読み取りアクセスマクロの戻り
値を calc メソッド内で引数として直接使用でき、他の 2 つのメソッドの戻り値を
データ書き込みアクセスマクロ内で直接使用できます。生成されるコードを図 8-
22 に示します。
付録 C：AUTOSAR 175



176
図 8-20 アトミックソフトウェアコンポーネント内で複数のメソッドを持つ
ASCET クラスインスタンスを使用する

図 8-21 シンプルなアルゴリズムを複数のメソッドに分割したもの

図 8-22 古典的 ASCET メソッドを含むクラスを使用する際に生成されるコード

クラスの古典的メソッドモデリングに加え、ASCET 6.0 ではメソッド内で out パ
ラメータを使用することができます。この機能は図 8-23 で使用されています。
ここでは、図 8-20 の 3 つの古典的 ASCET メソッドの代わりに、1 つの入力引数
と 2 つの出力引数を扱うメソッド calc_returnが使用されています。

C などのプログラミング言語と同様、出力引数はメソッドに「参照渡し」で渡さ
れます。つまり、メソッドを呼び出す前にメモリをアロケートする必要がありま
す。この例では、migration_runnable_Expl_class_10msに 2 つの
ローカル変数（return_aおよび return_b）があり、アルゴリズムの処理結
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果はここに書き込まれます。アルゴリズムは図 8-24 に示すとおりです。これは
引数の値に応じて排他的に機能するので、176 ページの図 8-21 に紹介したアル
ゴリズムのようなメンバ変数の追加は必要ありません。

ただし、少なくともランナブルローカル変数として多少の変数の追加が必要とな
るため、RTE アクセス用のソリューションとしては「明示的通信」が適していま
す。そこで、この例では変数（ランナブルローカル）arg_aを追加して使用して
います。生成されるコードを図 8-25 に紹介します。

図 8-23 1 つのメソッドを持つ ASCET クラスインスタンスの使用

図 8-24 1 つのメソッドの中のシンプルなアルゴリズム
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図 8-25 1 つのメソッドを持つ ASCET クラスインスタンスを使用するアトミック
ソフトウェアコンポーネント用に生成されるコード
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9 お問い合わせ先

製品に関するご質問等は、各地域の ETAS 支社までお問い合わせください。

ETAS 本社

ETAS GmbH

日本支社

イータス株式会社

その他の支社

上記以外の各国支社につきましては、ETAS ホームページをご覧ください。

Borsigstrasse 14 Phone: +49 711 8 96 61-0

70469 Stuttgart Fax: +49 711 8 96 61-105

Germany E-mail: sales@etas.de

WWW: http://www.etas.com/

〒 220-6217 Phone: (045) 222-0900

神奈川県横浜市西区 Fax: (045) 222-0956

みなとみらい 2-3-5 E-mail: sales.jp@etas.com

クイーンズタワー C 17F WWW: http://www.etas.com/

各国支社 WWW: www.etas.com/ja/contact.php

技術サポート WWW: www.etas.com/ja/contact.php
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