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1 はじめに

ASCET は、組み込みソフトウェアシステムのファンクション開発とソフトウェア開
発のための革新的なソリューションを提供します。ASCET は、新しい独自のアプ
ローチによって、モデリング、コード生成、シミュレーション実験、といった開発
プロセスの各段階を強力にサポートするので、品質向上や開発サイクルの短縮、さ
らにコスト低減を実現できます。

本書は、読者の方が ASCET について理解し、速やかに成果を得られるように支援す
るものです。システムについて順を追って紹介すると同時に、すべての情報を参考
資料として利用しやすい形にまとめてあります。

1.1 ASCET ファミリ

ASCET 製品ファミリに含まれる各製品には、それぞれシミュレーションプロセッサ
とのインターフェース、サードパーティのソフトウェアパッケージとのインター
フェース、さらに ASCET のリモートアクセスを行うためのインターフェース、と
いった機能が盛り込まれています。最新バージョンにおいては、ASCET 製品ファミ
リは以下の製品で構成されています。

• ASCET-MD
モデルの開発とオフラインシミュレーションに使用します。

• ASCET-RP
実験ターゲット（マイクロコントローラを搭載した ETAS シミュレーション
ボード）を使用した HiL（Hardware-in-the-Loop）シミュレーションやラ
ピッドプロトタイピングをサポートします。また INTECRIO との接続機能も
含まれます。

• ASCET-SE
ECU の各種マイクロコントローラターゲットへのコード実装をサポートしま
す。ターゲットとなるマイクロコントローラ用に最適化された実行コード

（任意に設定されたオペレーティングシステムを含む）が生成されます。さま
ざまなタイプのコントローラをサポートし、2 種類の OS を統合できます。

また、以下のオプションモジュールも利用できます。

• ASCET-DIFF
ASCET モデルの比較ツールです。

• ASCET-SCM
外部のコンフィギュレーション管理ツールとのインターフェースを提供しま
す。

これらの他にも、ご要望に応じてユーザー固有の製品を ASCET に組み込むことも可
能です。詳しくは ETAS までお問い合わせください。

1.2 マニュアルについて

1.2.1 ユーザープロファイル

このマニュアルは、ECU（自動車制御ユニット）の開発や適合作業の経験がある方
を対象としています。 このマニュアルをお読みいただくには、信号測定や ECU に関
する技術についての専門的な知識が必要です。 

また、Windows（XP、Vista、7）の操作についての知識も必要です。 メニューコマ
ンドの実行、ボタン操作、さらには Windows のファイルシステム、特にファイル
とディレクトリの関係についての知識が必要です。また Windows のファイルマ
ネージャやエクスプローラ等の基本的な使い方を理解されていて、「ドラグアンドド
ロップ」操作に慣れていることも必要です。
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Microsoft Windows の基本テクニックに慣れていない方は、まずそれらについて学
習してから、ASCET をご使用ください。 Windows オペレーティングシステムについ
ての詳しい説明は、マイクロソフト社発行のマニュアルを参照してください。

またさらに ANSI C や JAVA 等のプログラミング言語に関する知識があれば、ASCET
をより効率的にお使いいただくことができます。

1.2.2 マニュアルの構成

ASCET マニュアルは、以下の 3 つのドキュメントで構成されています。

1.『ASCET V6.1 入門ガイド』

ASCET で作業する際に必要な基本的な情報がまとめられています。

2.『ASCET V6.1 インストールガイド』

ASCET 製品のシステム要件やインストール方法についての情報がまとめられ
ています。

3. ASCET オンラインヘルプ

ASCET 製品の機能や操作方法が詳しく説明されています。

本ドキュメント『ASCET V6.1 入門ガイド』は、以下の章で構成されています。

• 第 1 章 「はじめに」（本章）

ASCET 製品とマニュアルについての概要、および操作時に役立つ一般情報が
まとめられています。

• 第 2 章 「ASCET の概要」

ASCET 製品ファミリの機能概要がまとめられています。

• 第 3 章 「ASCET による自動車用組み込み制御ソフトウェアの開発」

ASCET 製品ファミリと、それによってサポートされる開発プロセスについて
の概要です。ASCET を使用する前に必ずお読みください。

• 第 4 章 「チュートリアル」

この章は、ASCET を初めて使うユーザーを対象としています。例題について
実際に作業を進めながら、ASCET の使用方法を学習できます。チュートリア
ルは各工程ごとにいくつかのセクションに分かれていて、各セクションは互
いに関連し合っています。なお、チュートリアルの演習を行う際は、あらか
じめ「ASCET による自動車用組み込み制御ソフトウェアの開発」（15 ペー
ジ）をお読みください。

• 「用語集」

マニュアルで使用されている技術用語について解説されています。

• 「付録 A: ASCET に関するトラブルシューティング」

ASCET 使用時に ASCET 固有の問題が発生した際の対処法とエラーレポート
の作成方法について説明されています。

• 「付録 B: 一般的なトラブルシューティング」

ETAS ソフトウェア製品使用時に発生する可能性のある一般的な問題点とその
解決方法がまとめられています。

注記

ETAS では、ASCET のユーザートレーニングを実施しています。トレーニングに
ご参加いただくことにより、ASCET の基本的な機能と使用方法のほか、より詳し
い知識を短時間で習得していただくことができます。
はじめに



• 「付録 C: ISO26262 に準拠した「ツールのクラス分け」」

安全性が重要視されるソフトウェアを対象とした ISO 26262 に基づく開発
ツールの「クラス分け」について、ASCET の対応状況がまとめられていま
す。

インストールの手順は別のマニュアル（『ASCET インストールガイド』）に説明され
ています。

ASCET を用いた AUTOSAR 対応ソフトウェアの開発については、『ASCET 
AUTOSAR ユーザーズガイド』（ASCET V6.1 AUTOSAR_UG.pdf）に説明されています。

ASCET の機能や操作方法についての詳しい情報は、オンラインヘルプに記載されて
います。オンラインヘルプの使用方法については 1.3.3 項を参照してください。

1.2.3 本書の使用法

表現について

ユーザーが実行するすべてのアクションは、いわゆる “Use-Case” 形式で記述され
ています。つまり以下に示すように、操作を行う目標がタイトルとして最初に簡潔
に定義され（例：「新しいコンポーネントを作成する」、「エレメントの名前を変更す
る」）、その下に、その目標を実現するために必要な操作手順が列挙され、必要に応
じて ASCET のウィンドウやダイアログボックスのスクリーンショットが添付されて
います。

目標の定義：

• 手順 1

手順 1 についての説明 ...

• 手順 2

手順 2 についての説明 ...

• 手順 3

手順 3 についての説明 ...

まとめ ...

具体例：

新しいファイルを作成する：

• File → New を選択します。

“Create file” ダイアログボックスが開きます。

• 新しいファイルの名前を、“File name” フィールドに
入力します。

ファイル名は 8 文字以内でなければなりません。

• OK をクリックします。

ファイル名が確定され、ダイアログボックスが閉じま
す。

新しいファイルが作成され、ユーザーが指定した名前で保存されます。このファイ
ルを使用して以降の操作を行います。
はじめに 9
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表記上の規則

本書は以下の規則に従って表記されています。

特に重要な注意事項は、以下のように表記されています。

また PDF 文書において、索引、および他の部分を参照する個所（例：「xx を参照し
てください」の中の「xx」の部分）については、その参照先へのリンクが設けられ
ているので、必要な参照個所を素早く見つけることができます。

表記例 説明

File → Exit を選択して、... メニューコマンドは、青の太字で表記し
ます。

OK をクリックして、... ユーザーインターフェース上のボタン名
は、青の太字で表記します。

<Ctrl> を押して、... キーボードの各キーは、< > で囲んで表
記します。

“Open File” ダイアログボックスが
開きます。

プログラムウィンドウ、ダイアログボッ
クス、入力フィールド等のタイトル
は、“ ” で囲んで表記します。

setup.exeファイルを選択します。 リストボックス、プログラムコード、
ファイル名、パス名等のテキスト文字列
は、Courierフォントで表記します。

論理型のデータから算術型のデータへ
の変換はできません。

注意すべき個所、または新出の用語は太
字 、あるいは「 」で囲んで表記されま
す。

OSEK グループ（ÜííéWLLïïïKçëÉâJ
îÇñKçêÖL を参照してください）はさま
ざまな標準規格を策定しています。

インターネットへのリンクは、\\\\ で表
記されています。

注記

ユーザー向けの重要な注意事項
はじめに



1.3 ユーザーサポート機能

1.3.1 モニタウィンドウ

ASCET によって実行された処理に関する履歴は、モニタウィンドウ（詳しくは

ASCET オンラインヘルプを参照してください）に出力されます。履歴データには、
エラーや通知メッセージなども含まれます。何らかの情報が出力されると、直ちに
モニタウィンドウが最前面に表示されます。

モニタウィンドウは、情報を表示するだけでなく、エディタ機能も持っています。

• モニタウィンドウの “Monitor” タブに出力された履歴データは、自由に編集
できます。これによって、ユーザーのメモやコメントを ASCET の出力メッ
セージに付加できます。

• ASCET のメッセージを、付加したコメントと共にテキストファイルとして保
存できます。

• 既に保存されている他の履歴データをロードして、記録された処理値内容を
比較できます。

1.3.2 キーボードコマンドの一覧

<Ctrl> + <F1> を押すと、現在有効なキーボードコマンドの概要が表示されます。

1.3.3 マニュアルとオンラインヘルプ

デフォルト設定で ASCET をインストールすると、以下のマニュアルがマニュアルフォル

ダ（ETAS¥ETASManuals）にインストールされます。

• ASCET 入門ガイド（ASCET V6.1 Getting Started.pdf）

• ASCET インストールガイド（ASCET V6.1 Installation.pdf）

• ASCET AUTOSAR 入門ガイド（ASCET V6.1 AUTOSAR_UG.pdf）

PDF ファイルでは、索引やテキスト検索、または随所に設定されているハイパーリンクを
使用して、必要な情報に素早くアクセスすることができます。

また、ASCET 使用中に <F1> キーを押すと、コンテキスト依存のヘルプトピックが開き
ます。オンラインヘルプファイルは ETAS¥ASCET6.1¥Helpディレクトリにインス
トールされています。

注記

主なマニュアルとオンラインヘルプについては日本語版も用意されており、これらの
ファイルは ETAS のホームページからダウンロードしていただくことができます。詳し
くサポート窓口までお問い合わせください。
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2 ASCET の概要

ASCET は「モデルベース開発」をサポートするツールです。モデルベース開発は、
目的とするシステムの「モデル」、つまり「実行可能な機能記述」を構築し、開発の
早期工程においてシミュレーションや評価テストを実行してそのプロパティ（属性）
を確立していくものです。ASCET では、要件どおりのモデル挙動が得られた後に、
これを製品レベルのコードに自動変換することができます。

モデルベース開発の大きなメリットとしては、対象となるソフトウェアシステムを、
その分野のエキスパートがその分野固有の表現を用いて設計でき、その際に最終的
なコード化についての詳細な知識を必要としない、という点があげられます。モデ
ルベース設計については 3.1 項にその概念が詳しく説明されています。

ASCET にはさまざまなモデリングフレームワークが含まれています。各フレーム
ワークには独自のモデリング表記法が組み込まれていて、それぞれ以下のようなモ
デリングに適しています。

• ブロックダイアグラム（BD: Block Diagram） － 連続系制御システム

• ステートマシン（SM: State Machine） － イベントトリガシステム

• 条件テーブルと論理値テーブル － 複雑な算術式

• ESDL（Embedded Software Description Language） － テキスト形式のモデ
リング言語

モデリング言語は、低レベルの詳細な情報は含まれず、ECU 上で実行されるコード
として実現するための処理から分離されています。また ASCET では、「低レベル」
記述言語としての C コードを直接扱うこともできます。

ASCET の提供するシステマチックな手法により、「高レベルの機能仕様」（ASCET で
は「物理モデル」と呼ばれます）と「ターゲットへの実装情報」（ASCET では「実
装モデル」と呼ばれます）を効率的に記述することができます。実装モデルには、
モデルをターゲットハードウェア上で実行するために必要な低レベル情報（モデル
の物理値とターゲットの固定小数点値との変換式、マップ／カーブ用補間ルーチン、
最適化された算術演算サービス、ランライムスケジューリングを管理するリアルタ
イムオペレーションシステムとの統合、組み込みデバイス用メモリマッピングなど）
が含まれます。

物理モデルと実装モデルは ASCET 内において明確に分離されているため、ターゲッ
トに応じて実装情報を変更しても、元の機能記述が不用意に変更されてしまうこと
がありません。またこの「分離化」により、1 つの物理モデルを元に複数の異なる
特性を持つ実装モデルを作成することができるので、ソフトウェアのライフサイク
ルを通してモデルバリアントの数を少なく抑えることができます。

2.1 AUTOSAR 関連の機能一覧

2.1.1 ASCET-MD

• AUTOSARソフトウェアコンポーネントを含む自動車制御ソフトウェアのモデ
ルベース開発

• オブジェクト指向の階層的モデリングアーキテクチャ

• 物理値から固定小数点値へのシステマチックな変換をサポート

• カスタムブロックセットライブラリの作成

• AUTOSARソフトウェアコンポーネントのディスクリプションのインポート／
エクスポート

• Simulink® モデルと UML モデルのインポート

• 適合パラメータ（カーブ、マップを含む）のサポート
ASCET の概要 13
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• モデルのドキュメント化

• PC 上でのオフラインシミュレーション

2.1.2 ASCET-RP

• 実験ターゲット（ES910、ES1000 など）のハードウェアコンフィギュレー
ション設定

• HiL（ハードウェアインザループ）シミュレーションとラピッドプロトタイピ
ング

2.1.3 ASCET-SE

• 以下のような特徴を持つ製品用 C コードの自動生成

完全なモジュラー構造、高品質でオーバーヘッドが少ない、MISRA-C 2004
準拠、親モデルへのトレースが容易

• サードパーティ製の補間ルーチンや算術演算サービスルーチンの統合

• メモリセクションの構成やコンパイラ固有のシステム設定を生成コード内に
統合

• プラットフォーム統合のコンフィギュレーション設定

ASCET コードと OSEK オペレーティングシステム（RTA-OSEK など）や

ATOSAR RTE（RTA-RTE など）とのインターフェースを設定し、制御メカニ
ズムのリアルタイム性を確実なものにします。

• 「additional programmer」（「もう 1 人のプログラマ」）として、サードパー
ティ製ビルド環境への統合のためのソースコードとデータを生成

• 「Integration platform」（「統合プラットフォーム」）として、さまざまなコン
パイラやマイクロコントローラに対応する ECU 用実行イメージを「ワンク
リック」でビルドし、ユーザーによるフルカスタマイズも可能

• 適合ツール（INCA など）で使用する ASAM-MCD-2MC ディスクリプション
ファイルの生成

2.1.4 ASCET-SCM

• サードパーティ製バージョン管理ツールへの統合

2.1.5 ASCET-DIFF

• ASCET モデルのグラフィカルな比較
ASCET の概要



3 ASCET による自動車用組み込み制御ソフトウェアの開発

「自動車組み込みソフトウェア」の開発は、自動車の領域（インフォテイメント、
シャシー、ボディ、パワートレイン）間や会社（自動車メーカーとサプライヤ）間
の協力が要求される総合的な事業です。しかも、自動車組み込みソフトウェアは、
個々のメカニカルサブシステムにおいて非常に重要な部分を占めています。その特
徴は以下のような点です。

• センサからデータを読み取り、アクチュエータに送る制御値を計算する制御
アルゴリズムを実現します。

• 一般的に、ECU（Electric Control Unit: 電子制御ユニット）内で、1 つまた
は複数のマイクロコントローラとその他の電気部品や電子部品を用いて稼
働します。

• 通常、自動車のライフタイム全体にわたって変更されることはありません。

• メカニカルサブシステムの安全性と信頼性に関するすべての要件に適合して
いる必要があります。

このため、ソフトウェアで実装すべき機能についての「共通の理解」が、シームレ
スな統合、さらには機能自体には直接関係のない最適化（リソース消費など）のた
めの基盤となります。特に後者は、ECU の大量生産を考えた場合、顕著な結果を生
み出します。1 台の ECU について少しでもコストを減らすことができれば、製品ラ
イン全体の莫大なコスト節減につながります。たとえば、メモリ使用量を削減する
ことによって廉価なマイクロコントローラを使用できるようになれば、たとえ

ECU1 台当たりのコストの違いはわずかでも全体のコスト削減は非常に大きなもの
となります。

多くの場合、ECU ソフトウェアのファンクションをグラフィカルにモデリングする
ことが、上述の「共通理解」を実現するための要因となります。グラフィカルモデ
ルは、組み込み C コードより抽象的である一方、テキスト記述に比べて解釈の余地
がなく一義的であることから、より「形式的」であると言えます。グラフィカルモ
デルは PC 上でシミュレーション実行でき、また「ラピッドプロトタイピング」の手
法により、開発工程内の早い段階から実車を用いた動作検証を行うこともできます。
このようにファンクションのグラフィカルモデルは、「デジタル仕様書」としてさま
ざまな局面で利用できます。

ファンクションのグラフィカルモデルは、コード自動生成機能により自動車組み込
みソフトウェアに変換することができます。この際には、機能性に直接関係のない
製品特性（安全性、リソース消費など）を含む、各ターゲットに固有の設計情報を
ファンクションモデルに加味します。

ECU の動作環境は Hardware-in-the-Loop システム（HiL）によりシミュレートする
ことが可能であるため、ECU のテストを早期に実験室内で容易に行うことができま
す。ECU の HiL テストにおいては、実車テストの場合と比べて非常に柔軟なテスト
を実行することができます。

一般的に、自動車組み込みソフトウェアの「適合」は、開発工程の終わり近くにな
らないと完了させることができません。適合は多くの場合、実車においてシステム
全体（つまりソフトウェアを組み込んだすべてのメカニカルシステム）を稼働させ
た状態で実行されるため、専用のツールやメソッドが必要となります。ソフトウェ
ア生成時にはこのような条件についても考慮が必要です。

chapter 3.1 では「モデルベース設計」の諸段階について詳しく説明し、ファンク
ションのグラフィカルモデル作成のために ASCET で採用している「抽象化メカニ
ズム」についても説明します。chapter 3.2 では ECU 製品開発環境における

ASCET モデルの使用方法を紹介し、3.3 項で主要トピックについてまとめます。
ASCET による自動車用組み込み制御ソフトウェアの開発 15
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3.1 モデルベース設計

自動車組み込み制御ソフトウェアの開発は、V モデルの形で表すことのできる複数
の開発ステップからなります。最初に論理システムアーキテクチャの分析と設計、
つまり、制御ファンクションの定義を行い、続いて物理的アーキテクチャ（ECU
ネットワーク）を定義し、その後、ECU にソフトウェアを実装します。さらに各ソ
フトウェアコンポーネントの統合とテストを行ってから ECU を車両ネットワークに
統合し、最後の仕上げの工程として、実装されたファンクションを実行するシステ
ム全体を「適合」により微調整します。これは「トップダウン」式開発手法とは異
なり、シミュレーションとラピッドプロトタイピングによる早期フィードバックが
重要な要素となります。

図 3-1 ソフトウェアファンクションのモデルベース開発

3.1.1 制御アルゴリズム開発

最初の工程は制御アルゴリズムの開発で、これは主に制御工学的な作業となります。
まずは制御対象システム（「プラントモデル」と呼ばれます）を動的に分析すること
から始めます。プラントモデルは、車両（センサやアクチュエータなど）とその環
境（道路状態など）、およびドライバーで構成されます。一般的には、パワートレイ
ンを含むエンジンとドライバー、あるいはシャシーと道路状態、といったさまざま
なパターンに応じて、車両の各サブシステム（コンポーネント）について考察しま

物理システム

アーキテクチャ

1. ソフトウェアファンクション、およびドライバ／車両／環境のモデリング

2. 実車を用いたソフトウェアファンクションのラピッドプロトタイピング

3. ソフトウェアファンクションの設計と実装

4. 実験車両やテストベンチを用いたソフトウェアファンクションの統合と検証

5. 実車を用いたソフトウェアファンクションの検証と適合

ソフトウェアファンクションの実装 ドライバ、車両、環境

論理システム

アーキテクチャ

ソフトウェアファンクションのモデルベース開発の手法

ソフトウェアファンクションのモデル ドライバ、車両、環境のモデル
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す。これらのモデルは、分析的に解決される微分方程式などを用いた「分析的モデ
ル」と、数値的に解決される積分方程式による「シミュレーションモデル」のいず
れかですが、実際には、大抵のプラントモデルは両者の混合したものとなります。

次に、一定の品質基準に基づいた「制御規則」が適用されます。制御規則はプラン
トのダイナミクスを補うものであり、数多くの法則に基づく優れた制御規則を利用
することができます。自動車制御アルゴリズムは「閉ループ」の制御規則と「開
ループ」の制御方針を一体化して実現されることが多く、後者は多くの場合オート
マトンまたはスイッチング構造を採用したものです。このような制御アルゴリズム
は、システム理論の観点から見ると「ハイブリッド」なシステムであると言えます。
一般的に、制御規則は「制御機能」と「監視機能」を併せ持つ「セットポイント生
成」ファンクションであり、それらの機能はすべてソフトウェアにより実現されま
す（「ソフトウェアによる制御アルゴリズムの実現」という項を参照してください）。
ここでの第 1 ステップは、シミュレーションモデルにより表現される車両サブシス
テムを対象とする制御アルゴリズムを設計することです。ここでは制御アルゴリズ
ムとプラントモデルはどちらもコンピュータ上で実行されます。一般にプラントは
疑似連続系モデルとして設計され、制御アルゴリズムは離散系モデルとして設計さ
れます。どちらのモデルも値の範囲は連続的なので、制御アルゴリズムとプラント
が使用する状態変数とパラメータは、シミュレーションコード内では浮動小数点変
数として実現されます。このモデルは図 3-1（16 ページ）の上の部分に示されてい
ます。ここに示される「論理システムアーキテクチャ」は、ドライバー、車両、お
よび環境のモデルに結合される制御アルゴリズムを表すものです。1 の矢印は制御
アルゴリズム設計の段階を表し、制御アルゴリズムのモデリングは「共有信号の使
用」という観点において行われます。つまり、あるコンポーネントが信号の提供役
となり、他のコンポーネントが同じ信号の要求役となることにより、信号を共有し
ます。

ソフトウェアによる制御アルゴリズムの実現

制御アルゴリズムは「ハイブリッドシステム」、つまり、閉ループシステムと開ルー
プシステムの混成体で、ほとんどの場合、開ループ部は有限ステートマシンのよう
な非線形の離散システムです。制御アルゴリズムをマイクロコントローラ上で実行
するには順次プログラミング言語（C 言語など）に変換する必要がありますが、こ
れを最も容易に実現する方法は、割込みによりトリガされるメインループを作り、
そのループの中で順次プログラムを内包する複数のサブルーチンを呼び出すという
ものです。サブルーチン間のデータ交換はグローバル変数により行います。割込み
がメインループをトリガするたびに順次プログラムが繰り返し実行されるので、「タ
イミング割込み」を使用すれば、メインループで「サンプル値システム」を実現する
ことができます。

しかしこのように制御アルゴリズムをソフトウェアでストレートに表現する方法は、
「マルチレートシステム」（複数のサンプルレートを必要とするシステム）を実現す
るには限界があり、そのようなシステムは、1 つのメインループの代わりに複数の
タスクを使用して実現する必要があります。このような「マルチタスキングシステ
ム」においては、信号データがタスク間で適切に交換されなければなりませんが、
状態変数、パラメータ、入力／出力信号などを C コードレベルで確実に扱うことは
容易ではありません。そこで、制御アルゴリズムを ASCET で作成することにより、
このような制御アルゴリズムの「制御工学的視点」と「実装的視点」のギャップを
埋めることが可能となります。ASCET においては、C コードのように変数とサブ
ルーチンを単純に使用するのではなく、以下のような「構造」を用いて制御アルゴ
リズムをモデリングします。

• モジュール

• クラス

• プロジェクト

これらの構造を組み合わせることにより、さまざまなターゲット上で複雑な制御ア
ルゴリズムを構築し実行することができます。「ターゲット」とは制御アルゴリズム
が実行されるシステム、つまり PC やラピッドプロトタイピングシステム、または
ASCET による自動車用組み込み制御ソフトウェアの開発 17
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ECU のマイクロコントローラを指します。実行する際は、まず ASCET モデルを汎用
的な C コードに変換し、その C コードを各ターゲット上で実行可能なコードに変換
します。その際に使用されるすべての「モデリング構造」は、データベース内で維
持管理されます。

モジュール

「モジュール」は、（状態）変数、パラメータ、入力／出力信号に対する順次ステー
トメント（つまりそれらのアイテムに対して順に実行される命令文）を定義するた
めのものです。「順次ステートメント」は、ブロックダイアグラムエディタ（BDE）
において、変数に割り当てられた「シーケンスコール」によって定義されます。つ
まり、順番が定義された各シーケンスコールにより式の結果が変数に代入されます。
また複数の順次ステートメントを 1 つの「プロセス」（サブルーチンに相当します）
にまとめることができます。なお ASCET では、ステートメントの記述方法として

BDE の代わりに「ESDL プログラミング言語」を使用することもできます。

入力信号は「受信メッセージ」としてモデリングされ、受信メッセージの値を式に
読み込んで計算することができます。出力信号は「送信メッセージ」としてモデリ
ングされ、式の結果を送信メッセージに代入する（書き込む）ことができます。ブ
ロックダイアグラムエディタでは、メッセージへの代入は、変数の場合と同様に
シーケンスコールにより表されます。

「パラメータ」は独特な表現形式を持っています。パラメータの値を式に読み込むこ
とはできますが、パラメータに値を代入することはできません。

以上をまとめると、モジュールは送信メッセージと受信メッセージを使用して他の
モジュールとデータ交換を行います。また、モジュールは複数のプロセスを持ち、
プロセスには任意の数の順次ステートメントが含まれます。モジュールにはメッ
セージ以外に変数やパラメータも内包されます。受信メッセージから読み込んだ値
はモジュール内のプロセス間で共有できますが、送信メッセージへの書き込みには
各プロセス間の排他的アクセスが必要です。1 つのモジュール内のプロセス間でし
か交換されないメッセージが存在する可能性もあり、そのような専用メッセージは

「送受信メッセージ」と呼ばれます。

クラス

プロセスが実行される際、内部変数（制御アルゴリズムの状態など）を処理するた
めにデータを保存する必要が生じる場合があります。コンピュータサイエンスの観
点から、内部変数はいくつかの型に分類され、複数の型を組み合わせて「複合型」
を作成することもできます。複合型のエレメントについてはステートメントを定義
することができ、各処理を合わせて複数のサブファンクションまたはメソッドを形
成することができます。このうち「メソッド」は引数を取ることができ、通常の
データ操作で複合型のデータエレメントにアクセスすることができます。このよう
なメソッドを伴う複合型を「クラス」と呼びます。クラスは「型」のひとつである
ため、変数を定義する場合と同様に「インスタンス化」が可能です。ASCET では、
変数およびクラスのインスタンスをクラスまたはモジュールの中に定義することが
できます。

あるクラスを別の（= 外側の）クラスのスコープ内のインスタンスとして定義する
ことにより、インスタンス化されたクラスのメソッドを外側のクラスのメソッドか
ら呼び出すことができます。このようにしてメソッド（たとえばフィルタリングア
ルゴリズムなどの計算を実現するメソッド）をインスタンス化することにより、そ
の計算結果を呼び出し側のメソッドの計算の中で利用することができます。このメ
カニズムを利用すれば、制御アルゴリズムを「型定義されたオブジェクト階層」と
して表現することができます。トップレベルのクラス、つまり他のクラス内でイン
スタンス化されていない最も外側のクラスのメソッドを呼び出すと、「メソッドの出
力値」という結果が得られますが、その結果を算出する際は、組み込まれているメ
ソッドインスタンスが順次呼び出され、後続の計算に利用されます。このことから、

「トップレベルメソッドの実行」はオブジェクト指向プログラムの「順次実行」に相
当することがわかります。
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パラメータ

「パラメータ」を情報工学的に説明すれば、「プログラムからは読み込みのみ可能で、
書き込みできない特殊な変数」ですが、自動車制御工学の見地から説明すると「制
御アルゴリズムを特定の車両に合わせて調整するために使用されるデータ」となり
ます。パラメータの値は制御アルゴリズムの実行開始前に設定され、その値は制御
アルゴリズムの実行中には変化しません1。しかしそれでもパラメータは「変数」の
特殊な形であるため、変数と同様の方法で分類することができます。

クラスにはパラメータを定義することができ、その際、パラメータは複合型（クラ
ス）に含まれる 1 つの要素として表現されます。クラスは複数回インスタンス化で
きるので、そこに定義されたパラメータも複数回存在することができます。しかし
原則として、パラメータは読み取り専用メモリ内に存在し、起動時に専用メソッド

（コンストラクタなど）により初期化されることはありません。値の初期設定は実行
に先立って（設計時などに）行われ、その際に設定されたパラメータ値のセットを

「データセット」と呼びます。設計時にパラメータ値を挙動クラスのインスタンスに
割り当てる場合、データセットを特定のインスタンスに関連付けて設定する必要が
ありますが、ASCET では、クラス設計時に仮インスタンス用のデータセットを定義
しておき、特定のインスタンスへのデータセットの関連付けは、各インスタンスの
作成時に行います。

モジュール内でのクラスの使用

上述のように、制御アルゴリズムの順次実行はトップレベルクラスのメソッドを呼
び出すことから始まります。この「メソッド呼び出し」はプロセスの実行により開
始されます。一般に、メソッドの引数はプロセスの受信メッセージにより供給され、
メソッドの戻り値は送信メッセージに供給されます（さらにこれらのメソッドにもモ
ジュールの内部変数から値が供給される場合があります）。

リアルタイム処理の観点から見ると、トップレベルクラスのメソッドを呼び出すプ
ロセスは、カプセル化されたインスタンスに属するメソッドの「呼び出しスタック」
を形成します。「リーブインスタンス」（“leave instance”）のメソッドも、そのプロ
セスがマッピングされているタスクのコンテキストで実行されます。メソッドの呼
び出しスタックを深くするとイベントの反応性が低下してしまうため、クラスを設
計してリアルタイムコンポーネントに組み込む際には、オブジェクト指向の再利用
性とタスクスケジュールの反応性のバランスを調整する必要があります。

プラントモデリングのための連続系ブロック

ASCET には連続系モデルのための専用ブロックが用意されています。これらの「連
続系ブロック」（CT ブロック）には以下の 2 種類があります。

• エレメンタリブロックをグループ化した「構造ブロック」

• エレメンタリシステムのダイナミクスを定義した「基本ブロック」

基本ブロックは下に示す標準形の非線形システムを想定し、動的挙動をオブジェク
ト指向形式で定義したものです。

メソッドには、初期化メソッドと終了メソッド、f を実現するための入力／更新／デ
リバティブメソッド、さらに g を実現するための直接的／間接的な出力メソッドと
間接出力メソッドがあります。さらに、状態イベント検知メソッドや、状態イベン
ト発生時に実行する処理を記述するイベントメソッドもあります。それ以外にも重
要なものとして、従属パラメータを解決するためのメソッドがあります。式は ESDL
と C のどちらの構文でも記述できます。

1. 「アダプティブパラメータ」についてはここでは考慮しません。

),(
),(

uxgy
uxfx

=
=
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閉ループシミュレーション用プロジェクト

ECU ソフトウェアは、相互通信を行う一連のモジュールとオペレーティングシステ
ムとで構成されます。オペレーティングシステムの「コンフィギュレーション」に
タスクとそのスケジュールを定義し、オペレーティングシステム自体はタスクと
メッセージを実現します。「タスクスケジュール」にはプロセスのタスクへの割り当
て情報が含まれます。PC で閉ループシミュレーションを実行する場合は、制御アル
ゴリズムのリアルタイムコンポーネントに CT ブロック（19 ページの「プラントモ
デリングのための連続系ブロック」という項を参照してください。）がアタッチされ
ます。リアルタイムコンポーネントと CT ブロックのメッセージ間のバインディング
は、「名前」によるものではなく明示的に、つまりポートをグラフィカルに接続する
ことにより行われます。CT ブロックのメソッドは数値的な積分アルゴリズムから呼
び出されます。積分アルゴリズムは、最終的なオペレーティングシステムコンフィ
ギュレーション内の独立したタスクとして実行されます。

プロセスがタスクに割り当てられて適切な CT ブロックタスクの作成が終わると、

OS コンフィギュレーションが実行形式のコードに変換されます。PC 上での閉ルー
プシミュレーションの場合、適切なイベントキューと数値ソルバを備えたシミュ
レーション環境が生成されます。ただしこのシミュレーション環境は「リアルタイ
ム実行環境」ではありません。

3.1.2 ラピッドプロトタイピング

一般的に、設計時に使用されるプラントモデルは、設計工程全体にわたって一環し
て参照できるほど詳細には定義されていないため、モデルではなく実車を使用して
の制御アルゴリズムの検証は欠かせません。この検証工程において、制御アルゴリ
ズムは初めて「リアルタイム」で実行されることになります。ソフトウェアコン
ポーネントのエントリ（実行開始）ポイントはオペレーティングシステムタスク内
にマッピングされますが、それ以外に、ハードウェアアクセス専用のソフトウェア
コンポーネントを作成して制御アルゴリズムのソフトウェアコンポーネントに接続
する必要があります。この工程は、図 3-1（16 ページ）では、実際の環境でドライ
バーが運転する自動車と論理システムアーキテクチャの結び付け（図の矢印 2）と
して表されていて、ここではさまざまな方法が考えられます。1 つめは、自動車と
のインターフェース専用の I/O ボードを備えた専用の「ラピッドプロトタイピング
システム」を使用する方法です。ラピッドプロトタイピングシステム（「RP システ
ム」とも呼ばれます）は高性能のプロセッサボードと I/O ボードとで構成され、各
ボード間は内部バスシステム（VME など）により接続されています。一般に、これ
らのプロセッサボードは製品用 ECU とは異なり、浮動小数点演算ユニットを備え、

ROM や RAM の容量も大きく、高性能なものです。バス接続された I/O ボードを介
してセンサやアクチュエータとインターフェースを取るので、さまざまなユース
ケースに柔軟に対応できます。この工程においては、「ECU の生産コスト」よりも

「制御アルゴリズムのラピッドプロトタイピング」に重点が置かれます。

上記のようなラピッドプロトタイピングシステムにおいては、インターフェース要
件は、多くの場合、ボード上の専用回路で実現されます。しかしこれには柔軟性に
限界があるため、代わりに従来の ECU とそのマイクロコントローラペリフェラル、
およびその他の ECU エレクトロニクスを使用してセンサ／アクチュエータとのイン
ターフェースを実現するという方法も考えられます。それにより、I/O ハードウェア
抽象化レイヤのソフトウェアコンポーネントを後のシリーズ生産で再利用できると
いう副次的効果が得られます。図 3-2 は制御／監視ファンクションがバイパスシス
テム上で稼働し、そのバイパスシステムがセンサとアクチュエータを介して自動車
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に接続されているようすを示しています。

図 3-2 典型的なラピッドプロトタイピングシステム

図 3-2 に示すようなバイパス構成におけるラピッドプロトタイピングでは、ECU の
マイクロコントローラのペリフェラルを使用してセンサとアクチュエータを駆動し
ます。つまり、I/O ドライバは製品用 ECU 上で稼働し、制御アルゴリズムはラピッ
ドプロトタイピングハードウェア上で実行されます。3 つの信号 W、R、U はデジタ
ル値で、それぞれセットポイント、プラントの反応をサンプリングした値、デジタ
ルアクチュエータ信号を表します。アクチュエータ信号は、ドライバーの希望 W*
に合った状態で車両を動作させるための電気的または機械的信号 Y に変換されます。

W はサンプリングされたデジタル信号です。機械的または電気的信号 X で表される
車両の状態がサンプリングされ、デジタル信号 R として制御アルゴリズムに供給さ
れます。さらに、道路条件などのノイズ信号 Z が存在し、これは測定される入力信
号とは異なり、制御アルゴリズム内で直接考慮されるものではありませんが、車両
の挙動に影響を与えます。RP システムは、プロセッサボードと専用の通信ボードの
みを使用し、その他の車両信号を直接使用することはありません。センサ値 R、
セットポイント値 W、アクチュエータ値 U はハイスピードリンクで送信されます
が、一般的な ECU ハードウェアにはハイスピード通信リンクに対応する専用回路
が装備されています。

ソフトウェア開発の観点から見ると、製品 ECU 上で稼働する既存のソフトウェア
と、新たに開発された制御アルゴリズムにおける「構造化されたインターフェース」
により、ラピッドプロトタイピングの効率は大幅に向上します。

リアルタイム I/O モジュール

「ラピッドプロトタイピング実験」には、高性能マイクロプロセッサに加えて通信と

I/O のための専用のハードウェアが必要です。ETAS の ES1000 ファミリの場合、さ
まざまな機能を実現するための VME ボードを使用でき、システム内通信は VME バ
スにより行われます。

このようなラピッドプロトタイピングシステムは、構成を柔軟に変更できる「組み
込みシステム」であるといえます。通信と I/O ハードウェアの機能を実現するには
ハードウェアと制御アルゴリズムを結びつける「基本ソフトウェアモジュール」が
必要ですが、ASCET においては、これらすべての基本ソフトモジュールは「リアル
タイム I/O」と呼ばれる 1 つの ASCET モジュールで表現されます。たとえば、CAN
バッファから信号を読み込んでそれを送信メッセージとして提供するプロセスがあ

車両

ドライバー 環境

セットポイント アクチュエータ
制御対象

センサ
システムジェネレータ

コントローラ

／モニタ

ECU 実験システム
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る場合、このプロセスはオペレーティングシステムタスクの中で「スケジュール」
されますが、その際に使用する信号名と CAN フレーム ID を事前に専用エディタで
設定しておくことができます。

制御アルゴリズムを ETAS ラピッドプロトタイピングシステム上でテストする際は、
コンフィギュレーションパラメータに基づいてこの「リアルタイム I/O モジュール」
を生成する必要があります。このモジュールは汎用的な ASCET の C モジュールとし
て表現されるのので、これが他のリアルタイムコンポーネント、つまり、一般的な

ASCET モジュールにアタッチされることにより、実行可能なラピッドプロトタイピ
ング制御アルゴリズムができあがります。

ラピッドプロトタイピング用のプロジェクト

ラピッドプロトタイピング用のプロジェクトには連続系ブロックで表現されるプラ
ントモデルは内包されません。その代わりにリアルタイム I/O モジュールが内包さ
れ、ラピッドプロトタイピングプロジェクト用に設定されます。このモジュールは、
モデルレベルにおいてはメッセージにより制御アルゴリズムモジュールと通信を行
います。そのため、リアルタイム I/O モジュールのコンフィギュレーションに応じ
た複数のプロセスがオペレーティングシステムタスクにフックされます。

3.1.3 制御アルゴリズムの実装と ECU への統合

ラピッドプロトタイピングの工程を経た制御アルゴリズムは、実車 に対しても有効
なものとなります。ただしラピッドプロトタイピングシステム用に生成されたコー
ドは、RAM リソースや浮動小数点ユニットなど、専用プロセッサボードの強力な機
能を使用することを前提としています。それをメモリ容量や演算能力が限られた条
件下で実行できる制御アルゴリズムにするためには、制御アルゴリズムのモデルの
再設計が必要となります。たとえば、計算式を浮動小数点から固定小数点の制御ア
ルゴリズムに変換し、効率、スケーラビリティ、モジュール性といったさまざまな
制限事項に対処する必要があります。このようにして再設計されたデザインを用い
て、適切な製品用コードが自動生成されます。

浮動小数点から固定小数点への変換

自動車などの「物理プラントモデル」においては、車速と加速度、冷却液温度、
ヨーレート、バッテリ電圧などの「物理量」が扱われますが、シミュレーションモ
デルにおいてこれらの物理量は 64 ビットまたは 32 ビットの float 型変数で表現さ
れます。シミュレーションモデルは閉ループ制御システムであるため、車両モデル
と制御アルゴリズムモデルはどちらも浮動小数点で表現される必要があります。し
かし、実際には浮動小数点ユニットは高価であるため、一般の車載マイクロコント
ローラには使用されません。つまり、制御アルゴリズムを車載マイクロコントロー
ラに実装するためには、浮動小数点から固定小数点への変換が必要となります。

例 : 冷却液温度の範囲を -50 ℃～ 150 ℃とします。これらの値を直接 16 ビット整
数に実装するのでは極めて非効率的です。これでは図 3-3(a) に示すように 16 ビッ
トで表現できる範囲の 0.3％しか使用されず、温度の分解能は 1 ビット =1 ℃となっ
てしまい、測定された温度が 83.4 ℃であっても制御ソフトウェア内では 83 ℃とし
て表現されてしまいます。

これを、図 3-3(b) に示すように測定値に 217.78 を掛けることにより、分解能を 1
ビット当たり約 0.0046 ℃に変えることができます。しかしこの変換は単なる「浮
動小数点の乗算」であるため、適切なものとはいえません。

別の方法として、分解能を 1 ビット当たり 0.0078125 ℃に設定する方法がありま
す。この乗算は 7 ビットの左シフト演算により表現できます。この演算を温度範囲
に当てはめると、-6400 から 19200 までのビットパターンが得られるので、16
ビット整数型の値の範囲の 39％が使用されることになります。このスケーリングを
図 3-3(c) に示します。
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またさらに、符号なし 16 ビット整数値を使用し、1 ビット当たり 0.00390625 ℃と
いう分解能に加えて「オフセット」を併用することにより、使用率をさらに高める
ことができます。オフセットを -12800 に設定した場合、温度範囲は -12800 ～

38400 となり、51200 個の値の範囲を使用できることになり、使用率は図 3-3(d) に
示すように 78％を超えます。ただしここではオフセット計算のための減算処理が必
要になります。

図 3-3 スケーリングなしのマッピング (a)、任意マッピング (b)、27 スケーリング

(c)、28 スケーリングとオフセット (d)

この関係は下の線形関係で表現できます。

Impl_value = f_impl(phys_value) = phys_value*256+12800

または、以下のように一般的な形で表現することもできます。

impl=scal * phys_value + x

上の式の scalがスケーリングファクタで、xがオフセットです。分解能はスケーリ
ングファクタの逆数になるので、物理値は以下の式の実装値で表されます。

phys_value = impl_value / scal - ofs

固定小数点数の演算

変数に実装変換式（“implmentation formula”）を定義すると、その変数を扱うメ
ソッドやプロセスのステートメント、つまり式や代入文に影響を与えます。以下の
ような、物理値を表す 2 つの変数を用いた単純な代入文でさえも、実装情報

（“implementation"）、つまり割り当てられた実装変換式が異なると、単純な演算で
はなくなってしまいます。

a = b

a と b を符号なし 8 ビット変数（値の範囲 : 0 ～ 255）として、それぞれに以下の実
装変換式を適用してみましょう。

a = 2 * a_impl, b = 3 * b_impl

すると、a の物理値の分解能は 2 になり、b の物理値の分解能は 3 になります。こ
の実装情報に基づいて代入 a=b を表すと、以下のようになります。

2* a_impl = 3* b_impl
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これを以下のように単純に移項してみます。

a_impl = (3 / 2)* b_impl

このように、元のステートメント a=bから、a_impl = (3/2) * b_implという
ステートメントが得られました。実装変換式1 は、定数を用いた単純な算術演算で
す。しかし、最大精度を実現するための一連の演算においては注意が必要です。も
し上の式のとおりに最初に除算を行ってしまうと、除算は整数で行われるため、結
果に約 50％の誤差が生じ、変換式が効果的でなくなってしまいます。この変換に
は、以下のようなステートメントの方が適しています。

a_impl = 3 * b_impl / 2

物理変数を扱うステートメントにおいて、このように調整された実装変換式を使用
する場合でも、一般的に、さらにいくつかの要素を考慮する必要があります。

まずは「オーバーフロー」の問題です。上の式において最初に 3 をかけると、

b_implが 255/3=85 より大きい場合はオーバーフローが発生します。同様に、ア
ンダーフローと丸め誤差についても注意が必要です。先に 2 で割ると、右シフト演
算が行われ、最小桁のビットが失われてしまいます。これでは b_implの値が 1 ま
たは 0 である場合には値の区別がなくなり、どちらの場合も a_impl（つまり a）
には 0 が代入されてしまいます。また事実上、a=bという代入は物理範囲が同じ

（ここでは 0 ～ 510）である場合に限り意味をなすことから、b_implには 510/
3=170 という最大値が想定されますが、これではオーバーフローが発生する可能性
があるため、それを回避しなければなりません。この対策として、コード生成時に
ケースごとに処理を選択するという方法が考えられます。つまり、b_implが 170
以下の場合は先に乗算を行い、b_implが 170 より大きい場合は先に除算を行うよ
うにするのです。しかし、そのためには余分なコードが必要になってしまいます。
そのためここでは、値の範囲全体において最大精度 1.5 の許容誤差を受け入れる、
ということが必要になってしまいます。一般的に、複雑な結合や式を用いる場合は
言うまでもなく、オペランドの少ない通常の算術演算の場合でもこれ以上に困難な
状況となる可能性は十分にあります。

C コードのクラスとモジュール

レガシーコードの再利用やマイクロコントローラのペリフェラルアクセスを行うよ
うな場合、内部挙動が C コードで記述されたメソッド（またはプロセス）を含むク
ラス（またはモジュール）を定義する必要が生じる場合があります。C コードクラ
スと C コードモジュールのコードには実装情報が含まれ、このコードをターゲット
用実行プログラムに順に組み込んでいきます。つまり C コードクラスと C コードモ
ジュールはターゲットに依存しているので、プロジェクトのターゲットを変更する
場合は、変更後のターゲットに合った C コードを作成しなおす必要があります。

組み込みマイクロコントローラ用プロジェクト

上述のように、C コードクラスと C コードモジュールはマイクロコントローラのペ
リフェラルにアクセスすることができます。ASCET プロジェクトエディタではオペ
レーティングシステムの設定と生成を行えるため、制御アルゴリズムを記述したモ
ジュールを含む組み込みマイクロコントローラ用プロジェクトを「統合プラット
フォーム」として使用することができます。この際、コードジェネレータは、OS ス
ケジュールやモジュール間メッセージ通信を調べてタスクやメッセージを生成し、
さらにプロセスからメッセージへのアクセスコード2 を生成します。こうしてでき上
がったプロジェクトとそのすべての内包モジュールの C コードは、マイクロコント
ローラに書き込むための .hexファイルに変換され、その際、すべての測定変数と
適合変数（パラメータ）が定義された ASAP2 ファイルも生成されます。

1. 少なくとも ASCET がサポートする変換式の場合
2. 一般的にはマクロで実現されます。
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ただし製品 ECU 用の生成時には専用のビルド環境と基本ソフトウェアモジュールが
使用される場合も多く、そのような場合は、アプリケーションソフトウェア、つま
り制御アルゴリズムのモデリングのみを ASCET1 で行います。この場合は、プロセ
スのアクセスコードを含むメッセージとタスクボディ、つまり OS エディタで定義
されたプロセスのシーケンスが生成されるので、このタスクボディを外部の OS コ
ンフィギュレーションエディタにコピーします。

3.1.4 各種プロジェクトにおける制御アルゴリズムの再利用

ASCET のモデリングエレメントはすべてデータベース内で管理されますが、同じ制
御アルゴリズムを使用するプロジェクトでも、ターゲットが異なればモジュールの
数や種類が異なります。

• 閉ループシミュレーション用プロジェクト : 制御アルゴリズム用のモジュール
と CT ブロックを参照します。

• ラピッドプロトタイピング用プロジェクト : 制御アルゴリズム用のモジュール
（閉ループシミュレーションの場合と同じモジュール）とリアルタイム I/O モ
ジュールを参照します。リアルタイム I/O モジュール用のコンフィギュレー
ションデータはプロジェクトに保存されます。

• 組み込みマイクロコントローラ用プロジェクト : 制御アルゴリズム用のモ
ジュールとペリフェラルアクセス用のモジュール（C コード）を参照します。
固定小数点コードが必要な場合、モジュール、クラス、プロジェクトに実装
変換式を定義する必要があります。またコードを生成する前に、プロジェク
トに適した実装情報を選択する必要があります。

ASCET プロジェクトは PC、ラピッドプロトタイピングシステム、プロダクション

ECU2 などさまざまなターゲット上で実行できますが、PC またはラピッドプロトタ
イピングシステム上で実行される際は、ASCET の統合実験環境（EE）を使用して実
験を行います。また ECU を使用した実験の場合は、実車で行う制御アルゴリズムの
適合作業（ファインチューニング） 3 と同様、測定／適合システム INCA4 を用いて
行います。

ソフトウェアの面から見ると、実験には以下の 4 種類のタイプがあります。

1. 物理実験

2. 量子化実験

3. 実装実験

4. オブジェクトベースのコントローラ実装実験

「物理実験」には実装情報は必要ありません。「量子化実験」には量子化が必要で、
「実装実験」と「オブジェクトベースの実装実験」にはさらに整数の基本型と限界値
についての情報が必要です。ASCET の制御アルゴリズムモデルを構成するステート
メントから生成されるコードは、ターゲットと実験のタイプに応じて異なります。

「物理実験」においては、物理ステートメントが real64 の変数で表現されるので、
量子化の影響はありません。「量子化実験」でも real64 の変数が基礎に使用されま
すが、物理ステートメントに量子化の影響が付加されます。「実装実験」では実装情
報が使用され、整数型がベースとなります。つまり実装実験用に生成されるコード
の変数には、実装情報として指定されている基本型が使用され、物理ステートメン
トは実装変換式に基づく実装ステートメントに変換されます。

1. このユースケースは「additional programmer」と呼ばれます。
2. または評価ボード
3. 実験用の ECU リソースには限りがあるので、特別な対応が必要になります。これにつ

いては本書では説明しません。
4. ASCET プロジェクトが CT ブロックだけを含み、そのプロジェクトが PC またはラピッ

ドプロトタイピングシステム上で実行される場合、LABCAR OPERATOR の EE を使用し
ます。
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「オブジェクトベースのコントローラ実装実験」では、実装実験の型と実装ステート
メントが使用されますが、モジュールとクラスの構造は別の形で表現されます。

ASCET 内の各変数には基本型、限界値、実装変換式だけでなく、マイクロコント
ローラのメモリレイアウトが反映された「メモリクラス」も定義できます。しかし
前述のように、オブジェクトベースのコントローラ実装実験は製品 ECU 用でしか行
えないうえ、オンライン実験は INCA などの測定／適合ツールでしか行えません。

PC またはラピッドプロトタイピングターゲットを使用し、かつ基本型、限界値、オ
フセット、量子化に関するすべての実装情報がすべてのエレメントに定義されてい
る場合は、実験のタイプを切り替えるだけで、物理環境における実装変換式や整数
基本型の作用を観察することができます。

3.1.5 実験室における技術システムアーキテクチャのテスト

実装／統合工程の結果として、物理的システムアーキテクチャ、つまり「ECU ネッ
トワーク」ができあがります。これらの ECU のテストはプラントモデルを使用して
リアルタイムに行われます。プラントモデルは、センサ／アクチュエータのモデル
や専用ボードを使用することにより、本来は ECU の電装部品から取得される電気信
号をシミュレートできます。このようなシステムは Hardware-in-the-Loop システム

（HiL）と呼ばれ、プロセッサボードと I/O ボードとで構成されます。プラントモデル
には典型的な運転操作をシミュレートするさまざまな値が初期設定されていて、HiL
上で運転操作がシミュレートされることによって ECU に対するセンサデータが出力
され、さらに ECU からアクチュエータデータが入力されます。このようにして ECU
が正しく統合されたかどうかを調べることができます。HiL テストは図 3-1（16
ページ）の矢印 4 で示されている部分です。

3.1.6 実車における技術システムアーキテクチャのテストと仕上げ

前述のように、一般的なプラントモデルは車両のダイナミクスを完全に表せるほど
詳細化されていません。今日では適合作業の多くを HiL システムで行えますが、車
両の制御アルゴリズムの最終仕上げは実車の製品 ECU に組み込まれた製品ソフト
ウェアで行う必要があります。このためには、物理システムアーキテクチャを実車
に組み込み、性能試験場でテストを行う必要があります。この最終工程においては
制御アルゴリズムのパラメータ値の微調整のみを行います。
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3.2 生産環境における ASCET の利用

図 3-4 高度なソフトウェア生産環境

典型的な「ハンドコーディング環境」においては、複数のソフトウェア開発者に
よって、制御アルゴリズム用、およびオペレーティングシステムを含む基本ソフト
ウェアモジュール用の C コードが作成されます。さらに、「ECU インテグレータ」
の役割を持つ担当者がすべてのソースコードファイルを集め、コンパイラとリンカ
を起動する「Make ツールチェーン」を実行します。C コードはソフトウェア開発
者間でファイルシステムやソースコード管理（SCM）システム1 を介して受け渡さ
れます。「SCM」はさまざまなバージョンのソースコードファイルを保持しながらコ
ンフィギュレーションの作成と維持管理を行うことのできるデータベースです。こ
れは ECU ソフトウェアの生成／統合のベースラインとして使用されます。C コード
ファイルの 2 つのバージョン間の相違を調べる際は、「ディファレンスブラウザ」を
用いてプログラムテキスト内の相違点を強調表示させることができます。この 10 年
程の間に SCM システムとディファレンスブラウザは広く使用されるようになり、そ
れによって自動車組み込みソフトウェアの品質が大幅に向上しました。

高度なソフトウェア生産環境においては、一部の制御アルゴリズム用 C ファイルは
制御アルゴリズムモデル（実装情報が設定された ASCET モデルなど）から生成され
ますが、多くの基本ソフトウェアモジュール用 C ファイル（OS や COM スタックな
ど）はいわゆる「コンフィギュレータ」により生成されます。このような高度な生
産環境の例（ASAM-MCD-2MC ファイルの生成工程を除く）を図 3-4 on page 27
に示します。ここには C コード生成環境と、SCM データベースおよび Make システ
ムが示されています。このような高度な生産環境をさらに詳しく検討し、ASCET に
よる制御アルゴリズム用 C コードのモデルベース生成に注目すると、モデルは、
ソースコードの基礎となるものでありながら、一方では制御アルゴリズム開発の過

1. 一般的な SCM システムとして、CVS や SubVersion があります。
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程でラピッドプロトタイピングの結果を反映して進化していくものであることがわ
かります。したがって、モデルも SCM データベースで維持管理することが必要とな
ります。

ASCET コンポーネントはローカルデータベースに保存され、1 つのローカルデータ
ベースにはモデルの 1 つのバージョンだけが保存されますが、「ASCET-SCM イン
ターフェース」はローカルデータベースから SCM レポジトリ（= 貯蔵庫）へのリン
クを確立し、バージョン間のモデルの交換を可能にします。このモデル交換は図 3-5 
on page 28 の (a) に示されています。ソースコード開発ではバージョン間のディファ
レンスブラウジングが不可欠ですが、モデルベース開発においてもそれは同じです。

ASCET-SCM インターフェースを「Model-Diff-Browser」で強化すれば、たとえばモ
ジュールのブロックダイアグラムエディタ内に追加されたメッセージなどが強調表
示されるようにすることができます。

3.2.1 モデル変換

組み込みリアルタイムソフトウェアの開発は制御エンジニアとコンピュータエンジ
ニアの両者により進められます。開発工程においては、制御ソフトウェアの開発を

「挙動ドリブン」の観点から始める場合と、「構造ドリブン」の観点から始める場合
があり、さらには両方の観点から始める場合もあります。ASCET（および

AUTOSAR）の垂直アプローチにはこの両方のアプローチが統合されていますが、純
粋に挙動的または構造的なアプローチによるモデルを使用する必要がある場合も考
えられます。

「挙動的」な方法をとる場合、閉ループ制御アルゴリズムのモデリングには 
MATLAB?/Simulink? を使用するのが一般的です。それは、少なくとも PC シミュレー
ションを行う際に問題となる多くの構造体関連の詳細事項に煩わされることがない
ためです。そして PC シミュレーションを実行した後は、制御アルゴリズム部はブ
ロックダイアグラムの形式で ASCET のモジュールまたはクラスに引き継がれ、プラ
ント部は ASCET CT ブロックとして表現されます。

図 3-5 ASCET-SCM インターフェース。ディファレンスブラウジング機能がある
場合（b）とない場合（a）

「構造的」な方法をとる場合は、UML の 1.4 または 2.0 が一般的に広く使用されて
います。非常にシンプルなクラスとオブジェクトのダイアグラムに加えて、インタ
ラクションおよびコラボレーションのダイアグラムを使用して車両アクセスシステ
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ムや診断などの複雑なインタラクションを表記できます。ただしクラス、オブジェ
クト、およびそれらのインタラクションについては、ASCET モデルの中で改良され
ています。ASCET では、シーケンスコールによって、UML に相当するもの（つまり
クラスとオブジェクト）にオブジェクトインタラクションが反映されます。これら
のオブジェクトを ASCET リアルタイムオブジェクトの中に組み込めば、UML モデ
ルにリアルタイム的側面が加わるだけでなく、モデルをそのまま実行することが可
能になります。

ETAS のパートナーである Aquintos 社のモデルツーモデルコンバータ（M2M）を使
用すると、このような挙動的モデルや構造的モデルを ASCET 用に変換することがで
きます。このコンバータは UML 1.4 製品および MATLAB/Simulink に対応していま
す。

3.3 まとめ

ASCET は自動車組み込みソフトウェア開発のさまざまな段階において、制御アルゴ
リズムのモデルベース設計および実装をサポートします。抽象化の採用により、物
理的な制御アルゴリズムモデルを後続の開発工程全体におけるすべての実装情報の
基盤として使用でき、ターゲットを変更する際にブロックの交換などを行う必要が
ありません。さらにディファレンスブラウジング機能付きの SCM インターフェース
を使用すれば、ECU 生産開発環境への ASCET の統合をさらにシームレスに実現でき
ます。
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4 チュートリアル

このチュートリアルは、主に、ASCET を初めて使うユーザーを対象として、実際の
モデル記述作業を例に ASCET の基本的な使い方を説明するものです。チュートリア
ルは、互いに関連しあうコンポーネントを扱う複数のレッスンに分かれています。
なお、チュートリアルを始める前に、あらかじめ「ASCET による自動車用組み込み
制御ソフトウェアの開発」（15 ページ）を読んで ASCET の基本概念を理解しておい
てください。

4.1 単純なブロックダイアグラムを作成する

ASCET では、アプリケーションを構成するメインブロックとしてクラスやモジュー
ル等のコンポーネントを使用します。製品に含まれている既成のコンポーネントを
使ったり、独自のコンポーネントを新たに作成することもできます。

ASCET では、コンポーネントは、通常グラフィックを使用して記述します。すべて
のコンポーネントの定義が終わったらそれらを組み合わせ、ASCET ソフトウェアシ
ステムの基礎となるプロジェクトを構築します。最終的なソフトウェアシステムは、
グラフィカルなモデル記述から生成された C コードで構成され、マイクロコント
ローラや実験ターゲットコンピュータ上で実行することができます。

4.1.1 準備

最初に、まずチュートリアルのデータベースまたはワークスペースを開きます。こ
のチュートリアルで作業するコンポーネントはすべてこのデータベース／ワークス
ペースに格納されるので、すべての作業はこのデータベースを開いた状態で行いま
す。

このチュートリアルで作成するコンポーネントとプロジェクトは、データベース

Tutorial1 a 内の ETAS_Tutorial_Solutionsというフォルダ内にあらかじ
め格納されているので、ここで説明するコンポーネントをすべてユーザーが作成す
る必要はありません。

ただし、少なくともレッスン 1、3、および 4 のコンポーネントだけは、練習のため
にご自分で作成することをお勧めします。

ASCET を起動すると、コンポーネントマネージャが開き、前回のセッションで開い
ていたデータベース／ワークスペースがロードされます。初めて ASCET を起動した
場合は Tutorial1a データベースが開きます。

作業内容を明確にするため、ここで Tutorial用に新しいデータベース／ワークス
ペースを作成するか、または ASCET に含まれている Tutorial1a データベースを
使用することをお奨めします。

1. 以下の場所に格納されています。

a) ASCET のインストールディレクトリ下のデータベースディレクトリ（例 : 
C:¥ETASData¥ASCET6.1¥database¥Tutorial）
b) ASCET のインストールディレクトリ下のエクスポートディレクトリ（例： 
C:¥ETAS¥ASCET6.1¥export）内のエクスポートファイル Tutorial.expおよび

Tutorial.axlに収められています。ファイルのインポートの方法は 93 ページを参
照してください。
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新しいデータベースを作成する：

• コンポーネントマネージャから、File → New 
Database を選択します。

“New database” ダイアログボックスが開きます。

• Tutorialという名前を入力します。

• OK をクリックします。

新しいデータベースが作成されます。この時点ではデー

タベース名しか含まれていません。

Tutorialデータベースすでに存在している場合は、以下のようにしてそのデータベー
スを開きます。

データベースを開く：

• コンポーネントマネージャから、File → Open を選択
します。

または

• Open ボタンをクリックします。

または
チュートリアル



• <Ctrl> + <O> を押します。

“Select database or workspace” ダイアログボックス
が開き、現在のデータベースパスと、そのパスに存在
するデータベースの一覧が表示されます。

• Tutorialというデータベースを選択して OK をク
リックします。

コンポーネントマネージャに Tutorialデータベー
スの内容が表示されます。

新しいコンポーネントを作成するために、まず Tutorialという名前の新しいトッ
プレベルのフォルダと LessonNという各レッスン用のサブフォルダを作成します。

新しいトップレベルフォルダを作成する：

• “1 Database” ペインでデータベース名を選択します。

• メニューアイテム Insert → Folder を選択します。

または

• Insert Folder ボタンをクリックします。

または

• <Insert> を押します。

“1 Database” ペインに Rootという名前の新しい
トップレベルのフォルダが表示され、フォルダ名が強
調表示された状態となっています。

• Tutorialというファイル名を入力し、 <Enter> を
押します。

• フォルダ Tutorialを選択します。

• もう一度 Insert → Folder を選択します。

“1 Database” ペインに Folderという名前の新しい
フォルダが表示されます。

• 新しいフォルダの名前を Lesson1に変更します。

このチュートリアルで作成するコンポーネントはすべて、いずれかの LessonN
フォルダに格納します。各レッスンごとに新しいフォルダを作成してください。

注記

すべてのフォルダ名やアイテム名、およびそれらの中の変数やメソッドの名前は、

ANSI C 標準に準拠している必要があります。
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次に、最初のコンポーネントを Lesson1フォルダに作成します。

コンポーネントを作成する：

• “1 Database” ペインのフォルダ Lesson1をクリッ
クします。

• Insert → Class → Block Diagram を選択します。

“1 Database” ペインの Lesson1フォルダの下に、

Class_Blockdiagramという新しいコンポーネン
トが表示されます。このコンポーネントは class タイ
プです。class タイプは ASCET で頻繁に使用されま
す。

• このコンポーネントの名前を Additionに変更しま
す。

4.1.2 クラスを定義する

Tutorial/Lesson1フォルダに新しいコンポーネントを作成したので、次にその
機能を定義します。まず最初にコンポーネントのインターフェース、つまり、メ
ソッド、引数、および戻り値を定義し、次にそのコンポーネントの機能を定義する
ブロックダイアグラムを作成します。

コンポーネントの機能を定義する：

• “1 Database” ペインでコンポーネント Additionを
選択します。

• メニューアイテム Edit → Open Component を選択
します。

ブロックダイアグラムエディタが開きます。これは、
コンポーネントの機能を定義するためのメインウィン
ドウです。

“Outline” タブを含む

“Tree” ペイン

描画エリア

パレット
チュートリアル



• “Outline” タブに表示されているメソッド calcを選
択します。このメソッドは、デフォルトメソッドとし
て自動的に作成されたものです。

• Edit → Rename を選択します。

メソッド名 calcが強調表示されます。

• このメソッドの名前を DoAdditionに変更します。

• メソッド名をダブルクリックします。

このメソッドのシグネチャエディタが開きます。

クラスには、少なくとも 1 つのメソッドを定義する必要があります。ASCET におけ
るメソッドは、オブジェクト指向プログラミング言語で用いられる「メソッド」や、
手続き型プログラミング言語で用いられる「関数」に似ています。メソッドは任意
の数の引数を入力し、1 つの戻り値を出力することができます（これらはすべて任
意指定です）。引数は、コンポーネントにデータを渡すために使用され、戻り値はコ
ンポーネント内で行われた計算の結果を「外側」に返すために使用されます。

これらの「メソッドシグネチャ」は、シグネチャエディタを使用して定義します。
ここでは以下のようにして continuous型の引数を 2 つと戻り値を 1 つ定義しま
す。

メソッドシグネチャを定義する：

• シグネチャエディタで Argument → Add を選択しま
す。

“Arguments” ペインに、argという新しい引数が表
示されます。

• この引数の名前を input1にします。

• もう 1 つの引数を作成し、input2という名前を付け
ます。

デフォルトでは引数の型は continuous（または略し
て cont ）になっています。ここでは、この型のまま
使用します。

• シグネチャエディタの "Return" タブを選択します。

• Return Value オプションをオンにします。

戻り値の型も、デフォルトで cont になります。
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• OK をクリックして、シグネチャエディタを閉じま
す。

メソッド DoAdditionの引数と戻り値の名前が、ブロックダイアグラムエディタ
左側の “Outline” タブ内のメソッドの下に表示されます。これで、ブロックダイア
グラムを作成してこのコンポーネントの機能を定義する準備が整いました。

コンポーネント Addition の機能を定義する：

• “Outline” タブの第 1 引数をドラッグして、ブロック
ダイアグラムエディタの描画エリアにドロップしま
す。

この引数のシンボルが、描画エリアに表示されます。

• もう 1 つの引数と戻り値を描画エリアに追加します。

• “Basic Blocks” パレット内の Addition ボタンをク
リックします。

マウスカーソルに加算演算子がロードされました。

• 描画エリア内の、引数のシンボルと戻り値のシンボル
の間をクリックします。

加算シンボルが挿入されます。デフォルトでは、これ
には 2 つの入力ピン（矢印で示されます）と、1 つの
出力ピンが付いています。出力ピンは右側に付きま
す。

エレメントと演算子は、描画エリアの任意の位置にドラッグして配置することがで
きます。

次に、エレメント同士を接続して、情報の流れを定義します。

ダイアグラムエレメントを接続する：

• “General” ツールバー内の Connect ボタンをクリッ
クします。
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• または、描画エリア内の、エレメントが配置されてい
ない部分を右クリックします。

カーソルは、描画エリア内で十字カーソルに変わりま
す。

• 第 1 引数を表すシンボルの出力ピンをクリックして、
接続を開始します。

マウスカーソルを動かすと、それに従って線が引かれ
ます。描画エリア内でクリックするたびに、その時点
で引かれていた線が固定されます。このようにして、
接続線の道筋を確定していきます。

• 加算シンボルの左側にある入力をクリックします。

これで、第 1 引数のシンボルが加算シンボルの入力に
接続されます。

• 第 2 引数のシンボルを、加算シンボルのもう 1 つの入
力に接続します。

• 戻り値のシンボルを、加算シンボルの出力に接続しま
す。

加算演算子と戻り値との接続が、緑色の線で表示され
ます。緑色の線は、この演算のシーケンスがまだ決定
されていないときうことを表わしています。

• 空のシーケンスコール /0/DoAdditionをダブルク
リックして、加算のシーケンスを自動的に決定しま
す。

加算演算子と戻り値の間の接続が黒色の線で表示され
ます。

これで、最初のコンポーネントの定義、つまり機能記述は完了です。

最後に、コンポーネントのレイアウト、つまり、このコンポーネントが他のコン
ポーネント内で使用される際にどのように表示されるようにするかを定義します。

レイアウトの編集方法は 2 通りあります。
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コンポーネントのレイアウトを編集する：

• ウィンドウ右端の “Browse” タブをクリックして

“Browse” ビューに切り替えます。

• “Layout” タブを選択し、レイアウトが表示されたエ
リアをダブルクリックしてレイアウトエディタを開き
ます。

• または Edit → Component → Layout を選択しま
す。

レイアウトエディタ（“Layout Editor” ダイアログ）
が開きます。

• ブロックをクリックするとそのブロックのハンドルが
表示されるので、そのハンドルをドラッグしてブロッ
クを任意のサイズに変更します。
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• 引数と戻り値のピンをドラッグして、配置を調整しま
す。

• OK をクリックします。

これで、コンポーネントは完成しました。このレッスンの最後の作業として、コン
ポーネントをデータベースに保存します。

コンポーネント Additionを保存する：

• File → Save を選択します。

• File → Close を選択してブロックダイアグラムエディ
タを閉じます。

ブロックダイアグラムエディタ内で Save を選択する
と、変更部分がキャッシュメモリに格納され、ディス
クへの保存は行われません。作業中はコンポーネント
マネージャの Save ボタンで定期的に保存を行うこと
をお勧めします。

• コンポーネントマネージャで Save ボタンをクリック
します。

作業内容は、この操作をするまではディスクに書き込
まれません。

ユーザーオプションを設定して、変更内容が自動的に
保存されるようにすることもできます（オンラインヘ
ルプを参照してください）。

ここで、練習のため、同じ機能を ESDL（Embedded Software Description 
Language）でモデリングしてみましょう。これにより ESDL エディタや外部ソース
コードエディタの使用法を習得することができます。

まず初めに、モジュールインターフェースを ESDL タイプの新しいモジュールにコ
ピーしてから、そのモジュールの名前を変更します。それから、そのモジュールで
実現したい機能を、ASCET の ESDL エディタ、または外部テキストエディタを使用
して記述します。

コンポーネント Additionをコピーして定義する：

• コンポーネントマネージャの “1 Database” ペインで
コンポーネント Additionを選択します。

• ショートカットメニューから Edit → Reproduce As 
→ ESDL を選択します。

コンポーネントのコピーが作成され、Addition1と
いう名前が自動的に付けられます。

• 新しいコンポーネントの名前を AdditionESDLに
変更します。
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• “1 Database” ペインで、新しいコンポーネントの名
前をダブルクリックします。

AdditionESDL用のエディタが開きます。このエ
ディタにもさまざまな編集機能が備わっています。

• 内部テキストエディタの “Edit” ペインに、以下のよ
うな機能を入力します。

return input1 + input2;

• 今度は Activate External Editor ボタンをクリック
して、外部エディタモードに切り替えます。

変更内容を保存するかどうか、尋ねられます。

• Yes をクリックして確定します。

変更内容が保存され、ESDL エディタは外部エディタ
モードに切り替わります。

外部エディタモードに切り替わると、以下のような画
面になります。

“Edit” ペイン

（内部テキストエディタ）

パレット

プロセス／メソッドの
ペイン

プロセスやメソッドの
記述内容が表示されるペイン
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• プロセス／メソッドのペインから、定義したいメソッ
ドまたはプロセスを選択します。

すでに入力されている機能が定義フィールドに表示さ
れ、Start Edit ボタンが有効になります。

• Start Edit をクリックして外部エディタを起動しま
す。

• 外部エディタで機能を記述します。

• 記述した機能を保存します。

編集内容が ESDL エディタに転送されます。

外部エディタを閉じなくても ASCET での作業を続行
できます。

• 再度 Activate External Editor をクリックして、外
部エディタモードを終了します。

メッセージウィンドウが開くので、その内容をよく読
んでください。

• OK をクリックして処理を続行します。

• Build → Analyze Diagram を選択して、入力した
コードを検証します。

エラーがあった場合は、ASCET モニタウィンドウに
表示されます。

4.1.3 まとめ

このレッスンでは、ASCET で以下の作業を行いました。

• データベースを開く

• フォルダを作成して名前を付ける

• コンポーネントを作成して名前を付ける

• メソッドのインターフェースを定義する

• 描画エリアにダイアグラムエレメントを配置する

• ダイアグラムエレメントを接続する

• コンポーネントのレイアウトを編集する

• 機能記述用のビュー（“Specification” ビュー）とブラウザビュー（“Browse”
ビュー）とを切り替える

• コンポーネントを保存する

• コンポーネントのインターフェースをコピーする

• ESDL エディタを使用する

• 外部エディタを使用する

注記

外部エディタが起動されると、Windows に登録されている、*.cと *.hという
ファイルに割り当てられたアプリケーションが呼び出されます。この外部エディ
タと ASCET 間のデータ転送は一時ファイルを介して行われるので、外部エディタ
を閉じる前や ESDL エディタにデータを転送する前には、ファイルが保存されて
いることを確認してください。
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4.2 コンポーネントの実験を行う

Addition および AdditionESDL というコンポーネントができあがったので、
それを用いて実験を行います。実験環境では、コンポーネントがどのように機能す
るかを、シミュレーションによって運用時と同様に見ることができます。実験環境
には各種ツールが用意されていて、コンポーネント内の入力、出力、パラメータ

（適合変数）、および変数（測定変数）の値をモニタすることが可能です。

4.2.1 実験環境（Experiment Environment）を起動する

実験環境を、ブロックダイアグラムエディタまたは ESDL エディタから起動します。
起動するには、実験したいコンポーネントを指定して実験環境を開きます。

実験環境を起動する：

• ASCET コンポーネントマネージャから、Tutorial/
Lesson1フォルダに入っている Additionのブ
ロックダイアグラムを開きます。

• ブロックダイアグラムエディタで Build → 
Experiment を選択します。

実験用のコード生成が行われます。ASCET はユー
ザーが定義したモデルを分析し、そのモデルで記述さ
れている機能を実現する C コードを生成します。さま
ざまなプラットフォーム用のコードを生成することが
できます。

このレッスンでは、デフォルト設定を使用して PC 用
のコードを生成します。

コードの生成とコンパイルが終わると、実験環境が開
きます。

4.2.2 実験をセットアップする

実際に実験を開始する前に、環境の設定が必要です。つまり、実験用に生成する入
力値を指定し、さらに実験結果をどのように表示するかを指定します。このために、
イベントジェネレータ、データジェネレータ、そして最後に測定システムを順に
セットアップしていきます。
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イベントジェネレータをセットアップする：

• Open Event Generator ボタンをクリックします。

“Event Generator” ウィンドウが開きます。シミュ
レートする各メソッドごとにイベントを 1 つ作成する
必要があり、さらに generateDataイベントも必
要です。実際の運用時にはオペレーティングシステム
が行うスケジューリングが、これらのイベントによっ
てシミュレートされます。

• DoAdditionイベントを選択します。

• Channels → Enable を選択します。

• もう一度、イベント DoAdditionを選択します。

• Channels → Edit を選択します。

“Event” ダイアログボックスが開きます。

• dTの値を 0.001にします。

• OK をクリックします。

• イベントジェネレータ内で generateDataイベント
を選択し、その dT値を 0.001にします。

• “Event Generator” ウィンドウを閉じます。
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データジェネレータをセットアップする：

• Open Data Generator ボタンをクリックします。

“Data Generator” ウィンドウが開きます。

• Channels → Create を選択します。

“Create Data Generator Channel” ダイアログボック
スが開きます。

• エレメントの一覧から、input1/DoAddition お
よび input2/DoAdditionという変数を選択しま
す。

• OK をクリックします。

2 つの変数が “Data Generator” ウィンドウの “Data 
Elements” ペインにリストアップされます。

• “Data Elements” ペインの input1/DoAddition を
選択します。

• Channels → Edit を選択します。

“Stimulus” ダイアログボックスが開きます。
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• 以下の値を設定します。

• OK をクリックして “Stimulus” ダイアログボックス
を閉じます。

• 同様にして input2の値を以下のように設定します。

• “Data Generator” ウィンドウを閉じます。

上記のように設定すると、周波数と振幅が異なる 2 つの正弦波が得られます。

Additionコンポーネントはこの 2 つの正弦波を合成し、その結果として得られる
カーブを出力します。

これらのカーブをオシロスコープに表示して波形を確認できるようにするため、測
定システムをセットアップします。

測定システムをセットアップする：

• “Physical Experiment” ウィンドウの “Measure 
View” コンボボックスで、データ表示タイプとして

<2. New Oscilloscope>を選択します。

• “Outline” タブ内のエレメントリストを開きます。

• input1/DoAdditionを選択します。

Mode： sine

Frequency： 1.0Hz

Phase： 0.0s

Offset： 0.0

Amplitude： 1.0

Mode： sine

Frequency： 2.0Hz

Phase： 0.0s

Offset： 0.0

Amplitude： 2.0
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• Extras → Measure を選択します。

input1という測定チャンネルが割り当てられたオシ
ロスコープウィンドウが開きます。実験環境の

“Measure View” リストが更新され、そこにこの測定
ウィンドウのタイトルが追加されます。

• “Physical Experiment” ウィンドウの “Outline” タブ内の

input2/DoAdditionを選択します。

• Extras → Measure を選択します。

input2という測定チャンネルがオシロスコープに追
加されます。

• 同様にして return/DoAdditionを測定ウィンドウ
に追加します。

• 実験環境で、File → Save Environment を選択しま
す。

これで実験のセットアップが終わり、実験を開始することができるようになりまし
た。環境設定を保存したので、次回、このコンポーネント用の実験環境を起動する
と、同じ環境が再びロードされます。

4.2.3 実験環境を使用する

実験環境には、コンポーネント内の変数の値を表示したり、実験実行中にセット
アップ内容を変更するための機能が用意されています。また、値の表示方法を選択
したり調整することもできます。

実験を開始する：

• “Physical Experiment” ウィンドウの Start Offline 
Experiment ボタンをクリックして実験を開始しま
す。

シミュレーションが実行され、その結果がオシロス
コープに表示されます。

• Stop Offline Experiment ボタンをクリックして、
実験を停止します。
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この時点では、オシロスコープには、カーブのごく一部しか表示されていません。
オシロスコープにカーブの他の部分を表示するには、値軸（信号値を示す Y 座標軸）
のスケールを変更する必要があります。

オシロスコープのスケールを変更する：

• オシロスコープウィンドウの “Measure Channels” リ
ストから、3 つのチャンネルをすべて選択します。

複数のチャンネルを選択するには、<Ctrl> キーを押
し下げたまま個々のチャンネルをクリックします。

すべてのデータエレメントが強調表示され、これから
行う変更は 3 つのチャンネルすべてに反映されます。

• Extras → Setup を選択します。

“Display Setup” ダイアログボックスが開きます。

• “Value Axis” の範囲を -3 ～ 3 に変更します。

• “Time Axis Extent” を 3 にします。

• “Backgroud color” リストから背景色を選択します。

• <Enter> を押します。

これで、値が適切なスケーリングで表示されるようになりました。入力された 2 つ
の正弦波と、その 2 つを合成した出力波形が表示されます。入力値を調整して、出
力がどのように影響を受けるかを調べてみましょう。
チュートリアル 47



48
実験の入力値を変更する：

• “Physical Experiment” ウィンドウで Tools → Data 
Generator を選択して、“Data Generator” ウィンド
ウを開きます。

• データジェネレータ上で、変更したい変数を選択しま
す。

• Channels → Edit を選択します。

“Stimulus” ダイアログボックスが開きます。

• 値を適宜調整します。

• Apply をクリックします。

オシロスコープのカーブが、新しい設定に応じて変化します。実験の実行中に、す
べての設定を変更することができます。

4.2.4 まとめ

このレッスンでは、ASCET で以下の作業を行いました。

• 実験環境を呼び出す

• イベントジェネレータをセットアップする

• データジェネレータをセットアップする

• 測定システムをセットアップする

• 実験を開始し、停止する

• 実験の環境設定を保存する

• 実験実行中にスティミュレーションの内容を変更する

4.3 再利用可能なコンポーネントを定義する

このレッスンでは、マイクロコントローラソフトウェアでよく用いられる機能単位
である「積分器」のクラスを作成します。このダイアグラムはやや複雑ですが、こ
こまでに学習した方法で作成し、実験することができます。

この例では、与えられる時間と速度から走行距離を算出する積分器を定義します。
速度はメートル／秒の単位で与えられ、それを dT（秒）の周期で積算します。各周
期ごとに値がアキュムレータに累算され、アキュムレータの値は、所定の時間経過
後の走行距離（メートル）となります。

ASCET では、アキュムレータなどの標準ブロックは、シンプルに図示されます。

4.3.1 ダイアグラムを作成する

ダイアグラムを記述する前に、Additionコンポーネントの場合と同様の準備作業
が必要です。まず Tutorialフォルダ内に新しいフォルダを作成してから、新しい
クラスを追加します。これで、メソッドのインターフェース、さらにブロックダイ
アグラムとレイアウトを定義することができます。

まず、フォルダと新しいクラスを作成することから始めます。
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積分器のクラスを作成する：

• コンポーネントマネージャで、Tutorialフォルダ
を開きます。

• 新しいフォルダを作成し、その名前を Lesson3にし
ます。

• Lesson3フォルダ内に新しいクラスを作成し、 そ
の名前を Integratorにします。

積分器のインターフェースを定義する：

• “1 Database” ペインで、エレメント Integratorを
選択します。

• エレメントをダブルクリックするか、または Edit → 
Open Component を選択します。

ブロックダイアグラムエディタが開きます。

• メソッド calcの名前を integrateに変更しま
す。

• メソッド integrateを編集して、 引数 （cont
型） と戻り値 （cont型） を 1 つずつ追加しま
す。

• integrateの引数と戻り値を描画エリアに配置しま
す。

この積分器は、「変数」および「パラメータ」という 2 つのタイプのエレメントを使
用します。

「変数」は、プログラミング言語の変数と同じように用いられます。変数には値を格
納することができ、以降の計算ではその値を読みとることができます。これとは対
照的に、「パラメータ」は読みとり専用です。パラメータの値は、たとえば新しい実
験環境での適合作業によってなど、コンポーネントの外部でしか変更できず、コン
ポーネント内での計算で上書きすることはできません。なお ETAS の測定・適合ツー
ルでは、「変数」は「測定変数」、「パラメータ」は「適合変数」と呼ばれています。

さらにこの例では、「依存パラメータ 」を定義します。しかし、これは積分器の機能
とは無関係です。依存パラメータ は 1 つまたは複数のパラメータに依存するもの
で、その値は別のパラメータの値から算出されます。この計算は値が定義された時
や適合された時にだけ行われます。依存パラメータは、ターゲットコード内におい
ては通常のパラメータと全く同じように機能します。
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変数を作成する：

• “Elements” パレット内の Continuous Variables ボ
タンをクリックします。

プロパティエディタが開きます。

• “Name” フィールドに bufferという名前を入力し
ます。

• OK をクリックします。

変数の名前が bufferになりました。マウスカーソ
ルにこの continuous 型の変数がロードされ、カーソ
ルが十字カーソルに変わります。

• 描画エリア内をクリックして、変数を配置します。

変数が描画エリア内に配置され、“Outline” タブ内に
その変数の名前が反転表示の状態で追加されます。

上記の操作でプロパティエディタが自動的に開かない場合は、そのまま変数を描画
エリアに配置し、その後、“Outline” タブ内のその変数をダブルクリックしてプロ
パティエディタを開いてください。プロパティエディタの Always show dialog for 
new elements オプションをオンにしておけば、次回のエレメント作成時から、自動
的にプロパティエディタが開くようになります。

パラメータを作成する：

• Continuous Parameter ボタンをクリックします。

プロパティエディタが開きます。

• “Name” フィールドに Kiという名前を入力します。

• OK をクリックします。

• 描画エリア内をクリックして、パラメータを配置しま
す。
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• “Outline” タブでこのパラメータを右クリックし、
ショートカットメニューから Data を選択します。

データコンフィギュレーションウィンドウ（数値エ
ディタ）が開きます。

• 入力フィールドに 4.0と入力してから OK をクリッ
クします。

この値がパラメータのデフォルト値になります。ダイ
アグラム内のすべてのパラメータや変数について、こ
のようにしてデフォルト値を割り当てることができま
す。

依存パラメータを作成する：

• Continuous Parameter ボタンをクリックします。

プロパティエディタが開きます。

• “Name” フィールドに sqrt_Kiという名前を入力し
ます。

• “Attribute” フィールドの Dependent オプションを
選択します。

• Formula ボタンでフォーミュラエディタを開きます。

• “Formula” フィールドに xという名前を入力して仮
パラメータを作成します。

• “Formula” フィールドに変換規則を定義します。

“Operator” ／ “Function” コンボボックスで演算子と
関数を選択します。

• ここでは例として、仮パラメータの平方根を求める計
算を定義します。

Formal Parameter: x
Formula: sqrt(x)
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• OK でプロパティエディタを閉じます。

カーソルが十字カーソルに変わります。

• 描画エリア内をクリックして、パラメータを配置しま
す。

• ブロックダイアグラムエディタで、“Outline” タブの

sqrt_Kiを右クリックしてショートカットメニューを

開き、Data を選択します。

• “Edit Dependency” ウィンドウで、コンボボックス内
のモデルパラメータ（この例では Ki）を仮パラメー
タに割り当てます。

• OK をクリックして、データ入力を完了します。

これで、パラメータ Kiに依存し、適合時に Kiに基
づいて自動的に算出される依存パラメータが定義され
ました。後で実験を行う時に、この依存関係を確認す
ることができます。

すべてのエレメントを作成したので、次に積分器を定義します。ダイアグラムの残
りの部分を以下のようにして完成させてください。

ダイアグラムを作成する：

• “Basic Blocks” パレット内 “No. of arguments" コン
ボボックスの値を 3 にし、乗算演算子の入力の数を指
定します。

• 乗算演算子を作成し、描画エリアに配置します。
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• dT ボタンをクリックして dT エレメントを作成しま
す。

プロパティエディタが開きます。この演算子を作成す
る前に、“Argument Size” の値を 2に戻してくださ
い。

• dTエレメントを描画エリアに配置します。

• 2 つの入力を持つ加算演算子を作成し、描画エリアに
配置します。

この演算子を作成する前に、“Argument Size” の値を

2に戻してください。

• エレメントを下図のように接続します。

バッファと戻り値の入力を示す線は、緑色で表示され
ます。

ここまでで、ダイアグラムのすべてのエレメントの設定が終わりました。次に、
シーケンスコールを定義して、計算の順序を決定します。

シーケンスコールに値を割り当てる：

• 変数 bufferの上に表示されているシーケンスコール
を右クリックします。

• ショートカットメニューから Edit を選択します。

シーケンスエディタが開きます。

シーケンスコール
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• OK をクリックして、デフォルト設定を確定します。

この設定により、この代入処理は、積分器のアルゴリ
ズムの冒頭部分で行われます。

シーケンスコール内のシーケンス番号を調整する：

• integrateの戻り値の上に表示されているシーケン
スコールを右クリックします。

• ショートカットメニューから Edit を選択します。

• シーケンスエディタで、“Sequence Number” の値を

2 にします。

• OK をクリックします。

この設定により、変数 bufferが更新された後に戻
り値への代入が行われます。

レイアウトを調整する：

• Edit → Component → Layout を選択します。

レイアウトエディタが開きます。

• 引数を integrateからブロックの左側の中程にド
ラッグします。

• 戻り値をブロックの右側の中程にドラッグします。

• OK をクリックします。

これで、積分器クラスのダイアグラムは完成です。今度は File → Save を選択して、
ダイアグラムの変更内容を保存します。ダイアグラム自体に影響を与えない部分の
変更内容は、自動的に保存されます。次に、コンポーネントマネージャウィンドウ
で File → Save を選択して、変更内容をデータベースに保存します。

4.3.2 積分器の実験を行う

ここでも、初めにイベントジェネレータ、次にデータジェネレータ、最後に測定シ
ステムをセットアップします。

積分器用の実験をセットアップする：

• Build → Experiment を選択して、実験環境を開きま
す。

• “Physical Experiment” ウィンドウで Event 
Generator ボタンをクリックします。
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• イベント integrateをアクティブにして、 dTは
デフォルト値 0.01のままにします。

• “Event generator” ウィンドウを閉じます。

• Data Generator ボタンをクリックします。

• Channels → Create を選択して integrateから引
数を選択し、 integrateメソッド用のデータチャ
ンネルを作成します。

• 以下の値を設定します。

• データジェネレータを閉じます。

• integrateメソッドの argと returnをオシロス
コープウィンドウに割り当てます。

• 値軸の範囲を -10～ 10にし、時間軸の範囲を 10秒
にします。

• Start Offline Experiment をクリックして、実験を
開始します。

integrateメソッドの出力値は、引数が正なら増加し、負なら減少します。入力
カーブの正と負の部分の時間は等しいので、安定範囲内の値が出力され続けます。

実験を停止すると、その時点での変数とパラメータの値が保存され、実験を再開す
る際にそれらの値が使用されます。しかしすべての値をリセットしてから再開する
必要がある場合もあります。

実験をリセットする：

• “Physical Experiment” ウィンドウで Extras → 
Reinitialize → Variables（または Parameters 、
Both）を選択します。

選択したコマンドに応じて、すべての変数またはすべ
てのパラメータ、またはその両方が初期値にリセット
されます。

Mode： pulse

Frequency： 0.2 Hz

Phase： 0.0 s

Offset： -1.0

Amplitude： 2.0
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次に、実験の条件を変更して、積分器ファンクションのカーブを表示してみましょ
う。Kiパラメータを調整、つまり「適合」し、入力値を変更します。

積分器の実験を行う：

• “Outline” タブの Integratorエレメントを展開し
ます。

• パラメータ Kiを選択します。

• Extras → Calibrate を選択します。

このパラメータ用の数値エディタが開きます。

• 5を入力します。

オシロスコープの出力カーブの勾配が急になります。

• 値を 3にします。

出力カーブの傾斜が緩くなります。

• パラメータの値を 4に戻してから数値エディタを閉じ
ます。

• “Data Generator” ウィンドウを開きます。

• 入力パルスのオフセットを -0.5にします。

• OK をクリックします。

これで正の部分の方が大きくなるので、出力値が増加し、ある時点でオシロスコー
プの表示範囲を超えてしまいます。このような場合、個々の値について、オシロス
コープのスケールを変更することができます。また、以下のようにして数値表示
ウィンドウを開いて出力値を表示することもできます。

値を数値で表示する：

• 実験環境の “Measure View” コンボボックスから

<1. Numeric Display>を選択します。

• “Outline” タブで、integrateメソッドの戻り値

(return) を選択します。

• Extras → Measure を選択します。

“Numeric display” ウィンドウに、現在の戻り値が表
示されます。

• 依存パラメータ sqrt_Kiも表示します。

• Kiの値を変更し、sqrt_Kiの値が自動的に変化す
るのを確認します。
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4.3.3 まとめ

このレッスンでは、ASCET で以下の作業を行いました。

• パラメータを作成する

• 依存パラメータを作成し定義する

• 変数を作成する

• 複数の入力を伴う演算子を作成する

• シーケンスコールのシーケンス番号を設定する

• デフォルト値を割り当てる

• 実験中に値を適合する

• “Numeric display” ウィンドウに値を表示する

4.4 実際的な例 : コントローラ

このレッスンでは、標準の PI フィルタを若干拡張したものをベースにして、コント
ローラを作成します。このコントローラは、自動車のアイドリング時のエンジン回
転速度を一定に保つために用いられます。

エンジンのアイドリング速度をコントロールする場合、実際の回転数 nがアイドリ
ング時の目標値 n_nominalに近い状態を確実に維持する必要があります。

n_nominalから値 nを引いて、 コントロールする偏差を決定します。

この実際の回転数の偏差が、 air_nominalの値を算出するための基礎になりま
す。 air_nominalはスロットル位置、つまりエンジンの吸気量を決定します。

4.4.1 コントローラを定義する

コントローラのダイアグラムを作成する手順は、これまでのレッスンで用いた手順
と同じです。

• コンポーネントマネージャで新しいフォルダを追加し、コンポーネントを作
成します。

• インターフェースを定義し、ブロックダイアグラムを作成します。

これまでのレッスンと大きく異なるのは、コントローラをモジュールとして実装す
る点です。モジュールはプロジェクトの最上レベルのコンポーネントとして用いら
れます。モジュール内では、プロジェクトを構成する「プロセス」が定義されます。

コントローラコンポーネントを作成する：

• コンポーネントマネージャで、新しいサブフォルダを

Tutorialフォルダに追加し、 その名前を

Lesson4にします。

• Lesson4フォルダを選択し、Insert → Module → 
Block diagram を選択して新しいモジュールを追加
します。

• 新しいモジュールの名前を IdleConにし、ブロック
ダイアグラムエディタを開きます。

• “Outline” タブで、ダイアグラム processの名前を

p_idleに変更します。

モジュールの機能は「プロセス」という単位で定義されます。モジュールにおける
プロセスは、クラスにおけるメソッドに相当します。プロセスはメソッドとは異な
り、引数や戻り値を伴いません。ASCET におけるプロセス間の通信、つまりデータ
交換は、「受信メッセージ」（入力）および「送信メッセージ」（出力）と呼ばれる方
向性のあるメッセージを使用して行われます。
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ここで作成するコントローラは、実際の回転数を受信メッセージ nとして受け取り、
それを使用して算出されたスロットル位置を air_nominalという送信メッセージ
に代入して出力します。

コントローラのインターフェースを定義する：

• Receive Message ボタンをクリックして受信メッ
セージを作成し、その名前を nにします。

• メッセージ nのプロパティエディタを開き、Set() 
Method オプションをオンにします。

• Send Message ボタンをクリックしてから描画エリ
ア内をクリックして、送信メッセージを作成します。

• 送信メッセージの名前を air_nominalにします。

• メッセージ air_nominalのプロパティエディタを
開き、Get() Method オプションをオンにします。

このコントローラには、レッスン 3 で作成した積分器 Integrator を使用します。

コントローラに Integrator を追加する：

• Insert → Component を選択して、“Select item” ダ
イアログボックスを開きます。

• “1 Database” ペインの Tutorial/Lesson3フォ
ルダから Integratorを選択し、OK をクリックし
ます。

• 積分器がコンポーネント IdleConに内包されます。
コンポーネントは参照により内包されるため、この積
分器の元の定義を変更すると、他のコンポーネントに
内包されるこの積分器のコンポーネントにも、その変
更が反映されます。

これまでに追加したエレメント以外に、以下のエレメントをコントローラに追加す
る必要があります。

• 2 つの continuous 型変数（ndiff, pi_value）

• 3 つのパラメータ（n_nominal, Kp, air_low）
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コントローラの残りの部分を定義する：

• 必要な演算子や他のエレメントを作成してから、それ
らを下のブロックダイアグラムのように接続します。

• “Outline” タブから、n_nominalパラメータを選択
して、Edit → Data を選択します。

• n_nominalの値を 900にします。

• Kpの値を 0.5にします。

• ダイアグラム内の定義を保存し、変更をデータベース
に適用します。

4.4.2 コントローラの実験を行う

モジュールの実験は、コンポーネントの実験と同様の手順で行います。まず、デー
タジェネレータとイベントジェネレータをセットアップし、次に測定システムを
セットアップします。

実験をセットアップする：

• Build → Experiment を選択して、実験環境を開きま
す。

• “Event Generator” ウィンドウを開き、プロセス

p_idle用のイベントをイネーブルにして、 dTはデ
フォルト値の 0.01のままにしておきます。

プロセス用のイベントも、メソッド用のイベントと同
じように機能します。
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• “Data Generator” ウィンドウを開き、受信メッセー
ジ n用のチャンネルに以下の値を設定します。

• 変数 n_diffおよび air_nominalをオシロスコー
プに割り当てます。

• オシロスコープの値軸の範囲を -500～ 500に、 時
間軸の範囲を 2にします。

• Save Environment ボタンをクリックします。

これで実験のセットアップが終わり、回転数の偏差とスロットル位置の関係を表示
できるようになりました。

コントローラの実験を行う：

• Start Offline Experiment ボタンをクリックして、
実験を開始します。

• 変数 Kiおよび Kp用の適合ウィンドウを開きます。
そこから、 値 Kiおよび Kpを調整し、その出力に対
する影響を調べることができます。

有意義な値に戻すために、実験中にモデルを再初期化
する必要があるかもしれません。

4.4.3 プロジェクト

プロジェクトは、完結したソフトウェアシステムとして機能する ASCET ソフトウェ
アの単位です。プロジェクトは、実験ターゲットやマイクロコントローラターゲッ
トを使用して、オンラインでリアルタイムな実験を行うことができます。個々のコ
ンポーネントの実験はオフライン（PC ベース）でしか行えません。

実験はプロジェクト単位で実行されます。プロジェクト用のコードが生成されると、
オペレーティングシステムコードも必ず生成されます。ASCET で作成されたソフト
ウェアシステムをリアルタイムに実行するには、オペレーティングシステムのセッ
トアップが必要です。ソフトウェアシステムをリアルタイムに実行する実験を「オ
ンライン実験」と呼びます。これまでのレッスンで行った実験はすべてオフライン
実験であり、リアルタイムなシミュレーションは行われませんでした。

Mode： pulse

Frequency： 1.0 Hz

Phase： 0.0

Offset： 800.0

Amplitude： 200.0

注記

オンライン／オフラインにかかわらず、ASCET の実験は実際にはすべてプロジェ
クトの単位で行われます。このことはオフライン実験でデフォルトプロジェクト
を使用する（このプロジェクトはユーザーからは見えない場合もあります）こと
でも明らかです。オペレーティングシステムを定義する目ために明示的にプロ
ジェクトを作成してセットアップしなければならないのは、オンライン実験の場
合だけです。ただし、ユーザー独自のアプリケーション用にデフォルトプロジェ
クトを設定することもできます。
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4.4.4 プロジェクトをセットアップする

コンポーネントマネージャで、IdleConモジュールと同じフォルダにプロジェクト
を作成します。

プロジェクトを作成する：

• コンポーネントマネージャで、Insert → Project を選
択するか、または Insert Project ボタンをクリックし
て、新しいプロジェクトを追加します。

• プロジェクトの名前を ControllerTestにします。

• プロジェクトをダブルクリックします。

プロジェクト用のプロジェクトエディタが開きます。

次に、プロジェクトの “Outline” タブに IdleConコントローラを追加します。

プロジェクトにコンポーネントを追加する：

• プロジェクトエディタで Insert → Component を選
択して、“Select Item” ダイアログボックスを開きま
す。

• “1 Database” リストから、=Tutorial/Lesson4 
フォルダのコンポーネント、IdleConを選択します。

• OK をクリックして、このコンポーネントを追加しま
す。

コンポーネントの名前が、プロジェクトエディタの

“Outline” タブに表示されます。

参照されるコンポーネントは、非参照コンポーネントに内包されます。つまり、内
包されたコンポーネントのダイアグラムを変更すると、その変更がプロジェクト全
体に反映されます。

プロジェクトに含まれるタスクとプロセスのスケジューリングは、オペレーティン
グシステムによって行われます。プロジェクト用のコードを生成する前に、タスク
をいくつか作成してそれらにプロセスを割り当てておく必要があります。

オペレーティングシステムのスケジューリング条件は、プロジェクトエディタの

“OS” タブに定義します。ここで、p_idleプロセスが 10ms ごとに起動されるよ
うに、オペレーティングシステムのスケジュールを定義しましょう。
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プロジェクト用のオペレーティングシステムのスケジュールをセットアップする：

• “OS” タブをクリックします。

• Task → Add を選択して、新しいタスクを作成しま
す。

• 作成したタスクの名前を Task10msにします。

作成されるタスクは、デフォルトでは Alarm タスク、
つまり、オペレーティングシステムにより周期的に起
動されるタスクです。

• “Period” フィールドで、このタスクの周期を 0.01
秒にします。

この周期は、タスクが起動される頻度を規定します。
この例では、10ms ごとに起動されます。

• “Processes” リストの IdleConというアイテムを展
開します。

• プロセス p_idleを選択し、Process → Assign を選
択します。

このプロセスが Task10msタスクに割り当てら
れ、“Tasks” リストのこのタスク名の下に表示されま
す。

プロジェクト内においては、インポートエレメントやエクスポートエレメントを用
いてプロセス間通信を行います。これらのエレメントはグローバルエレメントで、
モジュール間通信の送信メッセージと受信メッセージに相当します。グローバルエ
レメントはプロジェクト単位で宣言され、プロジェクト内の各モジュールに含まれ
る同名のエレメントに結び付けられていなくてはなりません。

グローバルエレメントを定義する：

• プロジェクトエディタで、Extras → Resolve 
Globals を選択します。

グローバルエレメントが作成され、それぞれ対応する
エレメントに結び付けられます。同じ名前のエレメン
ト同士が自動的に結び付けられます。
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4.4.5 プロジェクトの実験を行う

まず、このプロジェクトのオフライン実験を行います。オフライン実験は、ハード
ウェアを接続せずに PC 上で行うことができます。プロジェクトのデフォルト設定で
は PC 上で稼働するようになっているので、この設定を変更する必要はありません。
プロジェクトのオフライン実験は、コンポーネントのオフライン実験と同様の手順
で行います。

実験をセットアップする：

• コンポーネントマネージャで、File → Save を選択し
ます。

実験環境を起動する前に、変更内容を必ずデータベー
スに保存することをお勧めします。

• プロジェクトエディタで Build → Experiment を選
択します。

プロジェクトのコードが生成され、オフライン実験が
開きます。

• Open Event Generator ボタンをクリックします。

プロジェクト用のイベントジェネレータには、コン
ポーネントの実験の場合のように各メソッドや各プロ
セス用のイベントではなく、実験で使用する各タスク
用のイベントが表示されます。

• ダイアログボックスからタスク generateDataを
イネーブルにし、dT値にはデフォルトの 0.01 秒を採
用します。

タスク Task10msはデフォルト状態ですでにイネー
ブルになっているので、 これでタスク

generateDataおよび 10ms のイベントの dT値は
ともに 0.01 秒になります。これ以上変更の必要はあ
りません。

• イベントジェネレータを閉じます。

• データジェネレータと測定システムを、前回の実験と
同じ値でセットアップします（59 ページの「コント
ローラの実験を行う」を参照してください）。

• File → Save Environment を選択して、環境設定を
保存します。
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実験を行う：

• Start Offline Experiment ボタンをクリックします。

• 前項と同様に Kiおよび Kpパラメータを調整して、
出力への影響を確認します。

4.4.6 まとめ

このレッスンでは、ASCET で以下の作業を行いました。

• モジュールを作成する

• モジュール内のメッセージを作成する

• コンポーネントマネージャで作成したコンポーネントをブロックダイアグラ
ムに組み込む

• プロジェクトを作成する

• プロジェクトにコンポーネントを内包する

• タスクを作成し、それらにプロセスを割り当てる

• プロジェクトの実験を行う

4.5 プロジェクトを拡張する

このレッスンでは、コントローラを少し改良して一層実用的なものにします。セン
サで読みとった値を実際の値に変換する、シグナルコンバータを作成します。たと
えば自動車制御アプリケーションで用いられるような多くのセンサは、温度、位置、
毎分の回転数などの測定値に対応する電圧を返します。この電圧と測定値の関係は、
必ずしも一次関数で表せるとは限らないので、ASCET では、この種の対応関係を効
率的にモデリングできる特性テーブルを使用できます。

4.5.1 シグナルコンバータを定義する

シグナルコンバータをモデリングするために、まずフォルダとモジュールを作成し
て、機能を定義します。シグナルコンバータは 2 つの特性カーブを使用して、入力
値に対する出力値を求めます。

モジュールを作成する：

• コンポーネントマネージャで、新しいフォルダ

Tutorial/Lesson5を作成します。

• 新しいモジュールを作成し、その名前を

SignalConvにします。

• エレメントをダブルクリックしてブロックダイアグラ
ムエディタを開きます。

• ブロックダイアグラムエディタで Insert → Process 
を選択して 2 つめのプロセスを作成します。

• 2 つのプロセスの名前を n_samplingと

t_samplingにします。

• “Outline” タブに、2 つの受信メッセージ U_nおよび

U_tと、2 つの送信メッセージ tおよび nを作成し
ます。

• One-D Table ボタンをクリックして、特性カーブエ
レメントを作成します。

プロパティエディタが開きます。

• t_sensorという名前を入力します。
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• “Dimension” フィールドの “x” の部分に値 13を入
力します。

これにより、この特性カーブを最大 13 列まで広げる
ことができるようになりました。

特性カーブは 1 次元なので、“Dimension” フィール
ドの “ｙ” の部分は無効になっています。

• “Interpolation” コンボボックスで Linear補間を選
択します。

• OK をクリックしてプロパティエディタを閉じます。

• 描画エリア内をクリックして、テーブルを配置しま
す。

このテーブルが “Outline” タブに追加されます。

• 第 2 のテーブル（最大 2 列でリニア補間）を作成し、

n_sensorという名前にします。

• 下図のようにエレメントを接続し、シーケンシングを
編集して、この処理を行うプロセスを割り当てます。

次に、2 つの特性カーブのデータを編集します。ASCET ではテーブルエディタを使
用して各種テーブルデータ（配列、特性カーブ、および特性マップ）を編集します。

テーブルを編集する：

• テーブル t_sensorを右クリックし、ショートカッ
トメニューから Data を選択します。

テーブルエディタが開きます。

• テーブルのサイズを以下のように調整します。

テーブルが 13 列に拡張され、z 値はすべてデフォル
トで 0 になります。

• 以下の値を入力します。上の行が X 行、下の行が Z 行
の値です。

まずサンプルポイント（X 値）を左から右の順に入力
して、テーブルを編集します。

• 編集しようとする X 値をクリックしてから、ダイアロ
グボックスに新しい値を入力します。

新しい値は両隣のサンプルポイントの間の値でなけれ
ばなりません。

0.00 0.08 0.30 0.67 1.17 2.5 5.00 7.50 8.83 9.33 9.70 9.92 10.00

-40.0 -26.0 -13.0 0.0 13.0 40.0 80.0 120.0 146.0 160.0 173.0 186.0 200.0
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• 次に、Ｚ 値（出力値）をクリックし、強調表示された
値の上に適切な値を入力します。

• 同じ方法で、以下のデータを使用して、第 2 のテーブ
ルを編集します。

• ブロックダイアグラムエディタで、File → Save を選
択します。

• コンポーネントマネージャで、Save ボタンをクリッ
クして、変更内容を保存します。

この例では、第 2 のテーブルは出力が入力の変化に従って直線的に変化する関係を
表せばよいので、必要なサンプルポイントは 2 つだけです。値の補間モードとして
線形補間を指定したので、これで充分に機能します。

線形補間では、2 つのサンプルポイント間の入力値に対応する出力値は、直線から
求められます。この場合、入力値が 0 なら 0 が返され、10 なら 6000 が返されま
す。入力値が 5 の場合、戻り値は補間により 3000 になります。

4.5.2 シグナルコンバータの実験を行う

新しいコンポーネントの実験を行い、テーブルによる変換処理の結果を調べてみま
しょう。2 つのテーブルの値の範囲は互いに異なるので、それぞれに専用のオシロ
スコープウィンドウを使用します。

実験をセットアップする：

• コンポーネントマネージャから Build → Experiment 
を選択して、実験環境を開きます。

• コンポーネント内の各プロセス（n_sampling、
t_sampling、 generateData）用にイベントを
作成し、各イベントの dT値を 4msにします。

0.0 10.0

0.0 6000.0
チュートリアル



• データジェネレータで、メッセージ U_n用と U_t用
にチャンネルを 1 つずつ作成し、両チャンネルに以下
の値を設定します。

• メッセージ nおよび U_nのオシロスコープウィンド
ウと、 メッセージ tおよび U_tのオシロスコープ
ウィンドウを作成します。

後者のオシロスコープを作成する際には、“Select 
Measure View” コンボボックスで必ず <2. New 
Oscilloscope>を選択しておいてください。

2 つのテーブルのサンプリングポイントの分解能とそれに対応する補間値は大きく
異なるので、各チャンネルの表示設定は、それぞれのオシロスコープ内で個別に行
う必要があります。

オシロスコープを測定値にあわせて調整する：

• プロセス n_sampling用のオシロスコープ（チャン
ネル U_nおよび n）を選択します。

• “Measure Channels” リストから、メッセージ nを選
択し、Extras → Setup を選択します。

メッセージ n用の “Display Setup” ダイアログボック
スが開きます。

• 値軸の範囲を 0～ 6000にし、時間軸の範囲を 0.5 に
します。

• メッセージ U_n用の “Display Setup” ダイアログ
ボックスを開きます。

• その値軸の範囲を -1～ 11にします。

時間軸の範囲は、1 つのオシロスコープウィンドウ内
のすべての変数について同じでなければならないの
で、時間軸の範囲を変更する必要はありません。

• プロセス t_sampling （チャンネル U_tおよび t）
用のオシロスコープを選択し、そのチャンネルを以下
のようにセットアップします。

• File → Save Environment を選択して、環境設定を
保存します。

これで、実験を実行してシグナルコンバータの機能を調べることができるようにな
りました。2 つの変換処理の相違を調べてみましょう。

Mode： sine

Frequency： 2.0 Hz

Phase： 0.0

Offset： 5.0

Amplitude： 5.0

U_t t

Min -1 -40

Max 11 200

Extent 0.5 0.5
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実験を行う：

• Start Offline Experiment ボタンをクリックします。

n_sensorテーブルでは、 入力される正弦波の振幅
だけが変化します。 ここでの入力は 0 ～ 10 ボルト
の電圧信号です。これが 0 ～ 6000rpm の回転速度に
マッピングされます。

テーブル t_sensorでは、一次関数では表せない
入力電圧と出力温度との関係が定義されています。こ
の関係は自動車制御用に一般に用いられている温度セ
ンサの応答特性カーブと一致します。

• データジェネレータからの入力をさまざまな波形に変
更して、両方の出力カーブに表れる影響を調べます。

4.5.3 シグナルコンバータをプロジェクトに統合する

シグナルコンバータの定義が終わったので、これを、レッスン 4 で作成したプロ
ジェクトに統合します。シグナルコンバータからの出力信号が、エンジンコント
ローラへの入力信号として使用されます。

プロジェクトにシグナルコンバータを統合するために、新しいプロセス用のタスク
をセットアップし、プロセス間通信に必要なグローバルエレメントを宣言してその
結び付けを行います。

シグナルコンバータをプロジェクトに追加する：

• プロジェクト ControllerTestをプロジェクトエ
ディタで開きます。

• モジュール SignalConvを、コンポーネントマネー
ジャの “1 Database” リストからプロジェクトの

“Outline” タブにドラッグします。

• “OS” タブをクリックして、オペレーティングシステ
ムエディタを開きます。

• 新しいタスク n_samplingを作成します。

• 新しいタスクの周期を 0.004秒にします。
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• プロセス n_samplingをタスク n_samplingに割
り当てます。

これで、プロジェクトに 2 つのタスクが定義されました。第 1 のタスクは 10 ミリ
秒ごと、第 2 のタスクは 4 ミリ秒ごとに起動されます。1 つのタスクに割り当てら
れているすべてのプロセスは、そのタスクに定義されているインターバルで実行さ
れます。この例ではそれぞれのタスクにプロセスが 1 つずつしかありませんが、必
要に応じて任意の数のプロセスを割り当てることができます。

シグナルコンバータを統合するためには、次にモジュール間の通信を解決します。
プロセス間通信はグローバルエレメントを介して行われます。プロジェクト内で用
いられるすべてのグローバルエレメントは、対応するモジュール内でメッセージと
して定義されていなければなりません。

デフォルトでは、送信メッセージはモジュール内に定義されますが、受信メッセー
ジは、通常モジュールにインポートされるものであるため、プロジェクト内で受信
メッセージを定義する必要があります。

各グローバルエレメントは、プロジェクト内で 1 回のみ定義します。複数回定義さ
れていると、コード生成時に以下のようなエラーが発生します。

グローバルエレメントをセットアップする：

• Extras → Resolve Globals を選択して、結び付けを
自動で行います。

必要なグローバルエレメントがすべて自動的に作成さ
れ、同じ名前のエレメントに結び付けられます。たと
えばグローバルメッセージ U_nは、SignalConv内
のメッセージ U_nに自動的に結び付けられます。

• プロジェクトからメッセージ nを削除します。

レッスン 4 ではメッセージ nをプロジェクトのグロー
バルメッセージとして定義しましたが、このレッスン
ではメッセージ nをモジュール SignalConvに定義
してモジュール内のプロセス間通信に使用するため、
グローバルメッセージは不要になりました。
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• プロジェクトに含まれている未使用のグローバルエレ
メントを検索して削除するには、以下のように操作し
ます。

－ Extras → Show Unused Elements を選択しま
す。

タブの下側部分に “Search Results” ビューが開
き、プロジェクトレベルの未使用エレメントが一
覧表示されます（詳細はオンラインヘルプを参照
してください）、

－ “Search Results” ビューの “Elements” タブで削
除したいエレメントをすべて選択し、<Delete> 
を押します。

プロジェクトの実験を行う：

• Build → Experiment ボタンをクリックして実験環境
を開きます。

• イベントジェネレータを開き、タスク n_sampling
をイネーブルにします。

• このタスクの dT値を 4 ミリ秒にします。

プロジェクトのオフライン実験では、オンライン実験
時にはオペレーティングシステムが行うスケジューリ
ングを、イベントジェネレータがシミュレートしま
す。

• データジェネレータを開き、既存のデータチャンネル
を削除します。

• メッセージ U_n用に新しいチャンネルを設定しま
す。

• チャンネル U_nを以下のように設定します。

• 回転速度センサの出力電圧 U_nをアクティブにしま
す。

シグナルコンバータは、 特性テーブル n_sensorを
使用してこの電圧値を回転数 nに変換します。

上記の値により、 nが前の実験（信号処理なし）と
同じ範囲で出力されます。

• Save Environment ボタンをクリックします。

• 実験を開始します。

出力されるカーブは、信号処理を行わない例で出力されたカーブと同じはずです。
データジェネレータによりスティミュレートされる値は異なりますが、テーブルで
処理され、前の実験と同じ出力値になります。

4.5.4 まとめ

このレッスンでは、ASCET で以下の作業を行いました。

• 特性カーブエレメントを作成して使用する

Mode： pulse

Frequency： 1.0 Hz

Phase： 0.0

Offset： 4/3

Amplitude： 1/3
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• コンポーネントをプロジェクトに追加する

• プロジェクト内のコンポーネント間の通信を定義する

4.6 連続系をモデリングする

物理、機械、電子、およびメカトロニクスに関する処理を現実的にモデリングする
には微分方程式を用いることが多く、連続系メソッドが要求されます。このような
メソッドをこれまでの章で作成したプロジェクトに統合する前に、本章では詳しい
例を用いて、連続系のモデリングについて説明します。

ASCET は、いわゆる「CT ブロック」による連続系のモデリングとシミュレーショ
ンをサポートしています。CT は “Continuous Time”（連続時間）の略で、疑似連続
的な時間ステップで計算処理が行われることを意味します。ASCET における連続系
モデリングは、連続系の設計に用いられる標準的な記述形式である、状態空間表現
をベースとしています。この形式では、CT 基本ブロックを非線形 1 次常微分方程式
と非線形出力方程式で定義することができます。ASCET は、これらの微分方程式の
最適な解を見つけるための、いくつかのリアルタイム積分メソッドを提供します

（詳細は ASCET オンラインヘルプを参照してください）。

以下に、ばね－質量系の、地球の重力による減衰を伴う動きを例にして、連続系の
モデリングの手順を説明します。

4.6.1 運動方程式

上図の質量 mには、以下の力が働いています。

• 重力 ： Fg = -mg
（g = 重力の加速度）

• ばねの力 ： FF = -c (x + l0)
（c = ばね定数、 l0 = 静止時のばねの長さ、 x = 質量 mの位置）

• 減衰 FD = - d x’
（d = 減衰定数、 x’ = 質量の速度）

これにより、 以下の運動方程式が得られます。

mx’’ = -mg + F あるいは x’’ = -g + F/m (ただし F = FF + FD)

この 2 次微分方程式を（x = x、 v = x’により）2 つの 1 次微分方程式にする
と、以下のようになります。

x’ = v
v’ = -g + F/m

以下のモデル設計では、これらの微分方程式を使用します。
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4.6.2 モデル設計

ばね－質量系のモデルは、CT ブロックを 1 つだけ用いてシンプルに設計することも
できますが、ここでは 2 つの CT ブロックを用いてこのモデルをモデリングします。
その過程で「直接通過」や「間接通過」のプロパティについて説明し、これらのプ
ロパティを適切に設定して算術ループを避ける方法を紹介します。

• Forceブロックでは、質量 mの位置と、速度 x’から求められる摩擦力に基
づいて、 ばねの力 Fを算出します。

• Massブロックでは、ばねの力 Fから加速度 x’’を算出します。x’’を積分
して、 速度 x’と位置 xを算出します。

一見して、このシステムでは、どちらのブロックも相手のブロックから要求される
出力を算出するために相手のブロックからの入力が必要なので、算術ループになっ
てしまうように見えます。

このループは、「直接通過 」または「間接通過」のプロパティを適切に設定すること
によって回避することができます。

• Forceブロックでは、 下の方程式により算出される出力変数 Fは、 入力変
数 xおよび x’に直接依存しています。 したがって、 このブロックは直接
通過として定義されます。

F = -c(x + l0) - dx’

• 一方、Massブロックでは、出力変数 xおよび x’は入力変数 Fに直接依存し
ているわけではなく、 ブロックの内部ステート変数に依存しています。 こ
れらは、 少なくとも初めは初期値になっているので、 入力変数 Fの値がわ
からなくても、 初期値に基づいて出力変数 xおよび x’を算出することがで
きます。 Fの値がわかっている場合は、 出力変数は微分方程式を用いて算
出されます。

x’ = v
v’ = -g + F/m 

したがって、このブロックは、間接通過として定義します。

モデルを作成する：

• コンポーネントマネージャでフォルダを作成し、その
名前を Lesson6にします。

• このフォルダ内で Insert → Continuous Time Block 
→ ESDL を選択して、Forceおよび Massというブ
ロックを作成します。

• Forceブロックをダブルクリックして、ESDL エディ
タを開きます。

• Input ボタンをクリックして、x および v という 2
つの入力 （continuous型）を作成します。

• Output ボタンをクリックして、出力 F
（continuous型）を作成します。

• Parameter ボタンをクリックして、定数 c （ばね定
数）、 d （減衰定数）、 l0（静止時のばねの長さ）
を作成します。

j~ëë
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“Outline” タブ内のメソッドは自動的に作成されま
す。

• “Outline” タブ内の各定数を右クリックして、ショー
トカットメニューから Data を選択します。

“Numeric Editor” ダイアログボックスが開きます。

• 定数に現実的な値を割り当てます（例、ばね定数 cに
は 5.0、減衰定数 dには 1.0、静止時のばねの長さ l0
には 2.0）。

• “Outline” タブ内のメソッド directOutputs()を
クリックします。

• 編集フィールドに、力を算出する以下の式を定義しま
す。

F = -c * (x + l0) - d*v;

• Generate Code ボタンをクリックします。

CT ブロック Forceがコンパイルされます。

• Massブロックをダブルクリックして、ESDL エディ
タを開きます。

• Forceブロックの場合と同様にして、 入力 F、2 つ
の出力 xおよび v、 パラメータ m（質量）、および定
数 g（重力加速度）を作成します。
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• Forceブロックの場合と同様にして、 gおよび mに
値を割り当てます （gは 9.81、質量 mはたとえば

2.0）。

• Continuous State ボタンをクリックして、出力を内
部で計算するためのステート変数 x_localおよび

v_localを作成します。

• derivatives()メソッドに、 計算に必要な微分方
程式を定義します。

x_local.ddt(v_local);

v_local.ddt(-g + F/m);

• nondirectOutputs()で、 ステート変数

x_localおよび v_localを出力 xおよび vに渡し
ます。

x=x_local;
v=v_local;

• init()メソッドでは、 ユーザーが

resetContinuousState()関数を使用して、 x
と vに現実的な初期値を与えることができます。

resetContinuousState(x_local,0.0);
resetContinuousState(v_local,0.0);

• Generate Code ボタンをクリックします。

CT ブロック Massがコンパイルされます。

ブロックダイアグラムエディタ（BDE： Block Diagram Editor）を使用して、2 つの
基本 CT ブロックを結合して 1 つの CT 構造ブロックにします。

2 つの基本 CT ブロックを結合する：

• コンポーネントマネージャの Lesson6 フォルダを
選択し、Insert → Continuous Time Block → Block 
Diagram を選択して新しいブロック Mass_Spring
を作成します。

• 新しいブロックをダブルクリックしてブロックダイア
グラムエディタ（BDE）を開きます。

• コンポーネントマネージャから Massおよび Force
ブロックを 1 つずつドラッグして BDE ウィンドウの

“Outline” タブにドロップし、Mass_Spring内に組
み込みます。
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• 対応する入力と出力とを接続します。

• Build → Experiment を選択します。

CT ブロックがコンパイルされ、実験環境が起動され
ます。

注記

CT 基本ブロックの 1 つをダブルクリックすると、そのブロックを編集できるよう
になります。ブロックに修正を加えるとライブラリ全体、つまり、その基本ブ
ロックを使用するすべての構造ブロックに影響します。
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• 以下のように数値エディタとオシロスコープを設定し
ます。

• オシロスコープ内のチャンネルのスケールを、xは -
10 ～ 0、vは -8 ～ +8 に調整します。

• 時間軸の範囲を 25s に設定します。

4.6.3 まとめ

このレッスンでは、ASCET で以下の作業を行いました。

• モデルを作成してプロセスをシミュレートする

• ESDL エディタを使用して、直接および間接通過の CT ブロックを作成する

• ブロックダイアグラムエディタを使用して、複数の CT ブロックを結合する

• 物理実験を行う
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4.7 プロセスモデル

前のレッスンでの CT ブロックの紹介に続いて、それらの CT ブロックを使用したコ
ントローラのテストを行います。ASCET では、制御対象となる物理プロセスのモデ
ルを開発し、閉制御ループによってコントローラモデルの実験を行うことができま
す。これにより、実際の車両を使用する前にコントローラのテストを入念に行って
おくことができます。

ここでは、モータの物理プロセスを扱います。この物理プロセスモデルはエンジン
回転速度センサの値 U_nを返します。そしてコントローラはこの値を処理し、値

air_nominalを返します。コントローラの出力値によりエンジンのスロットル位
置が決まり、さらにこのスロットル位置が回転速度に影響します。

図 4-1 閉ループ実験

このプロセスモデルには CT ブロックを使用します。連続系コンポーネントはプロセ
スモデルに特に適していて、モデルのベースとなるのは、PT2 系をモデリングする
以下の微分方程式です。

T2 s’’ + 2DTs’ + s = Ku

式 4-1 PT2 系

この方程式においては、パラメータ T、D、および K に適切な値を設定する必要があ
ります。

4.7.1 プロセスモデルを定義する

連続系コンポーネントの作成方法は、他のコンポーネントの作成方法とは異なりま
す。連続系コンポーネントには入力と出力があり、これらは引数と戻り値に相当し
ます。主な違いは、連続系ブロックは複数の入力と出力を伴うことができ、それら
が特定のメソッドと結びついていないことです。各連続系ブロック内には、あらか
じめ一連のメソッドが固定的に定義されていて、これをユーザーが変更することは
できません。

ここでは、ESDL コードを使用します。ESDL コードの構文は C++ や Java に似てい
ます。オブジェクトのメソッドは、「オブジェクト名 . メソッド名 ( 引数 ); 」の形式
で呼び出されます。微分に用いるメソッドは ddt()と呼ばれます。たとえば、方程
式  は、ESDL では s.ddt(sp);という文で表記されます。

連続系コンポーネントを作成する：

• コンポーネントマネージャでフォルダ Tutorial/
Lesson7を作成します。

• 連続系ブロックを追加するために、Insert → 
Continuous Time Block → ESDL を選択します。

• 新しいコンポーネントの名前を ProcModelにしま
す。
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• Edit → Open Component を選択して、ESDL エディ
タを開きます。

ここではもちろん外部テキストエディタも使用できま
す。使用方法は、チュートリアルの最初の部分に説明
されています。

プロセスモデルを編集するには、まず必要なエレメントを追加してから、メソッド

derivatives()および nondirectOutputs()を編集します。

プロセスモデルを編集する：

• ESDL エディタの Continuous State ボタンを使用し
て、2 つの連続ステートを作成します。

• これらのステートの名前を sおよび spにします。

• 入力 uを作成します。

• 出力 yを作成します。

どのエレメントも cont型です。

• 3 つのパラメータ（D、 K、 T）を作成します。

このプロセスモデルの “Outline” タブは、以下のよう
になります。

• 各パラメータを以下のように設定します。

D = 0.4
K = 0.002
T = 0.05

• “Online” タブで derivativesメソッドを選択し、
そのコードを以下のように編集します。

s.ddt(sp);

sp.ddt((K*u-2*D*T*sp-s)/(T*T));

この図は内部テキストエディタを使用した例です。

• “Outline” タブから nondirectOutputsメソッドを
選択し、以下のテキストを入力します。

y = s;

注記

微分方程式の解法については、ASCET オンラインヘル
プの連続系ブロックの記述法についてのトピックを参
照してください。
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• レイアウトエディタでレイアウトを調整します。

プロセスモデルの場合、出力を左側、入力を右側に配
置するのがよいでしょう。

• Edit → Save を選択します。

• コンポーネントマネージャの Save ボタンをクリック
して、プロセスモデルを保存します。

これで、新しいモデルを用いて実験を開始する準備ができました。

モデルの実験を行う：

• ESDL エディタで Build → Experiment を選択して、
実験環境を開きます。

• Open CT Solver ボタンをクリックして、“Solver 
Configuration” ダイアログボックスを開きます。

現在のコンフィギュレーションが表示されます。

• OK をクリックしてデフォルト設定を有効にします。

• データジェネレータを開き、入力 uのチャンネルを作
成します。

• 以下の値をチャンネル uに設定します。

• チャンネル uおよび yのオシロスコープウィンドウ
を開きます。

Mode： pulse

Frequency： 0.5 Hz

Phase： 0.0 s

Offset： -0.5

Amplitude： 1.0
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• オシロスコープの各測定チャンネルを、以下のように
設定します。

• Save Environment ボタンをクリックします。

• 実験を開始します。

出力は下図のようになるはずです。

4.7.2 プロセスモデルを統合する

閉制御ループを作成するために、前に作成したコントローラプロジェクトにプロセ
スモデルを統合します。これまでのレッスンと同様に、モジュールを内包させ、オ
ペレーティングシステムをセットアップしてグローバルエレメントを結び付けると
いう作業が必要です。

プロセスモデルを内包させる：

• コンポーネントマネージャから ControllerTest
用のプロジェクトエディタを開きます。

プロジェクトエディタで、 コンポーネント

ProcModelを “Outline” タブに追加します。

• プロジェクトエディタの “OS” タブを選択し、CT タ
スクのスケジューリングを定義します。

• タスク simulate_CT1を選択し、“Period” フィー
ルドの値を 0.01（秒）に設定します。

コントローラとプロセスモデルが、共に同じ時間間隔
で実行されます。

u y

Min -1 -0.002

Max 2 0.004

Extent 3.0 3.0

注記

作業を単純にするために、プロセスモデルを同じプロジェクトに追加します。こ
の方法は、閉ループシミュレーションの早い段階でのテストにしばしば役立ちま
すが、プロセスモデルは組み込みシステムの構成要素ではないため、通常は、
ネットワーク経由で各プロジェクト向けに配布されます。
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連続系ブロックとモジュールの結び付けを自動的に行うことはできないので、ブ
ロックダイアグラムで明示的に接続する必要があります。

モジュールと連続系ブロックの結び付きを調整する：

• “Graphics” タブをクリックします。

• “Outline” タブから、3 つのコンポーネントをドラッ
グし、描画エリアにドロップします。

• モジュールのメッセージを、CT ブロックの対応する
入出力に接続します。

この例では、ProcModelの出力 yにグローバルメッ
セージ U_nを接続し、 ProcModelの入力 uにグ
ローバルメッセージ air_nominalをそれぞれ接続
します。

• 各コンポーネントを右クリックして Ports → 
Unconnected Ports を選択し、未接続のポートがダ
イアグラムに表示されないようにします。

モジュール間通信のためのメッセージの結び付けは、自動的に行われます。同じ名
前のメッセージ同士が結びつきます。

これでプロジェクトが完成し、実験を行えるようになりました。今度はオンライン
実験を行うので、ASCET-RP がインストールされていることと、リアルタイムター
ゲット（ES1000 など）が接続されていることが必要となります。これらの条件が
揃っていない場合は、これまでどおりオフライン実験を行ってください。

プロジェクトをオンライン実験用にセットアップする：

• Project Properties ボタンをクリックします。

注記

オフライン実験を行う場合には、グローバルメッセージ U_nをデータジェネレー
タから必ず削除してください。
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• “Project Properties” ダイアログボックスの “Build”
ノードで、以下のようのオプションを設定します。

ターゲット ： ES1130または ES1135
コンパイラ ： GNU-C V3.4.4 (PowerPC)
オペレーティングシステム ： ERCOSEK 4.3

上記のオプション設定により、ハードウェアとそれに
対応するコード生成用コンパイラが指定されます。

• OK をクリックして、ダイアログボックスを閉じま
す。

Reconnect to Experiment of selected 
Experiment Target および Select Hardware ボタン
が有効になります。

• “OS” タブをクリックして、オペレーティングシステ
ムエディタを開きます。

• プリエンプティブレベルの数を 8に設定します。

• 前に作成したスケジューリング設定をコピーするため
に、Operating System → Copy From Target を選
択します。

• “Selection Required” ダイアログから

PC-->GENERICを選択して OK をクリックします。

これで、新しいターゲット用のプロジェクトに、以前
の PC でのオフラインシミュレーション用に定義した
ものと同じスケジューリング設定が定義されました。

オンライン実験には、オフライン実験とは異なる点がいくつかあります。オンライ
ン実験ではイベントジェネレータやデータジェネレータは用いません。イベント
ジェネレータは、オンライン実験用に生成されるオペレーティングシステムタスク
のスケジューリングをオフライン実験でシミュレートするためのものです。
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オンライン実験では、実験コードの実行（つまり OS の起動）と測定とを別々に開
始します。このためツールバーにもそれぞれ専用のボタンが用意されています。こ
れは、測定によって実験のリアルタイム動作が影響を受ける場合があるので、場合
によっては測定を行わずに実験を行う必要があるためです。

プロジェクトの実験をオンラインで行う：

• “Experiment Target” コンボボックスから Online 
(RP)を選択します。

Offline (RP)はターゲット上でオフライン実験を
行うためのものです。

• Build → Experiment ボタンをクリックします。

実験用のコードが生成され、前に定義した環境と同じ
環境で実験が開きます。

プロジェクトに複数のタスクが含まれている場合、各
測定変数の値をどのタスクで取得するかを尋ねるダイ
アログボックスが開きます。

• “Selection Required” ダイアログボックスで、#3 
simulate_CT1というタスクを選択して OK をク
リックします。

• nおよび n_nominalを既存のオシロスコープに設定
し、それらの値の範囲を 0～ 2000にします。

• 変数 n_nominal、 Ki、 Kp用の数値エディタを開
きます。
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• Start Measurement ボタンをクリックしてから、

Start OS ボタンをクリックします。

実験が開始され、結果がオシロスコープに表示されま
す。nの値が急速に n_nominalに近づき、 その状
態が維持されます。

• n_nominalを数値エディタで修正します。

n_nominalの値を変えると、 それに応じて nの値
が変わるはずです。

• パラメータ Kiおよび Kpを調整して、制御ループの
動作を最適化することができます。

4.7.3 まとめ

このレッスンでは、ASCET で以下の作業を行いました。

• 連続系ブロックを作成し、定義する

• 連続系ブロックの実験を行う

• 連続系ブロックをプロジェクトに統合する

• 変数の結びつきを定義する

• 異なるターゲットに切り替える

• プロジェクトの実験をオンラインで行う

4.8 ステートマシン

ステートマシンは、有限数の明確なステート間を遷移するシステムをモデリングす
る際に有効な手段です。ASCET は、コンポーネントをステートマシンとして定義す
るための強力な機能を備えています。このレッスンでは、温度によるアイドリング
エンジンの目標回転数の変化を表す、単純なステートマシンを定義しテストします。
それから、そのステートマシンをプロジェクトに統合します。そして次のレッスン
で階層ステートマシンを構築します。

エンジンが冷えている時には、高速アイドリングさせて回転を維持する必要があり
ます。エンジンが暖まったら、燃料消費を減らすためにアイドリングの回転速度を
下げます。このためのステートマシンは「エンジンが冷えている」および「エンジ
ンが暖まっている」という 2 つのステートを持つ 2 段階制御を行います。

4.8.1 ステートマシンを定義する

ステートマシンは、ステート図と、アクションやコンディションの定義から構成さ
れます。アクションやコンディションの定義により、さまざまなステート内におい
て、またステートからステートへの遷移時に何を行うかを指定できます。

アクションとコンディションのダイアグラムは、ブロックダイアグラムエディタや

ESDL エディタで定義します。また、ESDL エディタを使用せずに各ステートやトラ
ンジションごとに開くテキストエディタに ESDL コードを直接書き込む方法もありま
す。ステートマシンには、他のコンポーネントとのデータ交換に使用される入力と
出力があります。

ステートマシンを作成する：

• コンポーネントマネージャで、フォルダ Tutorial/
Lesson8を作成します。

• Insert → State Machine を選択するか、または 
Statemachine ボタンをクリックして新しいステート
マシンを作成します。

• 作成したステートマシンの名前を WarmUpにします。

測定開始OS 起動
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• “1_Database” リスト内の新しいステートマシンの名
前をダブルクリックして、ステートマシンエディタを
開きます。

ステートマシンを作成するには、まずステートダイアグラムを定義して、続いてス
テートやステートトランジションに関連付けるさまざまなアクションやコンディ
ションを定義します。

エンジンをコントロールするこのステートマシンには、「エンジンが冷えている」お
よび「エンジンが暖まっている」という 2 つのステートがあります。

ステートダイアグラムを定義する：

• State ボタンをクリックして、カーソルにステートア
イテムをロードします。

• 描画エリア内の、ステートを配置したい位置をクリッ
クします。

クリックした位置にステートシンボルが表示されま
す。

• ステートシンボルをもう 1 つ作成し、描画エリア内の
最初のステートの下に配置します。
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• 先に作成したステートシンボルを右クリックし、
ショートカットメニューから Edit State を選択して、
ステートエディタを開きます。

• “State” フィールドに coldEngineというステート
名を入力します。

• Start State オプションをオンにして、このステート
を、最初にステートマシンが起動されたときのステー
ト（「開始ステート」）にします。

1 つのステートマシンには必ず開始ステートを 1 つ定
義する必要があります。

• OK をクリックして、ステートエディタを閉じます。

ステートの名前が、ステートシンボル内に表示されま
す。

• もう 1 つのステートシンボルの名前を warmEngine
にします。

• 描画エリア内のシンボルが表示されていない位置を右
クリックして、 接続モードに切り替えます。

• coldEngineステートシンボルの右半分をクリック
して接続を開始し、 次に warmEngineステートシ
ンボルの右半分をクリックして、両ステートを接続し
ます。

両ステートシンボルを結ぶ線が引かれます。この線は
下向きの矢印になっていて、ステート間で起こり得る
トランジションを表します。
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• warmEngineから coldEngineへ、もう 1 つのト
ランジションを作成します。

• File → Save を選択し、作成したステートマシンを保
存します。

• コンポーネントマネージャで File → Save を選択して
データベースを保存します。

ステートマシン構築のための次のステップとして、インターフェースを定義します。
ここでは温度値用の入力と、回転数用の出力が必要です。さらに、高温と低温、お
よび回転数（rpm）を定義するパラメータも必要です。

ステートマシンのインターフェースを定義する：

• 入力 tを作成します。

• 出力 n_nominalを作成します。

• Continuous Parameter ボタンで 4 つのパラメータ
を作成します。

• 各パラメータの名前と値を以下のように設定します。

t_up = 70

t_down = 60

n_cold = 900

n_warm = 600

次に、両ステートと、その間のトランジションについて、アクションとコンディ
ションを定義します。各ステートに定義できるアクションは以下の 3 種類です。

• そのステートに入るたびに実行される Entry アクション

例外： ステートマシンの初回の起動時において、開始ステートの Entry アク
ションは実行されません。

• そのステートを離れるたびに実行される Exit アクション

• そのステート内に留まって、状態が変化しない時に実行される Static アクショ
ン

同様に、各トランジションには、トリガイベント、コンディション、優先度および
アクションを定義することができます。トリガ名とコンディション名は、トランジ
ションの隣に表示されます。ステートマシンが作成されるとトリガが 1 つ、自動的
に作成されます。

アクションとコンディションは、普通のダイアグラムか ESDL コードで定義されま
す。この例では、ESDL コードを使用します。

トリガのアクションとコンディションを定義する：

• coldEngineステートから warmEngineに向かっ
て接続されているトランジションを右クリックしま
す。

• ショートカットメニューから Edit Transition を選択
して、トランジションエディタを開きます。

coldEngineから warmEngineへ遷移するための
条件は、 「実際の温度値 tが t_upより大きい」と
いうことです。
チュートリアル 87



88
• “Condition” タブのコンボボックスから <ESDL> を
選択します。

このコンボボックスでプリセットされているオプショ
ン設定は、ASCET オプションダイアログボックスの

“Defaults” ノードで変更することができます。

• コンディションのコードペインに、下図のコードを入
力します。

1 行目はコメントで、2 行目が実際のコンディション
（遷移条件）になります。

このコンディションの評価結果が trueなら、 エン
ジンのアイドリング速度が n_warmになります。

このコードはステートマシンダイアグラムに表示され
ます。この例では、トランジションのコンディション
に別名（1 行目のコメント）を付けたので、それがダ
イアグラムに表示されます。

• アクション用にも <ESDL>を選択し、 以下のコード
を入力します。

n_nominal = n_warm;

• OK をクリックして、トランジションエディタを閉じ
ます。

ダイアグラムには、ステートマシンのコンディション
とアクションが表示されます。

• warmEngineから coldEngineへのトランジショ
ンを編集するために、 別のエディタを開きます。

• コンディションに <ESDL>を選択し、 以下のコード
を入力します。

t < t_down

このコンディションには別名（コメント）を付けな
かったので、ダイアグラムにはこのコンディションの
コード全体が表示されます。

注記

トランジションエディタでは、コンディションの終わ
りにセミコロンを付けません。これは、通常の ESDL
コードにおいてコンディションを括弧で囲んで記述す
る場合も同じです。
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• アクションに <ESDL>を選択し、下図のコードを入
力します。

n_nominal = n_cold;

• エディタを閉じ、File → Save を選択します。

アクションとコンディションは、ESDL の代わりに BDE で定義することもできます。
詳しくは ASCET のオンラインヘルプを参照してください。

この時点で、出力 n_nominalの初期値はまだ定義されていません。 パラメータ
とは異なり、 この値を設定することはできないので、 代わりに開始ステートであ
る coldEngineのアクションを定義します。ただし開始ステートの Entry アク
ションは最初にステートマシンが起動された時には実行されないため、初期値の定
義は Static アクション内で行う必要があります。

Static アクションを定義する：

• 開始ステート coldEngineを右クリックします。

• ショートカットメニューから Edit State を選択して、
ステートエディタを開きます。

• “Static” タブのコンボボックスから <ESDL>を選択
して、Static アクションを定義します。

ここでの設定は、ASCET オプションダイアログボッ
クスの “Defaults” ノードで設定されているデフォル
トの記述形式よりも優先されます。

• コードペインに n_nominal = n_cold;と入力し
て、 n_nominalの初期値を 900にします。

• OK をクリックして、ステートエディタを閉じます。

これで、ステートマシンの定義が終わりました。この実験を開始する前に、ここで
あらかじめステートマシンの動作を理解しておいてください。

4.8.2 ステートマシンの動作

一般的に、標準コンポーネントの動作（機能）はそのグラフィック記述を見れば簡
単に理解できますが、ステートマシンの場合はその動作が一見ではわかりにくい場
合があります。本項では、前項の例を用いて、ステートマシンの原理について説明
します。ステートマシンとその機能についての詳細は、ASCET オンラインヘルプの
ステートマシンエディタに関するトピックを参照してください。
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ステートマシンの各ステートにはステート名、Entry アクション、Static アクショ
ン、および Exit アクションが定義されています。さらに、各ステートは他のステー
トからとの間にトランジション（状態遷移を表す接続線）を持ち、各トランジショ
ンには優先度、トリガ、アクションおよびコンディションが定義されています。

各ステートマシンにはそれぞれ 1 つの開始ステートが必要です。ステートマシンが
初めて起動されると、開始ステートが有効になり、開始ステートのアクション（つ
まりステートマシンの初期処理）が実行された後、開始ステートから他のステート
へのトランジションを発生させるコンディションが調べられます。この例では、こ
のようなトランジションは 1 つしかなく、そのコンディションは t > t_upです。
ここでは、入力値が t_upパラメータの値より大きいかどうかが調べられます。も
しそうならコンディションは真（true）なので、トランジションが発生します。

パラメータ t_up および t_down は温度を規定します。エンジンがこれらの温度
にならないと、目標回転速度を変更することができません。今の例では、エンジン
温度が 70 度を超えたら、回転速度を 600rpm に下げることができます。その後、
エンジン温度が 60 度を下回ると、目標速度を 900rpm にリセットしなければなり
ません。

トランジションが発生すると必ず、そのトランジションに定義されているトランジ
ションアクションが実行されます。今の例では、coldEngineから warmEngine
へのトランジションが発生すると実行されるトランジションアクション

n_nominal = n_warmにより、 変数 n_nominalの値が 600 になります。反対
に、トランジションアクション n_nominal = n_coldは n_nominalの値を

900 にします。トランジションが発生すると、離れようとするステートの Exit アク
ションと、入ろうとするステートの Entry アクションも実行されます。この例では、
これらのアクションは定義されていないので、何も行われません。

ステートマシンが第 2 のステートに入ると、第 2 のステートから第 1 のステートへ
のコンディションが満たされるまでは、第 2 のステートに留まります。ステートマ
シンが 1 つのステートに留まっている間は、ステートマシンが起動されるたびに

Static アクションが実行されます。ステートマシンを起動させるのは必ず外部のイベ
ントで、1 回の起動によりステートマシンの 1 回のパスが開始されます。

ステートマシンの 1 回のパスは、まず現在のステートから他のステートへのトラン
ジションについてのすべてのコンディションを調べることから始まります。コン
ディションは、その優先度の順に調べられます。あるコンディションが true なら、
それに対応するトランジションが発生し、Exit アクション、トランジションアク
ションおよび Entry アクションが実行されます。最初に調べたコンディションが

true だった場合、同じステートから他のステートへの他のトランジション（最初に
調べたコンディションよりも優先度が低いコンディション）は調べられません。ど
のコンディションも true でない場合には、現在のステートのままになり、そのス
テートに留まるパスが実行されるたびに Static アクションが 1 回実行されます。

第 2 のトランジションのコンディションが true になると、つまり、入力値がしきい
値よりも小さくなると、ステートマシンは第 1 のステートに戻ります。それから、
入力値が再びしきい値より大きくなるまでは、そのステートのままになります（第

1 のステートには Static アクションが定義されていないので、何も行われません）。

4.8.3 ステートマシンの実験を行う

実験には、ステートマシンの場合も他のタイプのコンポーネントの場合と同様の機
能がありますが、それ以外に、ステートマシンの実験を行う場合にだけ使用できる
アニメーションという機能があります。これは、実験実行中にステートマシンダイ
アグラム内のカレントステート（現在アクティブになっているステート）を強調表
示する機能です。
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ステートマシンの実験を行う：

• ステートマシンエディタで Build → Experiment を
選択して、実験環境を開きます。

• ステートの 1 つを右クリックし、ショートカットメ
ニューから Animate States を選択します。

• triggerイベントをイネーブルにします。

• データジェネレータで、変数 tのチャンネルを作成し
ます。

• このチャンネルに周波数 1Hz、オフセット 70、振幅

20 の正弦波を割り当てます。

• t および n_nominal用のオシロスコープウィンド
ウを開きます。

• Start Offline Experiment ボタンをクリックして、
ステートマシンの実験を行います。

• 個々のステートの色を変えて表示を見やすくするため
に、Exit to Component ボタンで実験環境を終了し、
ステートエディタを開きます。

• “Color” コンボボックスで色を選択します。

• 再度実験を行います。

実験が実行されると、n_nominalの値は、正弦波が対応する温度しきい値を上回っ
たり下回ったりするたびに変化します。適合システムを使用してしきい値を変更し、
それによる出力の変化を調べることができます。また、ステートダイアグラムにお
いては、カレントステートが強調表示されます。
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4.8.4 ステートマシンをコントローラに統合する

ステートマシンは、ASCET の他のコンポーネントと同様に、別の任意のタイプのコ
ンポーネントを構成する要素として用いることができます。ここでは、ステートマ
シンをコントローラモジュールに統合し、回転速度をエンジン温度に合わせて調整
できるようにしましょう。

ステートマシンを統合する：

• コンポーネントマネージャから、ブロックダイアグラ
ムエディタでモジュール Lesson4/IdleConを開き
ます。

• ダイアグラムと “Outline” タブから、パラメータ

n_nominalを削除します。

ブロックダイアグラムにおいて、このパラメータの代
わりにステートマシンを使用します。

• Insert → Component を選択し、コントローラの

“Outline” タブにステートマシンを追加します。

• 受信メッセージを作成し、その名前を tにします。

• 削除した変数の代わりにコンポーネント WarmUpの
出力を減算の演算子に接続し、同コンポーネントの入
力を受信メッセージ tに接続します。

• ダイアグラムを下図のように調整します。すべてのア
イテムが正しい順序で接続されるように、シーケンシ
ングを調整します。

• ダイアグラムを保存し、コンポーネントマネージャで

Save ボタンをクリックします。

修正後のコントローラをプロジェクト内で機能させるために、プロジェクトにも変
更を加える必要があります。今度は、まだ使用されていなかった温度センサも統合
します。

プロジェクトを変更する：

• プロジェクト ControllerTest用のプロジェクト
エディタを開きます。

• “OS” タブに切り替えます。

• プロセス t_samplingをタスク Task10msに割り
当てます。

• Task → Move Up を使用して、プロセス

t_samplingをタスクの先頭に配置します。

• Build → Experiment を選択します。
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• 値 U_t用に、もう 1 つのスカラ適合ウィンドウを開
きます。

• 変数 tをオシロスコープに追加します。

• Start Measurement ボタンをクリックします。

• Start OS ボタンをクリックします。

• 値 U_tを調整し、その影響を調べます。

t の値が限界値（70 度）を超えると、ステートマシ
ンは n の目標値を低い方の値 600 に切り替えます。
温度が 60 度を下回ると（U_tを調整することにより
シミュレートされます）、 nの目標値は元の値 900
に戻ります。

4.8.5 まとめ

このレッスンでは、ASCET で以下の作業を行いました。

• ステートダイアグラムを作成する

• コンディション、アクション、およびトリガを作成し、ステートマシンに割
り当てる

• ステートマシンの実験を行う

• ステートマシンを他のコンポーネントに統合する

4.9 階層ステートマシン

前のレッスンでステートマシンの機能について理解できたので、今度はやや複雑な
システムを構築してみます。このレッスンでは階層ステートマシンについて集中的
に学習し、また、タイマなど ASCET に付属しているシステムライブラリとコンポー
ネントの使用法を学びます。

ASCET では、閉階層と開階層を用いてステートマシンを構築することができます。
開階層の場合はその中に含まれるサブステートも図示され、閉階層の場合それらは
省略されます。

交通信号制御システムを構築して、パラメータで指定できるタイミングを使用して
交通信号の各フェーズへの移り変わりを実現してみましょう。この交通信号にはエ
ラーステータスもあり、そのときには信号が点滅します。

4.9.1 ステートマシンを定義する

まず、必要なライブラリをインポートして準備します。

システムライブラリをインポートする：

• コンポーネントマネージャで Import ボタンをクリッ
クします。

“Select Import File” ダイアログボックスが開きます。

• “Import” フィールドの  ボタンで、 ASCET のイン
ストールディレクトリ下のエクスポートディレクトリ

（例：C:¥etas¥ASCET6.1¥export） に格納され
ている ETAS_System_Library.*1 というファイ
ルを選択します。

OK ボタンが有効になります。

1. * = exp（バイナリエクスポートファイル）または axl（XML ベースのエクスポート
フォーマット）

測定開始OS 起動
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• OK をクリックしてインポートを開始します。

“Import” ダイアログボックスが開き、選択された
ファイルに含まれるすべてのオブジェクトが一覧表示
されます。

• OK ボタンをクリックします。

ファイルがインポートされます。この処理には数分か
かります。インポートが終了すると、インポートされ
たアイテムの一覧が “Import Items” ウィンドウに表
示されます。

次に、交通信号を制御するために必要な 2 つのメインステート（NormalModeと

ErrorMode）を定義します。

ステートマシンを作成する：

• コンポーネントマネージャで、フォルダ Tutorial/
Lesson9を作成します。

• Insert → State Machine を選択して、新しいステー
トマシンを作成し、その名前を Lightにします。

• Edit → Open Component ボタンをクリックして、
ステートマシンエディタを開きます。

ここから、交通信号を制御するステートマシンを定義
します。

• 2 つのステート ErrorModeおよび NormalModeを
作成します。

次に、システムライブラリのタイマをプロジェクトに追加します。

タイマオブジェクトを追加する：

• Insert → Component を選択します。

• “Select item” ダイアログボックスで、

ETAS_SystemLibライブラリの Counter_Timer
フォルダにあるタイマオブジェクト、 Timerを選択
します。

• OK で確定します。

ステートマシンの “Outline” タブにオブジェクト

Timerが追加されます。

ステートダイアグラムを定義する：

• 必要なデータエレメントを以下のように定義します。

－ Logic型の入力 error

－ 信号の 3 色を表す、Logic型の 3 つの出力
（yellow、 green、 red）

－ 信号のさまざまなフェーズを表す、

Continuous型の 4つのパラメータ
（BlinkTime、 YellowTime、
GreenTime、 RedTime）

依存パラメータについて理解を深めるために、緑色の
フェーズの値だけを定義し、他のパラメータには緑色
のフェーズの値に依存する値が設定されるようにしま
す。
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RedTime = 2 * GreenTime
YellowTime = GreenTime/3
BlinkTime = YellowTime/10

• 次に、個々のパラメータの計算式と依存関係を定義し
ます。

• このためには、パラメータ RedTime、
YellowTimeおよび BlinkTimeについて、プロパ
ティエディタの “Dependency” の下にある 
Dependent オプションをオンを選択します。

プロパティエディタを起動するには、パラメータをダ
ブルクリックするか、または Edit ショートカットメ
ニューを使用します。

• Formula ボタンをクリックしてフォーミュラエディ
タを開きます。

• フォーミュラエディタを使用して、それぞれの依存パ
ラメータについての計算式を定義します。

Redtime : 2*x
YellowTime : x/3
BlinkTime : x/10

• フォーミュラエディタとプロパティエディタを閉じま
す。

• ショートカットメニュー Edit Data でディペンデン
シーエディタを開きます。

• それぞれの依存パラメータの仮パラメータ xに対応す
るモデルパラメータを割り当てます。 

RedTime : x = GreenTime
YellowTime : x = GreenTime
BlinkTime : x = YellowTime

• データエレメントに有意義な値を与えます（例、

GreenTime = 5）。

• ステート ErrorModeステートエディタで開きます。

• このステートを開始ステートとして定義し、色を赤に
します。

• 両方のステートを拡大表示し、階層を挿入できるよう
にします。

• 2 つのステートの間にトランジションを作成します。

• トランジションダイアログボックスにコンディション
を入力して、2 つのステートの間のトランジションを
定義します。入力 errorが false（つまり、エラー
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が発生していない）なら正常ステート NormalMode
になり、 エラーの場合には ErrorModeになるよう
に、ESDL でコンディションを記述します。

• File → Save を選択します。

• コンポーネントマネージャで作業内容を保存します。

• これらのメインステートについて、実験を行ってみて
ください。

次に、交通信号制御システムに必要なサブステートを定義します。ここではまずエ
ラーモード（ErrorModeステート）における処理を定義します。このステートでは、
黄色の点滅光が出力されます。このためには、YellowOffおよび YellowOnとい
う 2 つのサブステートを定義し、この両者間の切り替えをタイマで行うようにしま
す。YellowOnステートでは出力 Yellowが trueになり、YellowOffステート
では falseになります。

エラーモード用のサブステートを定義する：

• YellowOffおよび YellowOnというステートを作
成し、 それらをステート ErrorMode内に配置しま
す。

• YellowOffを開始ステートとして定義し、

YellowOnの色を黄色にします。

• ステート YellowOffの応答をステートエディタで
以下のように定義します。

－ Entry アクションを入力します。“Entry” タブの
コンボボックスで ESDLを選択し、以下ののコー
ドを入力します。

green = false;
red = false;
yellow = false;
Timer.start(BlinkTime);

－ Static アクションを入力します。“Static” タブに
以下のコードを入力します。
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Timer.compute();

• 次に YellowOnステートについて定義します。

Entry アクション：

yellow = true;
Timer.start (BlinkTime);

Static アクション：

Timer.compute();

• 今度は、2 つのサブステートの間のトランジションを
定義します。

状態遷移の条件は、タイマがタイムアウトすること
（Timer.out() == false）です。

つまり、ErrorModeステートは YellowOffステートで開始されます。このステー
トの Entry アクションで、黄色の点灯信号をオフにし、パラメータで指定される点
滅時間を計測するタイマを起動します。このステートの Static アクションではタイ
マ関数 compute()が毎回起動され、タイマカウンタをデクリメントします。この
カウンタ値が 0 になると、タイマ関数 out()がコード falseを返し、トランジ
ションのコンディションが真になります。そして、ステート YellowOnでは、Entry
アクションにより、黄色の点灯信号 Yellowがオンになります。

次に、正常動作時の動作を定義します。このためには、開始ステート AllOffを作
成して NormalModeステート内に配置します。そしてその Exit アクションで各色
の点灯信号を定義されたステートに設定します。では、交通信号制御システムとし
て、どのように処理すればよいかを考えてみましょう。

この例では、各色の点灯信号のオン／オフ切り替えを、今までのようにステートの

Entry アクションにではなく、トランジションアクションに定義します。

正常動作時のサブステートを定義する：

• ステート AllOff（開始ステート）、Yellow、Red、
RedYellow、Greenを作成して、NormalModeス
テート内に配置します。

• これらのステートの動作を定義します。これには、

Entry アクションで各色用のタイマを起動し、Static
アクションでタイマ処理（Timer.compute()）を行
うようにします。
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• ステートトランジションを定義し、トランジションア
クション内にステートの動作を定義します。

正常時は AllOffステートから Yellowステートに
遷移し、他のトランジションは、対応するタイマのカ
ウントダウンが終了した時に発生します。

• 各色の点灯信号用のアクションを、トランジションエ
ディタの “Action” タブに入力します。

• トランジションエディタを閉じて、File → Save を選
択します。

これで、交通信号制御システムの定義が終わりました。この実験を始めるには、各
色用タイマのパラメータに適切な値を入力する必要があります。

4.9.2 階層ステートマシンの実験を行う

階層ステートマシンの実験も、基本的なステートマシンの実験と同じ方法で行うこ
とができます。実験では、アニメーション機能を起動することを忘れないでくださ
い。

ステートマシンの実験を行う：

• ステートマシンエディタで Build → Experiment を
選択して、実験環境を開きます。

• ステートの 1 つを右クリックし、ショートカットメ
ニューから Animate States を選択します。

• triggerイベントをイネーブルにします。

• Start Offline Experiment ボタンをクリックして、
ステートマシンの実験を行います。

• GreenTimeパラメータの値を変更し、依存パラメー
タの値を変化させてください。

• error入力を trueにして、動作の変化を確認して
ください。
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4.9.3 階層ステートマシンの動作

階層ステートマシンは、通常のステートマシンと同じように機能します。基本的に、
階層ステートマシンはさまざまな動作すべてをグラフィック構造で表しているにす
ぎません。余裕のある方は、階層ステートマシンで定義した動作を、どのようにす
れば階層なしで実現できるか考えてみましょう。

この交通信号の例では、2 つの階層ステートを使いました。システムは論理入力変
数 errorの値に応じて、 2つのステート ErrorModeと NormalModeを切り替
えます。 それぞれの動作は、 これらのステートの中で定義されています。

これを理解するために、 ErrorModeステート内の処理に注目してみましょう。
トリガが起動されるたびに、 階層ステート ErrorModeから NormalModeへのコ
ンディション （コンディション ： !error） が調べられます。 主要ステートの
トランジションが必要ない場合には、 サブステートのトランジション YellowOff
から YellowOnへ、 またはその逆のトランジションのコンディションが調べら
れ、 必要なアクションが行われます。

NormalModeについて考えてみると、 トリガが呼び出されるたびに、 まず

error入力が trueかどうか、 つまり遷移が必要かどうかが調べられ、 この条件
に該当しなかった場合にのみ、 各サブステート （AllOff、 Yellow、 Red、
RedYellow、 Green） 間のコンディションが調べられます。 交通信号の例で
は、 タイマがタイムアウトしたかどうかも調べられます。

以上の処理を明らかにするために、ステートダイアグラムから生成されるコードを
見てみましょう。

生成されたコードを表示する：

• ステートマシンエディタで Build → View 
Generated Code を選択して、生成されたコードを
表示します。

コンポーネントのコードはテンポラリファイルに書き
込まれ、Windows に登録されているアプリケーショ
ンで開かれます。

4.9.4 まとめ

このレッスンでは、ASCET で以下の作業を行いました。

• 階層ステートダイアグラムを作成する

• ステートアクションとトランジションアクションの動作を定義する

• モジュール、クラス、コンポーネントをインポートする

• ASCET ライブラリのシステムコンポーネントをインポートする

• 既存の Timer コンポーネントを使用する

• 依存パラメータを使用する

• 生成されたコードを表示する

注記

生成されたコードを表示する際、拡張子 *.cおよび

*.hのファイルに関連付けられているアプリケーショ
ンが、Windows のレジストリ内から検索されて開きま
す。
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5 用語集

この用語集では、ASCET のドキュメントで使用されている用語について解説しま
す。各用語の一般的な意味よりも、ここでは、ASCET について使用される場合の意
味について説明します。

用語はアルファベット順、あいうえお順に並んでいます。

5.1 略語集

ASAM-MCD

Assosiation for the Standardization of Automation and Measurement 
systems（オートメーションおよび測定システム標準化委員会）の、測定

（Measurement）、適合（Calibration）および診断（Diagnosis）についての
ワークグループ

ASCET

ECU ソフトウェア開発ツール

ASCET-MD

ASCET Modeling and Design - ASCET モデリング／デザインツール

ASCET-RP

ASCET Rapid Prototyping - ASCET ラピッドプロトタイピングツール

ASCET-SE

ASCET Software Engineering - ASCET ソフトウェアエンジニアリングツール

AUTOSAR

Automotive Open System Architecture（ÜííéWLLïïïK~ìíçë~êKçêÖL 参照）

BD

Block Diagram（ブロックダイアグラム）

BDE

Block Diagram Editor（ブロックダイアグラムエディタ）

CPU

Central Procesing Unit（中央演算処理装置）

ECU

Embedded Control Unit（組み込み制御ユニット）

ERCOSEK

OSEK 準拠の ETAS リアルタイムオペレーティングシステム

ESDL

Embedded Softare Description Language（組み込みソフトウェア記述言語）

ETK

独語： Emulatortastkopf（Emulator Test Probe：エミュレータ・テストプ
ローブ）

FPU

Floating Point Unit（浮動小数点演算ユニット）

HTML

Hypertext Markup Language（ハイパーテキストマークアップ言語）

INCA

Integrated Calibration and Acquisition Systems（統合計測・適合システム）
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INTECRIO

ETAS の新しい製品ファミリ。さまざまなビヘイビアモデリングツールで作成
されたコードを統合してコンフィギュレーション設定や実行コードの生成を
行い、ラピッドプロトタイピング実験を行うための実験環境を提供します。

OS

Operating System（オペレーティングシステム）

OSEK

独語：Arbeitskreis Offene Systeme fur die Elektronik im Kraftfahrzeug
（Open Systems and the Corresponding Interfaces for Automotive 
Electronics：自動車エレクトロニクス用オープンシステムおよびインター
フェース）

RAM

Random Access Memory（ランダムアクセスメモリ）

RE

Runnable entity（ランナブルエンティティ： 実行時に RTE によってトリガさ
れる、SWC 内の一連のコードで、ASCET の「プロセス」にほぼ相当するも
の）

ROM

Read Only Memory（読み取り専用メモリ）

RTA-RTE

ETAS の AUTOSAR runtime environment（ETAS の AUTOSAR 実行環境）

RTE

AUTOSAR runtime environment（AUTOSAR 実行環境： ソフトウェアコン
ポーネント、基本ソフトウェア、オペレーティングシステム間のインター
フェースを提供するもの）

SM

Stetae Machine（ステートマシン）

SWC

Atomic AUTOSAR software component（アトミックな AUTOSAR ソフト
ウェアコンポーネント： AUTOSAR における分割不可能な最小単位のソフト
ウェアコンポーネント）

UML

Unified Modeling Language（統一モデリング言語）

XML

Extensible Markup Language（拡張マークアップ言語）

5.2 その他の用語

ASAM-MCD-2MC ファイル

プロジェクト用のデータ交換に使用される ASCII 形式の標準フォーマット
ファイルで、測定および適合に必要なディスクリプションが含まれています。

*.a2l という拡張子が付きます。

C コード

コンポーネントを記述する形式の 1 つで、内容はインプリメンテーションに
依存します。
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HEX ファイル

プログラムの 1 つのバージョンをハードウェア間で交換するためのファイル
形式です。フォーマットは Intel HEX と Motorola S Record のいずれかです。

Intel Hex

プログラムの 1 つのバージョンをハードウェア間で交換するためのファイル
形式です。

L1

ホストと、実験が行われているターゲットとの間でデータ転送を行うための
メッセージフォーマットです。データ転送は、たとえば測定ウィンドウでの
値の表示のために行われます

Motorola-S-Record

プログラムの 1 つのバージョンをハードウェア間で交換するためのファイル
形式です。

OSEK オペレーティングシステム

OSEK 準拠のオペレーティングシステムです。

アイコン

ASCET コンポーネントの機能を視覚的に表すために使用されます。

アクション

ステートマシンの構成要素で、ステートマシンのステートまたはトランジ
ションに関連付けて定義されます。一連の機能からなり、その実行はステー
トマシンによりトリガされます。

アプリケーションモード

ASCET のオペレーティングシステムの動作モードです。EEPROM プログラミ
ングや暖機運転モード、通常モードなどシステムに想定されるさまざまな状
態を表します。

イベント

オペレーティングシステムのアクション（タスクの起動など）の外部トリガ
となるものです。

イベントジェネレータ

実験環境の一部を成すもので、オフライン実験において、タスク（メソッド
／プロセス／タイムフレーム）起動のためのイベント生成の順序とタイミン
グを定義するために使用されます。

インターフェース

コンポーネントのインターフェースは、そのコンポーネントが他のコンポー
ネントとどのようにデータ交換を行うかを定義します。これは C 言語環境に
おける .h ファイルにたとえられるものです。

インプリメンテーション

物理記述（モデル）から実行形式の固定小数点コードへの変換方法を定義す
るものです。モデルデータの変換に使用される線形変換式と上下限値とで構
成されます。

インプリメンテーションキャスト

このエレメントを使用すると、連続する算術演算の中間値のインプリメン
テーションを、そのエレメントの物理表記を変えることなく任意に変更する
ことができます。
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インプリメンテーション型

プロジェクト全体で使用できる複数のインプリメンテーションを「インプリ
メンテーション型」として定義しておき、それを必要に応じて各エレメント
に個別に割り当てることができます。

ウィンドウエレメント

実験で使用される適合エレメントと測定エレメントを指す一般的な用語です。

エディタ

→「適合ウィンドウ」参照

エレメント

コンポーネントを構成する要素で、データ（変数やパラメータ、またはコン
ポーネント内で使用される他のコンポーネント）の読み取りや書き込みを行
います。

エレメントタイプ

エレメントのタイプには、変数、パラメータ、定数の 3 種類があります。変
数の値は読み取りも書き込みも可能です。パラメータの値は読み取ることし
かできませんが、実験中に適合（書き込みによる値の調整）を行うことがで
きます。定数の値は常に読み取ることしかできず、実験中でも書き込みは行
えません。

オシロスコープ

測定ウィンドウの一種で、実験中にデータの値をグラフ表示します。

オフライン実験

ASCET で生成されたコードが PC または実験ターゲット上で実行される環境
ですが、リアルタイムな実行はサポートされません。ここでは主にシステム
の機能記述についてのテストに重点が置かれます。

オペレーティングシステム

ASCET ソフトウェアシステムの起動や実行をスケジューリングするもので
す。また内部通信のためのサービス（メッセージ）やハードウェアの予約部
分（リソース）へのアクセスもサポートします。ASCET のオペレーティング
システムは、ERCOSEK というリアルタイムオペレーティングシステムをベー
スとしています。

オンライン実験

ASCET で生成されたコードが実験ターゲット上で、リアルタイムオペレー
ションシステムに設定された挙動に基づいてリアルタイムに実行されます。
ここでは、スケジューリング等のリアルタイムな挙動 すが、リアルタイムな
実行はサポートされません。ここでは主にシステムの機能記述についてのテ
ストに重点が置かれます。

階層

階層ブロックは、ブロックダイアグラムによるグラフィック定義を階層化
（構造化）するために使用します。

型 （またはモデルデータ型）

ASCET モデルでは、cont (continuous)、udisc (unsigned 
discrete)、sdisc (signed discrete)、log (logic)といったさま
ざまな型の変数やパラメータを使用できます。contは任意の値を持つこと
のできる物理量に使用され、udiscは正の整数値、sdiscは負の整数値に使
用されます。また logは論理値（trueまたは false）に使用されます。こ
れらの型は、生成されるコードで使用される実装データ型とは異なります。
加算や比較などさまざまな基本演算がそれぞれの型用に用意されています。
実装情報によって、モデルデータ型が実装データ型に変換されます。
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クラス

ASCET のコンポーネントの 1 つで、オブジェクト指向言語におけるクラスと
同じものです。クラスの機能はメソッドにより定義されます。

グループ適合カーブ／マップ

1 つの座標ポイントディストリビューションを共有する複数の特性カーブ／
マップを指し、総称して「グループテーブル」とも呼ばれます。各グループ
テーブルの出力値はそれぞれ異なります。座標ポイントのディストリビュー
ションと個々のグループテーブルは、それぞれ独立したエレメントとして定
義されます。

コード

コード（実行形式のコード）は、実際のアルゴリズムを含むプログラムで、
データは含まれません。コードは、CPU によって実行されるプログラムの部
分です。

コード生成

物理モデルから実行形式コードへの変換の第 1 ステップです。物理モデルが

ANSI C コードに変換されます。C コードはコンパイラ（つまりターゲット）
に依存するので、ターゲットごとに異なるコードが生成されます。

固定小数点コード

物理記述から生成されるコードの一種で、浮動小数点演算ユニットを持たな
いマイクロプロセッサ上で実行するためのものです。

コンディション

ステートマシンの制御フローを定義するためのものです。あるステートから
別のステートへのトランジションを発生させるかどうかを決める論理値を返
します。

コンテナ

プロジェクト、クラス、またはモジュールを保管しておくためのものです。
モデルやデータベース／ワークスペースの構築や、異なるデータベースアイ
テムやワースペースアイテムを共通のバージョン管理下に置くために使用さ
れます。

コンポーネント

ASCET における再利用可能な機能の基本単位です。コンポーネントはクラ
ス、モジュール、またはステートマシンによって定義されます。各コンポー
ネントは、演算子で接続されて機能を形成する数々のエレメントで構成され
ます。

コンポーネントマネージャ

ASCET の作業環境設定を行ったり、ユーザーによって作成されデータベース
またはワークスペースに格納されたデータの管理を行うためのユーザーイン
ターフェースです。

算術演算サービス

オンライン実験の環境設定が格納されます。測定／適合ウィンドウに関する
情報（ウィンドウのサイズや位置、およびウィンドウに含まれるデータチャ
ンネルの割り当てやサンプリングレート、表示形式等）や、イベントジェネ
レータ、データジェネレータ、データロガー等の設定が含まれます。

実験

コンポーネントやプロジェクトの機能をテストするために使用される実験環
境の設定が定義されたものです。ここには、測定ウィンドウや適合ウィンド
ウに関する情報（ウィンドウのサイズや位置、およびその内容）や、イベン
トジェネレータ、データジェネレータ、データロガーについての設定が含ま
れます。実験は、オフライン（非リアルタイム）またはオンライン（リアル
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タイム）で行われ、バイパスまたはフルパス環境において物理プロセスを制
御するシミュレーションが行われます。どの条件においても、ASCET で記述
されたモデルから生成されたコードが使用されます。

実験環境

測定／適合作業を行うための操作環境です。

実装データ型

C 言語の基礎であるデータ型（unsigned byte=Euint8F、signed word=
Esint16F、float）を指します。

スケジューリング設定

プロセスへのタスクの割り当て、およびオペレーティングシステムによるタ
スク起動に関する定義です。

スコープ

各エレメントは、ローカル（コンポーネント内でのみ使用可能）またはグ
ローバル（プロジェクト内で定義されている）のスコープを持ちます。

ステート

ステートマシンを構成する要素です。ステートマシンは常にそのステートの
うちの 1 つの状態（つまり、いずれか 1 つのステートがアクティブな状態）
になっています。いずれか 1 つのステートが開始ステートとしてマークされ
ていて、これがステートマシンの初期ステートになります。ステート同士は
トランジション（遷移）を示す曲線で接続されています。各ステートには

Entry アクション（そのステートに入ったときに実行されるアクション）、

Static アクション（そのステートのまま変わらないときに実行されるアク
ション）、および Exit アクション（そのステートから出るときに実行されるア
クション）が定義されます。

ステートマシン

ASCET のコンポーネントの 1 つです。その挙動は、トランジションで接続さ
れる複数のステートによって構成されるステートダイアグラムで記述されま
す。

測定値

実験中に画面上に表示される変数やパラメータの値です。値は、さまざまな
測定ウィンドウ（オシロスコープや数値ディスプレイ）に表示することがで
きます。

測定ウィンドウ

実験中に測定信号を表示する、ASCET の作業ウィンドウです。

測定チャンネルパラメータ

測定モジュールの個々のチャンネル用に設定されるパラメータです。

ターゲット

実験の対象となるハードウェアを指します。ターゲットには実験ターゲット
（PC、トランスピュータ、PowerPC）とマイクロコントローラターゲット
（ECU）があります。

ダイアグラム

コンポーネントをブロックダイアグラムまたはステートマシンによって定義
するために使用される記述形式です。
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タスク

オペレーティングシステムから起動される単位で、その中に複数のプロセス
とその実行順が割り当てられます。タスクは、アプリケーションモード、起
動用のトリガ、優先度、スケジューリングモード等の属性を持ちます。タス
クが起動されて実行されると、そのタスクに割り当てられたプロセスが指定
された順序で実行されます。

定数

ASCET モデルの実行中に値を変更することのできないエレメントです。

ディスクリプションファイル

ECU 内の特性値と測定変数の物理情報（名前、アドレス、変換式、ファンク
ション割り当てなど）を記述するファイルです。

ディストリビューション

1 つまたは複数の特性カーブ／マップのブレイクポイント（「サンプルポイン
ト」ととも呼ばれます）が定義されたものです。

ディメンション

基本エレメントのサイズを定義するものです。ディメンションの型は、スカ
ラ（0 次元）、配列（1 次元）、特性カーブ／テーブルのいずれかです。

データ

プログラム用の変数の集合で、適合時に使用されます。

データジェネレータ

実験環境の一部を成すものです。実験対象のモデルの入力または変数をス
ティミュレートするために使用されます。

データセット

コンポーネントまたはプロジェクトのすべてのエレメントの初期データ、あ
るいはその参照が設定されています。

データベース

ASCET で生成されるすべての情報が格納されます。ASCET 内ではデータベー
スはフォルダによる階層構造になっています。Windows ファイルシステムに
おいては、1 つのデータベースは 1 つのバイナリファイルとして保存されま
す。

データロガー

実験環境で測定されるデータを読み取り、後で分析できるようにディスクに
保存する機能を持ちます。

適合

ASCET モデルの実行（実験）中に、パラメータの値（物理／インプリメン
テーション）を調整することです。

適合ウィンドウ

パラメータの修正に使用する ASCET の作業ウィンドウです。

特性カーブ

2 次元のパラメータ（適合変数）です。

特性データ

マップ、カーブ、および特性値を表す一般的な用語です。（「パラメータ」も
参照してください。）

特性値

1 次元のパラメータ（適合変数）です。
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特性マップ

3 次元のパラメータ（適合変数）です。

トランジション

ステート間の遷移を表し、起こり得るステートの遷移について記述されたも
のです。各トランジションにはステートマシンのトリガの 1 つが割り当てら
れ、優先度、コンディション、アクションを持ちます。

コンディション

ステートマシンのフロー制御を定義するために使用されます。あるステート
から別のステートへのトランジションを起こすかどうかを決める論理値を返
します。

トリガ

タスクの実行、またはステートマシンの実行をトリガ（起動）するものです。

バイパス実験

ASCET がマイクロコントローラに直接接続され、マイクロコントローラソフ
トウェアの一部をシミュレートする実験です。

配列

基本スカラ型 continuousまたは discreteの静的な 1 次元リストで、基
本スカラ型 discreteのインデックスを持ちます。

パラメータ

ASCET のモデル内での計算では値を変更できないエレメント（特性値、特性
カーブ、および特性マップ）です。ただし実験中に適合させることができま
す。

引数

クラスメソッドへの入力です。その引数が属するメソッドの記述においての
み使用でき、クラス内の他のメソッドでは使用できません。

フォルダ

ASCET データベース／ワークスペースの階層構造を形成する単位で、この中
に各アイテムが格納されます。

フルパス実験

ASCET が実験用マイクロコントローラに直接接続され、アプリケーション全
体が ASCET によってシミュレートされる環境です。

プログラム

コードとデータから構成され、ECU の CPU により実行される 1 つの単位で
す。

プログラムバージョン

ECU プログラムが格納された HEX ファイルを指します。プログラムバー
ジョンの一部が、データバージョンと共に 1 つのファイルとなります。

プロジェクト

組み込みソフトウェアシステム全体についての記述です。機能を定義するコ
ンポーネント、オペレーティングシステムに関連した設定、および内部通信
を定義するバインディングのしくみが記述されます。

プロセス

並行して実行される機能の単位で、オペレーティングシステムにより起動さ
れます。プロセスはモジュール内に記述され、引数／入力や戻り値／出力を
持ちません。
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ブロックダイアグラム

コンポーネントをグラフィカルに記述するものです。さまざまなエレメント、
演算子、および入力／引数や出力／戻り値が、方向性のある線で接続されま
す。1 つのブロックダイアグラムは複数のダイアグラムで構成されます。ブ
ロックダイアグラムによる記述は、C コードによる記述とは異なり、物理記
述です。

変換式

インプリメンテーション（実装情報）の一部で、データのモデルデータ型か
ら実装データ型への変換方法を定義するものです。

変数

ASCET のモデルの実行中にモデルから値の読み取りや書き込みができるエレ
メントです。また適合作業において値を変更することもできます。

また広義では、パラメータ（特性データ）と測定信号を示す一般的な用語と
しても使用されます。

メソッド

オブジェクト指向プログラミングで使用されるクラスにおいて、そのクラス
の機能の一部を記述するものです。メソッドは任意の数の引数と 1 つの戻り
値を持ちます。

メッセージ

並行して実行されるプロセス間のデータ交換の整合性を保証するための、

ASCET のリアルタイム言語構造体です。

モジュール

ASCET のコンポーネントの 1 つです。オペレーティングシステムによって起
動される複数のプロセスが記述されています。モジュールを他のコンポーネ
ント内のサブコンポーネントとして使用することはできません。

モニタ

実験中にエレメントの値をダイアグラム上に表示する機能です。

ユーザープロファイル

ユーザー固有のオプション設定です。

優先度

各タスクに対して数値で与えられる優先度で、この数値が大きいほど優先度
が高くなり、優先的にスケジューリングされます。

ランナブルエンティティ

→ 「RE」 参照

ランタイム環境

→ 「RTE」 参照

リソース

組み込みシステムにおいて、排他的に使用される部分（タイマなど）をモデ
リングする際に使用されます。このような部分をアクセスするには、使用前
にそれを予約（確保）して使用後に解放する、という処理が必要ですが、こ
の一連の処理がリソースの概念によって行われます。

リテラル

コンポーネントの記述に使用されるもので、連続値や論理値として解釈され
る文字列を定義します。
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レイアウト

コンポーネントは、入力／引数や出力／戻り値を表すピンや、タイムフレー
ム、メソッド、プロセスを表すグラフィック表現（レイアウト）を持ち、さ
らにそのレイアウトには、そのコンポーネントが他のコンポーネント内で使
用される時のグラフィック表示に用いられるアイコンも含まれています。

ワークスペース

ASCET で生成されるすべての情報が格納されます。ASCET 内ではワークス
ペースはフォルダによる階層構造になっています。Windows ファイルシステ
ムにおいては、1 つのワークスペースは複数の XML ファイルとして保存され
ます。
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6 付録 A: ASCET に関するトラブルシューティング

この章では、ASCET 使用時に ASCET 固有の問題（ネットワーク等に関する一般的
な問題以外）が発生した際の対処方法を説明します。

6.1 トラブルシューティングと ETAS へのお問い合わせ

ASCET の製品開発においては、プログラムの機能上の安全性が最も重要視されてい
ます。しかし万一ご使用中にエラーが発生した場合には、以下の情報を ETAS までお
送りください。

• エラーが発生したときにどのような作業をしていましたか ?

• 発生したエラーはどのようなものでしたか ?（関数エラー、システムエラー、
システムのクラッシュなど）

• エラーが発生した時に、どのようなモデル（またはモデルエレメント）を編
集していましたか？

サポート機能を使用すると、ASCET は自動的にログディレクトリの内容（すべての 
*.logファイル）とテキスト情報を、...¥ETAS¥LogFiles¥サブディレクトリ
の EtasLogFiles00.zip というファイルに圧縮します。2 回目以降の ZIP ファ
イルには番号が付き、この番号は 1 から順に 19 までインクリメントされます。

重大なシステムエラーが発生すると、以下のようなウィンドウが開きます。

エラー発生時の操作：

1. Problem Report ボタン

• Problem Report ボタンをクリックします。

サポート機能が起動されます。

• エラー内容を記述し、作成された ZIP ファイルを使用
していたモデルと共に ETAS のホットライン窓口に送
信してください。

注記

ASCET の品質をより高めるためには、ASCET の操作中にエラーが発生した際に
ユーザーの皆様からお送りいただくレポートは、非常に重要です。お手数ですが、
できる限り以下の手順でレポートをお送りください。
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1. Exit ボタン

• Exit ボタンをクリックします。

ASCET が終了します。保存されていなかった変更は
すべて失われます。

データを保存することを勧めるメッセージボックスが
開いた場合、データの保存は行わずにメッセージボッ
クを閉じてください。

• ASCET を再起動します。

2. Continue ボタン

• Continue ボタンをクリックします。

ASCET は稼働し続け、エラー発生直前の状態に戻り
ます。

• データを保存します。

• ASCET を終了します。

• ASCET を再起動します。

一般には、エラーが発生したらデータの保存を行わずにプログラムを終了し、再起
動することをお勧めします。それにより、引き続いてより重大なエラーが発生する
ことを回避できます。

6.2 ASCET 上に表示される黒いアイコン

ASCET の稼動中に PC のグラフィックモードが変更されると、ASCET ユーザーイン
ターフェース上のアイコンの色が黒くなる場合があり、インストールされている

ASCET アドオンの種類によってはシステムエラーが発生する場合もあります。

PC の 2 番目のグラフィック出力（セカンダリモニタなど）の起動などによりグラ
フィックモードが自動的に変更されてしまう場合がありますが、現時点において、
そのような原因により発生する上記の障害を回復または回避する手段はありません。

注記

Continue ボタンは、重要なコンフィギュレーションを保存する必要があるよ
うな場合に限り使用してください。そのまま作業を続行すると、さらにエラー
が発生したり、不正なコンフィギュレーション設定が行われてしまう可能性が
あります。

注記

上記の障害が発生する可能性があるため、ASCET が稼動しているときは PC のグ
ラフィックモードを変更しないでください。
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7 付録 B: 一般的なトラブルシューティング

この章では、個々のソフトウェアやハードウェアに依存しない一般的な問題が発生
した場合の対処法について説明します。

7.1 問題と解決法

7.1.1 ETAS ネットワーク用のネットワークアダプタを選択できない

原因： APIPA が無効になっている

IP アドレッシングの代替メカニズムである APIPA は、通常すべての Windows 環境
では、通常は有効に設定されていますが、時にはネットワークセキュリティポリ
シーによって無効となっている場合もあります。そのような場合、DHCP 設定の
ネットワークアダプタ（ネットワークカード）を ETAS ハードウェアのアクセスに使
用することはできず、そのアダプタを選択すると ETAS ネットワークマネージャは警
告メッセージを表示します。

無効になっている APIPA メカニズムを有効にするには、Windows のレジストリを編
集する必要がありますが、これを行うには管理者の権限が必要です。ネットワーク
管理者の方にご相談のうえ行ってください。

APIPA メカニズムを有効にする：

• 以下のようにして Windows のレジストリエディタを
開きます。

－ Windows XP、Windows 7 の場合： スタート メ
ニューから ファイル名を指定して実行 を選択し、

regedit と入力して OK をクリックします。

－ Windows Vista の場合： スタート メニューをク
リックし、エントリフィールドに regedit と入
力して <Enter> を押します。

レジストリエディタが開きます。

• 以下のフォルダを開きます。

HKEY_LOCAL_MACHINE/SYSTEM/
CurrentControlSet/Services/Tcpip/
Parameters/

• 編集 → 検索 を選択して以下のキーを検索します。

IPAutoconfigurationEnabled

• APIPA メカニズムが有効になるように、

IPAutoconfigurationEnabledというキーの値を
すべて 1 に変更します。

Windows のレジストリ内には、この名前のキーがい
くつか含まれている場合があります。これらは一般的
な TCIP/IP サービス用のものと、個別のネットワーク
アダプタ用のものです。ETAS ネットワーク用に使用
するアダプタについてのみ値を変更してください。

• レジストリエディタを閉じます。

注記

レジストリ内にこのキーが 1 つも見つからない場合、APIPA メカニズムが無効に
なっていないことを意味するため、以下の操作は必要ありません。
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• 変更されたレジストリの内容を有効にするため、PC
を再起動します。

原因： ハードウェアバージョンと ETAS の MC ソフトウェアのバージョンに互換性
がない

ETAS ハードウェアを ETAS の MC ソフトウェアに接続して使用する場合、ETAS の

HSP アップデートツールを利用して、以下のようにハードウェアのファームウェア
バージョンをチェックすることができます。

• 最新の HSP（Hardware Service Pack： ハードウェアサービスパック）に含ま
れる HSP アップデートツールを使用します。

• HSP アップデートツールを使用して、ハードウェアのバージョンが MC ソフ
トウェアのバージョンと互換性があるかどうかをチェックします。

• PC ドライバが必要なハードウェアの場合、ドライバが正しくインストールさ
れているかどうかをチェックします。

最新バージョンの HSP は、ETAS のホームページ www.etas.com からダウンロード
できます。

最新の HSP アップデートツールでも検出されない場合は、そのハードウェアが Web
インターフェースを実装しているかをチェックしてください。実装している場合は

Web インターフェース経由で検索し、それでも見つからない場合は、以下の原因が
考えられます。

原因： パーソナルファイアウォールによる通信のブロック

パーソナルファイアウォールによって発生する可能性のある問題とその解決法は、

116 ページの「パーソナルファイアウォールによる通信のブロック」を参照してく
ださい。

原因： リモートアクセス用クライアントソフトウェアによる通信のブロック

ETAS ハードウェアネットワーク外で使用されている PC には、リモートアクセス用
クライアントソフトウェアがインストールされているものがあり、それによって

ETAS ハードウェアへのアクセスが妨害される場合があります。それには以下のよう
な状況が考えられます。

• イーサネットメッセージをブロックするファイアウォールが使用されている
（114 ページの「原因： パーソナルファイアウォールによる通信のブロック」
を参照してください）

• トンネリングに使用されている VPN クライアントソフトウェアが誤ってメッ
セージをフィルタリングしてしまうことがあります。たとえば Cisco VPN ク
ライアントの V4.0.x より前のバージョンでは、特定の UDP ブロードキャス
トを不正にフィルタしてしまう、というケースがありました。

このケースに該当する場合は、VPN クライアントソフトウェアのバージョン
をアップデートしてください。

原因： ETAS ハードウェアのフリーズ

ETAS ハードウェアが何らかの理由でフリーズしてしまった可能性もあります。この
場合は、ハードウェアの電源を切ってから再投入してください。これによってハー
ドウェアは再初期化されるので、多くの場合、正常に戻ります。

原因： ETAS ハードウェアがスリープモードになっている

ETAS ハードウェアには、省電力の目的で、他のデバイスは PC に接続されていない
ときにはスリープモードに切り替わるものがあります。
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スリープモードに切り替わらないようにするには、PC のイーサネットケーブルを
ハードウェアの “HOST” ／ “Sync In” ポートに接続し、ハードウェアの起動後に

Web インターフェースでハードウェアに接続し、設定を変更してください。詳しく
はハードウェアのマニュアルを参照してください。

原因： ネットワークアダプタへの IP アドレス割り当てが一時的に失われた

PC の接続を、DHCP が使用されている社内 LAN から ETAS ハードウェアに切り替え
る際、PC が ETAS ハードウェアを検知できるようになるまでに約 60 秒かかります。
これはオペレーティングシステムが DHCP プロトコルから ETAS ハードウェア用の

APIPA に切り替わる処理に要する時間です。

原因： ETAS ハードウェアが他の論理ネットワークに接続されている

1 つの ETAS ハードウェアに対して複数の PC からアクセスする場合、各 PC で使用
されるネットワークアダプタは、同じ論理ネットワークを使用するように設定して
おく必要があります。このように設定することが不可能である場合、他の PC を切り
替える前に ETAS ハードウェアの電源を切って再投入してください。

原因： ネットワークカード用のデバイスドライバが起動していない

ネットワークカード用のデバイスドライバが起動していない可能性があります。そ
の場合は、ネットワークカードを一旦無効にしてから再度有効にしてください。

ネットワークカードを無効にして、再度有効にする（Win XP、Win Vista）：

• ネットワークカードを無効にするには、Windows の 
スタート メニューから以下のように操作します。

－ Windows XP の場合： コントロールパネル → 
ネットワーク接続 を選択します。

－ Windows Vista の場合： コントロールパネル → 
ネットワークとインターネット → ネットワーク
と共有センター → ネットワーク接続の管理 を選
択します。

• ETAS ネットワーク用に使用されているデバイスを右
クリックし、ショートカットメニューから 無効 を選
択します。

• 続いて同じショートカットメニューから 有効 を選択
し、カードを有効にします。

ネットワークカードを無効にして、再度有効にする（Win 7）：

• ネットワークカードを無効にするには、Windows の 
スタート メニューから コントロールパネル → デバイ
スマネージャー を選択します。

• デバイスマネージャで ネットワークアダプター のツ
リー構造を開きます。

• 使用する接続をクリックしてその “< 接続名＞の状態

” ダイアログボックスを開きます。

• 使用するネットワークアダプタを右クリックして
ショートカットメニューから 無効 を選択します。

• 続いて同じショートカットメニューから 有効 を選択
し、カードを有効にします。
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原因： ラップトップ PC の電源管理システムによってネットワークカードが無効に
なっている

ラップトップ PC の電源管理システムにより、ネットワークカードが無効になってい
る場合があります。この場合、ラップトップ PC の電源管理を無効にしてください。

ラップトップ PC の電源管理を無効にする：

• Windows の スタート メニューから、以下のようにし
てデバイスマネージャを開きます。

－ Windows XP の場合： コントロールパネル → シ
ステム を選択し、“ ハードウェア ” タブを開いて 
デバイスマネージャ をクリックします。

－ Windows Vista の場合： コントロールパネル → 
システムとメンテナンス → デバイスマネージャ 
を選択します。

－ Windows 7 の場合： コントロールパネル → デバ
イスマネージャ を選択します。

• デバイスマネージャ ウィンドウで ネットワークアダ
プタ のツリーを展開します。

• 使用するネットワークアダプタを右クリックし、
ショートカットメニューから プロパティ を選択しま
す。

• 電源の管理 タブを選択し、コンピュータでこのデバイ
スの電源をオフできるようにする オプションをオフに
します。

• 詳細設定 タブを選択し、プロパティ に Autosense 
が含まれている場合、これを無効にします。

• OK をクリックして設定を有効にします。

原因： ネットワークの自動切断

ネットワークカードのデータトラフィックが一定の時間途絶えると、ネットワーク
カードが自動的にイーサネット接続を切断する場合があります。これは、レジスト
リの autodisconnectキーを設定することによって避けることができます。

レジストリキー autodisconnectを設定する：

• レジストリエディタを開きます。

• HKEY_LOCAL_MACHINE/SYSTEM/
ControlSet001/Services/lanmanserver/
parameters というフォルダに含まれるレジストリ
キー autodisconnect の値を 0xffffffff に
変更します。

7.1.2 パーソナルファイアウォールによる通信のブロック

パーソナルファイアウォールは、ETAS のイーサネットハードウェアへのアクセスを
妨害する場合があります。そのような場合、ハードウェアの自動検索時に、コン
フィギュレーションが正しく設定されているのにもかかわらずイーサネットハード
ウェアがまったく検出されない、という状態が発生する可能性があります。

また、ファイアウォールが適切に設定されていないと、ETAS ソフトウェアにおける
特定の操作（例： ASCET で実験を開く、INCA や HSP でハードウェアを検索する、
など）を実行する際に不具合が発生する場合があります。
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ファイアウォールによって ETAS ハードウェアとの通信がブロックされる場合は、

ETAS ソフトウェア使用中はファイアウォールソフトウェアを無効にするか、または
ファイアウォールの詳細設定を行って以下のアクセスを許可するようにしてくださ
い。

• UDP を経由する、デスティネーションアドレス 255.255.255.255 への出力
方向の IP ブロードキャスト（デスティネーションポート： 17099 または

18001）

• UDP を経由する、ソース IP アドレス 0.0.0.0 からデスティネーション IP アド
レス 255.255.255.255 への入力方向の IP ブロードキャスト（デスティネー
ションポート： 18001）

• UDP を経由する、ETAS ネットワークへの直接 IP ブロードキャスト（デス
ティネーションポート： 17099 または 18001）

• UDP を経由する、ETAS ネットワーク内のすてべの IP アドレスへの出力方向
の IP ユニキャスト（デスティネーションポート： 17099 ～ 18001）

• UDP を経由する、ETAS ネットワーク内のすてべの IP アドレスからの入力方
向の IP ユニキャスト（ソースポート： 17099 ～ 18020、デスティネーショ
ンポート： 17099 ～ 18020）

• ETAS ネットワーク内への出力方向の TCP/IP 接続（デスティネーションポー
ト： 18001 ～ 18020）

Windows オペレーティングシステムには「ビルトイン パーソナルファイアウォー
ル」が組み込まれていますが、それ以外に、サードパーティ（Symantec、McAfee、
Blackice）の各種パーソナルファイアウォールも一般的によく使用されています。こ
れらの各ファイアウォールではそれぞれ対処方法も異なる場合がありますので、お
使いのパーソナルファイアウォールの説明書をよくお読みください。

以下に一例として、一般的に使用されている Windows XP （+Service Pack 2）の
ファイアウォールの設定方法をご紹介します。

Windows XP ファイアウォールの設定： 管理者権限を持つユーザーの場合

PC の管理者権限を持っているユーザーの場合、ETAS ソフトウェアがファイア
ウォールによってブロックされると、以下のようなダイアログボックスが開きます。

注記

実際のポート番号は、使用するハードウェアに応じて異なります。ポート番号に
ついての詳しい情報は、ハードウェアのドキュメントを参照してください。
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製品のブロックを解除する：

• “Windows セキュリティの重要な警告 ” ダイアログ
ボックスで、ブロックを解除する をクリックします。

以降、該当する ETAS ソフトウェアはファイアウォー
ルによってブロックされなくなります。この設定は、
プログラムや PC の再起動後も維持されます。

上記の “Windows セキュリティの重要な警告 ” ダイアログボックスが開く前に、前
もって ETAS ソフトウェアのブロックを解除しておくこともできます。

ファイアウォールの設定を変更して製品のブロックを解除する：

• Windows のスタートメニューから 設定 → コント
ロールパネル を選択します。

• コントロールパネルから Windows ファイアウォー
ル を選択します。

“Windows ファイアウォール ” ダイアログボックス
が開きます。
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• “ 例外 ” タブを選択します。

このタブには、ファイアウォールによるブロックから
除外されているプログラムが一覧表示されます。

• プログラムの追加 または 編集 ボタンをクリックして、
新しいアイテム（プログラム）を追加するか、既存の
アイテムを編集します。

• 以下のようにして、使用する ETAS ソフトウェアとそ
れに関連するサービスについて、正しく例外設定され
ていることを確認します。

－ 例外リストから該当するアイテムを選択して 編集 
をクリックし、“ プログラムの編集 ” ダイアログ
ボックスを開きます。

－ スコープの変更 をクリックし、“ スコープの変更

” ダイアログボックスを開きます。

－ ETAS ハードウェアへのアクセスが行えるように、

192.168.40.xxxという IP アドレスがブロッ
ク解除されていることを確認してください。

－ OK をクリックして “ スコープの変更 ” ダイアロ
グボックスを閉じます。

• OK をクリックして “Windows ファイアウォール ”
ダイアログボックスを閉じます。

以降、該当する ETAS ソフトウェアはファイアウォー
ルによってブロックされなくなります。この設定は、
プログラムや PC の再起動後も維持されます。
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Windows XP ファイアウォールの設定： 管理者権限を持たないユーザーの場合

権限（システム変更、書き込み、ローカルログオンなど）が制限されているユー
ザーの場合は、以下のように操作してください。

ETAS ソフトウェアを使用するユーザーは、所定のディレクトリ（ETAS、
ETASData、ETAS の一時ディレクトリ）への “ 書き込み ” の権利が必要です。そ
れらの権利がない場合状態で ETAS ソフトウェアを起動すると、エラーメッセージが
表示され、その後データベースが開きますが、正しい操作は行えません。これは、

ETAS ソフトウェアの操作時にはデータベースファイルや *.iniファイルの書き換
えが必要なためです。

ETAS ソフトウェアは、必ず管理者権限のあるユーザーがインストールを行い、その
後、Windows XP ファイアウォールの例外リストにそのプログラムを正しく登録し
てください。これが行われていないと、以下の事柄が生じます。

• ファイアウォールにより制限されているアクションを実行する
と、“Windows セキュリティの重要な警告 ” ダイアログボックスが開きま
す。

製品のブロックを解除する（管理者権限のないユーザーの場合）：

• “Windows セキュリティの重要な警告 ” ダイアログ
ボックスで、このプログラムについてはこのメッセー
ジを表示しない をオンにします。

• OK をクリックしてダイアログボックスを閉じます。

この後、管理者権限のあるユーザーが “Windows 
ファイアウォール ” ダイアログボックスの “ 例外 ”
タブで適切な設定を行い、ETAS ソフトウェアがハー
ドウェアアクセスを行えるようにする必要がありま
す。
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8 付録 C: ISO26262 に準拠した「ツールのクラス分け」

近年、自動車システム内で特に安全性が重要視されるソフトウェアを対象とする
「ISO 26262」という規格が検討されていますが、この規格では、開発ツールに対し
て、ツールの品質を評価するための手段である「クラス分け」が要求されています。

「ツールのクラス分け」は、ツールにより開発中のシステム内にエラーが発生し、さ
らにそのエラーがそのまま看過されてしまう可能性を評価するものです。この「ク
ラス分け」はツールが実際に使用される状況において有効なものであるため、ユー
ザーのソフトウェア開発プロセス内で評価する必要があります。

本章は、ISO 26262 によるツール要件を満たすためのガイダンスです。引用箇所は 
<Part>§<Section> で示されており、たとえば 8§11 は規格の Part 8、Section 11 を
表します。

ツールのクラス分けのための主要な要件は 8§11.4.2 に記述されており、特に

8§11.4.2.1 には品質保証のための立案、8§11.4.2.2 には提示すべき情報について説
明されています。なおこれらの要件に対しては、ユーザーとツールサプライヤの両
方に責任がある、という点に注意してください。たとえば「ソフトウェアツールの
インストール処理」の場合、ETAS は ASCET のインストールについての一般的な事
項を明確にし、ユーザー側では、ツールをどこにインストールし、どのように開発
プロセスに統合したかを明確にする必要があります。

以下の表は、ISO 26262 に定義された「ツールのクラス分け」要件のうち ASCET が
関連するものをまとめたものです。各要件ごとに、関連する ASCET のメニューコマ
ンドや、説明文の参照先などが挙げられています。

注記

この規格は、本章が記述された時点（2010 年 10 月）においてはまだ ISO により
策定されていないため、本章で引用されている規格の章番号は、2009 年 6 月 28
日に公開された ISO/DIS 262626 のものです。その後の改版により、ツールのクラ
ス分けに関する要件や章番号などが変更される可能性があります。ISO 26262 の
最新バージョンについてのご質問は、ETAS までお問い合わせください。
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要

U
n

（

ー番号」 というバージョン文字列を用いた番号が付
ージョン文字列」には、より下位のバージョン番号で

.1 の初回のリリースはバージョン 6.1.0 となり、バグ
がリリースされるたびにリフレッシュ番号がインクリ

るには、ASCET メインウィンドウで Help → 

を確認するには、同じくメインウィンドウで Help → 
ジュールのバージョン情報がモニタウィンドウに表

ての情報を確認するには Help → Loaded 

イルがインストール先ディレクトリに生成されます。
全なパスとチェックサムが保存されます。

C
t

（
ン
定

義されます。
ベースとして存在）

*.ini、 *.a2l、 *.template、 *.xml） に保

U
（

SCET の利用が対象となります。ただし本書の第 2 章
囲をよくご理解いただいたうえでご使用ください。

E
（

ます。

M
b

（
範

。

件の概要 ISO26262
の参照箇所

ASCET の対応内容

nique identification 
umber
一意の識別番号）

8§11.4.2.1.a ASCET の各バージョンには、「メジャー番号 . マイナ
けられています（例： ASCET 6.1）。さらにこの「バ
ある「リフレッシュ番号」も含まれます。ASCET 6
修正等が盛り込まれた「リフレッシュバージョン」
メントされます。

使用中の ASCET の基本的なバージョン情報を確認す

About... を選択します。

インストールされているモジュールについての情報

Loaded Packages... を選択します。これにより各モ
示されます。

インストールされている ASCET-SE ターゲットについ

Targets... を選択します。

ASCET のインストール時に inst.ref というファ
このファイルにはインストールされたファイルの完

onfiguratin of software 
ool
ソフトウェアツールのコ
フィギュレーション設
）

8§11.4.2.1.b ASCET のコンフィギュレーションは以下のもので定

- ASCET モデル自身（ワークスペースまたはデータ

- ターゲットディレクトリ内の各ファイル（*.mk、
持されるコンフィギュレーション設定

se cases
応用）

8§11.4.2.1.c 対象外です。ユーザー側の開発プロセスにおける A
と第 3 章に書かれている ASCET の基本機能と応用範

xecution enbironment
実行環境）

8§11.4.2.1.d 対象外です。ユーザーの開発プロセスが対象となり

aximum ASIL that may 
e violated
許容される ASIL レベルの
囲）

8§11.4.2.1.e 対象外です。開発されるシステムが対象となります
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M
（

。

D
f

（

います。
はその他のユーザードキュメントに記述されていま

D
p

（
て

ASCET Installation Guide）に記述されています。

P
（
供

ザーマニュアルとオンラインヘルプが提供されていま

ます。
x.y 
または Help  Contents... を選択します。

V
e

（

ドオンのリリースノートに記載されています。リリー
。
x.y

B
a
c

（

たは意味的に不正なモデル、非互換のオプションな
チェックし、結果をモニタウィンドウの “Build” タブ

する PC にはインストールできません。

要

ethods for qualification
品質保証の手段）

8§11.4.2.1.f 対象外です。クラス分けの結果として出力されます

escription of product 
eatures
製品機能の説明）

8§11.4.2.2.a ASCET 製品の機能概要は本書の第 2 章に記述されて
個々の機能の詳細な情報は、オンラインヘルプまた
す。

escription of installation 
rocess
インストール方法につい
の説明）

8§11.4.2.2.b インストール方法は『ASCET インストールガイド』（

rovision of user manual
ユーザーマニュアルの提
）

8§11.4.2.2.c ASCET の各バージョンおよびアドオンに対してユー
す。
各マニュアルは以下のディレクトリに保存されてい
<install dir>¥..¥ETASManuals¥ASCET V
オンラインヘルプを開くには、<F1> キーを押すか、

alid operating 
nvironment
正しい動作環境）

8§11.4.2.2.d 正しい操作環境は、ASCET の各バージョンおよびア
スノートは以下のディレクトリに保存されています
<install dir>¥..¥ETASManuals¥ASCET V

ehavior under 
nomalous operating 
onditions
異常な操作条件下の挙動）

8§11.4.2.2.e ASCET コンフィギュレーションのエラー（構文的ま
ど）はコード生成とビルドの実行時にツール自身が
に表示します。

ASCET は、ASCET がサポートしていない OS が稼動

件の概要 ISO26262
の参照箇所

ASCET の対応内容



付
録

C
: ISO

26262
に

準
拠

し
た

「
ツ

ー
ル

の
ク

ラ
ス

分
け

」
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K
a

（
策

ースノートに記載されています。

es Report）に記載され、回避策がある場合はそれも併
され、すべての KIR は ETAS ホームページ（http://

点については、修正プログラムが「ホットフィック
知され、すべてのホットフィックスは ETAS ホーム

com/en/products/download_center.php）からダウン

D
o

（
出

を促します。コード生成はそのまま実行されますが、
。

」を「エラー」 にプロモートすることにより、そのタ
いようにすることができます。

留めるためのリリース前テストが入念に実施されます
在的に発生する可能性のあるエラーがすべて検出され
。これには ISO26262 の 8§9 で定義されている検証

要

nown issues and work-
rounds
既知の問題点とその回避
）

U¬NNKQKOKOKÑ リリース時点で判明している問題点は、ASCET リリ

リリース後に発見された問題点は KIR（Known Issu
記されます。KIR の発行は E メールでユーザーに通知

www.etas.com/kir）からダウンロードできます。

リリース済みの製品で発見された重要度の高い問題
ス」として提供されます。その情報はユーザーに通
ページのダウンロードセンター（ http://www.etas.
ロードできます。

etection of erroneous 
utput
出力に含まれる誤りの検
）

U¬NNKQKOKOKÖ ASCET は「ワーニング」を発行してユーザーの注意
設計の意図が正しく反映されない可能性があります

安全性確保の目的で、任意のタイプの「ワーニング
イプの障害が発生した場合にコード生成が行われな

ASCET については、コード生成のエラーを最小限に
が、ASCET が使用される開発プロセスにおいて、潜
るような仕組みを用意しておくことをお奨めします
要件に準拠する開発プロセスが適しています。

件の概要 ISO26262
の参照箇所

ASCET の対応内容

http://www.etas.com/kir
http://www.etas.com/ja/products/download_center.php


9 お問い合わせ先

製品に関するご質問等は、各地域の ETAS 支社までお問い合わせください。

ETAS 本社

ETAS GmbH

日本支社

イータス株式会社

その他の支社

上記以外の各国支社につきましては、ETAS ホームページをご覧ください。

Borsigstrasse 14 Phone: +49 711 89661-0

70469 Stuttgart Fax: +49 711 89661-106

Germany WWW: http://www.etas.com/

〒 220-6217 Phone: (045) 222-0900

神奈川県横浜市西区 Fax: (045) 222-0956

みなとみらい 2-3-5 E-mail: sales.jp@etas.com

クイーンズタワー C 17F WWW: http://www.etas.com/

各国支社 WWW: http:://www.etas.com/ja/contact.php

技術サポート WWW: http://www.etas.com/ja/hotlines.php
お問い合わせ先 125
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