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Test ASCET web services (with "SoapUI")

-
LA Question:

| want to consume a web service but it does not seem to work
Is there a way to test if web services are working correctly?
How to test a web service?

How to trouble shoot web service issues?

Answer:

e We will use the tool SoapUl which is popular among web service developers
e https://www.soapui.org

Create a SOAP project

e In SoapUl > Menu bar > File > New SOAP Project

r

4% SoaplI 5.4.0

oject Suite Case Step  Tools Desktop Help

F T 3 & o=

e All Farum Trial Preferences Proxy
Creates a new WSDL/SOAP based Web Service Project in this workspace h

Create Empty Project
Mew SOAP Project

Mew REST Project

Ctrl-N

Import Project Cirl-I
Import Packed Project
Import Remote Project

Import Postman Collection
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¢ |n dialog New SOAP Project > At field Project Name: Type name for the project (for example:

"Test ASCET webservices")
¢ In dialog New SOAP Project > Click OK button

i -
% New SOAP Project

New SOAP Project
Creates a WSDL/SOAP based Project in this workspace

===
o

Project Naquest ASCET webservices T

Initial WSDL: |

Create Requests: Create sample requests for all operations?
Create TestSuite: [ | Creates a TestSuite for the imported WSDL

Relative Paths:  [] Stores all file paths in project relatively to project file (requires save)

1 [
[The name of the project to create |Browse... l

Blox]) [ cancel

e In SoapUl > Projects > On the newly created project > Right mouse button click > Add WSDL

r

4% SoapUl 5.4.0

File  Project Suite Case Step  Tools Desktop Help

REdk
E B

Empty  SO0AP  REST

$ &

Trial Preferences

Right mouse g

button click

Show Project View

Add WADL

Import Swagger

Export Swagger

Proxy

oq
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e |n dialog Add WSDL > At field WSDL Location > Enter the path to the WSDL file
o For example: <ASCET _installation_directory>\XML\AaaToolInterface.wsdl
o Replace <ASCET installation_directory> according to your installation
o Example: C:\ETAS\ASCET6.4.3\XML\AaaToolInterface.wsdl
¢ In dialog Add WSDL > Click OK button

4+ Add WSDL [ = ]
Add WSDL :@
Creates a WSDL Interface from a WSDL definition
WSDL Location: °C:\I:—I'A5\ASCI:—I'6.4.3\XML\AaaToollnterface.wsdl | [ Browse... ]

Create Requests:

Create TestSuite:

Create MockService: [ Creates a Web Service Simulation of the imported WSDL

Create sample requests for all operations?

[[] Creates a TestSuite for the imported WSDL

Cancel

e The methods which are available via this web service are displayed

45 SoapUl5.4.0

File  Project Suite Case

2 8 9
Empty  SOAP REST Save All

Step Jools Desktop Help

Import Forum Trial
Projects
E}. Test ASCET webservices

£ 5% AaaToollnterfaceBinding

z
2
5
=
=
=

- About

C’z ActivateMNoSaveMode

-2 ApiVersion

’:1 ClearMenitorCentents

’:1 CloseCurrentDatabase

- CloseDataStorage

-+ CloseMessageDialeg

o) ConvertDatabaseToWorkspace

’:1 CreateDatabase

- CreateWorkspace

- DatabasePath

o) DataStoragePath

o] ExportBuildMessagesAsXMLToFile

-+ ExportDCMFerComponentWithoutReferencesToFile
[} ExportDCMForComponentWithReferencesToFile

’.3 ExportlternToPath

o] ExportltemToPathWithOptions

-+ ExportitemToZipFile
[} ExportltemToZipFileWithOptions

’.3 ExportltemWithReferencesToPath

o] ExportitemWithReferencesToZipFile

-+ ExportMappingFerComponentToFile

o) exportMappingForSoftwareComponent_toFile

’:1 FlashTarget

- GetCustomerDataForAscetlink

- GetCustomerDataForAscetLinkForName

’:1 GetLastErrorMumber

’:1 GetLastErrorText

- GetProcessld

-2 ImpertDCMFerComponentWithoutReferencesFromFile

o) ImpetDCMForComponentWithReferencesFromFile

o] ImportFromFile

-+ ImportFromPath

F O e W O v O = O O == O OO e O OO = O DO = O = O v OO = OO == O OO OO OO = O DO = O = OO0 == OO0 = OO = 0 == O = OO0 =~ O == = 0
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Test the ASCET webservice interface

e In SoapUl > Projects > <Project> > AaaToollnterfaceBinding > About > Requestl: Left
mouse button double click

4% SoapUlI 5.4.0

File  Project Suite Case Step  Tools Desktop  Help

E B B X g 9

Empty  S0AP REST  Import  SaveAll Forum

> ApiVersion
"':J ClearMonitorContents

: "':; CloseCurrentDatabase

i CloseDataStorage

7 CloseMessageDialeg

"':; ConvertDatabaseToWorkspace

¢ In dialog Requestl > Click on green triangle

inp Request1 :

=0

hE http:/flocalhost:32510,/5st\WSServlet

H <spapenv:Envelope xmlns:scapenv="http://schemss.xmlsocep.org/soap/eny*
<gopapenv:Header />

= <goapenvy:Body>

Rawe | ML

<urn:ibout/>

< /apapenv:Body>

</ goapenv:Envelope>

[ »

Auth  Headers (0) Attachments (0 WS5-A W5-RM VS Headers IS Properties (1)
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e |n case there is following error displayed at the bottom of this dialog
e Error getting response ... Connection to ... refused

iﬂ Request 1

b ¥y @O £ http://localhost:32510/5stWSServlet

[E <soapenv:Envelope xmlns:scapenv="http://schemas. xmlsoap.org/socap/eny~ ;
<apapenv:Header/>

= <socapenv:Body>

Fawne | ML

<urn:ibout/ >

Fawne | ML

</3papenv:Body>

</ apapenv:Enveloper

[ » i

Headers (0) Attachments (0) W5-A WS-RM 1S Headers INES Property (0) Headers (0) Atta

Error getting response; org.apache.http.conn.HttpHestConnectException: Connection to http://localhost:32510 refused

e SOLUTION: Make sure that ASCET is up and running and try again!

¢ In dialog Requestl on the right hand side: There is the response from ASCET

e 1

bY@ OL N http://localhost32510/5s0WSServlet [-]% +
g L] <scapenv:Envelope xmlns: v="http://schemas.xmlscap.org/scap/en|* § g <SOAP-ENV:Envelope xmlns:xsdl="http://www.w3.0rg/2Z001l/XMLSchema" xmlns:SORP-ENV="htrt
= <soapenv:-Header/> = <SORE-ENV:Bodys
P =] <soapenv:Body> =l <ati:AboutResponse xmlns-ati="urn-RzaToclInterface"s
& <urn:Ebout/> <outMsgrASCET Rutomation APT - (e}
</scapenv-Body>

2015 ETAS GmbH</outMsg>
</ati:Aboutlesponse>

</SCAD-ENV:Body>
</8OAD-ENV: Envelope>

</soapenv:Envelopes

D []
Auth Headers (0) Attas

its (0) WS-A WS-RM M5 Headers  JMS Property (0] Headers (3} Attachments (0) 550 Info WSS (0) WS (0]
response time: 17ms (442 bytes)
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e The same procedure can be executed for other web service methods, for example ApiVersion

4% SoapUl 5.4.0

E B B X g

:D: ==
Projects
% El. Test ASCET webservice
Elz AaaToollnterfaceBinding
B About
% Acti

atebloSavelMode

E‘CJ" ApiVersion

El’:; ClearMonitorContents
El’:; CloseCurrentDatabase
El’:; CloseDataStorage

¢ Request (left hand side) and response (right hand side):

e

File  Project Suite Case Step  Tools  Des

Empty S0AP REST Import Sawve All

Py EOLR [ttp://localhost:32510/SstWsSerdet

=l <sospenv:Envelope imlns:scspenv="hitp://schemas.wmlsosp.orgssasp/en]=] § =
<soapenv:Header/> =

= <scapeny:Bedy>

=
= <SOAP-ENV:Body>
=

Raw | XML

</scapenv:Envelope>

[»

Auth  Headers (0) Attachments (0) WS-A WS-RM IS Headers JWS Property (0)
response time: 13ms (416 bytes)

e Just another example: ToolVersion

- SwitchLoggingOn
i

(o ir Reques

E:'} "':; WritePonitorContentsToPath

e Request and response:

= Request 1 ':': :

ApiVersionResponse)xmlns:zti="urn:AzaToolInterface”s

<at
<outMsag| /outMsg>
</soapenv:Body>

</ati:ApiVersionResponse>
</SOAP-ENV:Body>
</ SORP-ENV:Envelope>

<SOAP-ENV:Envelope amlns:xsdl="http://www.w3.0rg/2001/KMLSchema” umlns:SOAP-ENV="htt]=

Headers (3) Attachments (0) S50Info WSS (0] NS (0)

s gt ot [

[t e R A | hittps//localhost:32510/SstWSSenvlet

T +

<sozpenviHeader/>

Rauw |

=
= <S0AP-ENV:Body>
=

= |2 <scapenv-Envelope xmlns:soapenv="http://schemas_ xmlsoap. org/scap,/enya §

</sospenv:Body>

</ati:ToolVersionResponse>
</SOAP-ENV:Body>
</SORP-ENV:Envelope>

</soapenv:Envelope>

fesoap-env:Envelope umins:xsdi="http:/fwww ws org/2001/¥MLSchema” wmlns:SOAB-ENV="htt]~

El  <socepenviBody: <ati|ToolVersionResponse)umins:ati="urn:2zeToolInterface”>
> <outMag{Ve.4.3J/cutsg>
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e Parameters: Some methods require parameters
e For example: Method CreateDatabase requires a path for the database:

37 Requestl 77

|@§2 B O & & [0 [http/localhost32510/SstwSServiet

<scapenviHeadexr/>

El  <scapenv:Body>
=] <urn:CreateDatabase> {
<databasePathfMyTest—Creat=DBviaWS}/detabas=Path>

</urn:CreateDatabase>

Rawy | XML

</ soapenv:Body>

</soapenv:Envelope>

El<scapenv:Envelope xmlns:soapenv="http://achemas xmlsosp org/soap/envelc=||§

Auth  Headers (0) Attachments (0) WS-A WS-RM IS Headers IMS Property (0)
response time: 768ms (419 bytes)

Rawy | XML

El ks0ap-2NV-Envelope xmins-xsdl="http://wew w3 org/2001/XMLSchema"
=] <SORD-ENV:Bedy>
= <ati:CreateDatabaseResponse xmlns:ati="urn:izzToocllnterface”>
<outMsg/>
</ati:CreateDatzbaseResponses
</SORD-ZNV:Bodys
</SORP-ENV:Envelope>

Headers (3) Attachments (0) 551 Info WSS (0) 1M (0)

e As aresult, the database is created as can be seen in ASCET:

{85 ASCET-MD-SE *

File Edit WView Insert

B IEE

@ o

mytest—createdbuiawsl
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¢ Find information regarding the ASCET web services in the ASCET Online Help

e In ASCET > Menu bar > Help > Contents

(38 ASCET-MD-SE

File Edit View Insert Build
|mea|+ |5
J > O

e Indialog ASCET Online Help > tab Contents > ASCETAutomationAPI

(32 ASCET Online Help |

0 e 2 &

(- Editing Implementations

(- Layout Editor

- Anthmetic Services

- Automatic Documentation

(- Adding User-Defined Functions
(- INTECRIO Connectivity / ASCET-RP
(- Operation Hints

(- Trouble Shooting

(- System Libraries

(- Software Corfiguration Management
(0] Glossa

[£] ASCET Automation AP Editor-Interface

- [£] ASCET Automation APl Toolnterface
i [7] ETAS Contact Addresses
i [2] hittp:/ wrwew stas.com

|£] ASCET Automation AP| Experment-Inteface

4

API Build-Interface

Hide Back Forward  Print
ASCETAutomationAP!
| Qorrtentsn(l Search | Favorites | Glossary]| ASCETAutomationAPI

@ Reconds -

-4 Experimentation Sources

@ Signals and lcons

-4 Froperties Editor Name Description

-4 Data Edior ASCET Automation  This is the AaaBuildinterface semnvice.

This interface contains methods which
are related to the code generation.

ASCET Automation
API Editor-Interface

This is the AaaEditorinterface senice.
This interface contains methods to
open and close editors within ASCET
for components and elements.

m

API Tool-Interface

ASCET Automation  This is the AaaExperimentinterface

AP| Experiment- semvice. This interface contains

Interface methods which are related to the build
in experiment of ASCET.

ASCET Automation  This is the AaaToolinterface semvice.

This interface contains methods which
are related to the data base handling of
ASCET.
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e From here we can dig deeper, for example to ASCET Automation APl Experiment-

Interface Web Service

P
2 ASCET Online Help

= = &
Hide Back Forward Print

Qorrtents| Igdexl §earch| Fa\rori_t&il Qlossary|

ASCETAutomationAPI
ASCET Automation APl Experiment-Interface Web Service

@ Records
@ Expermentation
@ Signals and Icons
@ Properties Editar
@ Data Editor
@ Editing Implementations
@ Layout Editar
@ Arthmetic Services
@ Automatic Documentation
@ Adding User-Defined Functions
@ INTECRIO Connectivity / ASCET-RP
@ Operation Hints
@ Trouble Shooting
@ System Libraries

@ Glossary

-[£] ASCETAutomation API
--[E] ASCET Automation AP Build-Interface
|£] ASCET Automation API Editor-Interface
ASCET Automation AP| Experiment-Interface )
- [E] Methods
[£] ASCET Automation AP Tool-Interface
ETAS Contact Addresses

@ Software Corfiguration Management (ASCET-SCM) §&

Description
This is the AaaExperimentinterface service. This interface contains methods which are
related to the build in experiment of ASCET.

See Also

. <thods |

e Click on the link Methods to discover further details

ASCETAutomationAP!
Methods: ASCET Automation APl Experiment-Interface

Methods

Name

Description

CloseExperiment

Lookup for an open experiment. An open experiment will be closed by performing the window
close action. The current experiment environment will not be saved. Return an error in case of: -
Data Logger is active (use stop experiment)

CloseMessageDialog

Close the message box created with OpenMessageBox to enable control by the user interface.
Example: CloseMessageDialog()

GetlLastErrorNumber

Return the value of the error from the last method call. Example: GetLastErrorfumber()

Getl astErrorText

Return the text of the error from the last method call. Example: GetLastErrorText()

IsExperimentOpen

Lookup for an open experiment. Return an error in case of: - No open experiment available

LoadParameters

Read in the specified DCM style parameter file into the experiment. All entries of the parameter
file will be read. Parameters as well as none volatile variables. The popup of the log file after
read will be suppressed. Return an error in case of: - Experiment no open. - file path name is no
valid. - Internal problem while reading.

OpenExperiment

Open the experiment for the specified component. If the component has to be opened within a
project this must be done explicitly. If an experiment for the component is already open this
experiment will be reused. If an experiment for another component is already open this
experiment will be closed. The specified experiment configuration will be read for the
experiment. If the default configuration should be used you can either use the string 'Default” or
pass an empty string. The experiment will be opened as child window of the component
manager. If necessary the build will automatically started before opening the experiment. Return
an error in case of. - No database open. - ltem not found in database. - Invalid component
specified. - Hardware not defined. - Experiment configuration not available. - Error in build
occured. - Component is no project and the project option ‘Message Usage Variant' is

#MON_OPT COPY TASK

e You can drill deeper by clicking on the method name

e The same information can be found under <ASCET installation_directory>/Web Service
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=X Do you still have questions?

You will find further FAQ articles on the ETAS homepage: www.etas.com/en/faq

Movies corresponding to FAQ articles can be found on the ETAS YouTube channel as well
Please feel free to contact our Support Center, if you have further questions.

Here you can find all information: http://www.etas.com/en/hotlines.php

This information (here referred to as ,FAQ") is provided without any (express or implied) warranty, guarantee or
commitment regarding completeness or accuracy. Except in cases of willful damage, ETAS shall not be liable for

losses and damages which may occur or result from the use of this information (including indirect, special or
consequential damages).
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