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Consume ASCET web service with script in C# in Microsoft Visual Studio 2010

-
LA Question:

¢ | want to consume an ASCET web service via a script in C# in Microsoft Visual Studio 2010
e How to create a web service reference to ASCET web services in Visual Studio?

M Answer:

¢ In Microsoft Visual Studio 2010 > Menu bar > View > Start Page

Microsoft Visual Studiol
View | Debug Team Data Tools Test Window

] (43 Team Explorer Ctrl+#, Ctrl+M
| Solution Explorer Ctrl+Alt+L
Source Control Explorer

History

Pending Changes

Output Ctrl+Alt+0
Call Hierarchy Ctrl+Alt+K
Start Page

Find Results
Other Windows

Toolbars
& Full Screen Shift+Alt+Enter
ey Properties Window F4
=] Property Pages Shift+F4
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e Click on New Project...

©0 Start Page - Microsoft Visual Studio I3
File Edit View Debug Team Data Tools Test Window Help

ISdd| s B85 m RIABORT I -

Start Page X

Microsoft® -
OB Visual Studio 2010 Professional

+ Get Started =~ Guidance and Resources = Latest News
L:l Connect To Team Foundation Server

Welcome Windows Web Cloud Office SharePoint Data
@ New Project...

[E] Open Project...

Recent Projecs \ I--

| What's New in Visual Studio 2010
Learn about the new features included in this release.
Visual Studio 2010 Overview

What's New in .NET Framework 4
Customize the Visual Studio Start Page

E 1 Creating Applications with Visual Studio
o
;:, = Extending Visual Studio
; ; == Community and Learning Resources
e

5

¢ In dialog New Project > Visual C# > Windows > Console Application
e Select location and click button OK

=
New Project M
Recent Templates [.NFF Framework 4 - ] Sort by: [Defanllt | Search Installed Ternplates R |
Installed Templates T Visual C#
i i E‘Eﬁl Windows Forms Application Visual C# ype: Visua
__Visual Basic = A project for creating a command-line
z o ) application
Windows .| WPF Application Visual C#
Web
Office 3 Console Application Visual C#
Cloud
Reporting Class Library Visual C#
SharePaoint
Silverlight WPF Browser Application Visual C2
Test
WCF . Em ' .
pty Project Visual C#
Workflow m
Visual C++ _§#I Windows Service Visual C#
Windows Installer XML
Visual F# ¢ WPF Custom Control Lib Visual C#
Python L ustom Control Library Isua
Other Project Types i
Database ‘El WPF User Control Library Visual C#
Test Projects
- @ Windows Forms Control Library Visual C#
Online Templates
MName: Consolefpplicationl
Location: DA\ETASData\ ASCETG 4.3\Webservices\ | -
Solution name: Consolefpplicationl Create directory for solution
|| Add te source control
5
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e Console application stub is generated

e Consolefpplication] - Microsoft Visual Studio
File Edit View Refacter Build Debug Team Data Tools Test

=1 IR =Y ==Y

Program.cs <

ﬁgConsoleApplicationl.Program
[Flusing System;
using System.Collectiens.Generic;
using System.Ling;
using System.Text;

[-Inamespace ConsoleApplicationl
'
E|| class Program

{

= static void Main(string[] args)

e In Visual Studio > Menu bar > View > Solution Explorer

oo ConsgleApplication] - Microsoft Visual Studio
View | Refactor Build Debug Team Data Tools

Open With...
- % Team Explorer Ctrl+*, Ctrl+-M
@ Solution Explorer Ctrl+ Alt+L ]‘l}

Source Control Explorer

{5 History

ﬁ Pending Changes

Output Ctrl+Alt+0

e Solution Explorer is displayed

& ConsolefApplication] - Microsoft Visual Studio
File Edit View Build Debug Team Data Toels Test Window Help
=2 LI || Lo = () €5 (3R
Seolution Explorer
e
G Solution 'CenscleApplicationl’ (1 proj
4[5 ConsoleApplicationl

[» [=d Properties

[+ [+3 References

] Program.cs
9

ﬁgConsoIeApplicationl.Program
Flusing System;
using System.Collectiens.Generic;
using System.Ling;
using System.Text;

Fnamespace ConsoleApplicationl

'

= class Program

Cd

= static void Main(string[] args)

{

E1/AS
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¢ In Solution Explorer > Move mouse pointer on the newly created application > Right mouse
button click > Add Service Reference...

on ConsoleApplicationl - Microsoft Visual Studio
File Edit Wiew Refactor Build Debug Team Data Toecls Test Window Help

ErCIEY _ 15 3 (5

Solution Explorer

| @ 2] | ﬁg':EIHSI:I|Eﬂ.pp|it3tiﬂﬂ1.prﬂgram
Selution 'Cons ationl' (1 proje Flusing System;
al [iE mp‘“icaﬁ"l using Swstem.Collections. Generic;
[ [ Properties [ Build
[ [« References Rebuild
#] Program.cs Clean
#.  Publish..
Add ]
Add Reference... 12[]
Add Service Reference... ] lb

Bi Manage NuGet Packages...

5,1 Wiew Class Diagram

Set as StartUp Project

¢ Indialog Add Service Reference > Click button Advanced...

=
Add Service Reference m

To see a list of available services on a specific server, enter a service URL and click Go. To browse for available
services, click Discover,

Address:
| A l Go I | [Disccwer |'I

Services: Operations:

MNamespace:

ServiceReferencel
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¢ In dialog Service Reference Settings > Click button Add Web Reference...
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Service Reference Settings

Client

Access level for generated classes: Public

[C] Generate asynchronous operations

Data Type

[C] Always generate message contracts

Collection type: ’System.n.nay

Dictionary collection type: ’System.CuI.I.ectiuns.Generic.Dictiunaly

Reuse types in referenced assemblies
@ Reuse types in all referenced assemblies

() Reuse types in specified referenced assemblies:

El-= Microsoft.CSharp

[ -Omscorlib

[C] -3 System

[C] -3 Systermn. Configuration

[ -3 system.Core

[C] -3 System.Data

O-a System.Data.DataSetExtensions

Compatibility

Add a Web Reference instead of a Service R
Web Services technology.

Add Web Reference...

will generate code based on NET Framework 2.0
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¢ In dialog Add Web Reference
¢ Infield URL: Enter the path and file name of the ASCET web service WSDL
e Find the WSDL in <ASCET_installation directory>\XML\
e Click on white arrow in green square (on the right side of field URL)
¢ In field Web reference name: Enter a name for the web reference
e Click button Add Reference

&
Add Web Reference M

Mavigate to a web service URL and click Add Reference to add all the available services.
0O @dEa
:\EmS\ASCEm.3\XML\AaaToolInterface.wsd| | a@
" i = =i .| Web services found at this URL:
AaaToollnterface" Description = :
B 2 Services Found: -
Documentation - AaaToolInterface-interface
This is the AaaToolInterface service, - AaaToollnterface
Methods
= About()
Return a fix about string. APT-Result-Codes: NO RESULT CODES! @example About()
@param outMsg About string for the ASCET Automation APL. -
= ActivateNoSaveMode ()
Mo changes in the current opened workspace will be saved. All changes get lost when Web reference name:
dosing the tool or the workspace, Return an error in case of: - Mo workspace is opened.
API-Result-Codes: 0 1004 No database. 1040 Mo workspace, @example ASCETWebReference I
ActivateMoSaveMode() @param outiMsg If no problem occured an empty string is
returned. Otherwise the result string contains the error description.
. P a Add Reference |l
m ApiVersion ()
Return the current version of the ASCET Automation API. API-Result-Codes: NO
RESULT CODES! @example ApiVersion() @param outMsg Version string for the ASCET
Automation APL
m ClearMonitorContents ()
Clear the current manitor contents. APT-Result-Codes: 0 @example
ClearMonitorContents() @param outMsg If no problem ocoured an empty string is
returned. Otherwise the result string contains the error description.
m CloseCurrentDatabase ()
The current used database will be dosed. Return an error in case of: - The database
could not been cosed. APIl-Rels'.uIt-Codes: 0 1005 Operation failed. 1021 A Iongllasting -
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¢ In Solution Explorer: The newly created web reference is listed

Solution Explorer v L B Program.cs
158
m Solution 'Consolefpplicationl’ (1 project)
4 [ ConsoleApplicationl
4 |7 Properties
#] Assemblylnfo.cs
] Settings.settings
4 |7 References

ﬁgCu:uns-:ulEAppIicatiDnl.Prngram

Fusing System;

using System.Collections.Generic;
using System.Ling;
| using System.Text;

Flnamespace Consolefpplicationl

1
<2 Microsoft.Csharp = class Program
< System {
<3 Systemn.Core &l static wvoid Main(string[] args)

1
¥

<3 Systern.Data
<3 Systern.Data.DataSetExtensions
< Systemn.EnterpriseServices
<3 Systermn.\Web.Services
<3 Systern.Xml
<3 Systemn.Xrl.Ling

[_d Service References

4 Web References

i | ASCETWebReference | I
i app.config
] Program.cs

e Make adjustments to the program as suggested per the following image/code sample:

Selution Explorer

| éj 2] | [=] 994 -ﬁgConsoIeApplicationl.Program
m Solution 'ConsoleApplication]’ (1 project) Elusing System;
a @ ConsoleApplicationl using System.Collections.Generic;
4 [ Properties using System.Ling;
& Assemblylnfo.cs using System.Text;

. . using System.Web.Services;
=] Sett et . - .
> H INgs.setings using Consolefpplicationl.ASCETWebReference;
4 | _¥ References

3 Microsoft.CSharp namespace ConsocleApplicationl

Bl

- System | {

- System.!ore - E|I class Program
El

Pregram.cs®

<2 System.Data 1

<30 System.Data.DataSetExtensions static veid Main(string[] args)

<3 System.EnterpriseServices 1
.3 System.Web Services AaaTeolInterface tool = new AaaToolInterface();
Conscle.Writeline ("AscetWebService version: " + tool.Ping()});
+3 System.Xml Conscle.Writeline ("AscetWebService version: " + tool.About());
-3 SystemXml.Ling Censele.Writeline("AscetWebService version: " + tool.ApiVersion());
|g Service References Censole.Writeline("AscetiebService version: " + tool.TeolVersion());
4 | Web References | }
@ ASCETWebReference L }
=% app.config L}

] Program.cs
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e Code

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

using System.Web.Services;

using ConsoleApplicationl.ASCETWebReference;

namespace ConsoleApplicationl

{
class Program
{
static void Main(string[] args)
{
AaaToolInterface tool = new AaaToolInterface(),
Console.WriteLine("AscetWebService version: + tool.Ping());
Console.WriteLine("AscetWebService version: " + tool.About());
Console.WriteLine("AscetWebService version: " + tool.ApiVersion());
Console.WriteLine("AscetWebService version: " + tool.ToolVersion());
}
}
}

e Now Save All files

an ConsoleApplicationl - Microsoft Visual Studic
Eile Edit ‘l."lew i

IIEP

I,j; Solution 'Consoledpplicationl’ (1 project)
4 (5] ConsoleApplicationl

4 |7 Properties
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e Execute the application

en ConsoleApplication] - Microsoft Visual Studic
File Edit VYiew Refactor BuDehungeam Data Toocls Test Window Help

A= B= I WEE RN PR Windows v B €3 5 -

Solution Explorer b__Start Debugging F5
=) £=| B 5‘1 2 [*  Start Without Debugging Ctrl+F5 ] L\}
j Solution 'Conselefpplicationl’ a Attach to Process...
4 E ConsoleApplicationl Exceptions... Ctrl+AR+E \Generic;
a4 | Properties SE  Steplnto F11
] A blylnfo. -=
__)I ssembyina.cs [,Z Step Over F10 i
] Settings.settings |
i (ETkWebReference;
a4 | References Toggle Breakpoint Fa r
3 Microsoft.Csharp Mew Breakpoint (3|

3 System

1 S prtarm (Care

Cr

e Result:

BN Ch\Windowssystem32omd.exe

AscetllebhService version:

AscetWehService version: ASCET Automation API — <c?> 20815 ETAS GmbH
AscetWebhService version: 1.8.3

AscetWehService version: Ub.4.3

Presz any key to continue . . .

[\
‘8‘ Do you still have questions?

You will find further FAQ articles on the ETAS homepage: www.etas.com/en/faq

Movies corresponding to FAQ articles can be found on the ETAS YouTube channel as well
Please feel free to contact our Support Center, if you have further questions.

Here you can find all information: http://www.etas.com/en/hotlines.php

This information (here referred to as ,FAQ") is provided without any (express or implied) warranty, guarantee or
commitment regarding completeness or accuracy. Except in cases of willful damage, ETAS shall not be liable for
losses and damages which may occur or result from the use of this information (including indirect, special or
consequential damages).
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