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1 安全と個人情報保護
本章には、使用目的、対象となるユーザー、安全性や個人情報に関する情報が記載されてい
ます。
本製品を使用する際には、ユーザーの負傷やデバイスの損壊などを避けるため、「ETAS 
Safety Advice - 安全上のご注意」（Help > Safety Advice）、および下記の注意事
項をよくお読みいただき、その指示に従ってください。

1.1 本製品に関する注意事項
本製品を安全に使用するには、一般的な注意事項に加え、以下の要件も守ってください。

本製品の準備や操作を行う前に、本製品を使用する環境が所定の条件を満たしてい
ることを確認してください。各条件については、使用するPCやハードウェアのドキュメントを
参照してください。

1.2 製品の正しい使用法
ETAS ASCMOツールファミリは、オフラインデータに基づくモデリングや、モデルベース適合、さらに
は物理値モデルのパラメータの効率的な最適化を目的としています。稼働中のシステムで直接
動作することは意図されていません。
ASCMO-STATICとASCMO-DYNAMICを使用すれば、少量の測定データから複雑なシステ
ムの挙動を正確にモデル化することができます。このモデルは、入力パラメータの分析と最適化に
使用したり、他のシミュレーション環境においてプラントモデルのブラックボックスとして使用すること
もできます。これとは対照的にASCMO-MOCAは、定義された構造を持つ既存の物理値モデ
ルを使用して、モデル自体のパラメータを調整して最適化します。その結果は「提案」として扱わ
れるもので、後続の処理を行う前に検証を行う必要があります。
製品の不適切な使用や安全に関する注意事項に従わないことにより生じた一切の損害につい
て、ETAS GmbH は責任を負いません。詳細は Help → Safety Advice を参照してくださ
い。

1.3 対象ユーザー
このユーザーガイドは、自動車用ECUの開発および適合の分野に携わる技術者の方を対象とし
ています。本書の内容をご理解いただくには、計測や、制御ユニットのエンジニアリングに関する専
門知識が必要です。

1.4 安全に関する注意事項の記述書式
以下の「安全に関する注意事項」は、人身事故や物的損害につながる危険性を警告するもの
です。

危険 

危険：記載事項を守らないと死亡または重傷のリスクが高い危険性について説明していま
す。
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 警告  

警告：記載事項を守らないと死亡または重傷のリスクを招く可能性のある危険性について説
明しています。

 

注意 

注意：記載事項を守らないと軽～中程度の負傷のリスクを招く可能性のある危険性につい
て説明しています。

 

ご注意ください！ 
ご注意ください！：記載事項を守らないと物的損害を招く可能性のある状況について説明
しています。

 

1.5 安全に関する注意事項

ご注意ください！ 
誤った実験計画による損害
ASCMO-STATIC ExpeDesにおける誤ったエンジン設定は、エンジンやテストベンチの損傷
を招きます。例：ノッキングが多発するような点火角度設定などにより、動作ポイントがエンジ
ンに過大なストレスを与え、損傷の原因となります。

実験計画の一般設定は、システムと対象物に適合している必要があります。誤った設定
の例：最大6000rpmのエンジンに対して、実験計画内で10000rpmが設定されてい
る
動作ポイントは、許容値の範囲内に制限してください。ETAS ASCMOは、エンジンパラ
メータに関する情報を一切持っていません。
実験計画をエクスポートする前に、一般設定においてエンジン負荷の範囲を制限してくだ
さい。
実験計画を使用するには、その内容を検証する必要があります。

7.2 「ステップ1：一般設定 」（ページ163）および7.11 「ステップ9：エクスポート
（"Export"） 」（ページ192）を参照してください。
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1.6 個人情報保護に関する注意事項
ユーザーの個人情報保護の問題はETASにとっても重要な案件であるため、本項では、本製品
（および）によってどのようなデータが処理されるか、どのような種類のデータを使用するか、また
個人情報の保護のためにユーザー自身がどのような技術的対策を講じるべきか、といった内容に
ついて説明します。さらに、本製品が個人情報を保存する場所や、その削除方法について、詳
しく説明します。

1.6.1 データの処理
本製品の使用時には、個人データが処理されます。本製品の購入者は、GDPR（General 
Data Protection Regulation：EUの一般データ保護規則）のArticle4 No. 7に従って
データ処理を行う法的責任があります。製造者であるETAS GmbHは、当該データの不適切
な扱いに関して、いかなる場合も責任を負いません。
また、ETASライセンスマネージャでユーザーベースライセンスを扱うと、以下のような個人データ
が、ライセンス管理の目的で記録される可能性があります。

通信データ：IPアドレス
ユーザーデータ：ユーザーID、WindowsのユーザーID

1.6.2 技術的／組織的な対策
本製品は、個人データを記録する際に暗号化を行いません。記録されるデータの機密保持のた
め、ユーザー側のITシステムに適した技術的対策または組織的対策を講じてください。
ログファイル内の個人データは、オペレーティングシステムのツールを用いて削除することができま
す。
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2 ETAS ASCMOについて
本章ではETAS ASCMOの概要をご紹介します。

2.1 ETAS ASCMOの概要
ASCMO（Advanced Simulation for Calibration, Modeling and Optimization）
は、「実験計画法」（DoE： Design of Experiment）と呼ばれる手法により得られる測定
データに基づいて、未知のシステムの入出力挙動をモデリングするためのツールです。
システムを物理式で正確に定義できない場合は、このような「データに基づくモデリング」を行うこと
が必要となります。この手法では質の高いモデルを作り上げることができるので、たとえば、内燃機
関の大域的挙動といった複雑な関係もマッピングできます。
モデリングが終わると、ETAS ASCMOはシステムの挙動を「視覚化」し、モデルを使用して「適
合」／「最適化」を行うための各種選択肢を提示します。ここで適合作業を行い、「内燃機関」
システムのモデリングと最適化を実現します。
ここで使用されるモデリングと最適化の手法は、入力変数によって出力変数の値が連続的に変
化するようなシステムにも適用できます。

2.1.1 実験計画法（DOE：Design of Experiment）
「実験計画法」は、未知のシステムをデータに基づいてモデリングするための手法です。

図 2-1: 実験計画の立案からモデルベースの最適化まで

最初のステップは実験計画の立案です。ここで立案した計画に基づいて最小限の測定を行うこ
とにより、モデルトレーニングに用いられるデータが得られます。
モデルは数学的近似法を基礎とし、測定対象システムの挙動を再現することができます。
モデリングの最終目的は、システム挙動を評価し最適化することです。内燃機関を例にとれば、
パフォーマンスの最大化、および燃費と排ガス排出量の最小化を実現するための最適な出力変
数を導き出す入力変数を決定することにあります。 

2.1.2 モデルベース適合
昨今のECUの適合作業は、さまざまな要因により複雑化の一途をたどり、コストも増大していま
す。
主な要因としては以下のようなものが挙げられます。

派生車種の多様性
テスト対象（エンジン、車両）の可用性の低下
燃費、排出物、診断に関する要件の厳格化
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このように複雑化した適合作業は、従来の「古典的な」手法では扱いきれなくなってきています。
定型的な作業を自動化したとしても、以下のようなステップを反復的に行う必要があります。

ECUパラメータの測定と変更
実験車両／エンジンのレスポンス測定
測定値の解析
段階的な最適化

この手続きをすべて実行することにより、1つの最適なデータセットが算出されます。
ASCMO-STATIC または ASCMO-DYNAMIC でのモデルベースの適合では、以下のような
処理がすべてモデル上で行えるため、実験計画の立案後に行う実システム上での計測作業は、
1回だけですみます。それ以外はすべてモデル上で行われます。

最適化目標を定義した後に、1回の最適化実行により最適なパラメータセットを算出で
きます。
マップを変更し、その結果得られる挙動を予測することができます。
適合対象の仕様に応じた最適な結果を達成できます。 
 l 小型車の場合は燃費、スポーツカーの場合はトルク
 l スポーティな運転挙動（トルクを即座に得られる）vs：快適性

この場合、n回の反復により、最適化されたn個のデータセットが算出されます。

例
直噴エンジンの「モデルトレーニング」と「最適化」の一例を、6 「チュートリアル: ASCMO-
STATICの操作」（ページ66）という章で紹介しています。この例では、一連のマップがいくつか
のファクタ（燃費、エンジンのスポーティさ、ばい煙、NOx 排出量）に関して最適化されていま
す。

2.2 ASCMO-DYNAMICの概要
今日のモデルベース適合ツールでは、モデリング時に定常状態のエンジン挙動しか考慮しないた
め、動的影響を予測に反映させることができません。これでは、時間に依存する関係や過渡的
な関係を伴う動的なエンジンプロセス（エンジン吸気系や排ガスエミッションなど）をシミュレート
するには不十分です。
このような問題は、ETAS ASCMOのダイナミックモードを扱うASCMO-DYNAMICで解決する
ことができます。
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ASCMO-DYNAMICとASCMO-DYNAMIC ExpeDesについての詳細は、ASCMO-
DYNAMICユーザーガイド（<installation>\ManualsフォルダのManual_
dynamic_jp.pdf）に記載されています。

2.3 より詳しい情報について
本書（ユーザーガイド）だけでなく、特にユーザーインターフェースでの操作を行っている際には、
オンラインヘルプをご活用いただくことをお勧めします。Help > Online Help を選択するとオン
ラインヘルプが開き、また F1 を押下すると、現在開いているウィンドウに応じたコンテキストヘルプ
が開きます。
Pコードバージョンの機能に関するヘルプを開くには、Help > Interface Help を選択しま
す。
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3 インストール
本章では、ソフトウェアのインストール準備とインストール方法、およびライセンス管理について説
明します。

3.1 「ASCMO-STATICのバージョンとアドオン」（下記）
3.2 「準備」（下記）
3.3 「インストール」（次ページ）
3.4 「ライセンス管理」（ページ19）
3.5 「アンインストール」（ページ20）

3.1 ASCMO-STATICのバージョンとアドオン
ETASの各種アドオンパッケージは、それぞれ個別のライセンスで管理されます。よく使われるアド
オンとしては、以下のものがあります。

ASCMO-SDK（Software Developer Kit：ソフトウェア開発キット）：3.3.3 「P
コードバージョン」（ページ18）
ASCMO-GO（Global Optimization：グローバル最適化）：「グローバル最適化 
」（ページ54）
ASCMO-ME（Model Export：モデルエクスポート）：6.10 「モデルのエクスポー
ト」（ページ147）

ライセンスなどに関する詳細は、リリースノート（「Functions at a glance」の項）やETAS
ホームページのダウンロードセンター（"オーダー情報"）を参照してください。

3.2 準備
インストールを行う前に、PCがシステム要件（リリースノート「System Prerequisites」の項を
参照）を満たしていることを確認してください。またインストールを実施するユーザーは、オペレー
ティングシステムやネットワーク接続について必要なユーザー権限を持っていることを確認してくださ
い。

注記 

ソフトウェアのインストールや操作を行うには、Windowsレジストリデータベースに対するアクセ
ス権が必要です。アクセス権が不明な場合は、システム管理者の方にお問い合わせください。

3.2.1 ユーザー権限
ソフトウェア本製品のインストールと操作のためのユーザー権限については、以下の注記に従って
ください。

インストール時に必要なユーザー権限
PCにソフトウェアをインストールするには、管理者のユーザー権限が必要です。詳細はシステム管
理者の方にお問い合わせください。
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操作時に必要なユーザー権限
ソフトウェアの操作は、標準ユーザーのユーザー権限で行えます。

3.2.2 その他のソフトウェア要件
必要なソフトウェアコンポーネントがPCにインストールされていない場合は、ETAS ASCMOのイン
ストール時にすべてインストールされます。

3.3 インストール
 1. インストールファイルが格納されているディレクトリを開きます。
 2. Setup_ASCMO_x64.exe というファイルをダブルクリックします。

セットアップウィザードが開きます。

 3. Next をクリックします。
"License Agreement" ウィンドウが開きます。
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 4. ライセンス許諾書の内容をよく読んで、I accept the agreement オプションを選択
します。

 5. Next をクリックします。
"Set Destination Location" ウィンドウが開きます。
すでにPCにETAS ASCMOがインストールされている場合は、現在使用されているパス
（インストール先フォルダとスタートメニューのフォルダ）が使用されます。

 6. 提示されるデフォルトフォルダを承諾、または Browse をクリックして新しいフォルダを選
択します。

 7. Next をクリックします。
"Select Start Menu Folder" ウィンドウが開きます。

 8. 提示されるデフォルトフォルダを承諾、または Browse をクリックして新しいフォルダを選
択します。

 9. Next をクリックします。
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 10. デスクトップアイコンを作成するには Create a desktop icon をオンにします。

 11. MATLAB® Compiler Runtimeのインストールに関するオプションを選択します。
 12. 必要に応じて Install Prerequisites をオンにします。
 13. Next をクリックします。

"Ready to Install" ウィンドウが開きます。ここまでの各ウィンドウで入力した情報を確
認することができます。
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 14. 設定内容を変更するには Back をクリックします。
 15. Install をクリックしてインストールを開始します。

インストールが実行されます。進捗インジケータにインストールの処理状況が表示されま
す。インストール処理がすべて終了すると、"Completing the ETAS ASCMO Setup 
Wizard" ウィンドウが開きます。

 16. Finish をクリックします。
インストールが完了します。ETAS ASCMOが起動できる状態になります。

3.3.1 スタートメニュー
インストールが正常に終了すると、インストーラの "Select Start Menu Folder" ウィンドウで設
定したスタートメニューのフォルダに、以下のエントリが追加されます。

ASCMO Desk V5.11
ASCMO-DESKウィンドウが開き、ここからETAS ASCMOの各コンポーネントを起動す
ることができます。
ASCMO Dynamic V5.11
ASCMO-DYNAMICを起動します。
ASCMO ExpeDes Dynamic V5.11
ASCMO-DYNAMIC ExpeDesを起動します。
ASCMO ExpeDes V5.11
ASCMO-STATIC ExpeDesを起動します。
ASCMO MOCA Runtime V5.11
ASCMO-MOCA Runtime（機能制限付き）を起動します。
ASCMO MOCA V5.11
ASCMO-MOCAを起動します。
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ASCMO Static V5.11
ASCMO-STATICを起動します。
Manuals and Tutorials
ASCMOドキュメントフォルダ（<installation>\Manuals）を開きます。ここには
以下の情報や文書が保存されています。
 l ASCMOInterfaceDoc - インターフェースに関する文書が保存されたフォルダ
 l Examples - 各種サンプルデータ（ASCMOプロジェクト、

MF4／DCM／XLS／FMUファイル、テンプレート、プラグインなど）が含まれるフォル
ダへのショートカット

 l HTMLフォルダ - インストール済みコンポーネント用のオンラインヘルプファイル
（<F1> キーで開きます）

 l Manual_dynamic_en.pdf／Manual_dynamic_jp.pdf - ASCMO-
DYNAMICの基本機能に関するチュートリアルを含むユーザーガイド

 l Manual_en.pdf／Manual_jp.pdf - ASCMO-STATICの基本機能に関す
るチュートリアルを含むユーザーガイド

 l MOCA_*.pdf - ASCMO-MOCAの基本機能の説明やチュートリアルを含むユー
ザーガイド

3.3.2 ファイルとディレクトリ
プログラムに関連するすべてのファイルは、インストール時に指定された <installation> 
ディレクトリとそのサブディレクトリに保存されています。
<installation> のデフォルトはC:\Program Files\ETAS\ASCMO 5.11です。

MATLAB®/Simulink®用のPコードファイルは、<installation>\pCode\ascmo  に
保存されています。
詳細は、Pコードバージョンの項を参照してください。

3.3.3 Pコードバージョン
PコードバージョンのETAS ASCMO（3.3.2 「ファイルとディレクトリ」（上記）参照）は、
MATLAB®から直接起動することができます。

前提条件
Pコードバージョンを使用するには、MATLAB® R2016a ～ R2019bがインストールされている
必要があります。さらに、以下のMATLAB®ツールボックスも必要です。

Optimization Toolbox™
Statistics and Machine Learning Toolbox ™

ETAS ASCMOの実行
MATLAB®で、ディレクトリ <installation>\pCode\ascmo に切り替えます。続いてコ
マンドウィンドウに以下の表のコマンドを入力します。
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コマンド 機能

AscmoDesk ASCMO-DESKを起動します。

ascmo static ASCMO-STATICを起動します。

ascmo expedes ASCMO-STATIC ExpeDesを起動します。

ascmo dynamic ASCMO-DYNAMICを起動します。

ascmo expedesdynamic ASCMO-DYNAMIC ExpeDesを起動します。

ascmo moca ASCMO-MOCAを起動します。

ascmo mocaruntime ASCMO-MOCA Runtimeを起動します。

ascmo cyclegenerator ASCMO Cycle Generator（スタンドアロン走行サ
イクルジェネレータ）を起動します。

ascmo scatterplot ASCMO Scatter Plot（スタンドアロン走行サイクル
ジェネレータ）を起動します。

ascmo 

calibrationdataeditor
ASCMO-Calibration Data Editor（スタンドアロン
走行サイクルジェネレータ）を起動します。

ETAS ASCMOツール（ASCMO Scatter PlotとASCMO-Calibration Data Editorを除
く）内で実行される全ステップは、コマンドを使用して自動化することができます。コマンドについて
の説明を参照するには、メインメニューから Help > Interface Help を選択してください。

3.4 ライセンス管理
本製品を使用するには、ライセンス契約に基づいて発行されたライセンスファイルが必要です。ラ
イセンスファイルは、社内のツール管理者の方から、またはホームページのライセンスポータルサイト
（http://www.etas.com/support/licensing）から入手できます。ライセンスファイルのお
申し込み時には、製品購入時にETASから発行された「アクティベーション番号」が必要です。
Windowsスタートメニューから E > ETAS > ETAS License Manager を選択します。
ダイアログに表示される指示に従って操作してください。ETASのライセンスモデルについての説明
や、ライセンスマネージャの操作方法（ライセンスの確認、登録／削除、借用／返却など）につ
いては、ライセンスマネージャのオンラインヘルプを参照してください。オンラインヘルプを開くには、ラ
イセンスマネージャで <F1> キーを押します。

ライセンスマネージャのFAQ
FlexNet EmbeddedテクノロジーとETASライセンスマネージャについての詳細は、ETASウェブ
サイトのダウンロードセンターにある『ETAS License Management FAQ』をご覧ください。
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3.5 アンインストール

注記 

各コンポーネントを個別にアンインストールすることはできません。この処理によって すべての 
ETAS ASCMOコンポーネントがアンインストールされます。

ETAS ASCMOのアンインストールは、Windowsコントロールパネルの プログラムと機能 から開
始します。
ETAS ASCMOをアンインストールする

 1. アンインストールを開始します。
確認のメッセージが開きます。

 2. はい をクリックして処理を実行します。
 3. OK をクリックしてアンインストールを完了します。
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4 ASCMO-STATICの基礎
本章では、ASCMO-STATICの基本概念について説明します。
主な内容は以下のとおりです。

4.1 「応用分野」（下記）
本項では、ETAS ASCMOの応用分野について説明します。
4.2 「実験計画法（DOE：Design of Experiment）」（次ページ）
本項では、「実験計画法」について説明します。
4.3 「ASCMO-STATICで行うモデルトレーニング」（ページ28）
本項では、ASCMO-STATICで行うモデルトレーニングについて説明します。
4.3.5 「ASCMO-STATICのモデルタイプ」（ページ31）
ASCMO-STATICでは、生成されるモデルのタイプを選択することができます。本項で
は、各タイプについて設定できるパラメータについて説明します。
4.4 「モデルの評価と改良 」（ページ38）
本項では、ASCMO-STATICで作成したモデルの品質を評価する方法や、必要に応じ
てモデルを改良する方法について説明します。
5.1 「ASCMO-STATICのユーザーインターフェース」（ページ60）
本項では、ASCMO-STATICのユーザーインターフェースについて概説します。
4.5 「ASCMO-STATICの高度な設定 」（ページ44）
本項では、詳細パラメータの概要と、高度な設定の表示切り替えの方法について説明し
ます。
4.6 「最適化 」（ページ53）
本項では、さまざまな「最適化手法」とそれらに適用される「最適化目標」について説明
します。
4.7 「モデル評価（モデルスクリーニング） 」（ページ56）
本項では、モデルスクリーニング（Extra > Model Screening）によるモデル評価につ
いて説明します。

4.1 応用分野
ETAS ASCMOは以下のような分野に応用できます。

ECU（ガソリン／ディーゼル）の適合
エンジンパラメータの最適化： エミッション、O2 センサヒーターなど
動的ファンクションの最適化： ドライバビリティ、過給圧など
ECUモデルのパラメータ化（シリンダ充填率、トルクなど）

「適合」分野でETAS ASCMOを使用することには以下のような利点があります。
測定と解析の工程全体の効率が大幅に向上します。
複雑性を適切に扱うことができます。
データの品質が向上します。
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モデルの再利用が可能になります。

システムやファンクションの研究開発
実験エンジンの適合と評価を迅速に行えます。
新規ファンクション（コントローラストラテジなど）のテストや開発に実エンジンのモデルを
使用できます。
未知のシステムの解析と最適化が可能です。
 l ハイブリッド車（バッテリサイズ、排気量など）
 l スタータジェネレータシステム： ジェネレータ電流や軸受温度などのモデリング
 l 噴射システムの開発（形状の最適化）
「メタモデリング」が物理シミュレーションを加速します。

研究開発分野における主な利点は、システム理解が迅速化され向上することと、さまざまな方
法でインパクト解析を行えることが挙げられます。

4.2 実験計画法（DOE：Design of Experiment）
「実験計画法」（DoE： Design of Experiments）は、測定データに基づき未知のシステ
ムをモデル形式で記述するためのものです。DoEの手順には、統計的側面に基づく実験計画の
立案とモデルの作成、さらにモデリングされたシステムの最適化が含まれます。
実験計画の立案は、測定の工数を最小限に抑えることを目的に行われ、測定を行うたびに実
験計画に対していくつかの変数が修正されます。モデルトレーニングには数学的近似法が用いら
れます。

図 4-1: DoE計画から得られるデータによるモデルトレーニング

応用例としては、内燃機関の挙動をモデルとして記述する、といったことが挙げられます。ECUの
マップの最適化は、実システムではなくモデルを使用して行われます。
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4.2.1 実験計画立案のプロセス
第1世代の「古典的DoE」では、システム挙動は多項式ベースで記述されます。このプロセスのメ
リットは、わかりやすい確立されたプロセスであり、多くのツールを利用できることにあります。ただ
し、このプロセスでは単純な局所的関係（2次以内）しかマッピングできません。
このプロセスの大きなデメリットは、パラメータ化に多くの工数が必要なことや、外れ値に対してロ
バスト性が低いことです。
これより革新的なプロセスは「ニューラルネットワーク」をベースとしています。このプロセスでは、複
雑な関係のマッピングも可能です。比較的わかりやすく、使用できるツールもいくつかあります。
デメリットとしては、やはりパラメータ化が必要であることや、過剰適合（オーバーフィッティング）の
危険性があることが挙げられます。さらに、トレーニングや検証のために非常に多くの測定データが
必要になります。
ETAS ASCMOは、「ガウスプロセス（Gaussian process）」をベースとする「第2世代の
DoE」に属しています。このプロセスにおいては、任意の数の関係（内燃機関の大域的挙動な
ど）をマッピングすることが可能です。
このプロセスには、「測定工数とモデル精度」の最適なバランスが保てるという非常に大きなメリッ
トがあります。つまり、少ない測定工程で高いモデル精度を実現することが可能です。
そのほかにも、以下のようなメリットがあります。

パラメータ化が不要
外れ値に対するロバスト性
優れた操作性

ただし、理論があまり説明的でないこと、またPCのメモリを比較的多く使用する、といったデメリット
もあります。

4.2.2 古典的な実験計画
古典的な実験計画は、実験空間の「グリッド（格子）型」または「スター型」の測定に基づいて
作成されます。

図 4-2: 実験空間の測定 － グリッド型とスター型

ASCMO-STATIC V5.11 | ユーザーガイド



4 ASCMO-STATICの基礎 | 24

グリッド測定
一般的にグリッド測定は、モデルがなくても解析可能なため、どのようなタイプのモデリングにも適し
ています。
しかし、必要な測定値の数は指数関数的に増加します。変更するパラメータの数が3～4個より
多くなると、この手法は実用的ではなくなってしまいます（表 4-1を参照してください）。また、非
常に多くの測定を行ってもパラメータ空間の適切なカバー率を達成することができません。
4.2.2は、従来のグリッド測定とDoE手法に必要な測定値の数を比較したものです。DoE手法
で必要な測定値の数は、グリッド測定とは異なり、パラメータの数が増えてもそれほど増加しませ
ん。これらの値は、期待される複雑さが中程度のシステム（7.2 「ステップ1：一般設定 」
（ページ163）のオプション Expected System Complexity が Medium であるシステ
ム）のものです。

パラメータの数 必要な測定値の数

グリッド測定 
（パラメータあたり5ステップ）

DoE手法 
（空間充填）

1 5 5

2 25 10

3 125 20

4 625 35

5 3125 50

6 15625 70

7 78125 90

8 390625 115

9 1953125 145

10 9765625 175

表 4-1: 古典的なグリッド測定とDoE手法（空間充填）： パラメータ数に応じた測定工
数

スター型測定
スター型測定（図 4-2 の右側）では、一度に 1 個のパラメータしか変更されないので、グリッド
測定に比べて測定工数が大きく低減されます。
しかしこのプロセスではパラメータ間の相互関係が軽視され、実際の最適値に到達できないこと
も多いため、複雑なシステムのモデリングには不適切です。

4.2.3 DoEに基づく実験計画
上述のプロセスに代わる最新世代の「DoE に基づく実験計画」として、D（またはV）最適計
画と「空間充填実験計画」とがあります。
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D（またはV）最適計画
この実験計画は特に多項式モデルに適していて、多項式の次数に応じて精度が決まります。
しかしこの方法で実験計画を作成するには、システム挙動についての事前知識が必要で、パラ
メータのレベル数が少なくなければなりません。その結果、境界域の重みが大きくなり、個々のポ
イントの重要度が比較的高くなります。

図 4-3: D最適計画の例

ETAS ASCMOで扱うには、このタイプの実験計画よりも「空間充填計画」の方が適していま
す。

空間充填計画
空間充填計画（ソボル、ラテンハイパーキューブなど）の特色は、測定ポイントがパラメータ空間
内に均等に分布していることと、すべてのパラメータレベルの最適カバー率を実現できることです。
ここでは測定対象システムについての事前知識は必要なく、得られるデータはASCMO-
STATICで行うモデルトレーニングに最適です。
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図 4-4: 空間充填実験計画の例

このような測定計画は、次項に示すASCMO-STATIC ExpeDesなどを用いて作成します。

4.2.4 ASCMO-STATIC ExpeDesによる空間充填実験
ASCMO-STATIC ExpeDesは、DoEに基づいて空間充填実験計画を作成するためのツー
ルです。ASCMO-STATICでのモデルトレーニングには、エンジン回転数と負荷の動作ポイント
のグリッド（格子）全体に計画点を分布させる必要がありますが、ASCMO-STATIC 
ExpeDes を用いてこれを効率的に行うことができます。
動作範囲の境界値を柔軟に設定したり、測定ポイントを限定的な範囲に圧縮したりできます。
ASCMO-STATIC ExpeDesを使用して実験計画を作成する方法は、7 「チュートリア
ル：ASCMO-STATIC ExpeDesの操作」（ページ160）に説明されています。
図 4-5は4個のパラメータ x1,...,x4 の測定ポイントを示し、ここでは動作ポイントに依存する実
験空間境界（赤と緑の面）が設定されています。
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図 4-5: 測定ポイントと実験空間境界

4.2.5 実験手順用の重要な境界条件
実験手順は、結果が再現可能である必要があります。特に、ドリフトのある測定変数を除外す
るか、少なくともそれを識別して適切に対応する必要があります。

実験の再現性とドリフト
実験の再現性を明らかにして「時間的ドリフト」を見積もるには、複数の反復ポイントの測定を
行う必要があります。これは実験の冒頭、中頃、終盤において行うことが推奨されます。
また時間的ドリフトとパラメータによる影響とが区別されるように、パラメータ測定は、名前の昇順
や降順ではなくランダムな順序で行ってください。

テストベンチオートメーションの要件
テストベンチオートメーションの環境においては、運転不可能な条件により緊急停止して測定が
中断されることがないようにしなければなりません。
そのためには、重要な変数（温度、ピーク圧力、ばい煙、失火など）の監視が必要です。値が
限界値を超えた場合は、安全な中間ポイントに戻って所定の安定化時間を守る、といった対応
も要求されます。

4.2.6 DoE手法の利点
測定工数を大幅に低減できます。
平均化／平滑化により信号のノイズを除去できます。
解析や最適化の工程を測定作業から分離できるため、試験設備（エンジンベンチ、
シャシダイナモ、車両など）の使用率が向上します。
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最適化目標が変わっても、新たな測定は必要ありません
モデルは、不正確な可能性もある「システム挙動についての推定」ではなく、実際の測定
に基づいて作られます。
モデルから、パラメータ間の相互関係などのシステム挙動の説明、解析、文書化などを行
うことができます。

4.2.7 DoE手法の制限事項
微分可能な信号波形や連続微分可能な信号波形は、非常に的確にモデリングできま
す。関数の導関数が微分可能な場合、その関数は「連続微分可能」であると言いま
す。
微分不可能な信号波形は、的確には記述できません。
S/Nの値が小さすぎると、モデルは意味を持たなくなります。

図 4-6: DoE手法に適した信号波形と適さない信号波形

4.3 ASCMO-STATICで行うモデルトレーニング
本項では、ASCMO-STATICで行うモデルトレーニングについて説明します。

4.3.1 「データ測定要件」（下記）
4.3.2 「外乱要因、ドリフト、実験の再現性」（ページ30）
4.3.3 「グローバルモデルとローカルモデル」（ページ30）
4.3.4 「モデリングのプロセス」（ページ30）
4.3.5 「ASCMO-STATICのモデルタイプ」（ページ31）

4.3.1 データ測定要件
基本的に、ASCMO-STATICでのモデルトレーニングを成功させるには、1つの単純な原則を念
頭に置いておく必要があります。それは「モデルの正確性はトレーニングデータに依存する」というこ
とです。言い換えれば、不正確なデータや不完全に変更されたデータを使用してモデルをトレーニ
ングすると、モデルの有用性は低くなってしまう、ということになります。
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DoEに基づいて得られたトレーニングデータを使用し、パラメータ範囲内の測定値の有意な変動
に特に注目することによって、最適な結果が得られます（4.2 「実験計画法（DOE：Design 
of Experiment）」（ページ22）を参照）。
測定中に想定される誤差原因については、4.3.2 「外乱要因、ドリフト、実験の再現性」（次
ページ）を参照してください。

注記 

トレーニングに使用されるデータは、物理実験で得られたものである必要はなく、コンピュータシ
ミュレーションの結果を使用することもできます。

データの妥当性評価
測定後は、モデルトレーニングを行う前にトレーニングデータの妥当性評価を行うことをお勧めしま
す。
その際には特に以下の点に注意してください。

すべてのパラメータが実験計画に従って変化し、計測対象のシステムが目的に合った動
作モードを示しているか
出力変数の値は物理的に意味のある範囲内になっているか
0より大きくなければならないデータ（エミッション、燃料消費量など）に対しては、必要に
応じてオフセットを加えたり差し引いたりしてください。
反復ポイントは測定されているか？またその結果はどのようになったか？

測定ファイル
測定データをASCMO-STATICにインポートするには、以下のようなファイルが必要です。

ファイルフォーマット：Microsoft Excel
入力変数と出力変数が各列に1つずつ割り当てられていること
変数名（単位を含めることも可能）が第1行（または第1行と第2行）に入力されてい
ること

図 4-7: 測定データの例
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空白行はASCMO-STATICで処理できるので、削除しておく必要はありません。また一部の値
が空白になっていても問題ありません。

4.3.2 外乱要因、ドリフト、実験の再現性
モデルの品質は測定データの品質に大きく左右されます。エンジンなどの測定に悪影響を与える
可能性のあるファクタとしては、時間的ドリフトだけでなく、エンジン、オイル、給気の温度などの外
乱要因も考えられます。
そのため、測定を行うたびに、特に所定の動作ポイントにおいて測定の時間範囲全体（測定の
冒頭、中間、終盤）がカバーされるよう、反復ポイントの測定を行ってください。
これらの測定ポイントは実験の再現性（RMSE）の判定に使用されるため、高度な計測技術
なしにモデルの精度を高めることはできません。
また一方では、このような測定を行うことにより、外乱要因に基づくドリフトを測定時刻または測
定ポイント番号により識別することが可能です。この場合、外乱要因をモデルの入力とすることに
より、ドリフトによる影響を補正できます。この外乱要因の補正を行うには、外乱要因と他のモデ
ルパラメータとの間に相関関係がまったくないこと（つまりパラメータを「ソート」せずに測定するこ
と）が重要です。

4.3.3 グローバルモデルとローカルモデル
ASCMO-STATICでは、モデルトレーニングとパラメータの最適化を「グローバルモデル」と「ローカ
ルモデル」の両方について行うことができます。
「グローバルモデル」の場合は動作ポイントのグリッド（格子）があり、最初にシステム内で重要
なすべての入力変数と出力変数が測定されます。
典型的な例としては、エミッション、燃料消費量、運転快適性などに関して最適なマップを生成
することを目的とする内燃機関の測定が挙げられます。
システムに動作ポイントがない場合（O2センサなど）や、当面はシステムの動作ポイントが重要
でない場合は、「ローカルモデル」で十分です。
ローカルモデルを使用できるケースとしては、システム開発／アドバンストエンジニアリングの分野に
おいては数点のみの動作ポイント（アイドリング、中負荷、全負荷）で新しい噴射システムを評
価するような場合、また適合終了後にアイドリングの最適化のみを行うような場合が考えられま
す。

4.3.4 モデリングのプロセス
古典的なプロセス（第1世代のDoEやニューラルネットワーク）では、システム挙動のモデリング
は、多項式やニューラルネットワークのようなファンクションクラスだけで行われます。しかしこの方法
では柔軟性に限界があり、過剰適合（オーバーフィッティング）の危険性も伴います（図 4-8
を参照してください）。
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図 4-8: 多項式を使用したフィッティング

モデリングに関与していないデータを用いてモデル評価を行えば（Leave-One-Out 誤
差：4.4.2 「モデル品質判定の手法とデータ」（ページ43）を参照）、このような過剰適合
は、モデル評価用変数（4.4.3 「変数RMSEおよびR2」（ページ43）を参照）の値の著しい
悪化によって顕著になります。
一方、ASCMO-STATICはガウスプロセスを利用し、理論上可能なすべてのファンクションを考
慮してモデルトレーニングを行います。

図 4-9: ASCMO-STATICによるフィッティング

このモデルトレーニングでは、誤差とデータの比較によりモデルが評価されます。この際、ファンク
ションの複雑度が低くなるように特別の注意が払われます。

4.3.5 ASCMO-STATICのモデルタイプ
ASCMO-STATICでは、生成されるモデルのタイプを選択することができます。本項では、各タイ
プのモデルについて設定できるパラメータについて説明します。
ASCMO-STATICのモデルには以下のタイプがあります。
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No Model（モデルを使用しない）
ASC GP Model（ASC GPモデル）
MLP Model（MLP モデル）

高度な設定（Advanced Settings オプションがオンの状態）においては、さらに以下のタイプ
も使用できます。

Polynom Model（多項式モデル）
ASC Compressed Model（圧縮モデル）
Classification Model（クラス化モデル）
ASC GP-SCS Model（ASC GP-SCS モデル）

No Model（モデルを使用しない）
データポイントとして測定データのみが表示されます。設定できるパラメータはありません。

ASC GP Model（ASC GPモデル）
ここではASCMO Gaussian Process（ASC GP）が標準のタイプです。これが最も推奨され
るタイプです。適したモデルサイズは、トレーニングデータポイントが4000以下、入力が15点以下
です。トレーニング期間とメモリ消費量は、特にデータポイントの数に応じて増加します。データポ
イントの量がさらに多い場合は、他のモデルタイプの方が適している場合があります。
以下のパラメータ設定が行えます。

"Automatic Transformation" チェックボックス
モデルのトレーニング時に、自動的に最適なBox-Cox変換が決定されるようにしたい場合
は、オンにします。

"Output Transformation" ドロップダウン
"Automatic Transformation" がオンでない場合は、モデルのトレーニング時に使用する
出力のBox-Cox変換を選択します。

"Advanced" 編集ボタン
詳細はオンラインヘルプ（<F1>）を参照してください。

MLP Model（MLP モデル）
Bosch ECU用フラットバッファフォーマットにエクスポートすることができるMLP（Multilayer 
Perceptron：多層パーセプトロン）モデルです。
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以下のパラメータ設定が行えます。

Automatic Transformation チェックボックス
このオプションがオンになっていると、モデリング時において最適なBox-Cox変換が自動的
に決定されます。
Transformation ドロップダウン
自動変換が適していない場合は、出力のBox-Cox変換をここで手動設定することがで
きます。
Iterations 入力フィールド
10回の反復においてモデルパラメータが向上しなかったモデルトレーニングにおいて行う反
復の回数を指定します。標準は200です。
Multistart 入力フィールド
異なる開始値でオプティマイザを実行する回数を指定します。回数が多いほど所要時間
が長くなりますが、最適なモデルが見つかる可能性が高くなります。
Validations Ratio [%] 入力フィールド
検証サンプルの比率を定義します。値は、トレーニングデータからランダムに選択される検
証サンプルの相対数です。
Use Test as Validation Data チェックボックス
テストデータを検証データとして使用したい場合は、チェックボックスをオンにします。
Continue Training チェックボックス
新しいトレーニングを開始する代わりに既存のトレーニングを続行するには、このオプション
をオンにします。例：複雑な活性化関数（Activation Function）を使ってモデルト
レーニングを行い、その後、ECUに合ったより効率的な活性化関数に交換して、トレーニ
ングを続行します。
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Layers 領域
常に1つ以上の隠れ層と1つの出力層が存在します。
Activation Functions：プルダウンメニューから活性化関数を選択します。
> Linear: y = x
> RELU: y = max(0, x)
> LeakyRelu: y = max(0.01 * x, x)
> Sigmoid: y = 1 / (1 + exp(-x))
> PrecTanh: y = 2 / (1 + exp(-2 * x)) - 1
> Elliotsig: y = x / (1 + abs(x))

 Insert
隠れ層（HiddenLayer_n）を追加します。一般的には1～3個を使用します。

 Delete
選択されている層を削除します

Polynom Model（多項式モデル）

注記 

モデルタイプ "Polynom" は、Advanced Settings オプション（File > Options）がオ
ンになっている場合にのみ使用できます（参照：Enabling the Advanced Settings）。

ここでは多項式モデルを作成することができます。以下のパラメータ設定が行えます。

Automatic Transformation
このオプションがオンになっていると、モデリング時において最適なBox-Cox変換が自動的
に決定されます。
Output Transformation
自動変換が適していない場合は、出力のBox-Cox変換をここで手動設定することがで
きます。"Automatic Transformation" オプションがオンになっていると、ここには使用
される変換が表示されます。
Interaction 1/2
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 l 以下のような一次相関
xi * xj（i != j）

 l 以下のような二次相関
xi * xj * xk（i、j、kはすべて、または一部が異なる）

Order
多項式の最大次数
Stepwise Regression
このオプションがオンになっていると、回帰モデルが段階的に構築されます。ここには5%未
満のp値（有意レベル）を持つ各項が順に含まれます。新しい項が含まれることにより、
すでに含まれている項の有意レベルが変わる可能性があります。p値が10%より高い項
は、除去されます。このメソッドは変数増減法（Forward Selection Method）とも
呼ばれます。

ASC Compressed Model（圧縮モデル）

注記 

モデルタイプ "Compressed Model" は、Advanced Settings オプション（File > 
Options）がオンになっている場合にのみ使用できます（参照：Enabling the 
Advanced Settings）。

このモデルタイプでは、モデル内の基底関数の数を制限することができます（参照：Model 
Compression）。以下のパラメータ設定が行えます。

Model Size
圧縮モデル用の基底関数の数
Number of Iterations 1/2
モデルトレーニングにおいて行う反復の回数を指定します。回数が多いと結果は向上しま
すが、トレーニングの所要時間が長くなります。
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Multi Start
異なる開始値で圧縮を繰り返す回数を指定します。回数が多いとモデル品質が向上し
ます。これにより、モデルトレーニングの所要時間は長くなります。
Plot Error
モデルトレーニング中に発生した誤差の情報を表示します。
Output Transformation
出力のBox-Cox変換は、ここで手動設定することができます。変換を利用することにより
モデル予測を改善できます。トレーニングデータの値が負またはゼロの場合、このフィールド
は無効になります。
Advanced
"Advanced" に関する詳細は、オンラインヘルプ（F1）を参照してください。

Classification Model（クラス化モデル）

注記 

モデルタイプ "Classification" は、Advanced Settings オプション（File > Options）
がオンになっている場合にのみ使用できます（参照：Enabling the Advanced 
Settings）。

このモデルタイプでは、既存の測定データ（入力値）を2つのクラス（クラス0とクラス1）に分類
することができます。クラス化モデルに示されるカーブは、現在の入力値がクラス1に分類される確
率と同じものになります。たとえば、エンジンノックのデータを特定の構成に含める（クラス1に分類
する）か、それとも含めない（クラス2に分類する）かを指定することができます。
以下のパラメータ設定が行えます。

Number of Iterations
モデルトレーニングにおいて行う反復の回数を指定します。回数が多いと結果は向上しま
すが、トレーニングの所要時間が長くなります。
Kernel
モデルトレーニングに使用するカーネル関数を選択します。
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 l Squared Exponential (ARD)：よりソフトなカーブ特性値を使用します。
 l Matern (ARD)：よりハードなカーブ特性値を使用します。過剰適合（オーバー

フィッティング）を招く可能性があります。
Plot Category
このオプションがオフの場合は、入力がクラス1に割り当てられる確率がプロットされます。
オンの場合は、しきい値以上の確率値がクラス1に割り当てられ、クラスのメンバ数がプ
ロットされます。
Category Threshold
モデル評価において、ここで指定した「しきい値」以上の測定値をクラス1に割り当てます。
このしきい値を有効にするには、Plot Category オプションをオンにする必要があります。

ASC GP-SCS Model（ASC GP-SCS モデル）

注記 

モデルタイプ "ASC GP-SCS" は、Advanced Settings オプション（File > Options）
がオンになっている場合にのみ使用できます（"Options" Window (ASCMO-STATIC)" 
on page 1を参照してください）。

ASCMO Gaussian Process Sparse Constant Sigma（ASC GP-SCS）タイプのモデル
は、トレーニングデータの数が多い場合に推奨されます。以下のパラメータ設定が行えます。

No. Basis Functions 入力フィールド
早く収束させるには、実際のモデルトレーニングで使用するより小さなサイズ（20など）を
指定してください。
Output Transformation ドロップダウン
出力のBox-Cox変換を選択できます。none（デフォルト）、log(y)、Bounded、
log(y+c) などから選択することができます。出力変数の変換によるモデル改良を参照
してください。
Optimize Positions チェックボックス
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このチェックボックスがオンの場合は、ランダムに選択されたトレーニングデータの位置におい
て基底関数が使用される代わりに、最適化位置において仮想的（疑似的）入力が使
用されます。
トレーニングに使用する入力の数は、"No. Basis Functions" オプションで指定しま
す。
Multistarts 入力フィールド
異なる開始値でオプティマイザを実行する回数を指定します。回数が多いほど所要時間
が長くなりますが、最適なモデルが見つかる可能性が高くなります。
Input Length Scale Squared 編集ボタン
Edit をクリックすると、"Input Length Scale Squared" ウィンドウが開きます。ここで
各入力のハイパーパラメータを編集することができます。入力のサイズに関するハイパーパ
ラメータの値は、ガウス分布のベルカーブのコア幅です。

Automatic をオンにすると、その入力に対して適切なハイパーパラメータが自動設定さ
れます。オフにすると、任意の値を入力することができます。

4.4 モデルの評価と改良 
本項では、ASCMO-STATICで作成したモデルの品質を評価する方法や、必要に応じてモデ
ルを改良する方法について説明します。

4.4.1 「モデル品質の可視化 」（次ページ）
4.4.2 「モデル品質判定の手法とデータ」（ページ43）
「変数RMSEおよびR2」（ページ43）
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4.4.1 モデル品質の可視化 
ASCMO-STATICで作成したモデルは以下のようにして評価できます。

「測定値とモデル予測を比較表示する」（下記）
「トレーニングデータのサイズによる誤差」（次ページ）
「インターセクションプロットにシグマを表示する」（ページ41）
「モデル統計値の概要」（ページ42）

測定値とモデル予測を比較表示する
Model メニューには、各出力のモデル予測と実際に測定されたデータとを比較するための一連
のコマンドがあります。
Model > Error (Leave-One-Out) > Measured vs. Predicted を選択すると、
下図のウィンドウが開きます。

図 4-10: 測定データとモデルデータ

これらのプロットでは、測定値がY座標、モデル予測値がX座標として表示されます。両者が完
全に一致すると、青色のライン上（y = x）にプロットされます。
青色のラインからの逸脱が大きいほど、測定値とモデル予測の差が大きいことになります。このよう
にしてモデル品質を視覚的に判断し、外れ値を識別することができます（6.5.2 「外れ値の識
別と削除によるモデル改良」（ページ86）を参照してください）。
さらに、各出力について2つのパラメータ（RMSEとR2）が表示されます（4.4.3 「変数RMSE
およびR2」（ページ43）を参照してください）。この例では、これらの値はLeave-One-Out手
法により算出されています（4.4.2 「モデル品質判定の手法とデータ」（ページ43）を参照して
ください）。
この他、以下の表示機能を利用して測定データとモデル予測を比較することができます。

絶対誤差または相対誤差とモデル予測とを比較する
Model > Error (<method>) > Error vs. Output
モデル予測に対する誤差が表示されます。図 6-7: 「"Error vs. Predicted"：モデル
予測に対する絶対誤差」（ページ88）の例を参照してください。
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ヒストグラムと正規確率プロット（絶対誤差または相対誤差）を表示する
Model > Error (<method>) > Probability Plot
正規確率プロットは、x 軸上にプロットされたデータが正規分布になっているかどうかを示
すものです。誤差の実際の分布状況が、グラフ内の正規分布（ライン）と重ねてヒスト
グラムで描かれます。図 6-8: 「"Probability Plot"：正規確率プロット」（ページ
89）の例を参照してください。

トレーニングデータのサイズによる誤差
この機能は、使用されるトレーニングデータのサイズがモデル品質にどの程度影響するかを評価す
るのに役立ちます。
この機能を実行するには、Model > Error (Leave One Out) > Error over 
Training Data Sizeを選択します。ここでは、調査開始時のデータ量、調査終了時のデー
タ量、次のデータサイズまでの間隔、および異なるサブセットによる反復の回数を指定します。

すると、"Analyze model Leave-One-Out error for <output>" ウィンドウに、使用され
たトレーニングデータサイズに対応するモデルの2乗平均平方根誤差（RMSE）が、出力ごとに
表示されます。
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トレーニングデータセットの指定数（"Number of Repetitions" で指定した反復回数）のサ
ブセットが解析用に選択され、それぞれの場合のLeave-One-Out 誤差が算出されます。グラ
フ上の実線は結果の平均値を表します。
これを用いて、「使用するトレーニングデータを増やすとモデルを改良できる」、または「あるサイズか
ら始めたがあまり改良が見られなかったのでトレーニングデータを減らしてもよい」などといったことを
見極めることができます。

注記 

サブセットの数が多いほど、この計算時間は長くなります。

インターセクションプロットにシグマを表示する
View > Show Model Sigmaを選択すると、標準偏差が直交座標系上に表示されま
す。赤色の破線は標準偏差の大きさを表し、出力値の隣には、現在選択されている入力値に
対応する出力値の標準偏差の大きさが表示されます。
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モデル統計値の概要
Model > Show Statistics を選択すると、別ウィンドウが開き、モデリング対象の出力に関
する変数、カバー率、正規確率プロットがまとめて表示されます。

図 4-11: "Model Statistics" ウィンドウ
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4.4.2 モデル品質判定の手法とデータ
モデル品質の判定（RMSE とR2の算出：4.4.3 「変数RMSEおよびR2」（下記）を参照）
は、さまざまな手法（データ）を用いて行うことができます。ここではこれらのメソッドについて説明
します。

Leave-One-Out（LOO）手法
LOO（Leave-One-Out method）手法においては、それぞれn-1個のトレーニングデータを
持つn個のモデルが形成されます。その後、モデルトレーニングに関与しなかった 1 つのデータポイ
ントのモデル誤差が算出されます。
この手法の大きなメリットは、それ以上測定を行わなくてもモデルを現実的に評価できることで
す。

テストデータ
上記の手法以外に、モデルトレーニングに関与しなかったテストデータセットとつきあわせてモデル
予測を検証するという方法でも、モデルを現実的に評価することができます。
この場合のテストデータは、トレーニングデータとしてインポートされたデータの一部のみを使用して
得られるため、無作為に選択された残りのデータが自動的にテストデータセットになります。
別の測定データを使用する手法もありますが、この場合はさらに測定作業が必要となります。

トレーニングデータ
この手法では、モデルトレーニングに使用したデータと同じものを使用します。
これはモデルを肯定的に評価しすぎてしまうため、ASCMO-STATICで行うようなガウスプロセス
に基づくモデルトレーニングには適していません。

4.4.3 変数RMSEおよびR2

モデル品質の定量化には一連の変数が使用されます。ここではこれらの変数について説明しま
す。

RMSE（Root Mean Square Error：2乗平均平方根誤差）
RMSE（Root Mean Square Error）は以下のように定義されます。

式 4-1: 2乗平均平方根誤差（RMSE）

ここで、nは測定データの数です。また、SSRは以下の式で表されます。

式 4-2: 残差二乗和（SSR）
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RMSEは、モデルについて予想される「ばらつき」（標準偏差）を表します。第2の測定値は、
68%の確率でモデル予測値から1 RMSE未満（95.5%で2 RMSE未満、99.7%で3 
RMSE、など）になります。

決定係数R2

決定係数 R2は、モデルトレーニング後に残るばらつき（SSR）を全測定データの平均値に関す
るばらつき（SST）と比較することにより導き出されます。

式 4-3: 決定係数R2 - ここでSSTは以下の式で表されます。

式 4-4: 二乗の総和（SST）

R2はファンクションの出力誤差を評価するための相対的な指標です。分散した測定データのどの
部分がファンクションにより表されているかを示します。

RMSEとR2を使用してモデルを評価する
ここで最も重要な指標は決定係数R2で、この大きさに応じて以下のように評価されます。

0 < R2 < 0.5
このモデルは信頼できる予測に適していません。
0.6 < R2 < 0.8
このモデルは定性的予測に適しています。
0.9 < R2 < 1
このモデルは非常に優れていて、定量的予測に適しています。

絶対誤差RMSEは、個別に以下のように評価する必要があります。
最良の場合、RMSEは実験再現性と同程度の望ましさになる可能性があります。
R2が望ましい値であっても、モデリングされた変数の変動範囲が非常に大きい場合など
は、RMSEが小さくなり過ぎてしまう可能性があります。
R2の値が低くても、モデルの入力パラメータ全域にわたり、モデリングされた変数の変動範
囲が僅かである場合などは、RMSEは十分に望ましい値になっている可能性があります。

4.5 ASCMO-STATICの高度な設定 
本項では、詳細パラメータの概要と、高度な設定の表示切り替えの方法について説明します。
Advanced Settings というオプションがオンの状態でのみ表示されるメニューコマンドやオプショ
ンは、ユーザーインターフェース上に斜体で表示されます。

ASCMO-STATIC V5.11 | ユーザーガイド



4 ASCMO-STATICの基礎 | 45

図 4-12: 「高度な設定」として表示されるメニューコマンドの例

注記 

高度な設定についての詳しい情報はオンラインヘルプ（<F1>）を参照してください。

4.5.1 高度な設定の有効化／無効化 
 1. メインウィンドウで File > Options を選択します。

"Options" ウィンドウが開きます。

 2. Advanced Settings チェックボックスをオンにします。
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 3. OK をクリックします。
ASCMO-STATICにおいて高度な設定が行えるようになります。"Options" ウィンドウ
が閉じます。

注記 

ASCMO-DYNAMICにおいて高度な設定（Advanced Settings オプション）のオ
ン／オフを変更した場合は、次にプロジェクトを開いた後に新しい設定が有効になりま
す。

4.5.2 高度な設定の概要
Advanced Settings オプションをオンにすると（File > Options）、ASCMO-STATICで
は以下の機能が有効になります。

メニューコマンド
 l In/Outputs > Link Inputs

 l Model > Valid Model Range
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 l Model > Reference Model > * > *

 
 l Model > Error (Leave One Out) > Show in ISP

 l Model > Model Compression > *
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 l Model > Scatter Plot Valid Model Range > *
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ダイアログウィンドウ
 l 出力／モデルの詳細パラメータ（ASC GPモデルとCompressedモデル）

 l Model > Error (Leave One Out) > Error over Training Data 
Size: "LOO-Error on Training Data over Training Size" ウィンドウの 
"Number of Repetitions" フィールド

Model > Error (Leave One Out) > Measured vs. Predicted: 
"Measured/Error vs. Predicted" ウィンドウのメニューエントリ "Set Outlier 
Threshold"、Extras > Set Outlier Threshold を参照してください。
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Optimization > * Optimization："Single Result 
Optimization"／"Multi Result Optimization" ウィンドウの詳細設定
 l Settings > Advanced Parameter: Edit

"Valid Model Range" ダイアログボックス
モデル出力の有効範囲を決定するためのしきい値（最大標準偏差の絶対値）を指定
します。Model > Valid Model Range メニューオプションで、指定された範囲が表
示されます。
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Default をクリックすると、ヒューリスティックな値が設定されます。
この値は出力のトレーニングデータの最大標準偏差に相当します。したがって、これより標
準偏差の小さいモデル予測は、「有効である」と評価されます。
Advanced をクリックするとビューアが開き、データとしきい値が表示されます。黒い逆三
角形の付いた赤い線で示されるしきい値は、マウスで移動することができます。

ISPビューでは、入力の無効値と無効範囲も表示されます。
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"Link Inputs" ダイアログボックス
各入力について、特定の条件下でモデル予測に影響を与えないようにすることができま
す。
 l 例：speed == 2000 の場合、load への影響はなくなります。

注記 

ここでは複数の条件を同時に設定することができます。

ISPビューを見ると、loadが影響を受けなくなっていることがわかります。

ASCMO-STATIC V5.11 | ユーザーガイド



4 ASCMO-STATICの基礎 | 53

4.6 最適化 
本項では、さまざまな「最適化手法」とそれらに適用される「最適化目標」について説明します。

4.6.1 最適化手法

単一目的最適化 
1 個の変数、または複数個の変数の加重合計を、勾配降下法により最適化する手法です。こ
の最適化の結果、好ましい最適化目標を達成するための一連の設定パラメータ（入力値）が
得られます（4.6.2 「最適化目標 」（次ページ）を参照してください）。
エンジンにおいては、NOx 排出制限を守りながら燃料消費量を最低限にするための最適化など
に利用されます。
単一目的の最適化を行うには、Optimization > Single Result を選択します。
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複数の動作ポイントで行う最適化 
単一目的の最適化を複数回（動作ポイントごとに1 回）実行するものです。動作範囲全体を
カバーすることによってマップが作成されます。
動作ポイントグリッドを定義すると、これらすべてのポイントにおいて自動的に最適化が実行され
ます。この結果作成されるマップでは、動作ポイントとは一致しない、別のグリッドノード（格子
点）を設定できます。
複数個の動作ポイントで行う最適化を行うには、Optimization > Single Result を選
択してから Optimize at OPs をクリックします。

注記 

"Single Result Optimization" ウィンドウの Optimize at OPs ボタンは、動作ポイント
用の軸が選択されている場合にのみ表示されます（6.3.3 「入力と出力の割り当て」（ペー
ジ70）を参照してください）。軸を選択するには In/Outputs > Set Operating 
Point Axes コマンドを使用します。

多目的最適化 
一連のパレート最適解を得ることのできる「真の」多目的最適化です。最適化を行う際に他の
目標（他の入力や出力の値など）を使用して解を選択することができます。
多目的最適化を行うには、Optimization > Multi Result を選択します。

グローバル最適化 
最適化手順が、すべての動作ポイントにおいて勾配降下法により同時に実行されます。その結
果、複数の動作ポイントで逐次最適化を行った場合と同様の適合マップが作成されます。
目標条件に関しては、走行サイクル運転の予測データとその結果として作成されるマップ（2 次
導関数）の平滑度を考慮に入れることができます。コンポーネントが目標条件に与える影響
（「加重」）は、個々の要件に合わせて設定することができます。
グローバル最適化を開始するには、Optimization > Global Optimization を選択しま
す。

注記 

Optimization メニューの Global Optimization コマンドは、動作ポイント用の軸が選
択されている場合にのみ表示されます（6.3.3 「入力と出力の割り当て」（ページ70）を参
照してください）。軸を選択するには In/Outputs > Set Operating Point Axes コ
マンドを使用します。

4.6.2 最適化目標 
1個または複数個の出力の最適化については、一連の目標条件があります。これらについて下
の表で説明します。
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目標 値 意味

Minimize/
Maximize

なし 他に制限を設けずに最小値／最大値に最適化します。

 Hard Upper/
Lower Bound

上限／下限を設けて最小値／最大値に最適化します。

Target  目標値に最適化します。目標からの逸脱量が最小限に
抑えられます。

Bound  境界値を使用して最適化します。

 Hard Upper / 
Lower Bound

オプティマイザ用に固定の境界値を指定します。上限値ま
たは下限値を超えた場合は、最適化処理は結果を出さ
ずに終了します。
"Single Result at OPs" タイプの最適化の場合、以降
の最適化には "weak upper/lower bound" 目標が
使用されます。

 Weak 
Upper/Lower 
Bound

"Hard ... Bound" を弱めた「ソフト上限値」と「ソフト下
限値」です。
しきい値まで最小化／最大化し、それを超える値は最適
化されません。

表 4-2: 最適化目標の意味

4.6.3 進化的アルゴリズム - 親の選択と生存者の選択 
進化的アルゴリズム（EA: Evolutionary Algorithm）は進化的計算（Evolutionary 
Computation）のサブセットで、生物の個体群のシミュレーションなどに利用されるメタヒューリ
スティックな最適化アルゴリズムです。EA は、生物の進化から着想されるメカニズム、つまり「生
殖」（reproduction）、「突然変異」（mutation）、「遺伝子組み換え」
（recombination）、「淘汰」（selection）などを用います。最適化問題に対する解の候
補群が、1 つの母集団（個体群）として機能し、適合度関数によりその品質が決定されます。
このような演算が反復実行され、母集団の進化が起こります。

進化的アルゴリズムのシーケンス
ASCMO-STATICで使用される進化的アルゴリズムは、1つの「初期化」と、停止目標に達する
まで反復実行される1つの「ループ」から成ります。多目的最適化の停止目標（Number of 
Evaluations）は、"Multi Result Optimization" ウィンドウ（Optimization > 
Multi Result > Settings）で設定することができます。

 1. 初期化（Initialization）：固体群である母集団の初期状態をランダムに生成しま
す。これが第一世代となります。

 2. 評価（Evaluation）：母集団内の各個体の適合度（生存しやすい度合）を評価
します。

 3. 停止目標（Number of Evaluation）に達するまで、以下の世代交代を繰り返しま
す。
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 i. 選択（Selection）：生殖に最も適した固体の選択
 ii. 遺伝子組み換え（Recombination）：遺伝子の交差（Crossover）による

新種の固体の生成
 iii. 突然変異（Mutation）：子孫においてランダムに発生する変化
 iv. 評価（Evaluation）：上記（ステップ2）を参照
 v. 選択（Selection）：新しい世代の決定

ここでASCMO-STATICは、以下の選択処理を識別します。

親の選択（Parent Selection） 
この選択処理においては、評価と遺伝子組み換えに親世代が関わります。この背景として、ラン
ダムな突然変異による新しい世代の生成があるため、最適化目標に向かって努力する必要は
ありません。これは、適合度関数に従って子を生成するより好ましいとも言えます。

生存者の選択（Survivor Selection）
この選択処理においては、評価と遺伝子組み換えに親世代が関わりません。

4.7 モデル評価（モデルスクリーニング） 
ASCMO-STATICでは、モデルスクリーニング（Extra > Model Screening）によりモデ
ルの評価が行えます。特定の入力値に対するモデル出力値が Results of Evaluation 
フィールドに表形式で表示されます。この評価結果は、分布図に表示したり表形式でエクスポー
トしたりすることができます（File > Export Results、または <Ctrl> + <E>）。
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"Model Screening" ウィンドウでは、評価に使用する入力値を定義します。ここには3つのタブ
があり、それぞれのタブにおいて以下の方法で評価を行えます。

4.7.1 「入力値のグリッド定義」（下記）
4.7.2 「入力ポイントのインポート（"Import Input Points from File" タブ）」（次
ページ）
4.7.3 「マップを入力として使用（"Use Inputs from Maps" タブ）」（次ページ）

4.7.1 入力値のグリッド定義
出力を計算するための各動作ポイントを手動で定義します。各ポイントの定義方法は、2つの定
義タイプ（Definition Type）から選択できます。

定義タイプ：始点と終点（Start & Stop）
最小値（Min）と最大値（Max）の範囲で、等間隔のポイントが自動的に生成されます。ポ
イントの数（Count）も任意に指定できます。

上図の例では、3つのポイントが生成されます。入力の最小値（"Min"の値）のポイントが1番
目のポイント、最大値（"Max" 列の値）のポイントが3番目のポイントとなります。2番目のポイ
ントはASCMO-STATICによって生成され、このケースでは他の2つのポイントのちょうど中間点と
なります。
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注記 

"Definition Type" 列で "Support Points" を選択すると、自動計算された値が表示さ
れます。

定義タイプ：ブレイクポイント（Support Points）
それぞれのポイントの値を、値の配列として定義します。

"Count" 列の値を大きくすると、新しいポイントの値が計算され、配列に追加されます。また配
列の値を直接編集すると、それに合わせて "Count" 列のポイント数も自動的に更新されます。

4.7.2 入力ポイントのインポート（"Import Input Points from File" タブ）
入力値が格納されているファイルを指定して読み取ります。一般的に、ロードできるフォーマット
は、*.xls、*.csv、*.txt、*.ascii です。たとえば、入力値をテンプレートとして保存し
ておくことにより、異なるモデルにおいて同じ入力値に対する出力値を調べることができます。

注記 

"Rounding of Values" フィールドのオプションで、読み込んだ値を丸めることができます。

4.7.3 マップを入力として使用（"Use Inputs from Maps" タブ）

注記 

"Model Screening" ウィンドウの "Use Inputs from Maps" タブは、動作ポイントの軸が
選択されている場合に限り表示されます（「入力と出力の割り当て」を参照）。軸を選択す
るには In/Outputs > Set Operating Point Axes コマンドを使用します。

入力値を読み取りたいマップから動作ポイントリストを取得します。以下のタイプのリストやマップを
使用できます。

Manual OP grid
出力値を算出したい動作ポイントを手入力で設定します。速度（speed）と負荷
（load）などの動作ポイント軸を定義します。他の値は既存のマップから読み取られま
す。
Grid nodes from Maps
マップを選択して、出力値の計算に使用するブレイクポイントを読み取ります。
OP lists
既存の動作ポイントリストを選択して、出力値の計算に使用する動作ポイントを読み取
ることができます。
Driving Cycles
走行サイクルを指定して、走行のトレースデータから出力値の計算に使用する入力値を
読み取ります。
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OP list from file
ASCMO-STATICにインポートされていない動作ポイントリストを使用するには、ファイル
を指定してリストを読み取ることができます。読み取られたリストはモデル予測にのみ使用
され、ASCMO-STATICへのインポートは行われません。

注記 

Allow duplicates オプションをオンにすると、動作ポイントのコピーがモデル評価に含まれま
す。

4.7.4 モデル予測の結果（評価結果）
モデル評価の結果は、指定された入力から算出された出力値です。この出力値は "Results 
of Evaluation" 領域に表形式で表示されます。
以下のオプションを選択して、モデル評価に影響を与える設定や制限を定義することができま
す。

Use Map Bounds
マップの境界（Calibration > Map Bounds over OP）を超えるモデル予測の入力
値を無視します。
Label Points Outside Hull as NaN
指定されている外殻（In/Outputs > Hull on Inputs）の外側の入力値を 
"NaN"（非数）としてマークします。外殻評価は出力ごとに行われます。
Calculate Model Sigma
各出力値についてモデルの不確かさ（モデルシグマ）を計算し、"Sigma <Output>" 
列に表示します。以下の "Label non-valid Points as NaN" オプションを使用する
場合は、このオプションをオンにする必要があります。
Label non-valid Points as NaN
モデルの有効範囲外の値に "NaN"（Not a Number）というラベルを付けます。

注記 

このオプションは、Calculate Model Sigma オプションがオンになっている場合にのみ使用
できます。

評価結果の数は "Number of Evaluations" フィールドに表示されます。この数は、一般的
には "Result of Evaluation" テーブルの列数で、モデル予測の計算の所要時間に影響しま
す。
Compute Model Prediction をクリックすると、指定された入力値を用いたモデル予測の
計算が実行されます。
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5 ASCMO-STATICの操作

5.1 ASCMO-STATICのユーザーインターフェース
本項では、ASCMO-STATICのユーザーインターフェースについて概説します。
メインメニューの機能と、それに関連する各種ダイアログウィンドウについての詳細な説明は、コン
テキスト依存のオンラインヘルプ（<F1>、または Help > Online Help）に記載されていま
す。本書内のチュートリアル（6.6 「可視化」（ページ90）を参照）でもユーザーインターフェー
スの操作について紹介されています。

5.2 ASCMO-STATICユーザーインターフェースのエレメント
下図は、ASCMO-STATICのユーザーインターフェースでプロジェクトを開いたところを示していま
す。このメインウィンドウは「ISPビュー」とも呼ばれ、入力に対する出力の依存関係がインターセク
ションプロットとして表示されます。

図 5-1:  ASCMO-STATICグラフィカルユーザーインターフェース（GUI）－ プロジェクトが
開いた状態

GUIは以下の領域に分かれます。
➀メインメニュー
➁ツールバー
➂出力
➃メイン作業ウィンドウ：インターセクションプロット（ISPビュー）と入力
➄ログウィンドウ
ステータスバー（最下行）: 現在のステータス情報

ユーザーによる操作の多くはメインメニューから実行します。また、入力領域（下部）、出力領
域（左部）、インターセクションプロット（5.3 「インターセクションプロット 」（ページ64）を参
照）は、それぞれ相互的に関連して機能します。これらについて以下に説明します。
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メインメニュー
メインメニューと各種ウィンドウ、ダイアログボックスの機能については、文脈依存のオンラインヘルプ
（<F1>）に詳しく説明されています。

入力
入力 x1,..., xn（インターセクションプロットの下）と出力 y1,..., ym（インターセクションプロッ
トの左）によりマトリックスができ、その交点にはそれぞれのインターセクションプロット y1 = f
(x1),..., ym= f(xn)が表示されます。
下図は、"NOx_rel = f(injection)" と "NOx_rel = f(ignition)" のインターセクションプロッ
トです。

図 5-2: ISPビュー：入力

非表示化されている入力のリスト（A）
ISPビューに表示されていない入力が一覧表示されます。リスト内の入力をダブルクリック
すると、その入力がISPビューに再表示されます。
入力の名前（B）
名前フィールドの右側にある  アイコンをクリックすると、"<input> - Parameters" 
ウィンドウ が開きます。

ここでは、入力の名前、単位、表示範囲、その他の設定を変更することができます。
入力の現在値（B）
値を変更するには、このフィールドの値を直接変更するか、インターセクションプロット内を
クリックします。

 入力の非表示化

入力を非表示化する際に、ステータス（ロック、アンロック、マップ使用）は変わりません。

 入力のステートの変更

以下のステートがあります。
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 アン
ロック

手動操作または最適化処理により値を変更でき
ます。
入力名は青色で表示され、値フィールド（2）の
編集が可能です。

 ロッ
ク

値は固定されています。手動操作でも最適化処
理でも変更できません。
入力名は灰色で表示され、値フィールド（2）は
読み取り専用となります。

 マップ使
用

値は、現在の速度と負荷に応じて適合マップから
補間されます。
入力名は赤色で表示され、値フィールド（2）は
読み取り専用となります。

出力
モデリングされる出力は、インターセクションプロットの左側に表示されます。

図 5-3: ISPビュー：出力

出力の名前（A）
このボタンをクリックすると、"Output Properties for <output>" ウィンドウが開きま
す。
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このウィンドウで、モデルタイプの選択や、モデルパラメータへのアクセス（Edit ボタン）、
出力の名前、単位、表示範囲、その他の設定変更が行えます。
たとえば、ここでモデルタイプを選択することができます。出力の変換（6.5.1 「出力変数
の変換によるモデル改良」（ページ86）を参照）はモデルパラメータ内で手動で定義で
き、これらのパラメータには Edit ボタンでアクセスできます。詳しい内容はオンラインヘルプ
（<F1>）を参照してください。
出力のモデルタイプ（B）
ここをクリックすると、モデルパラメータを定義するダイアログボックスが開きます。モデルタイプ
についての詳細は、4.3.5 「ASCMO-STATICのモデルタイプ」（ページ31）を参照し
てください。
出力の現在値（C）
入力の現在値に対応する出力値が表示されます。

ログウィンドウ
メインウィンドウの下部には、実行されているコマンド（機能）についての情報やエラーメッセージ
などが表示されます。
ログウィンドウ内の青い下線部分は、文脈依存のヘルプ情報へのリンク（help は文脈依存の
HTMLフォーマットヘルプ（F1）、Manual/Tutorial はPDFマニュアル）や、最適化処理の
一部として実行される操作や機能に関する情報（例："Created new project.You 
should check your training data."）になっています。
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図 5-4: ログウィンドウに表示される情報の例

 
ログファイルを保存する

 1. ログウィンドウ内でマウスを右クリックし、ショートカットメニューから Save Log to File を
選択します。
"Save Log file As" ウィンドウが開きます。

 2. ファイル名を指定して Save をクリックします。
ログファイルが保存されます。

5.3 インターセクションプロット 
ある 1 個の出力についてモデルトレーニングを行うと、以下の形式の関数が導き出されます。
youtput = f(xinput_1,...,xinput_n)

これを表示すると n+1 次元空間の超平面になり、n > 2 ではグラフィック表示できなくなりま
す。
そこで、ASCMO-STATICのメインウィンドウでは超平面をグラフィカルに表示する代わりに、この
超平面を通るn 個の交点を表示します。これは「インターセクションプロット」と呼ばれます。これら
の各交点においては1つの次元だけが変化して他の次元の値は定数になるので、以下のように
なります。
youtput = f(xinput_1), ..., youtput = f(xinput_n)

n 個の入力とm 個の出力がある場合、インターセクションプロットは n x m 個になります。入力 
x1, ..., xn（インターセクションプロットの下）と出力 y1, ..., ym（インターセクションプロットの
左）によりマトリックスが形成され、その交点においてそれぞれのインターセクションプロット y1 = f
(x1), ..., ym= f(xn) が表示されます。
1 つの出力が2 つの入力に依存する場合は、図 5-5のように表示されます。
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図 5-5: 2 次元交点のインターセクションプロットで表されるn+1 次元超平面（n = 2 の
場合）

上図の例は、回転数 speed と負荷 load に対する出力 NOx_rel（NOx の相対排出
量）の依存性モデルを示しています。
第1の交点は定速の平面で発生します。このインターセクションプロットでは、NOx 排出量には
負荷に対する関数依存性があることがわかります（図の左）。他のすべての入力パラメータ（こ
の例では回転数のみ）は一定のままです。
第2の交点は定負荷の平面で発生します。このインターセクションプロットは、NOx 排出量が回
転数に依存することを示しています（図の右）。
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6 チュートリアル: ASCMO-STATICの操作
本章では、例を用いてASCMO-STATICの基本機能を紹介します。
このチュートリアルの以下のような内容で構成されています。

6.1 「測定対象エンジンの入力と出力」（下記）
本項では、チュートリアルの概要のほか、測定対象となるエンジンの入出力、使用される
測定データなどについて説明します。
6.3 「モデルトレーニングの準備」（ページ68）
本項では、ASCMO-STATICの起動方法と、トレーニングデータセットの品質を評価し
て改良する方法について説明します。これによりトレーニング後のモデル品質を向上する
ことができます。
6.4 「モデルトレーニング」（ページ84）
本項では、データの読み取りからモデルトレーニングまでの一般的な手順を説明します。
6.5 「モデルの改良 」（ページ86）
本項では、トレーニングされたモデルを評価して改良する方法を説明します。
6.6 「可視化」（ページ90）
本項の内容は、以降のステップを続けるにあたって必須のものではありません。しかしなが
ら、ASCMO-STATICの操作に役立つモデル表示機能について説明されていますので、
参考にしてください。
6.7 「最適化 」（ページ99）
本項ではASCMO-STATICのさまざまな最適化処理を実行します。また複数の動作ポ
イントにおけるグローバルな最適化の結果を活用する方法も習得します。
6.8 「走行サイクル予測 」（ページ125）
本項では、走行サイクルを使用してASCMO-STATICで予測単位変換規則を定義す
る方法を説明します。
6.9 「走行サイクルのグローバル最適化」（ページ138）
本項では、ASCMO-STATICで走行サイクルのグローバル最適化を行う方法について、
ディーゼルエンジンのモデルを例に用いて説明します。
6.10 「モデルのエクスポート」（ページ147）
本項では、ASCMO-STATICモデルを他のツール（MATLAB®、INCA/MDA、
Python、Simulink®、Excel、Cコード、GT-SUITE、FMI）用にエクスポートする方
法を説明します。

6.1 測定対象エンジンの入力と出力
このチュートリアルでは、層状給気を行う直噴ガソリンエンジンを例として使用しています。図 6-1
に示す入力と出力について測定されたデータを使用し、各入力／出力の詳細は表のとおりで
す。
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図 6-1: 測定とモデリングの対象となるエンジン

 名前 意味

 
 
 
入力
 
 
 

injection 噴射終了タイミング [° KW]

Ignition 噴射終了タイミングから点火タイミングまでの差 [° 
KW]

fuel_pressure 燃料圧力 [bar]

EGR EGR 率 [%]

ex_cam 排気バルブの閉じ終わり角度 [° KW]

in_cam 吸気バルブの開き始め角度 [° KW]

SCV スワール制御バルブ [ ]

 
動作ポイント

speed エンジン回転数 [1/min]

load 負荷（平均有効圧力により定量化）[bar]

 
 
出力
 

fuel_mass 燃料質量 [kg/h]

CoV エンジンラフネス [%]

soot 排煙濃度SN [ ]

NOx_rel NOx の相対排出量 
[g/kg fuel]

表 6-1: 測定対象エンジンの入出力の名称と意味

6.2 モデリング用データ
チュートリアルで使用されるデータはExcelファイルExample_GDI_Engine.xlsに保存され
ており、以下のディレクトリに格納されています。 
<installation>\Example\AscmoStatic（<installation> のデフォルトは
C:\Program Files\ETAS\ASCMO 5.11）
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このデータはASCMO-STATICでモデリングを行うためのトレーニングデータの要件を満たしてい
ます。

エンジンデータはDoE手法（空間充填法）により得られたもので、各測定値を互いに
無関係に変化させて試験したものです。
出力は、無意味な値になること（たとえば燃料消費量や排出量が0以下になり、出力
の変換が不可能になるようなこと）はありません。

6.3 モデルトレーニングの準備
本項では、ASCMO-STATICの起動方法と、トレーニングデータセットの品質を評価して改良
する方法について説明します。これによりトレーニング後のモデル品質を向上することができます。

6.3.1 ASCMO-STATICの起動 
ETAS ASCMOを起動し、既存のプロジェクト、または新規プロジェクト用のトレーニングデータを
ロードします。

 1. WindowsスタートメニューのETAS ASCMO 5.11プログラムグループから、ASCMO 
Desk V5.11 を選択します。

または
Windowsキーを押して、"ASCMO .." または "Desk" とキー入力し、ASCMO 
Desk V5.11 を開きます。
"ASCMO-DESK" ウィンドウが開きます。

図 6-2: "ASCMO-DESK" ウィンドウ

 2. "ASCMO-DESK" ウィンドウで "Static Modeling and Optimization" タイルをク
リックします。
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ASCMO-STATICが開きます。

図 6-3: ASCMO-STATICスタートウィンドウ

6.3.2 トレーニングデータのロード
新しくプロジェクトを作成するには、まずモデルトレーニングに必要なトレーニングデータをロードする
必要があります。

 1. スターウィンドウの左側のメニューパネルで、New をクリックしますASCMO-STATIC。

 2.  をクリックします。

"ASCMO Data Import" ウィンドウとオープンファイルダイアログが開きます。
 3. オープンファイルダイアログで、トレーニングデータが含まれるファイルを選択します。
 4. ファイルに複数のワークシートが含まれている場合は、"Measured Data" というシートを

選択します。
 5. 開く をクリックします。

データが読み取られます。

注記 

ファイルのサイズによっては読み取り処理に時間がかかる場合があります。

データの読み取りが終わると、ファイルの情報が "ASCMO Data Import" ウィンドウに表示され
ます。
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このウィンドウの上部（"Data Preview" 領域）には読み取られたデータが表示され、左下部
（"Available Data" 領域）には各測定値列の名前が表示されます。これらの値をモデル入
力（"Inputs" 領域）とモデル出力（"Outputs" 領域）に割り当てます。

6.3.3 入力と出力の割り当て
入力変数（Inputs）を選択する
モデルの入力変数を定義するには、以下のように操作します。

 1. 以下の測定変数を選択します（複数選択可能）：
 l speed

 l load

 l injection

 l ignition

 l fuel_pressure

 l EGR

 l ex_cam

 l in_cam

 l SCV

 2.  をクリックします。

選択した変数が "Inputs" 領域に追加されます。
動作ポイントを選択する（グローバルモデルの場合）
グローバルモデルの場合は、所定の入力を「動作ポイント」として宣言する必要があります。
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 1. "Inputs" 領域において、各入力の"Type" 列で以下を選択します。

名前 タイプ

speed [rpm] Operating Point Axis 1

load [bar] Operating Point Axis 2

SCV Discrete

その他の入力は Normal タイプとして使用します。

出力変数（Outputs）を選択する
最後に、モデリングする出力変数を定義します。

 1. 以下の測定変数を選択します：
 l Fuel_mass

 l CoV

 l Soot

 l NOx_rel

 2.  をクリックします。 

選択した変数が "Outputs" 領域に追加されます。これでトレーニングデータの割り当て
が完了しました。
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6.3.4 データの視覚的な妥当性確認
インポートを実行する前に、インポートする測定データの内容をグラフィカルに表示して確認するこ
とができます。
インポート前に測定データを表示する

 1. "Available Data" フィールドで、1つ以上の測定変数を選択します。

 2. Plot Selected をクリックするか、Extras > Plot Selected を選択します。
ウィンドウが開き、選択されている変数の数に応じて、以下の内容が表示されます。
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 A. 1個の場合：データ番号に対する測定データ

 B. 2個の場合：1つの測定データに対するもう1つの測定データ（例： speed に対する
load）

 C. 3個の場合：2つの測定データで構成された面に対する1つの測定データ
（例：speed-load の面に対する ignition）
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 D. 4個以上の場合：一連の散布図

このウィンドウで、測定データが均一に分布しているかどうかを視覚的に確認することがで
きます。

注記 

3Dプロットの詳しい操作方法は、6.6 「可視化」（ページ90）を参照してください。
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6.3.5 コンフィギュレーションの保存とロード
コンフィギュレーションファイル（*.ini）は、現在選択されているトレーニングデータの各列の 
"Inputs" グループ（"Type" も含む）と "Outputs" グループへの割り当てが設定されていま
す。
コンフィギュレーションの保存とロードを行う

 1. File > Save Channel Config (*.ini) を選択します。
 2. ファイル選択ダイアログボックスが開くので、現在のコンフィギュレーションを保存するファイル

のパスと名前を入力し、保存 をクリックします。
 3. すでに保存されているコンフィギュレーションをロードするには、File > Load Channel 

Config (*.ini, *.lab) を選択します。

6.3.6 測定データのインポート
次に、モデルトレーニングに使用する測定済みデータをインポートします。
測定データをインポートする

 1. "ASCMO Data Import" ウィンドウで、Import をクリックします。
測定データがインポートされ、プロジェクトが作成されます。測定データはISP
（intersection plot：詳細は5.3 「インターセクションプロット 」（ページ64）を参
照）ビューに表示されます。

ユーザーインターフェースの詳細については、5.1 「ASCMO-STATICのユーザーインターフェー
ス」（ページ60）を参照してください。ISPビューでの操作は、このチュートリアルの6.6.1 「イン
ターセクションプロット（ISP）」（ページ90）という項で説明されています。
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モデリング用の出力変数を選択する
 1. In/Outputs > Select Outputs を選択します。

 2. すべての出力を選択して、OK をクリックします。
次の作業に進む前に、ここでプロジェクトを保存しておきます。
プロジェクトを保存する

 1. File > Save を選択します。パスやファイル名を指定して保存するには、File > Save 
As を選択します。

6.3.7 トレーニングデータセットのレビューと編集
実際のモデリング（6.4 「モデルトレーニング」（ページ84）を参照）はシンプルで、データの前
処理は必要なく、初めてのユーザーでも実行できますが、ここで、ロードされたデータセットの分析
を行っておくことをお勧めします。

注記 

トレーニングデータのレビューと編集を省略する場合は、6.4 「モデルトレーニング」（ページ
84）に進んでください。

Data メニューにはモデル品質の向上に役立つツールが用意されていて、ロードされたデータセット
の確認や変更を行うことができます。
トレーニングに使用されない測定データはランダムに選択され、テストデータとして識別されます。
希望の量を選択すると、削減されたトレーニングデータセットですべてのモデルが再トレーニングさ
れます。指定されたトレーニングデータとテストデータの数は、メインウィンドウの右下にも表示され
ます。

トレーニングサンプル数の設定
データインポート後はすべての測定ポイントがトレーニングデータとして使用される設定になってい
て、使用する測定ポイントの数は最大数よりも少なくすることができます。モデルトレーニングを成
功させるには当然、十分な数の測定ポイントを残しておくことが必要です。
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トレーニングサンプルの数を減らす
 1. メインウィンドウで Data > Set Number Training Samples を選択します。

"Training Samples" ウィンドウが開きます。トレーニングサンプルの現在数が表示され
ます。

 2. トレーニングサンプルの数を500に変更します。
 3. Farthest First オプションをオンにします。

Farthest First アルゴリズムが有効になり、測定ポイントの空間充填的サブセットが選
択されます。詳しくはオンラインヘルプを参照してください。

 4. OK をクリックします。
"Training Samples" ウィンドウが閉じます。ステータスバー上の測定ポイントの数が更
新されます。

トレーニングサンプルの数を最大化する
 1. 再度 "Training Samples" ウィンドウを開きます。

824個のデータサンプルのうち500個がトレーニングデータとして使用されています。モデル
のテストには残りの324個のデータサンプルを使用できます。
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 2. Select All をクリックします。
"Training Samples" ウィンドウにおいて、トレーニングデータのサンプル数が最大数に
変更されます。

 3. OK をクリックします。
"Training Samples" ウィンドウが閉じます。ISP ビュー上の測定ポイントの数が更新さ
れます。

注記 

すでにモデルトレーニングを実施している場合は（6.4 「モデルトレーニング」（ページ84）を
参照）、トレーニングサンプル数を変更して確定すると、自動的にモデルの再トレーニングが実
行されます。

トレーニングデータのチェック
Data > Check Training Data を選択すると、使用するトレーニングデータが空間充填的
に分布しているかどうかを調べることができます。"Check Training Data: Inputs" ウィンドウと 
"Check Training Data: Outputs" ウィンドウが開きます。どちらのウィンドウにも、各入力／
出力の測定値が他の入力／出力に対応してプロットされます。
"Check Training Data" ウィンドウを開く

 1. Data > Check Training Data を選択します。
"Check Training Data: Inputs" ウィンドウと "Check Training Data: 
Outputs" ウィンドウが開きます。
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プロット内の測定ポイントを削除する
 1. "Check Training Data: *" ウィンドウで外れ値を探します。

 2. 1つ以上の外れ値が見つかったら、  ボタンをクリックして、そのポイントの周りに四角形
の囲み線を描きます。

選択されたポイントは異なる色でハイライト表示されます。
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 3. 囲み線内のポイントを「外れ値」としてマークするには、その線上を右クリックし、ショートカッ
トメニューから Mark を選択します。

All Outputs - Mark を選択すると、全出力の外れ値がマークされます。
<output_name> - Mark を選択すると、その出力の外れ値のみがマークされます。
All Outputs - Mark Outside を選択すると、囲み線の外側のすべてのポイントが
マークされます。

 4. 描画した囲み線を消去するには、Remove Rectangle を選択します。
ポイントのマークはそのまま保持されます。

 5. マークしたポイントを削除してモデルトレーニングを再実行するには、Extras > Delete 
Marked Points / Retrain を選択します。

反復ポイントの分析
"Repetition Point Analysisで、一連の測定値内において、指定された公差の値
（Current Tolerance Level）に基づいて決定された「反復ポイント」のグループを表示する
ことができます。
これらの測定ポイントは実験の再現性（RMSE）の判定に使用されるため、高度な計測技術
なしにモデルの精度を高めることはできません。
一方では、このような計測を行うことで、外乱要因に基づくドリフトを測定時刻または測定ポイン
ト番号によって識別することが可能になります。この場合、外乱要因をモデルの入力とすることに
より、ドリフトによる影響を補正できます。この外乱要因の補正を行うには、外乱要因と他のモデ
ルパラメータとの間に相関関係がまったくないこと（つまりパラメータを「ソート」せずに測定するこ
と）が重要です。
"Repetition Point Analysis" ウィンドウを開く

 1. Data > Repetition Point Analysis を選択します。
"Repetition Point Analysis" ウィンドウが開きます。このウィンドウには、指定された公
差の値に基づいて決定された「反復ポイント」のグループが表示されます。
各グループには識別子（"Repetition Point Group ID" 列）が割り当てられていま
す。"Quantity" 列にはそのグループに属するポイントの数が表示され、以降の列にはポ
イントの平均が表示されます。
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 ボタンで、反復ポイントの表示と編集を行うための以下のような機能が利用できま
す。

反復ポイント分析に使用する入力を選択して反復ポイントの基準値を設定する

 1. "Repetition Point Analysis" ウィンドウで  を選択します。

"Detection Threshold and Input Selection" ウィンドウが開きます。すべての入力
が反復ポイント分析用に使用されようになっています。
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一般的には、すべての入力を使用してすべての反復ポイントを識別し、必要に応じて削
除するようにすることをお勧めします。

 2. 以下のいずれかを行います。
 l 評価したい入力を選択します。
 l All Inputs をオン／オフして、すべての入力を選択、または選択解除します。

 3. OK をクリックします。
"Repetition Point Analysis" ウィンドウで、反復ポイントグループが更新されます。

許容しきい値を設定する
許容しきい値（"tolerance threshold"）は、反復ポイントを決定する基準となるものです。
値が大きいほどより多くのポイントが反復ポイントとして識別されます。

 1. "Repetition Point Analysis" ウィンドウで  を選択します。

"Detection Threshold and Input Selection" ウィンドウが開きます。
 2. "Normalized Radius in Percent" フィールドの公差しきい値を大きくします。
 3. OK をクリックします。

"Repetition Point Analysis" ウィンドウで、反復ポイントグループが更新されます。
新しい反復グループのうち、グループメンバーの距離がしきい値未満のものが表示されま
す。既存のグループについては、距離が変更前のしきい値より大きいものと新しいしきい
値未満のものとがマージされます。

 4. 公差のしきい値を 2 に戻します。
測定値のドリフトを表示する
"Repetition Point Analysis" ウィンドウには、各反復ポイントで測定された出力の詳細を表
示することができます。ここではRMSE（Root Mean Square Error）のみ表示されます。

注記 

測定データのドリフトについての詳細は、「4.3.2 「外乱要因、ドリフト、実験の再現性」
（ページ30）」の項を参照してください。

 1. "Repetition Point Analysis" ウィンドウで、表示したい反復ポイントグループの行のい
ずれかのセルをクリックします。

 2. Legend 領域の Drift チェックボックスをオンにします。
ドリフトを示す線が表示されます。
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反復ポイントを削除する
 1. "Repetition Point Analysis" ウィンドウで、削除したい反復ポイントグループのいずれ

かの列を選択します。ここでは複数のグループを選択することもできます。
 2. Remove Groups をクリックします。

"Remove Inputs for Selected Repetition Groups" ウィンドウが開きます。ここ
で、選択されたポイントセットを置き換える方法を指定します。
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Delete all points but median point：各ポイントは、リストのメジアンポイント
（中央ポイント）に置き換えられます。

注記 

グループ内の反復ポイントの数（"Quantity"）が等しい場合は、インデックスが平均
のインデックスに最も近いポイントが選択されます。

Replace group by mean value：各ポイントは、削除されるリストの平均値ポイ
ントに置き換えられます。

 3. いずれかの方法を有効にして、OK をクリックします。
選択された反復ポイントグループが削除されます。"Remove Inputs for Selected 
Repetition Groups" ウィンドウが閉じます。

削除された反復ポイントを表示する
削除された反復ポイントは、"Removed Duplicates" ウィンドウで確認できます。

 1. "Repetition Point Analysis" ウィンドウで  Show Removed を選択します。
"Removed Duplicates" ウィンドウが開きます。

削除された各データポイントの値が、ID（"Removed Group Id" 列）と共に表示さ
れます。

6.4 モデルトレーニング
本項では、データの読み取りからモデルトレーニングまでの一般的な手順を説明します。

注記 

モデルトレーニングの部分を省略する場合は、トレーニング済みのモデルを含むプロジェクト
（<installation>\Example\AscmoStatic\Example_GDI_

Engine.ascmo）をロードし、6.5 「モデルの改良 」（ページ86）に進んでください。

6.4.1 モデルトレーニングの開始
ここまでの準備が終わると、モデルトレーニングを実行することができます。
モデリングを実行する

 1. Model > Start ASC GP Model Training を選択します。
モデリングが開始されます。モデリングの処理には多少時間がかかる場合があります。進
行状況は画面下部のステータスウィンドウで確認できます。
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モデルトレーニングが終了すると、インターセクションプロットが更新されます。

注記 

燃料消費量や排出量などの変数に対して非常に大きな影響を与える
変数（speed や load）は、以下のようにして非表示にすることによ
り、各プロットのスケーリングが調整されてデータが読み取りやすくなりま
す。

 2. 入力 speed および load の横の矢印をクリックします。

ここで、再度プロジェクトを保存しておくことをお勧めします。
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6.4.2 モデルトレーニングのまとめ
以上でモデルトレーニングの工程が終わりました。トレーニングデータに基づき、すべての入力（n 
個）と出力（m 個）の依存関係がモデリングされました。
これらの出力変数のモデルを使用して、最適化された出力変数（燃料消費量や排出量など）
に対する最適な入力値を見つけることができます。
さまざまな最適化手法（6.7 「最適化 」（ページ99）を参照）を適用する前に、まず次項で
モデルの評価と改良についてよく把握してください。

6.5 モデルの改良 
本項では、トレーニングされたモデルを評価して改良する方法を説明します。

注記 

モデルの評価と改良の部分を省略する場合は、6.6 「可視化」（ページ90）または6.7 「最
適化 」（ページ99）に進んでください。

6.5.1 出力変数の変換によるモデル改良
出力変数の変換（「Box-Cox変換」とも呼ばれます）により、モデルをさらに改良することがき
ます。この場合、平方根、反転、対数などの関数が使用されます。

図 6-4: 変換によるモデル改良

これにより、入力変数に対して線形または2乗の関係を持たないエンジンベースのさまざまな振る
舞いをマッピングすることができます。
最適な変換を決定するため、すべての変換が出力に適用され、RMSEが最も低いものが選択さ
れます。実際には、特定の出力変数にどのような変換を適用すればよいかは、すでに十分な経
験値が得られていることが一般的といえます。

6.5.2 外れ値の識別と削除によるモデル改良
モデル誤差（モデル予測を基準とした測定値の偏差）が大きい測定ポイントを「外れ値」と呼
びます。
プロット上で視覚的に評価する（図 6-5参照）こともできますが、条件を定量的に解釈するこ
ともできます。残差が 3-4 x RMSE より大きければ外れ値の可能性があります。
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視覚的評価は、「モデル予測に対する測定値」の表示（Model > Error (<method>) 
> Measured vs. Predicted、<method> = Leave-One-Out / Test Data / 
Training Data）を利用して行います。
下図は、エンジンの測定データをモデル予測に重ねて表示しています。マークされたポイントは、
ASCMO-STATICによって外れ値として識別されたものです。

図 6-5: "Measured vs. Predicted" ディスプレイ内の外れ値

このような偏差が発生する原因としては、測定装置の不具合などに起因する単純な測定誤差
があります。また、エンジンの運転限界付近の不安定な領域で測定が行われたためにモデルによ
るマッピングができなかった可能性も考えられます。
このような測定ポイントはモデルに悪影響を与えます。図 6-6の緑色のグラフは青色のポイントに
基づくモデリングから得られるものですが、赤色の外れ値も使用してモデルトレーニングを行うと、
測定データから逸脱したグラフ（赤色）になってしまいます。

図 6-6: 外れ値を含めるモデリング（赤色）と削除するモデリング（緑色）

以下に、外れ値を識別して削除する方法について説明します。
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外れ値を識別する
 1. Model > Error (Leave-One-Out) > Measured vs. Predicted を選択し

ます。
実際の測定値と、モデルによって予測された出力値が表示されます。

 2. Extras > Set Outlier Threshold を選択します。
このメニューエントリは、Advanced Settingsがオンになっている場合にのみ使用できま
す。このオプションは、メインウィンドウの File > Options で設定できます。
スライダ（"Outlier Threshold:"）と入力フィールド（"Sigma"）が表示されます。

 3. "Sigma" を 4 のままにし、有意水準を高くします。
有意水準が高いほど、外れ値の数が多くなります（赤色の部分）。
外れ値は、以下のように絶対誤差または相対誤差も表示できるようにしたりデータを正
規確率プロットで表示したりすることにより、さらに明確になります。

 4. 以下のいずれかを選択します。
 l Model > Error (Leave-One-Out) > Error vs. Output を選択します。
 l Model > Error (Leave-One-Out) > Probability Plot を選択します。
選択したメニューコマンドに応じて、以下のいずれかのウィンドウが開きます。

図 6-7: "Error vs. Predicted"：モデル予測に対する絶対誤差
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図 6-8: "Probability Plot"：正規確率プロット

各ポイントを識別するには、ポイントを右クリックします。

外れ値を削除する
外れ値を1 つ、または複数まとめて削除するには、以下のように操作してください。

 1. Model > Error (Leave-One-Out) > * で表示したプロット内で、マウスの左ボ
タンを押し下げたまま、選択したいポイントを囲むように四角形を描いて、1 個または複数
個のポイントを選択します。
選択したポイントがカラーで強調表示されます。

 2. 必要に応じて、別の四角形を描いてさらにポイントを選択します。
 3. 四角形内のポイントを外れ値としてマークするには、四角形の端を右クリックし、ショート

カットメニューから Mark as Outlier in Selected/All Outputs を選択します。
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この操作を取り消すには、ショートカットメニューから Unmark in Selected Output 
を選択します。

 4. 選択した測定ポイントをトレーニングデータセットから削除するには、Extras > Delete 
Marked Points and Retrain を選択します。
データを削除した後には、出力用にモデルのトレーニングが再度行われます。

6.6 可視化
本項の内容は、以降のステップを続けるにあたって必須のものではありません。しかしながら、
ASCMO-STATICの操作に役立つモデル表示機能について説明されていますので、参考にし
てください。

6.6.1 インターセクションプロット（ISP）
入力に対する出力変数の依存性モデルが「インターセクションプロット」で可視化されます。イン
ターセクションプロットの概要については、「5.3 「インターセクションプロット 」（ページ64）」の項
を参照してください。
プロジェクトをロードする
保存済みのASCMO-STATICプロジェクトがある場合は、それを開いて作業を続行することがで
きます。以下のように操作してください。

 1. 以下のいずれかを行います。
 l ASCMO-STATICスタートウィンドウで Open ASCMO Project をクリックします。

（「ASCMO-STATICスタートウィンドウ」（ページ69）を参照）
 l ASCMO-STATICメインメニューで File > Open を選択します。

（「 ASCMO-STATICグラフィカルユーザーインターフェース（GUI）－ プロジェクト
が開いた状態」（ページ60）を参照）
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 2. ファイル選択ダイアログボックスでプロジェクトファイル（*.ascmo）を選択し、開く をクリッ
クします。
プロジェクトが開きます。

軸のスケールを設定する
基本的に、Y軸（出力）のスケールは自動設定されます。このスケーリングは手動で変更するこ
とができます。

 1. プロット内を右クリックします。
ショートカットメニューが開きます。Autoscaled Output Range <output> オプ
ションがデフォルトでオンになっています。

 2. Manual Output Range <output> を選択します。
表示範囲を指定するためのウィンドウが開きます。

 4. 最小値と最大値を入力し、Apply または OK をクリックします。
入力についても同様に、ショートカットメニューから手動（Manual Input Range *）または
自動（Autoscaled Input Range *）で軸のスケールを設定することができます。
各入力の表示／非表示を指定する

 1. In/Outputs > Input Properties を選択します。
 2. "Input Properties" ダイアログボックスで、表示したい入力の Show オプションをオン

にします。
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図 6-9: "Input Properties" ウィンドウ

ロックされた入力は最適化されないので、一般的には、すべての入力について 
unlocked のデフォルト設定をそのままにしておくことをお勧めします。

 3. OK をクリックします。
選択されていない入力のインターセクションプロットは表示されなくなります。その代わりに、
入力の名前が左下に一覧表示されます。

または、
各入力の名前の左側にある矢印をクリックして、その入力を非表示にすることもできま
す。

 4. 非表示になっている入力のリスト内の名前をダブルクリックすると、その入力が再表示され
ます。また、<CTRL>キーで複数の入力を選択して矢印アイコンをクリックすると、それらを
一度に再表示することができます。
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入力の値を設定する

値を設定する (A)
プロット内のポイントをクリックして、X値を設定します。
連続的に値を操作するには、マウスの左ボタンを押し下げたままプロット内で十字カーソル
をドラッグし、ボタンを離します。
入力の現在値（B）
入力の値は、入力名の下のフィールドに直接入力することもできます。
出力の現在値（C）
各出力の値も表示されます。これに従って他のすべてのプロットの形状が調整されます。

結果を手動で最適化して保存する
ここでは簡単な最適化を手動で実行することができます。

 1. In/Outputs > 2D Plot Operating Points を選択し、"Operating Points 
Manager" ウィンドウで動作ポイントを表示します。
"Operating Points Manager" ウィンドウが開きます（図 6-10:  ページ96参照）。

 2. プロット表示部で、load の値が約3、speed の値が約3000の位置をクリックします。
 3. すべての入力を調整して、Fuel_mass 出力の値ができるだけ小さくなるようにします。

Fuel_mass 出力のインターセクションプロットを見ると、燃料消費量に対する影響が最
も大きい入力は injection と EGR であることがわかります。

 4. 望ましい設定（Fuel_mass の値は4に近くなります）を確定したら、メインメニューで 
Extras > Evaluation List > Add Current Settings to List を選択しま
す。
モデル評価リスト（"Model Evaluation List" ウィンドウ）が開き、ISPビューで現在
セットされている値がここにコピーされます。
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 5. オプション：このデータを保存するには、このウィンドウのメニューから File > Export を
選択します。

6.6.2 入力と出力の2D／3Dプロット表示
ISPビューには関数依存性を表示できるだけでなく、2個の入力を2Dプロットで表示したり、1個
の出力と2個の入力を3Dプロットで表示したりすることもできます。
2個の入力を2D表示する

 1. In/Outputs > 2D Plot Inputs を選択します。
"Select Axes" ウィンドウが開きます。

 2. "Matrix" タブを開きます。

 3. Deselect All をクリックして、プリセットされている選択内容をすべて解除します。
 4. "EGR" 行、"speed" 列のチェックボックスをオンにします。
 5. OK をクリックします。

回転数に応じたEGR（排気再循環）の測定データが、黒色の点としてプロットウィンド
ウに表示されます。
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赤色の点は、ISPビュー内で現在選択されているspeedとEGRの値を示しています。
 6. プロット内の任意の1点をクリックします。

クリックされた位置に赤色の点が移動し、ISPビューが更新されます。

逆に、ISPビューでspeedまたはEGRの値を変更すると、2Dプロットが更新されます。
動作ポイント専用の2D表示を行う
グローバルモデルの場合は、動作ポイントを表示するための専用の2D表示が行えます。この表
示機能は、"Operating Points Manager" ウィンドウ、または動作ポイントマネージャ
（operating points manager）と呼ばれます。動作ポイントとして指定されている変数は、
燃料消費量や排出量などの出力変数に最大の影響を与えることが多いため、ISPビューの外に
個別に表示すると便利です。ISPビューでは、他の入力の影響力のダイナミズムが失われてしまう
場合があります。

 1. In/Outputs > 2D Plot Operating Points を選択します。
"Operating Points Manager" ウィンドウが開きます。
ここで、ナビゲーション（つまり動作ポイントの選択）を個別に行うことができます。

ASCMO-STATIC V5.11 | ユーザーガイド



6 チュートリアル: ASCMO-STATICの操作 | 96

 2. 必要に応じて、ISPビュー内の動作ポイントを非表示状態にすることができます。
 3. 新しい動作ポイントを選択するには、以下のいずれかを行います。

 l プロット内をクリックします。
 l プロットの上にある入力フィールドに値を入力します（図 6-10:  下記の(A)）。

現在の設定を動作ポイントリストに追加するには、Add OP をクリックします。
 4. 動作ポイントが移動するたびにその動作ポイントから単一目的最適化が開始されるよう

にするには、Extras > Optimize on Move を選択します。
 5. プロットに動作ポイントを表示する（図 6-10:  下記の(B)）には、View > Show 

OPs を選択します。
 6. プロットに測定ポイントを表示する（図 6-10:  下記の(C)）には、View > Show 

Measurement Points を選択します。
 7. プロットの凸包を表示する（図 6-10:  下記の(D)）には、View > Show 

Convex Hull を選択します。

図 6-10: 動作ポイントマネージャ（A：動作ポイント値の入力フィールド、B：動作ポイン
ト、C：測定ポイント、D：プロットの凸包）

出力変数に対する入力変数の影響を3D表示する
モデリングされる出力に対する2個の入力の影響を可視化することもできます。

 1. In/Outputs > 3D Plot Outputs を選択します。
入力（出力1個に対して2個）を選択するためのウィンドウが開きます。

 2. ここでは一例として、出力 "Fuel_mass" に対して入力 "speed" と "load" を選択し
ます。

 3. "Grid nodes" フィールドに、軸あたりのグリッド数を入力します。
 4. OK をクリックします。
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speed/loadの値の範囲に対応する Fuel_mass のモデルの3Dビューが表示されま
す。

黒い線の交点は入力の現在値を示していますが、このプロット内でこの位置を変更する
ことはできません。
表示されている入力変数をISPビューで変更すると、プロット内のポイントの位置も更新さ
れます。

 5. 3Dビューのツールバー内の Insert Colorbar  をクリックすると、プロットの右側に出
力値のカラーバーが表示されます。
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 6. Show Training Data をクリックすると、トレーニングデータが表示されます。

図 6-11: speed と load に対する Fuel_mass の3Dプロット - トレーニングデータ
（青い点）とカラーバーが表示された状態

 7. View > Show Training Data Bounds を選択すると、トレーニングデータの上
下限値が表示されます。
適合マップ（例：図 6-16:  ページ120）と結果マップについても同様のコマンドが用意
されています。
 l 適合マップ：View > Map Bounds
 l 結果マップ：View > Single Result Bound / View > Global 

Optimization Bound
詳細は6.7.5 「適合 」（ページ118）を参照してください。

3Dプロットの回転や反転を行う

 1. プロットの回転や反転を行うには、Rotate 3D  をクリックします。

プロットが回転モードに切り替わり、プロット上のマウスポインタが丸矢印に変わります。
マウスの左ボタンを押し下げたままマウスポインタをプロット上で任意の方向に移動すると、
プロットを回転したり反転することができます。

 2. 回転モードを終了するには、再度 Rotate 3D をクリックします。
3Dプロットに等高線と凡例を表示する
必要に応じて、3Dプロットに等高線を表示することができます。等高線は、適合マップと結果マッ
プにも表示できます。詳細は6.7.5 「適合 」（ページ118）を参照してください。

 1. 3Dプロット内で View > Contour Mode を選択します。
プロットに等高線が追加されます。プロットが回転し、speed - load面を上部から見下ろ
した表示になります。
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 2. 必要に応じてプロットを回転させます。

図 6-12: speed と load に対する Fuel_mass の3Dプロット（等高線モード）

 3. 等高線モードの設定を変更するには、View > Contour Options > * を選択しま
す。
詳細はオンラインヘルプを参照してください。

View > Contour * コマンドは、適合マップと結果マップでも使用できます。6.7.5 「適合 」
（ページ118）を参照してください。

6.7 最適化 
本項ではASCMO-STATICのさまざまな最適化処理を実行します。また複数の動作ポイントに
おけるグローバルな最適化の結果を活用する方法も習得します。
本項では以下のトピックについて説明します。

6.7.1 「1つの目標の加重合計を使用する単一目的最適化 」（下記）
6.7.2 「複数の動作ポイントで行う最適化 」（ページ105）
6.7.3 「多目的最適化」（ページ109）
6.7.4 「グローバル最適化 」（ページ116）
6.7.5 「適合 」（ページ118）

注記 

走行サイクルのグローバル最適化については、6.9 「走行サイクルのグローバル最適化」（ペー
ジ138）を参照してください。

6.7.1 1つの目標の加重合計を使用する単一目的最適化 
課題：燃料消費量（Fuel_mass）を最小限に抑えながら、エンジンラフネス（CoV）、ばい
煙（Soot）、NOx（NOx_rel）などの変数を規定値以下に抑えます。
動作ポイントを定義する

 1. In/Outputs > 2D Plot Operating Points を選択します。
動作ポイントを定義する2個の変数（load と speed）が別ウィンドウに表示されま
す。
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 2. このウィンドウ内で、最適化を行う動作ポイントを指定します（例：speed = 2000 
rpm、load = 2 bar）。

最適化実行中に speed と load の値が変化しないよう、これらの値をロックしておく必
要があります。

 3. "speed" と"load" の横にあるロックアイコン（ ）をクリックします。

2つの入力がロックされ、アイコンがロック状態（ ）になります。

入力フィールドが無効になり、プロット内の赤い点の位置が固定されます。
 1. Optimization > Single Result を選択します。

"Single Result Optimization" ウィンドウが開きます。"Output" 列で最適化する出
力を選択し、他の列で最適化目標を指定します。

ASCMO-STATIC V5.11 | ユーザーガイド



6 チュートリアル: ASCMO-STATICの操作 | 101

図 6-13: "Single Result Optimization" ウィンドウ

 2. "Output" 列の空のセルをクリックします。

 3. ドロップダウンリストから Fuel_mass を選択します。
選択された出力の最適化目標として、デフォルト値が設定されます。さらに新しい空の行
が追加されます。

 4. 同様に、他のすべての出力（CoV、Soot、NOx_rel）を選択します。
 5. 各出力の最適化目標を以下のように設定します。

Output 目標 Value Weight

Fuel_

mass
Minimize None - - Constant 1

CoV Bound Weak Upper 
Bound

Constant 5 [%] Constant 1

Soot Bound Weak Upper 
Bound

Constant 0.3 [] Constant 1

NOx_rel Bound Weak Upper 
Bound

Constant 30 
[g/kg]

Constant 1

最適化結果の範囲を制限する
"Single Result Optimization" ウィンドウでは、さまざまな方法で最適化結果をモデル出力
の有効範囲に制限することができます。
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 1. 最適化結果が自動的にモデルの有効出力範囲内に収まるようにするには、以下のよう
に操作します。
 i. Model Validity ボタンをクリックします。

"Valid Model Range" ウィンドウが開きます。
 ii. このウィンドウで、有効なモデル範囲内に制限したいエレメントを有効にします。
 iii. OK をクリックして設定内容を確定し、"Valid Model Range" ウィンドウを閉じま

す。
 2. 入力の最小値と最大値を設定するには、以下のように操作します。

 i. Input Bounds ボタンをクリックします。
"Input Bounds" ウィンドウが開きます。ここで入力の最小値と最大値を設定するこ
とができます。

図 6-14: "Input Bounds" ウィンドウ

 ii. すべての境界値を測定データに合わせるには、Fit をクリックします。
または

入力ごとに制限を設定するには、以下のいずれかを行います。
 l 最適化用の有効な変動範囲（"Min"/"Max"）を入力します。
 l OP Dependent チェックボックスをオンにします。

入力の "Map Bounds" ウィンドウが開きます。ここで、グリッドポイントを操作して
パラメータの変動範囲を設定することができます。

 iii. OK をクリックして設定内容を確定し、"Input Bounds" ウィンドウを閉じます。
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注記 

OP Dependent Input Bounds オプションを用いてパラメータの有効な変動範
囲を定義する方法についての詳しい情報は、6.7.5 「適合 」（ページ118）を参
照してください。

 3. パラメータの変化の範囲が、指定した外殻の範囲内のデータに限定されるようにするに
は、以下のように操作します。
 i. Hull ボタンの横のチェックボックスをオンにします。

パラメータの変化の範囲が、指定した外殻の範囲内のデータに限定されます
（In/Outputs > Hull on Inputs）。現在の設定は Hull ボタンで確認でき
ます。

単一目的最適化の設定を変更する
 1. "Single Result Optimization" ウィンドウの Settings をクリックします。

"Settings" ウィンドウが開きます。

注記 

詳細パラメータをカスタマイズするための Edit ボタンは、"Advanced Parameters" 
オプションがオンになっている場合（4.5 「ASCMO-STATICの高度な設定 」（ペー
ジ44）を参照）にのみ表示されます。

 2. "Start Design Type" ドロップダウンリストで、最適化に使用する探索開始点を指定
します。
以下の設定が可能です。
Last：ISPビューの現在の設定値が開始値になります。
Space Filling：開始値はソボルアルゴリズムにより空間充填的に選択されます。
All Edges：開始値 = 実験空間の全コーナー。母集団の残りは、ソボルアルゴリズム
に従ってパラメータ空間に分散されます。

 3. "Number of Starts (Multi Start)" 入力フィールドで、最適化の実行回数を指定で
きます。
グローバル最小値が必ず見つかるようにするには、さまざまな開始値を使用して複数回オ
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プティマイザを実行する必要があります。
 4. OK をクリックして設定内容を確定します。

設定が確定されます。ログウィンドウにメッセージが表示されます。
最適化を実行する

 1. "Single Result Optimization" ウィンドウの Optimize をクリックします。
最適化が実行されます。
最適化の結果がISPビューの下のログウィンドウに詳しく表示され、ISP ビューに最適値が
反映されます。

この結果では、燃料量以外の出力を規定値以下に抑えながら、燃料量が最小限に抑
えられています。

注記 

出力のモデルはトレーニングデータの前処理（外れ値の削除や反復ポイントなど）に
より少しずつ変わるので、実際の最適化結果は上図に表示されている結果とは少し
異なっている可能性があります。

ローカル最適化の結果を保存する
 1. メインウィンドウで Extras > Evaluation List > Add Current Settings to 

List を選択して、最適化データを保存します。
モデル評価リスト（"Model Evaluation List" ウィンドウ）が開き、そこに最新の最適
化結果が追加されます。

 2. この評価リストを保存して後で利用できるようにするには、ウィンドウのメニューから File > 
Export を選択します。

 3. "Save Data" ウィンドウが開きます。ファイルのタイプ（*.xlsx、*.xls、*.csv、
*.ascii）、パス、名前を指定し、保存 をクリックします。

動作ポイント選択時に自動的に最適化が行われるようにする
ASCMO-STATICでは、新しい動作ポイントを選択すると自動的に単一目標最適化が実行さ
れるように設定することができます。
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 1. 動作ポイントマネージャ（図 6-10:  ページ96）で、Extras > Optimize On 
Move オプションをオンにします。

 2. このプロット内をクリックして新しい動作ポイントを選択します（赤色の点）。
選択された動作ポイントについて、選択されている目標に基づく最適化が開始されます。

6.7.2 複数の動作ポイントで行う最適化 
6.7.1 「1つの目標の加重合計を使用する単一目的最適化 」（ページ99）で説明されている
方法は、バッチモードでも実行できます。一連の動作ポイントについてオプティマイザが連続的に
実行されることにより、「グローバルな」最適化が行われます。
この最適化は、モデリングされた出力に基づいてマップを作成するための第1歩になります。
動作ポイントのグリッドを定義する
最初に、最適化を行いたいポイントを以下のようにして選択します。

 1. Calibration > Operating Points を選択します。
"Operating Points Manager" ウィンドウ（図 6-10:  ページ96を参照）が開きま
す。

 2. デフォルトとは異なるグリッドを作成するため、このウィンドウで Data > Edit List > 
Redefine Grid を選択します。
"Redefine Grid for OP List <n>" ウィンドウが開きます。

 3. このウィンドウで、以下のように操作します。
 i. 各パラメータのドロップダウンリストから Begin/End を選択します。
 ii. 入力フィールドに speed と load の範囲を入力します。
 iii. "Count" 列にグリッド数（例：5x5）を入力します。

 iv. Constraint to Operating Points Hull オプションをオンにすると、動作ポイン
トの外殻の外側に位置する動作ポイントは無視されます。

 v. OK をクリックして選択を確定し、ウィンドウを閉じます。
等間隔のポイントからなる 2 次元グリッドが作成されます。各ポイントは動作ポイント
マネージャに表示されます。

既存の動作ポイントリストをロードするには、動作ポイントマネージャで File > Import 
を選択します。

最適化目標を定義する
 1. Optimization > Single Result を選択します。

"Single Result Optimization" ウィンドウが開きます。このウィンドウには前回のローカ
ル最適化の目標がロードされています。

 2. NOx_rel 出力の"Value" の中央の列を Constant から per OP に変更します。
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"Value" の右の列が Map ボタンに変わります。
 3. Map をクリックします。

定義されているすべての動作ポイントについて最適化されたプロットが開きます。

すべての動作ポイントの出力値には、Constant 設定のデフォルト値であった30がコ
ピーされています。

 4. 各動作ポイントの出力値は、以下のいずれかの方法で編集できます。
 l マウスでポイントを移動する
 l View > Table を選択して "Optimization Target Table for Output *" ウィ

ンドウを開き、値を編集する
 5. 設定（各動作ポイントの値）が格納されているExcelファイルをロードするには、File > 

Import Map を選択します。
 6. このチュートリアルを続行するには、Cancel をクリックして変更内容をすべて破棄します。
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すべての動作ポイントで最適化を実行する
 1. "Single Result Optimization" ウィンドウで Optimize at OPs をクリックします。

最適化が実行されます。
別ウィンドウが開き、そこで各動作ポイントの最適化の進行状況を確認することができま
す。

各動作ポイントの最適化実行時には、最適値がISPビューにセットされ、さらにステータス
ウィンドウに出力されます。
緑色の動作ポイントにおいて最適化が成功したことが示されています。

 2. 各動作ポイントでの最適化の結果をテーブル形式で表示するには、"Single Result 
Optimization" ウィンドウの Extras > Optimization at OPs >Show 
Results  を選択します。
"Optimization Results" ウィンドウが開きます。すべての動作ポイントについて最適化
された結果が表示されます。

さらにこのテーブルには各動作ポイントの標準偏差も表示されます。
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 3. "Optimization Results" ウィンドウで、テーブルの任意の1行をマークし、File > 
Show Current Row in ISP View を選択します。
各入力の値とその入力に対応する出力がISPビューにセットされます。
このリストをExcelファイルにして保存することもできます（File > Export）。

最適化結果を適合マップに転送する
 1. "Optimization Results" ウィンドウで File > Apply Results to Calibration 

Maps を選択します。
 2. メインウィンドウで Calibration > Calibration Maps > * を選択すると、新しい

適合マップが表示されます。

注記 

適合マップの扱いや可視化についての詳細は、6.7.5 「適合 」（ページ118）を参
照してください。

最適化実行後の出力変数の特性マップ（Result Map）を表示する
 1. Calibration > Result Maps > Open all Maps を選択します。

すべての出力についての結果のプロットが開きます。

表示される各点は、最適化が実行された動作ポイントを表しています。
 2. これらのプロットのウィンドウを閉じるには、メインウィンドウで View > Close Child 

Windows を選択します。
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注記 

最適化実行後の入力変数のマップについては、6.7.5 「適合 」（ページ118）で説明してい
ます。

6.7.3 多目的最適化
エミッションなどの値の減少と、燃料消費量などの値の増加が連動する、といった状況がよく見ら
れますが、多目的最適化は、このようなトレードオフの関係がある出力の最適値探索に使用で
きます
多目的最適化の設定を変更する

 1. Optimization > Multi Result を選択します。
"Multi Result Optimization" ウィンドウが開きます。

 2. "Multi Result Optimization" ウィンドウの Settings をクリックします。

注記 

詳細パラメータをカスタマイズするための Edit ボタンは、"Advanced Parameters" 
オプションがオンになっている場合（4.5.1 「高度な設定の有効化／無効化 」（ペー
ジ45）を参照）にのみ表示されます。

 3. "Number of Evaluations" 入力フィールドで、全世代に渡る評価の最大数を指定で
きます。
評価の最大数は、子を生成する親の数（"Advanced Parameters" の "Parent 
Population Size"）の約200倍である必要があります。

 4. "Parent Selection" フィールドで、評価と遺伝子組み換えへの親の関与を有効にする
かどうか（On/Off）を指定します。
詳細は4.6.3 「進化的アルゴリズム - 親の選択と生存者の選択 」（ページ55）を参
照してください。

 5. OK をクリックして設定内容を確定します。
パラメータの変動範囲を制限する
すべての入力について、モデリング時に考慮すべき範囲を以下の方法で定義することができま
す。以下のように操作してください。
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 1. "Multi Result Optimization" ウィンドウの Input Bounds をクリックします。

 2. すべての境界値を測定データに合わせるには、Fit をクリックします。
または

入力ごとに制限を設定するには、以下のいずれかを行います。
 l 最適化用の有効な変動範囲（Min/Max）を入力します。
 l OP Dependent オプションをオンにします。

入力の "Map Bounds" ウィンドウが開きます。ここで、グリッドポイントを操作してパ
ラメータの変動範囲を設定することができます。

 3. OK をクリックして選択を確定し、"Input Bounds" ウィンドウを閉じます。

注記 

OP Dependent Input Bounds オプションを用いてパラメータの有効な変動範囲を
定義する方法についての詳しい情報は、6.7.5 「適合 」（ページ118）を参照してく
ださい。

最適化結果の範囲を制限する
最適化結果は、さまざまな方法でモデル出力の有効範囲に制限することができます。

 1. "Multi Result Optimization" ウィンドウで、Hull ボタンの横のチェックボックスをオンに
します。
パラメータの変化の範囲が、指定した外殻の範囲内のデータに限定されます
（In/Outputs > Hull on Inputs）。

 2. Model Validity をクリックします。
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 3. このウィンドウで、有効なモデル範囲内に制限したいエレメントを有効にします。
 4. OK をクリックして設定内容を確定し、"Valid Model Range" ウィンドウを閉じます。

注記 

"Valid Model Range" ウィンドウ内のオプションは常にオンに設定し、後にオプティマ
イザが検出する解がモデル有効範囲に収まるようにしてください。このオプションを使用
するには、各変数が有意な有効範囲を持っていることが前提条件となります。そうでな
い場合は、モデルトレーニングが不完全であることを示しています。

多目的最適化
 1. 必要に応じて "Multi Result Optimization" ウィンドウを開きます。
 2. 出力 Fuel_mass と CoV の "Output" 列で Remove を選択し、これらの変数を削

除します。
 3. 2個の出力 Soot および NOx_rel について、最適化目標として Minimize を選択

します。

 4. 動作ポイントマネージャを開きます（図 6-10:  ページ96を参照）。
 5. このウィンドウで、最適化を実行したい動作ポイントを選択します。

 l 2000 rpm
 l 2 bar（平均有効圧力）

 6. 「動作ポイントを定義する」（ページ99）を参照して、speed と load をロックします。
 7. "Multi Result Optimization" ウィンドウで Optimize をクリックします。

最適化が開始され、ウィンドウ下部に進行状況が表示されます。
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最適化が完了すると、"Select Axes" ウィンドウが開きます。
 8. このウィンドウの"List" タブまたは"Matrix" タブで、表示する軸のペアを選択します。

 l "List" タブを使用する場合は、X軸フィールドで NOx_rel、Y軸フィールドで Soot 
を選択して、Select → をクリックします。

 l "Matrix" タブを使用する場合は、"Soot" 行と "NOx_rel" 列の交点のチェックボッ
クスをオンにします。

 9. OK をクリックします。
ばい煙と窒素酸化物の排出量の相互依存性がプロット表示されます。
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注記 

このプロット各点が最適化目標を満たすパレート最適解です。

さらに第2のウィンドウも開き、入力と出力の依存関係が表示されます。
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"Inputs and Outputs" ウィンドウの機能については、「複数のパレート解に関するデー
タを表示する」（次ページ）を参照してください。

個々のパレート解に関するデータを表示する
 1. プロット内の任意の点（つまり最適化の解の1つ）を右クリックします。

選択された解のショートカットメニューが開きます。
 2. Show Result in Other Views を選択すると、この解がISPビューに表示されま

す。
 3. Show Result を選択すると、この解に対応する入力の値が別ウィンドウに表示されま
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す。

複数のパレート解に関するデータを表示する
 1. Mouse selection * ボタンのいずれか（四角形または投げ縄）をクリックします。

 2. 目的の解を囲む線（四角形または投げ縄）を描きます。

囲み線の内側の解がカラーで強調表示されます。

注記 

これらの解は、"Inputs and Outputs" ウィンドウ内の他のプロット内でも強調表示
されるので、注目すべき入力に関係する領域が特定できます。

 3. 囲み線（四角形または投げ縄）の枠を右クリックします。
ショートカットメニューが開き、そこで以下のアクションを実行できます。
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 l Remove Rectangle／Remove Lasso：囲み線を消去し、解の選択を解
除します。

 l Set Position：四角形のみ。
"Create Rectangle" ダイアログボックスを開き、四角形の位置を座標値で指定し
ます。

 l Mark：囲み線（四角形または投げ縄）の内側の解をすべてマークします。
 l Show Number of Solutions：囲み線（四角形または投げ縄）の内側の

解の数を表示します。
 4. 囲み線（四角形または投げ縄）の辺をドラッグして移動して、異なるソリューションをマー

クすることができます。

 5. 囲み線（四角形のみ）の囲み線の枠の頂点をドラッグして、枠の大きさを変更すること
ができます。

投げ縄で囲んだ線は、サイズ変更できません。
 6. View > Select Axes でさらに他の軸を追加すると、選択された領域がそれらの変数

に与える影響も見ることができます。
結果を保存する
パレート最適解の集合全体、または選択された領域内の解をファイルに保存することができま
す。

 1. 任意のプロットウィンドウから、File > Export All Data ／ Export 
Intersection of Selected Data / Export Union of Selected Data のい
ずれかを選択します。
ファイル選択ウィンドウが開きます。

 2. ファイル名を入力して 保存 をクリックします。
解がExcelファイルに保存されます。

6.7.4 グローバル最適化 
単一目的最適化の場合は各動作ポイントについてバッチモードで順に最適化が行われますが、
グローバル最適化では、すべての動作ポイントについて同時に最適化が行われます。
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注記 

Calibration メニュー、および Optimization メニューの Global Optimization コマ
ンドは、データのインポート時に動作ポイント用の軸が選択されている場合にのみ表示されます
（6.3.3 「入力と出力の割り当て」（ページ70）を参照してください）。インポート後に軸を
選択するには、メニューで In/Outputs > Set Operating Point Axes を選択しま
す。

これにより、さらに以下の2つが可能になります。
マップの平滑度と勾配の考慮
各動作ポイントに留まる時間に応じて加重された走行サイクルの合計値の観察（6.8 
「走行サイクル予測 」（ページ125）を参照）

グローバル最適化に必要な条件と制限は、"Global Optimization" ウィンドウで設定できま
す。"Global Optimization" ウィンドウについての詳細は、ASCMO-STATICオンラインヘルプ
を参照してください。
最適化目標を定義する

 1. Optimization > Global Optimization を選択します。
"Global Optimization" ウィンドウが開きます。

図 6-15: "Global Optimization" ウィンドウ

 2. "Sum Criteria" 領域で、4つの出力をすべて選択し、条件のタイプを Minimize にし
ます。

 3. "Constraints" 領域で、以下を行います。
 l Input Bound ボタンをクリックして、パラメータの変動範囲を制限します（「パラ

メータの変動範囲を制限する」（ページ109）を参照）。
 l Hulls ボタンの横のチェックボックスをオンにして、パラメータの変化の範囲が、指定さ

れている外殻（In/Outputs > Hull on Inputs）の範囲内のデータに限定さ
れるようにします。

注記 

最適化のためのパラメータ変動の定義についての情報は、6.7.5 「適合 」（次ページ）を参
照してください。
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グローバル最適化の設定を変更する
 1. "Global Optimization" ウィンドウの Settings をクリックします。

"Settings" ウィンドウが開きます。

 2. "Number of Iterations" フィールドに、モデルトレーニングにおいて行う反復の回数を
指定します。
回数が多いと結果は向上しますが、トレーニングの所要時間が長くなります。

 3. "Number of Starts (Multi Start)" フィールドに、最適化の実行回数を指定しま
す。各ポイントを異なる開始点で最適化します。

 4. Apply または OK をクリックして設定を適用します。
Default をクリックすると標準設定に戻ります。

最適化を実行する
 1. "Global Optimization" ウィンドウの Optimize をクリックします。

最適化が実行されます。
最適化目標を保存する

 1. "Global Optimization" ウィンドウで File > Save Criteria を選択して、最適化
目標を *.cocrit ファイルに保存し、他のプロジェクトで利用できるようにします。

6.7.5 適合 
本項では、グローバル最適化で得られたマップを編集します。

注記 

Calibration メニュー、および Optimization メニューの Global Optimization コマ
ンドは、すでに動作ポイント用の軸が選択されている場合にのみ表示されます（6.3.3 「入力
と出力の割り当て」（ページ70）を参照してください）。軸を選択するには In/Outputs 
> Set Operating Point Axes コマンドを使用します。

適合マップを見る
 1. Calibration > Calibration Maps > Open all Maps を選択します。

複数のウィンドウが開き、最適化で得られたすべての入力のマップがそれぞれ表示されま
す。
下図は injection 入力の適合マップです。
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カラー表示された各点は、最適化が実行された動作ポイントです。
 l 最適化結果が測定データの範囲内に収まった点は緑色でマークされます。
 l 入力の境界値（試験時に測定された最小値と最大値）の点は赤色でマークされて

います。
 l この境界値と、当該動作ポイントに適用される測定範囲の境界との間の値は、黄色

でマークされています。
 2. 測定範囲の境界を表示するには、適合マップウィンドウで View > Map Bounds を

選択します。

注記 

これらの境界は、先に調整して測定範囲に合わせておく必要があります。「境界を測
定範囲に合わせる」（次ページ）を参照してください。

適合マップのプロット内に、測定範囲の境界が描かれます。
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図 6-16: 適合プロット（マップの境界が表示された状態）

境界を測定範囲に合わせる
 1. Calibration > Map Bounds over OP > <input_name> を選択します。

ここでは<input_name> として injection を選択します。
"injection - Map Bounds" ウィンドウが開きます。

 2. Edit > Fit Bounds to Data を選択します。
"Fit Map Bounds to Data" ウィンドウが開きます。

 3. このウィンドウで、必要に応じて以下の操作を行います。
 l マップ境界の平滑度係数を入力します。
 l "Grid Nodes" 領域でグリッドを調整します。
 l 変更内容をすべての "<input_name> - Map Bounds" マップに適用するには、

Apply to all maps オプションをオンにします。
 4. OK または Apply をクリックして続行します。

injection 入力の測定範囲の下限と上限を表す面が、測定データに合わせて調整
されます。
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 5. ウィンドウを閉じます。
各入力について個別に境界を調整する代わりに、Calibration > Map Bounds 
over OP > Fit Bounds to Data／Fit Bounds to Min/Max を選択して、
全入力について一度に調整することもできます。

動作ポイント上の値を変更する
 1. "injection Calibration Map" ウィンドウで Operating Points > Table of 

Values at OPs を選択します。
"Values at Operating Points: injection" ウィンドウが開きます。

 2. "injection Calibration Map" ウィンドウのマップ上にカラー表示されている動作ポイン
トのいずれかにマウスポインタを置き、マウスの左ボタンを押し下げます。
マウスポインタが上下矢印に変わります。同時に、テーブル内でそのポイントがマークされま
す。
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 3. マウスボタンを押し下げたまま、そのポイントを動かします。
テーブルとISPビュー内の injection の値も変化します。

 4. "Values at Operating Points: injection" ウィンドウで、別の動作ポイントの 
injection の値を変更して <ENTER> を押します。
変更された値に応じてプロットが調整され、View > Update ISP Online オプション
がオンの場合はISPビューも調整されます。
また、プリセットされている走行サイクルにこれらの変更が与える影響について予測すること
もできます。

予測ウィンドウを開く
 1. Calibration > Prognosis > Results を選択します。

"Prognosis Results" ウィンドウが開きます。

 2. "injection Calibration Map" ウィンドウのマップ内の点を前述（「動作ポイント上の
値を変更する」（前ページ））のように動かします。
この変更が出力に与える影響が、直ちに"Prognosis Results" ウィンドウに反映されま
す。
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グリッドのノードを調整する
 1. "injection" マップの表示を見やすくするため、プロットウィンドウの View > Map 

Bounds をオフにします。
 2. Grid Nodes > Grid Nodes > Define Grid Nodes を選択します。

"Change Grid Node Vectors" ウィンドウが開きます。
 3. 適合マップ内のグリッドノードの数を変更するには、以下のように操作します。

 i. "Count" 列にノードの数を入力します。

注記 

Apply to all Maps チェックボックスをオンにすると、変更されたグリッドノード数が
すべてのマップに適用されます。

 ii. Apply をクリックします。
上図の例では、マップに8 x 8の等間隔のグリッドノードが描かれます。各軸の値は、そ
れぞれ等間隔になります。

または
グリッドベクトルを直接入力するには、以下のように操作します。
 i. 各入力のコンボボックスから Support Vector を選択します。

グリッドノードのベクトルが、各入力マップのフィールドに表示されます。
 ii. 各要素の値を適宜変更し、OK をクリックします。

マップのグリッドノードが設定に応じて調節されます。"Change Grid Node 
Vectors" ウィンドウが閉じます。

注記 

ベクトル（Support Points）を追加または編集すると、"Count" 列の値は
自動的に調整されます。

マップを編集する
 1. "injection Calibration Map" ウィンドウで、Grid Nodes > Edit Grid を選択し

ます。
動作ポイント上の injection の最適化された値と同じく、選択されたグリッドノードの
値（補間により算出されたもの）がカラーの点でマークされます。最適化が行われた動
作ポイントも小さな点で表示されます。
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 2. マップのオリジナルの状態を保存するには、File > Set as Reference Page を選
択します。

 3. グリッドノード上の値は、「動作ポイント上の値を変更する」（ページ121）で説明した方
法で編集することができます。

 4. マップの状態をリセットして最適化結果に戻すには、File > Reset from 
Reference Page を選択します。

適合マップを保存する
マップを最適化し、必要に応じて編集を行ったので、最後にそれをエクスポートします。

 1. "injection Calibration Map" ウィンドウで、File > Export を選択します。
ファイル選択ウィンドウが開き、ここではマップをDCMファイル（*.dcm）またはCSVフォー
マット（*.csv）として保存することができます。デフォルトファイル名は <project_
name>_CM_Injection.* です。

 2. 下図のウィンドウで、保存するラベル名を入力して OK をクリックします。
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マップが保存されます。

6.8 走行サイクル予測 
本項では、走行サイクルを使用してASCMO-STATICで予測単位変換規則を定義する方法
を説明します。
過渡走行サイクルデータは車速の変化を時間軸上に並べたデータです。走行サイクルは、車両
の性能（燃費や汚染物質排出量など）をさまざまな方法で評価するためのものです。
燃費と汚染物質排出量のテストは、シャシダイナモにおいて施行されます。テールパイプにおいて
計測された排気は、車両の性能値となります。走行サイクルはASCMO-STATIC等のシミュ
レーションでも使用できます。

6.8.1 走行サイクルデータ 
走行サイクルデータはASCMO-STATICの要件に一致している必要があります。これは、走行
サイクルデータの軌跡が動作ポイント軸上に広く分布している必要があることを意味します。
ASCMO-STATICでは一般的に、エンジン回転数 speed と負荷 load が動作ポイント軸と
して使用されます。
計測データの要件についての詳細は4.3.1 「データ測定要件」（ページ28）を参照してくださ
い。
走行サイクルデータをインポートする

注記 

Calibration メニューは、データのインポート時に動作ポイント用の軸が選択されていた場合
にのみ表示されます（6.3.3 「入力と出力の割り当て」（ページ70）を参照してください）。
インポート後に軸を選択するには、メニューで In/Outputs > Set Operating Point 
Axes を選択します。

 1. Calibration > Driving Cycles を選択します。
"Driving Cycle Manager" ウィンドウが開き、メッセージ "No Driving Cycle 
loaded, click to import" が表示されます。

 2. "Driving Cycle Manager" ウィンドウで、以下のいずれかを行います。
 l File > Import Driving Cycle を選択します。
 l "No Driving Cycle loaded, click to import" というメッセージをク

リックします。
ファイル選択ウィンドウが開きます。
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 3. ファイル選択ウィンドウで、<installation>\Example\AscmoStatic  ディレクト
リ内のファイル Example_Cycle_Trajectory.xls を選択します。

 4. 開く をクリックします。
 5. ドロップダウンリストから time を選択します。

"Time Vector" ドロップダウンリストから、時間情報が含まれる列を選択します。選択し
なかった場合は、ASCMO-STATICが自動的に、"Sample Time" に入力された値に
基づく時間ベクタを作成します。

 6. OK をクリックします。
"Import Data" ウィンドウが開きます。ASCMO-STATICは、ロードされたファイルの入
力名を動作ポイント軸と合わせることを試みます。

 7. プロジェクト内の名前（"Project Import" 列）がファイル内の名前（"Import 
Name" 列）と異なっている場合は、手動で変更します。

 8. "Time Base" と "Other settings" は、デフォルト値を使用します。
 9. インポートされたファイル名と異なる名前を走行サイクル名として使用するには、

"Dataset Name" フィールドに任意の名前を入力します。
この名前は、ASCMO-STATICのユーザーインターフェースで使用されます。

 10. Import をクリックしてインポート処理を開始します。
走行サイクルデータファイルがインポートされます。"Driving Cycle Manager" ウィンドウ
にデータがテーブル形式で表示されます。
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注記 

複数の走行サイクルを使用するには、File >Import Driving Cycle を選択し、
"Modification Mode" として Add を選択してインポートするか、または File > 
Load Database で既存のデータベース（*.cycles）をロードします。
ASCMO-STATICはそれらすべての走行サイクルを使用してサイクル予測を行いま
す。

インポートされたデータは、これらの走行サイクルデータを使用した単位変換規則に基づくグロー
バル最適化に利用することができます（メインメニュー：Calibration > Prognosis > 
Calculation Rules："Driving Cycle Based" タブ）。

"Driving Cycle Manager" ウィンドウ（走行サイクルマネージャ）
メインウィンドウで Calibration > Driving Cycles を選択すると、"Driving Cycle 
Manager" ウィンドウが開き、プロジェクトの走行サイクルを管理することができます。このウィンド
ウは大きく3つの領域（走行サイクルリスト、データテーブル、統計情報）に分かれています。

図 6-17: "Driving Cycle Manager" ウィンドウ

File メニューからは、Load/Save Databases と Import/Export Driving Cycles 
コマンドを実行できます。
これらのコマンドについての詳細は、オンラインヘルプ（<F1> または Help > Online 
Help）を参照してください。
"Driving Cycles" ペイン：ウィンドウ左側の "Driving Cycles" ペインには、現在プロジェ
クトで使用できる走行サイクルのリストが表示されます。1つまたは複数の走行サイクルを選択で
きます。
"Data" テーブル：ウィンドウ中央の "Data" テーブルには、左側のリストで選択された走行サ
イクル（複数可）のデータテーブルが表示されます。
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テーブル内の任意のセルを選択すると、その行に対応するポイントが、右側のプロット上で赤い点
で示されます。複数の行を選択することもできます。その場合、複数のポイントを示す赤い点と各
ポイント間を接続する赤いトレース線が表示され、"Statistics" 領域（統計領域）の表示内
容が選択範囲のみの情報に更新されます。

走行サイクルのデータは編集可能で、行（複数可）を選択して編集や削除を行うことができま
す。ただし、左側のリスト内で複数の走行サイクルが選択されている場合は、編集は行えませ
ん。プロット上の任意のポイントをクリックして選択することもできます。
"Statistics" 領域（統計情報）：ウィンドウの右側には、選択されている走行サイクルの各
種統計値とプロットが表示されます。
Show Convex Hull オプションをオンにすると、プロット上に凸包が表示されます。

View > Convex Hull Selection で、凸包の計算に使用する走行サイクルを指定するこ
とができます。
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走行サイクルデータを散布図で表示する
 1. "Driving Cycle Manager" ウィンドウで View > Scatter Plot を選択します。
 2. "Show Scatter Plot" ウィンドウで、プロットしたい走行サイクルを選択し、OK をクリック

します。
または、Scatter Plot ボタンをクリックします。"Driving Cycles" ペインで選択されて
いる走行サイクルがプロットされます。
"Driving Cycle Scatter Plot" ウィンドウが開き、選択した走行サイクルの動作ポイン
トと勾配のプロットが表示され、さらに "Driving Cycle Time" ウィンドウが開きます。こ
れらのウィンドウでも他の散布図と同様に、囲み線を描画することができます。

注記 

ここでは1つの散布図に複数の走行サイクルが表示されるので、各走行サイクルを比較
することができます。

走行サイクルデータを密度プロットで表示する
 1. "Driving Cycle Manager" ウィンドウで View > Density Plot を選択します。
 2. "Show Density Plot" ウィンドウで、プロットしたい走行サイクルを選択し、OK をクリッ

クします。
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または、Density Plot ボタンをクリックします。"Driving Cycles" ペインで選択されて
いる走行サイクルがプロットされます。
選択されている走行サイクルごとに "Density Plot Driving Cycle" ウィンドウが開きま
す。

走行サイクルデータをスコープビューで表示する
 1. "Driving Cycle Manager" ウィンドウで View > Scope View を選択します。
 2. "Show Density Plot" ウィンドウで、プロットしたい走行サイクル（複数可）を選択し

て OK をクリックします。
または、Scope View ボタンをクリックします。"Driving Cycles" ペインで選択されてい
る走行サイクルがプロットされます。
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選択されている走行サイクルごとに "Scope View Driving Cycle" ウィンドウが開きま
す。

走行サイクルを生成する
一般的に、モデル（排出量モデルなど）の品質は、異なる一連の「走行サイクルセット」で性能
を試験することによって評価することができます。
さらに、RDE（Real Driving Emissions：実走行時の排ガス測定）に対応するには、モデ
ルをさまざまなバリエーションの走行サイクルで評価して、可能な限り広範囲の走行条件をカバー
することが重要となります。
ASCMO-STATICでは、既存の走行サイクルセット（路上やテストベンチで実際に計測された
もの）を基に、複数の「仮想走行サイクル」を生成することができます。生成された走行サイクル
は、既存の走行サイクルに類似し、それぞれ異なる特徴を持っています。

 

注記 

ASCMO-STATIC（GUI: Calibration > Driving Cycles）またはASCMO Cycle 
Generatorで生成された走行サイクルは、既存の走行サイクルに類似しています。規制には
適合しておらず、ベースとなった走行サイクルの特性を満たしていることもありません。生成は、
確率モデル（マルコフ連鎖）に基づいて行われたものです。
生成されたサイクルは、RDE認証などの正式な目的で用いられることを前提したものではあり
ません。

 1. "Driving Cycle Manager" ウィンドウで、Data > Generate Driving Cycle
(s) を選択します。
ダイアログウィンドウが開き、使用できる走行サイクルのリストが表示されます。

 2. 新しい走行サイクルのベースとして使用する走行サイクルを選択し、OK をクリックします。
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 3. "Generate Driving Cycle(s)" ウィンドウが開きます。
OK をクリックして続行します。

 4. 必要に応じてパラメータを設定します。
各パラメータについての詳細は、ASCMO-STATICのオンラインヘルプに記載されていま
す。

 5. Generate をクリックします。
設定に従って新しい走行サイクルが生成され、"Driving Cycle Manager" ウィンドウの 
"Driving Cycles"ペインに追加されます。

走行サイクルデータを適合マップで表示する
適合マップ（メインメニューで Calibration > Calibration Maps > * を選択して開きま
す）に走行サイクルの軌跡を表示することにより、走行サイクルで使用される領域を可視化する
ことができます。

注記 

Calibration メニューは、データのインポート時に動作ポイント用の軸が選択されていた場合
にのみ表示されます（6.3.3 「入力と出力の割り当て」（ページ70）を参照してください）。
インポート後に軸を選択するには、メニューで In/Outputs > Set Operating Point 
Axes を選択します。

 1. "<input> Calibration Map" ウィンドウで View > Driving Cycle を選択しま
す。
プロジェクトに複数の走行サイクルが含まれる場合は、走行サイクルを選択するための 
"Driving Cycle in Map" ウィンドウが開きます。
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 2. 表示したい走行サイクルを選択して、OK をクリックします。
走行サイクルの軌跡が適合マップ上に青い点で表示されます。

6.8.2 走行サイクルトレースを用いた動作ポイントの重み設定 
1つ以上の走行サイクルを使用して、動作ポイントに重みを割り当てることができます。
走行サイクルトレースを使用して動作ポイントの重みを設定する

 1. "Driving Cycle Manager" ウィンドウで Data > Assign OP Weights using 
a Driving Cycle を選択します。
"Assign Driving Cycle" ウィンドウが開きます。

 2. "Driving Cycles" コンボボックスで、重み付けに使用したい走行サイクルを選択しま
す。
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 3. "Operating Point List" コンボボックスで、重み付けを行いたい動作ポイントリストを選
択します。

注記 

このチュートリアルでは、これらのオプションはデフォルト設定をそのまま使用できます。

 4. OK をクリックします。
"Prognosis OP-Weights" ウィンドウと "Calculated Operating Point Weights 
from Driving Cycle 1" ウィンドウが開きます。

"Prognosis OP-Weights " ウィンドウでは、走行サイクルで定義された動作ポイントの
重みを、必要に応じて手動で変更することができます。

 5. "Prognosis Weights" 列に重みの値を入力します。

 6. <ENTER> を押して値を確定します。

6.8.3 走行サイクルトレースを用いた動作ポイントの位置設定 
重みのほかに、動作ポイントの位置も走行サイクルトレースから設定することができます。

注記 

動作ポイントを走行サイクルトレースに割り当てると、動作ポイントに設定されていた重みと位
置は削除されます。
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走行サイクルトレースを用いて動作ポイントの位置を設定する
 1. "Driving Cycle Manager" ウィンドウで Data > Assign OP Weights using 

a Driving Cycle を選択します。
"Assign Driving Cycle" ウィンドウが開きます。

 2. 使用したい走行サイクルと動作ポイントリストを選択します。
 3. Find Optimal OP Position チェックボックスをオンにします。

 4. OK をクリックして割り当てを確定します。
"Prognosis OP-Weights" ウィンドウと "Calculated Operating Point Weights 
from Driving Cycle 1" ウィンドウが開きます。動作ポイントの位置が変更されていま
す。

6.8.4 走行サイクルの動作ポイントの重みを用いた性能予測 
走行サイクルに沿った動作ポイントの重み設定が完了すると、単位変換設定を行っていない状
態でも、走行サイクルに基づいた性能予測が可能になります。
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注記 

Calibration メニューは、データのインポート時に動作ポイント用の軸が選択されていた場合
にのみ表示されます（6.3.3 「入力と出力の割り当て」（ページ70）を参照してください）。
インポート後に軸を選択するには、メニューで In/Outputs > Set Operating Point 
Axes を選択します。

単位変換設定を行わずに走行サイクル性能予測をする
 1. Calibration > Prognosis > Results を選択します。

"Prognosis Results" ウィンドウが開きます。最適化を繰り返して実行する際に、結果
を参照することができます。

最適化の実行についての詳細は、6.7 「最適化 」（ページ99）を参照してください。

6.8.5 走行サイクルの性能予測のための単位変換規則 
固定的な測定値からサイクル値を得るには、いくつかの変換（時間ベースの測定からルートベー
スの予測への変換など）が必要になります。本項ではそのような単位変換規則を定義する方法
（ISPビューから Calibration > Prognosis > Calculation Rules を選択）を説明
します。

注記 

Calibration メニューは、データのインポート時に動作ポイント用の軸が選択されていた場合
にのみ表示されます（6.3.3 「入力と出力の割り当て」（ページ70）を参照してください）。
インポート後に軸を選択するには、メニューで In/Outputs > Set Operating Point 
Axes を選択します。

単位変換を定義する
 1. Calibration > Prognosis > Calculation Rules を選択します。

"Calculation Rules for Prognosis" ウィンドウが開きます。このウィンドウの内容につ
いての詳細は、ASCMO-STATICのオンラインヘルプ（<F1>）に記述されています。

 2. "Calculation Rules for Prognosis" ウィンドウで、"Driving Cycle Based" タブを
選択します。

 3. "Output" 列で4つの出力（Fuel_mass、CoV、Soot、NOx_rel）を順にすべて
選択します。
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 4. Apply をクリックします。
予測パラメータが変更されたという旨の情報メッセージが、ログウィンドウに表示されます。

単位変換をインポートする
サイクル予測の単位変換規則をインポートするには、以下のように操作します。

 1. "Calculation Rules for Prognosis" ウィンドウで File > Import Settings 
(*.ini) > Template を選択します。
"Load Prognosis Calculation Rule from ini" ウィンドウが開きます。

 2. 単位変換規則が含まれるファイル（*. ini）を選択し、開く をクリックします。
"Load Prognosis Calculation Rule" ウィンドウが開きます。

 3. 使用したいテンプレートベースの単位変換規則を適切な出力に割り当てます
 4. 必要に応じて Clear All Before オプションをオンにします。

注記 

Clear All Before オプションをオンにすると、既存の単位変換規則はインポート時
に削除されます。
Clear All Before オプションをオフにすると、インポートされた設定が既存のものに追
加されます。

 5. Apply をクリックします。
ログウィンドウに、単位変換規則を変更したことを示すメッセージが表示されます。

6.8.6 走行サイクルトレースに沿った最適化（グローバル最適化）
走行サイクルに依存する動作ポイントの重みと位置を単位変換によって設定したので、これを用
いてグローバル最適化を行うことができます。グローバル最適化についての詳細情報は、6.9 「走
行サイクルのグローバル最適化」（次ページ）を参照してください。

6.8.7 走行サイクルトレースに沿った最適化（手動操作）
自動化されたグローバル最適化に加えて、適合マップを手動で編集して最適化を行うこともでき
ます。最適化で得られたデータは、適合マップに転送されます。新しい適合マップの動作ポイント
は、「最適化」によって変更することができます。適合マップを調整した結果は、"Prognosis 

ASCMO-STATIC V5.11 | ユーザーガイド



6 チュートリアル: ASCMO-STATICの操作 | 138

Results" ウィンドウ（Calibration > Prognosis > Results）に直接反映されます。
適合マップを適合して最適化する方法についての詳細情報は、6.7.5 「適合 」（ページ118）
を参照してください。

注記 

Calibration メニュー、および Optimization メニューの Global Optimization コマ
ンドは、すでに動作ポイント用の軸が選択されている場合にのみ表示されます（6.3.3 「入力
と出力の割り当て」（ページ70）を参照してください）。軸を選択するには In/Outputs 
> Set Operating Point Axes コマンドを使用します。

6.9 走行サイクルのグローバル最適化
一般的な燃焼エンジン（乗用車やトラックなど）については、各種テストサイクルにおいて、法的
に定められた排ガスのしきい値条件（Euro 6規格など）に適合していることを証明する必要が
あります。そのため適合を行う際には、所定のしきい値条件を満たして最良の消費率を実現する
と同時に、圧力や温度のしきい値といったその他のすべての制限事項にも従わなくてはなりませ
ん。
走行サイクルには、固定的な動作ポイントのリストとして定められているものと、エンジン回転数と
負荷による過渡走行サイクルとして定められているものとがあります。静的情報に基づいて信頼
性の高い動的な結果を予測するには、過渡走行サイクルの動作ポイントをできる限り削減し、
代表的な動作ポイントのリストにする方法が一般的です。
本項では、ASCMO-STATICで走行サイクルのグローバル最適化を行う方法について、ディーゼ
ルエンジンのモデルを例に用いて説明します。

6.9.1 最適化問題
走行サイクルのグローバル最適化で使用するディーゼルエンジンモデルの入力と出力は下表のと
おりです。

入力 動作ポイント 出力

Airmass [mg/Str] Speed [1/min] NOx [g/h]

SOI [° CA] Load [bar] Particle [g/h]

pRail [bar]  Noise [dB]

qPilot1 [mm3/Str]  Fuelmass [kg/h]

qPilot2 [mm3/Str]  BSFC [g/kWh]

tiPilot1 [µs]   

tiPilot2 [µs]   

Swirl [%]   

表 6-2: ディーゼルエンジンモデルの入力と出力
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モデリングデータ
走行サイクルのグローバル最適化に使用するディーゼルエンジンモデルのサンプルは、Example_
Diesel_Engine_Model.ascmoに収められています。このファイルは、
<installation>\Example\AscmoStaticディレクトリ（<installation>のデ
フォルトはC:\Program Files\ETAS\ASCMO 5.11）にコピーされています。
また、このチュートリアルステップでは以下のファイルも使用します。

Example_Diesel_Engine_OP_List.xls

最適化を行う動作ポイントのリストが定義されています。
Example_Diesel_Engine_OP_Weights.xls

走行サイクル予測に使用される個々の動作ポイントの重みが定義されています。
サンプルモデルを開く

 1. ASCMO-STATICの起動画面で、Open Demo Project または Open ASCMO 
Project をクリックします。

 2. ファイル選択ダイアログボックスで、以下のファイルを選択します。 
Example_Diesel_Engine_Model.ascmo

 （<installation>\Example\AscmoStaticディレクトリ）
モデルが開きます。このモデルは、オリジナルの内容のまま再利用できるように、書き込み
禁止になっています。

 3. モデルを変更して保存する場合は、別の名前で保存してください。

6.9.2 最適化する動作ポイントと重みの定義
最適化する動作ポイントは手動で入力でき、ファイルから読み込むことも可能です。ファイルには
各動作ポイントの重みも定義しておくことができます。「動作ポイントの重みを定義する」（次
ページ）を参照してください。

注記 

Calibration メニューは、データのインポート時に動作ポイント用の軸が選択されていた場合
にのみ表示されます（6.3.3 「入力と出力の割り当て」（ページ70）を参照してください）。
インポート後に軸を選択するには、メニューで In/Outputs > Set Operating Point 
Axes を選択します。

最適化する動作ポイントを定義する
 1. Calibration > Operating Points を選択します。

"Operating Points Manager" ウィンドウが開きます。
 2. 必要に応じて、Show OP List をクリックして動作ポイントリストを表示します。
 3. 定義済みの動作ポイントのリストをロードするため、File > Import を選択します。
 4. ファイル選択ダイアログボックスで、以下のファイルを選択します。 

<installation>\Example\AscmoStatic\

Example_Diesel_Engine_OP_List.xls

 5. "Import Grid" ダイアログボックスで下図のように選択します。
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 6. OK をクリックします。
リストがインポートされます。インポートされたデータは、"Data of ’<list name>’" テー
ブルと "View of ’<list name>’" プロットに表示されます。既存のリストはそのまま保
持され、"Combined OP List" に全リストの内容がマージされます。

 7. あるいは、Data > Add New List > * を使用して動作ポイントのグリッドを作成す
ることもできます。

動作ポイントの重みを定義する
動作ポイントの重み付けは、動作ポイント自体の定義と同じく、手動で、または重みの値をファイ
ルから読み込んで行うこともできます。

 1. Calibration > Prognosis > Weights を選択します。
"Prognosis OP-Weights" ウィンドウが開きます。

 2. 編集したいリストのタブを選択します。
このチュートリアルでは "Imported_List" を編集します。
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 3. "Prognosis Weights" 列に値を入力します。
または

 4. File > Import を選択します。
 5. 以下のファイルを選択します。 

Example_Diesel_Engine_OP_Weights.xls

"Operating Point Prognosis Weights Import" ウィンドウが開きます。
 6. OK をクリックして設定内容を確定します。

ファイルから情報が読み込まれます。
動作ポイントの重みは、軌跡を測定して算出することもできます（走行サイクルマネージャで 
Data > Assign OP Weights using a Driving Cycle を選択）。この処理では、測
定のすべての時間ステップがそれぞれ1つの動作ポイントに割り当てられ、それを合わせた結果
が、各動作ポイントの重みになります。走行サイクルデータを用いて単位変換規則を定義する方
法については、6.8 「走行サイクル予測 」（ページ125）を参照してください。
複数の動作ポイントリストを使用する
動作ポイントのセットを複数使用する場合は、以下のようにして複数のリストをセットアップするこ
とができます。

 1. Calibration > Operating Points を選択します。
"Operating Points Manager" ウィンドウが開きます。

 2. 必要に応じて、動作ポイントリストを表示します。
 3. リストを追加するには、Data > Add New List > Define Grid を選択します。

"Define New Grid" ウィンドウが開きます。

 4. 各軸の動作ポイントの数を入力します。
詳しい情報はオンラインヘルプ <F1> に記載されています。

 5. OK をクリックします。
新しいリストがセットアップされ、動作ポイントマネージャ（下図参照）と別のウィンドウに
表示されます。リストは単独で選択、または他のリストと合わせて選択することができま
す。
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複数のリストがセットアップされていると、これらを使用して走行サイクル予測を行うことがで
きます。

6.9.3 走行サイクル予測のための単位変換設定
固定的な測定値からサイクル値を得るには、いくつかの変換（例： 時間ベースの測定 → ルー
トベースの予測）が必要になります。

注記 

Calibration メニューは、データのインポート時に動作ポイント用の軸が選択されていた場合
にのみ表示されます（6.3.3 「入力と出力の割り当て」（ページ70）を参照してください）。
インポート後に軸を選択するには、メニューで In/Outputs > Set Operating Point 
Axes を選択します。

単位変換を定義する
 1. Calibration > Prognosis > Calculation Rules を選択します。

"Calculation Rules for Prognosis" ウィンドウが開きます。

各設定項目の内容は、ASCMO-STATICオンラインヘルプ（<F1>）を参照してくだ
さい。

6.9.4 最適化用パラメータの定義 
最適化を開始する際には、先にすべての変数についてパラメータの許容変動範囲を定義してお
く必要があります。 
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注記 

Calibration メニューは、データのインポート時に動作ポイント用の軸が選択されていた場合
にのみ表示されます（6.3.3 「入力と出力の割り当て」（ページ70）を参照してください）。
インポート後に軸を選択するには、メニューで In/Outputs > Set Operating Point 
Axes を選択します。

パラメータの変動範囲を制限する
 1. Calibration > Map Bounds over OP > Fit Bounds to Data を選択しま

す。
すべての "<input> - Map Bounds" ウィンドウが開きます。さらに "Fit Map 
Bounds to Data" ウィンドウが開きます。後者のウィンドウでは、Apply to all Maps 
がオンになっています。

 2. "Fit Map Bounds to Data" ウィンドウで、必要に応じて以下の操作を行います。
 l マップ境界の平滑度係数を入力します。
 l "Grid Nodes" 領域でグリッドを調整します。

 3. OK または Apply をクリックして続行します。
すべての入力の有効範囲が実測値の範囲に調整されます。これにより各パラメータは、
すべての動作ポイントにおいて実測範囲内の値にしか調整できなくなります。
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 4. この境界値を手動で変更するには、緑色の動作ポイントの1つをクリックします。
マウスカーソルが上下矢印になり、境界を上下に動かせるようになります。

オプティマイザのパラメータを設定する
 1. Optimization > Global Optimization を選択します。

"Global Optimization" ウィンドウが開きます。
 2. "Sum Criteria" 領域で、汚染物質排出量のしきい値を入力します。

 l NOx：Weak Upper Bound / 0.2 g/km
 l Particle：Weak Upper Bound / 0.02 g/km

 3. 出力の計算ルールを定義します。
ASCMO-STATICオンラインヘルプには、欧州の走行サイクルにおいてg/hで測定された
汚染物質排出量をg/kmに変換する方法が記載されています。

 4. 燃料消費を最小量に抑えるため、出力 Fuelmass の目標を Minimize にします。
その他にも、たとえばエンジンノイズ Noise が80dBを超えないようにする、というような目
標も定義できます。これは、"Local Criterion"（Hard Upper Bound / 80 dB）と
して指定でき、これはすべての動作ポイントに対して（"Value" = Constant）、また
は個々の動作ポイントごとに（"Value" = per OP）設定することができます。
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 5. 最適化結果をモデル出力の有効範囲に制限する方法は、「最適化結果の範囲を制限
する」（ページ101）を参照してください。
次に、各最適化目標の重み付け（優先度決定）を行います。

最適化目標の重み付けを行う
 1. "Sum Criteria" 領域の "Weight" 列に、各全体目標の重みを入力します。
 2. "Local Criteria" 領域の "Weight" 列に、各ローカル目標の重みを入力します。

数値が大きいほど重みが大きくなります。

注記 

目標タイプが Hard Upper Bound または Hard Lower Bound の場合は、重
みの値は入力できません。

6.9.5 最適化の実行
すべてのパラメータと条件の定義が終了したので、ここで最適化を実行します。

注記 

Calibration メニューは、データのインポート時に動作ポイント用の軸が選択されていた場合
にのみ表示されます（6.3.3 「入力と出力の割り当て」（ページ70）を参照してください）。
インポート後に軸を選択するには、メニューで In/Outputs > Set Operating Point 
Axes を選択します。

最適化を実行する
 1. 最適化を開始する前に、"Prognosis Results" ウィンドウを開きます（「単位変換設

定を行わずに走行サイクル性能予測をする」（ページ136）を参照してください）。
このウィンドウには、現在の（つまり最適化されていない）アプリケーションパラメータを使
用した出力値の予測が表示されます。

 2. "Global Optimization" ウィンドウで、Optimize をクリックして最適化を開始します。
最適化が終了すると、その結果が "Prognosis Results" ウィンドウに表示されます。
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 3. 目標（Fuel_mass の重みなど）を編集し、最適化を再実行します。
予測結果が変わります。

適合マップをチェックする
 1. メインウィンドウで Calibration > Calibration Maps > Open all Maps を選

択して、マップをそのまま確定するか、それともさらに平滑化を行う必要があるかを調べま
す。

 2. 必要に応じて、以下のようにしてマップ平滑化（"CM Smoothing"）の重みを大きくし
ます。
 i. "Global Optimization" ウィンドウで CM Smoothing Weight をクリックしま

す。
 ii. "Map Smoothing" ウィンドウで、マップの平滑度を調整します。

0（平滑化を行わない）から1（非常に強い平滑化を行う）までの値を入力できま
す。

 3. 必要に応じて、以下のようにしてマップの勾配を最小化します。
 i. "Global Optimization" ウィンドウで Minimize CM Gradient Weight をク

リックします。
 ii. "Minimization of Calibration Map Gradient" ウィンドウで、各軸についてマッ

プの勾配を最小化するための重みを設定します。
0（最小化を行わない）から1（非常に強い最小化を行う）までの値を入力できま
す。

 4. 必要に応じて、以下のようにしてマップの個々の入力について勾配の許容限度を設定し
ます。
 i. "Global Optimization" ウィンドウで Constrain CM Gradient をクリックしま

す。
 ii. "Limitation of Calibration Map Gradient" ウィンドウで、勾配の許容限度を

設定したい入力と動作ポイントの組み合わせをオンにします。
許容限度は、各動作ポイントについて個別に設定できます。

 iii. 入力フィールドに、入力ポイントと動作ポイント軸の勾配の下限値と上限値を入力し
ます。

 5. 最適化を繰り返します。
この最適化処理は、要件に合う結果が得られるまで、結果を調べて重みを変更する処理を繰り
返し実行します。
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6.10 モデルのエクスポート
本項では、ASCMO-STATICモデルを他のツール（MATLAB®、INCA/MDA、Python、
Simulink®、Excel、Cコード、GT-SUITE、FMI）用にエクスポートする方法を説明します。

注記 

演算されたモデル（Calculated Models）のエクスポートは行えません。

6.10.1 MATLAB®へのエクスポート 
MATLAB®へのモデルのエクスポートでは、エクスポートのタイプを選択することができます。

Model Output (Basic) （次ページ）
Model Output and Gradient （次ページ）
Model Output, Gradient and Hessian （次ページ）
Model Output, Gradient, Hessian, Sigma, SigmaGrad and Validity （次
ページ）

モデルをMATLAB®用にエクスポートする

 1. File > Export Model > Matlab を選択します。
"Export to Matlab (*.m)" ウィンドウが開きます。

 2. エクスポートに関する以下の情報を設定します。
Base Name：エクスポート先のファイルのベースネーム（<base name>_

<Output>）
Target Folder：エクスポート先の場所
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Type：エクスポートするデータのタイプ（内容）
 3. エクスポートする出力（Outputs）と入力（Inputs）を選択します。必要に応じて

入力の順番を変更でき、"Used Inputs only" オプションも使用できます。
 4. Export をクリックします。

エクスポート処理が開始され、指定されたパスにファイルが保存されます。

"Model Output (Basic)" タイプ
各モデル／出力ごとに、モデル予測を行うMスクリプトが作成されます。

注記 

作成されたMスクリプトはASCMO-STATICのコードを使用しないため、使用する際に
ASCMO-STATICがインストールされている必要はありません。ただしMATLAB®へのエクス
ポートを行う際には、MATLAB®環境がインストールされている必要があります。

Y1 という名前のモデル出力については、predict_Y1.m というスクリプトが作成されます。呼
び出しは次のようになります。

>> Y = predict_Y1(x)

ここで x は入力の数と同じ長さのベクトルです。この関数の戻り値はスカラ型のモデル予測です。
MATLABプロンプトの例（入力は4個、出力名はY1）：

>> x = [0.3 7.5 100 66.1];

>> y = predict_Y1(x)

>> y =

>> 0.503

また、列の数が入力の数に等しい行列を入力することもできます。各行はモデルの入力値に対
応します。出力はベクトルで、そのi番目の要素がi番目の入力行（入力値）のモデル予測にな
ります。

 "Model Output and Gradient" タイプ
"Model Output, Gradient and Hessian" タイプ
"Model Output, Gradient, Hessian, Sigma, SigmaGrad and 
Validity" タイプ
Y1 という名前のモデル／出力については、predict_Y1.m というスクリプトと predict_
Y1.mat というファイルが作成されます。
モデル予測以外に以下のような出力値を使用する場合は、MATLAB®クラスへのエクスポート
が必要になります。

モデル予測の勾配
モデル予測のヘッセ行列
モデル予測のシグマ（標準偏差）
シグマの勾配
モデルの有効性（モデルの有効範囲）
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勾配は、勾配オプティマイザをASCMO-STATICモデルと共に使用するような場合に必要となり
ます。

注記 

"Model Output, Gradient, Hessian, Sigma, SigmaGrad and Validity" タイプのエ
クスポートを行うと、ほとんどすべての情報がエクスポートされるため、* .mat ファイルのサイズ
が非常に大きくなる可能性があります。

出力タイプ "Model Output and Gradient" の例：
>> M = predict_Y1;

>> [y, yGrad] = M.modelval_ygrad([0.3 7.5 100 66.1]);

出力タイプ "Model Output, Gradient and Hessian" の例：
>> M = predict_Y1

>> Y = M.modelval(x)

>> [Y, Ygrad, Yhessian] = M.modelval_hessian(x);

出力タイプ "Model Output, Gradient, Hessian, Sigma, SigmaGrad and 
Validity" の例：

>> M = predict_Y1

>> Y = M.modelval(x)

>> [Y, Ystd_1, Ystd_2] = M.modelval_std(x)

>> [Y, Ygrad, Yhessian, Ystd_1, Ystd_2, Ystd_1grad, Ystd_

2grad, Ystdgrad_t, Validity] = M.model-val_ygrad_std(x)

 

注記 

MATLAB®/Simulink®がPCにインストールされていない場合は、File > Export 
Model > Simulink Script で、モデルをMATLAB®スクリプト（*.m）にエクスポートす
ることができます。後にこれを用いてSimulinkモデルを生成することができます。詳細は、オン
ラインヘルプを参照してください。

6.10.2 INCA／MDAへのエクスポート 
モデルをINCA用の演算シグナルとしてエクスポートします。演算シグナルは、Perl モジュール
（*.pm）としてINCA／MDAの所定のディレクトリに保存されます。
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モデルをINCA／MDA用にエクスポートする
 1. File > Export Model > INCA/MDA を選択します。

"Export to INCA/MDA (*.pm)" ウィンドウが開きます。

図 6-18: "Export to INCA/MDA" ウィンドウ

 2. "Location" 列で、INCA／MDAのバージョンを選択します。

注記 

INCA／MDAへのエクスポートを行うには、V6.2以降のINCA／MDAが必要です。
それより古いバージョンのものは、インストールされていても "Export to INCA / 
MDA" ウィンドウに表示されません。

 3. "BaseName" フィールドにファイル名を入力します。
実際のエクスポートファイル名は次のようになります：<Basename>_<Outpu>.pm

 4. 出力（Outputs）を選択します。
 5. Export をクリックします。

"Location" 列に表示された場所にデータがエクスポートされます。

注記 

エクスポートされたデータをINCAやMDAで使用する方法については、各製品のユー
ザーガイドやオンラインヘルプを参照してください。ユーザーガイドはETASウェブサイトの
ダウンロードセンター（https://www.etas.com/ja/products/download_
center.php）からも入手できます。
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6.10.3 Pythonへのエクスポート
Pythonへのモデルのエクスポートでは、エクスポートのタイプを選択することができます。以下に、
エクスポートの各タイプについて説明します。いずれのタイプについても、各モデル／出力ごとの
Pythonクラス（*.py）、MATファイル（*.mat）、および呼び出しが含まれるファイル
（ModelEvaluationExample.py）が作成されます。

注記 

このエクスポートを実行するには、インストールされているPythonに "NumPy" および 
"SciPy" というパッケージが含まれている必要があります。Pythonのインストール状態について
の詳細情報は、システム管理者の方にお問い合わせください。

モデルをPython用にエクスポートする
 1. File > Export Model > Python を選択します。

"Export to Python (*.py)" ウィンドウが開きます。

 2. エクスポートに関する以下の情報を設定します。
Base Name：エクスポート先のファイルのベースネーム（<base name>_

<Output>.py）
Target Folder：エクスポート先の場所
Type：エクスポートするデータのタイプ（内容）

 3. エクスポートする出力（Outputs）と入力（Inputs）を選択します。必要に応じて
入力の順番を変更でき、"Used Inputs only" オプションも使用できます。

 4. Export をクリックします。
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エクスポート処理が開始され、指定されたパスにファイルが保存されます。
モデル出力の名前が Y1 の場合、predict_Y1.py というスクリプトと 
predict.mat というMATファイル、さらに ModelEvaluationExample.py とい
うファイルが作成されます。

注記 

pyスクリプトはASCMO-STATICのコードを使用しないため、使用する際にASCMO-
STATICがインストールされている必要はありません。

モデル予測以外に以下のような出力値を使用する場合は、Pythonクラスへのエクスポートが必
要になります。

モデル予測のシグマ（標準偏差）
モデル予測の勾配
シグマの勾配
モデルの有効性（モデルの有効範囲）

勾配は、勾配オプティマイザをASCMO-STATICモデルと共に使用するような場合に必要となり
ます。
出力タイプ "Model Output (Basic)" の例：

from numpy import array, NAN import scipy.io

from predict_Y1 import *

 

xtest = array ([[0.3, 7.5, 100, 66.1]])

M = predict_Y1()

[Yval] = M.modelval(xtest)

出力タイプ "Model Output and Gradient"、
"Model Output, Gradient and Hessian"、
"Model Output, Gradient, Hessian, Sigma, SigmaGrad and Validity" の
例：

from numpy import array, NAN

import scipy.io

from predict_Y1 import *

 

xtest = array ([[0.3, 7.5, 100, 66.1]])

M = predict_Y1()

[Yval] = M.modelval(xtest)

[Yval, Ystd1, Ystd2] = M.modelval_std(xtest)

[Yval, Ygrad, Yhessian, Ystd1, Ystd2, Ystd1_grad, ↵
 Ystd2_grad, YstdGradNoBoxCoxTrans, Validity] = ↵
 M.modelval_ygrad_std(xtest)
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6.10.4 Simulink®モデルへのエクスポート 

注記 

エクスポートを行うには、PCにSimulink®がインストールされている必要があります。

Simulinkモデルファイル（*.mdl、*.sxl）と共に、データを含むMスクリプト（*.m）がエク
スポートされます。これらのスクリプトはSimulinkモデルを開くと自動的に開始されます。このスク
リプトに入力データを定義することもできます（"inputData"）。

図 6-19: Simulinkにエクスポートされたモデル（視認性のために簡略化したもの）

動的に作成されるファイルだけでなく、SファンクションとCコードもエクスポートされます。
Simulinkでのシミュレーションには、Sファンクション（call_asc_predict_

novar.mexw32 などのDLLファイル、または *.tlc  ファイル）が必要です。
ETAS LABCAR でモデル予測を行うためのコードをSimulinkモデル用に作成するよう
な場合（Simulink® Coder™、以前はReal-Time Workshop®）は、Cコードが
必要です。

注記 

エクスポートされたモデルは複数のインスタンスとして使用できます。

Simulinkモデルはバージョンに応じて異なります。PCに複数バージョンのSimulinkがインストー
ルされている場合、ASCMO-STATICは、デフォルトにおいて、バージョンの新旧には関わらず、
最後にインストールされたバージョンを使用します。しかし、エクスポート時にはバージョンを指定し
てエクスポートすることができます。
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エクスポート先のSimulinkバージョンを指定する
 1. メインウィンドウで File > Options を選択します。

"Options" ウィンドウが開きます。

 2. "Simulink Version" ドロップダウンメニューで、使用したいバージョンを選択します。
 3. OK をクリックします。

モデルをSimulink®用にエクスポートする

 1. File > Export Model > Simulink Model を選択します。
"Export to Simulink Model (*.mdl/.slx)" ウィンドウが開きます。

 3. エクスポートに関する以下の情報を設定します。
Target File：エクスポートファイルの保存先のパスと、ファイル名（<file name>_

<model name>）を指定します。必要に応じて "Used Inputs only" オプションも使
用できます。
 

 4. Export をクリックします。
エクスポート処理が開始されます。選択されているバージョンのSimulinkモデルが作成さ
れます。各ファイルは指定されたパスに保存されます。

注記 

MATLAB®/Simulink®がPCにインストールされていない場合は、File > Export 
Model > Simulink Script で、モデルをMATLAB®スクリプト（*.m）にエクスポートす
ることができます。後にこれを用いてSimulinkモデルを生成することができます。詳細は、オン
ラインヘルプを参照してください。
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6.10.5 Excelマクロへのエクスポート
Excelのエクスポートを行うと、出力ごとにVBAスクリプト（*.bas）が作成されます。つまり、
Y1 という出力に対しては predict_Y1.bas というVBAスクリプトが作成されます。
モデルをExcel用にエクスポートする

 1. File > Export Model > Excel Macro を選択します。
"Export to Excel Macro (*.bas)" ウィンドウが開きます。

 2. エクスポートに関する以下の情報を設定します。
Base Name：エクスポート先のファイルのベースネーム（<base name>_

<Output>.bas）
Target Folder：エクスポート先の場所

 3. エクスポートする出力（Outputs）と入力（Inputs）を選択します。必要に応じて
入力の順番を変更でき、"Used Inputs only" オプションも使用できます。

 4. Export をクリックします。
エクスポート処理が開始され、指定されたパスにファイルが保存されます。

 
エクスポートされたスクリプトファイルは、以下のようにしてMS Excelにインポートします。

Excel 2003：Tools > Macro > Visual Basic Editor
Excel 2007/2010/2013/2016：Developer リボン > Visual Basic 
VBAエディタから：File > Import File

*.bas ファイルのインポートが終了すると、Excelでモジュール M_predict_Y1 が利用可能に
なります。Visual Basicエディタは閉じることができます。モデル予測はExcel用の関数として提
供されます。以下のように、モデル予測用の入力データ（例：A2、B2、C2、D2）を入力し、
予測結果のセル（E2）で関数（例："=predict_Y1(A2:D2)"）を使用してください。
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6.10.6 Cコードへのエクスポート 
モデルをCコードとしてエクスポートすると、出力ごとに *.c ファイルが作成されます。
モデルをCコードにエクスポートする

 1. File > Export Model > C Code を選択します。
"Export to C Code (*.c)" ウィンドウが開きます。

 2. エクスポートに関する以下の情報を設定します。
Base Name：エクスポート先のファイルのベースネーム（<base name>_

<Output>.c）
Target Folder：エクスポート先の場所
Type：エクスポートするデータのタイプ（内容）

 3. Outputs（入力の外殻モデルを含む）と Inputs 必要に応じて入力の順番を変更
でき、"Used Inputs only" オプションも使用できます。 を選択します。

 4. Export をクリックします。
エクスポート処理が開始され、指定されたパスにファイルが保存されます。

エクスポートを実行すると、モデルファイル（*.c）に加え、出力タイプに応じて以下のファイルが
生成されます。
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タイプ 生成されるサンプルファイル 用途

Model Output (Basic)
 

mexPredict.c MATLAB MEXファイルの生
成

slPredict.c Sファンクションの生成

Model Output and 
Gradient

mexPredictGrad.c MATLAB MEXファイルの生
成

MEXファイル：mexファイルは、エクスポートされたASCMO-STATICモデルから、MATLAB®

で以下のようにして生成することができます。
mex mexPredict.c -DNUMINPUTs=<n_inputs>

 -DCALLFUNC=predict_<output> -output predict_<output>

これにより、ファイル predict_<output>Matlab.mexw64  が生成され、MATLAB®から
以下のように呼び出すことができます。

>> predict_<output>Matlab([1.1 2.2 3.3 ...])

この結果は以下のようになります。
ans = 23.32343

Sファンクション：エクスポートされたASCMO-STATICモデル用のSファンクションは、
MATLAB®で以下のようにして生成することができます。

mex slPredict.c -DNUMINPUTS=<n_outputs> 

 -DCALLFUNC=predict_<output> -output predict_<output>

これにより、ファイル predict_<output>Simulink.mexw64 が生成されます。
エクスポートファイルのフォーマット例（3つの有効な入力を持つモデル）：

#include <math.h>

void predict_Fuel_mass(double* pInArray, double* 

pOutPrediction)

{

[...]

}

上記の例は以下のように使用できます。
extern predict_Fuel_mass(double*, double*);

double modelInput[3];

double modelOutput;

modelInput[0] = 1.1;

modelInput[1] = 2.2;

modelInput[2] = 3.3;

predict_Fuel_mass(modelInput, modelOutput);

ここで、modelOutput変数には入力ベクトル [1.1, 2.2, 3.3] 用のモデル予測が格納されま
す。
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6.10.7 GT-SUITEへのエクスポート 
GT-SUITEへのモデルエクスポートはCコードエクスポート機能の拡張バージョンで、ASCMO-
STATICモデルをGT-SUITE（V2016）に直接ロードして使用することができます。モデルと出
力をGT-SUITEにエクスポートすると、モデル／出力ごとに*.cファイルが1つずつ作成されます。
モデルをGT-SUITE用にエクスポートする

 1. File > Export Model > GT-Suite を選択します。
"Export to GT-SUITE (*.c)" ウィンドウが開きます。

 2. エクスポートに関する以下の情報を設定します。
Base Name：エクスポート先のファイルのベースネーム（<base name>_

<Output>.c）
Target Folder：エクスポート先の場所

 3. Outputs（入力の外殻モデルを含む）と Inputs を選択します。必要に応じて入力
の順番を変更でき、"Used Inputs only" オプションも使用できます。

 4. Export をクリックします。
エクスポート処理が開始され、指定されたパスにファイルが保存されます。

6.10.8 FMIへのエクスポート 
ASCMO-STATICモデルを、FMI（Functional Mockup Interface）規格に準拠する
FMU（Functional Mockup Unit）としてエクスポートすることができます。FMIは
Modelisar Consortiumによって策定されたツール非依存の規格です。拡張子 *.fmu の圧
縮ファイルに保存されたXMLファイルとコンパイル済みCコードを用いて、ダイナミックモデル同士の
モデル交換と連成シミュレーション（Co-Simulation）をサポートします。
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これにより、ASCMO-STATICモデルを他のツールを用いた以降のプロセスに使用することが可
能になります。
Y1 という名前のモデルには、predict_Y1.fmu が作成されます。このファイルには、Cコードと
Windows（32／64ビット）用DLLファイル、および入出力仕様のXMLメタディスクリプションが
含まれます。

注記 

FMI規格についての詳細な情報は、FMIのウェブサイト（https://www.fmi-
standard.org/）を参照してください。

モデルをFMI用にエクスポートする
 1. File > Export Model > FMI を選択します。

"Export to FMI (*.fmu)" ウィンドウが開きます。

 2. エクスポートに関する以下の情報を設定します。
Base Name：エクスポート先のファイルのベースネーム（<base name>_

<Output>.fmu）を定義します。
Target Folder：エクスポート先の場所
FMI Version：FMIバージョン（1.0 または2.0）

 3. エクスポートする出力（Outputs）と入力（Inputs）を選択します。必要に応じて
入力の順番を変更でき、"Used Inputs only" オプションも使用できます。

 4. Export をクリックします。
エクスポート処理が開始され、指定されたパスにファイルが保存されます。 
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7 チュートリアル：ASCMO-STATIC ExpeDesの操作
ASCMO-STATIC ExpeDesは、空間充填による統計的実験計画を作成するためのツールで
す。ASCMO-STATIC ExpeDesは、動作ポイント（速度／負荷）のグリッド空間内への測
定値の分散を計画するのに最適で、これはASCMO-STATIC ExpeDesでのモデルトレーニン
グを行うための要件となります。

ASCMO-STATIC ExpeDesで実験計画を作成する際の規則
実験計画の作成時には以下の規則が適用されます。

作成された実験計画は常に有効で、いつでもエクスポートすることができます。
実験計画は次の作業ステップに移る際に自動的に更新されますが、手動で更新するに
は、ツールバーの Apply changes and update viewer アイコンをクリックするか、
メニューコマンド View → Update を実行します。
いずれかの変更内容が無効である場合は、現在のステップに留まって内容を訂正する
か、または変更を破棄して次のステップに進むこともできます。
各ステップは任意の順に実行できますが、実際にはここで示されている順で実行すること
をお勧めします。
処理中には、View メニューにより実験計画の内容をいつでも可視化することができます
（7.3 「実験計画の可視化」（ページ166）を参照）。
各ステップ間の依存関係により自動的に設定変更が行われると、メッセージペインに警告
メッセージが表示されます。たとえば、範囲の制限（Constraint）に使用されている入
力がステップ1において削除されると、その制限は自動的に削除されます。

ASCMO-STATIC ExpeDesを起動する
ASCMO-STATIC ExpeDesは、Windowsスタートメニュー、または "ASCMO-STATIC 
ExpeDes" ウィンドウ（「"ASCMO-DESK" ウィンドウ」（ページ68）参照）から起動します。

 1. ASCMO-STATIC ExpeDesを起動するには、以下のいずれかを実行します。
 l Windowsスタートメニューの ETAS ASCMO5.11 プログラムグループから、

ASCMO ExpeDes V5.11 を選択します。
 l "ASCMO-DESK" ウィンドウで "Static Test Planning" タイルをクリックします。
ASCMO-STATIC ExpeDesスタートウィンドウが開きます。ASCMO-STATIC 
ExpeDesを空のプロジェクトで起動し（New >  Empty Project）、デモプロジェ
クト（Demo Files）または既存のプロジェクト（Open >   Open 
Project/Recent Projectsから選択）を開くことができます。
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図 7-1: ASCMO-STATIC ExpeDesスタートウィンドウ

 2. ASCMO-STATIC ExpeDesメインウィンドウを空のプロジェクトで開くには：
 a. 左側のメニューパネル内の New をクリックします。

 b.  をクリックします。

ASCMO-STATIC ExpeDesメインウィンドウの第1ページが開き、デフォルト設定が表
示されます。

図 7-2: ASCMO-STATIC ExpeDesメインウィンドウ

ASCMO-STATIC V5.11 | ユーザーガイド



7 チュートリアル：ASCMO-STATIC ExpeDesの操作 | 162

 3. ここで既存のASCMO-STATIC ExpeDesプロジェクトを開くには、以下のように操作し
ます。
 i. ASCMO-STATIC ExpeDesメインウィンドウで、左側のメニューパネル内の Open 

をクリックします。

 ii.  をクリックします。

オープンファイルダイアログが開きます。
 iii. 開きたい *.exde ファイルを選択し、Open をクリックします。

選択したプロジェクトが開き、ASCMO-STATIC ExpeDesメインウィンドウに表示されま
す。

メニューとツールバーの機能の詳細については、オンラインヘルプ（Help > Online Help）、
またはその状況依存トピック（<F1>）を参照してください。

7.1 ASCMO-STATIC ExpeDesの操作ステップ 
このチュートリアルでは、ASCMO-STATIC ExpeDesを用いて実験計画を作成する方法を、
ステップを追って説明します。

ご注意ください！ 
誤った実験計画による損害
ASCMO-STATIC ExpeDesにおける誤ったエンジン設定は、エンジンやテストベンチの損傷
を招きます。例：ノッキングが多発するような点火角度設定などにより、動作ポイントがエンジ
ンに過大なストレスを与え、損傷の原因となります。

実験計画の一般設定は、システムと対象物に適合している必要があります。誤った設定
の例：最大6000rpmのエンジンに対して、実験計画内で10000rpmが設定されてい
る
動作ポイントは、許容値の範囲内に制限してください。ETAS ASCMOは、エンジンパラ
メータに関する情報を一切持っていません。
実験計画をエクスポートする前に、一般設定においてエンジン負荷の範囲を制限してくだ
さい。
実験計画を使用するには、その内容を検証する必要があります。

7.2 「ステップ1：一般設定 」（次ページ）および7.11 「ステップ9：エクスポート
（"Export"） 」（ページ192）を参照してください。

7.2 「ステップ1：一般設定 」（次ページ）
最初のステップとして、実験計画の測定ポイント数、および入力の数とコンフィギュレーショ
ンを定義します。
7.3 「実験計画の可視化」（ページ166）
計画データは、グラフやテーブルで表示して、いつでも評価することができます。
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7.4 「ステップ2：範囲制限（"Constraints"） 」（ページ168）
このステップでは、ある変数の測定値の制限範囲を、他の1つまたは2つの変数の関数と
して定義します。
7.5 「ステップ3：入力タイプの設計（"Input Design Types"） 」（ページ
179）
このステップでは、各入力の測定方法を定義します。
7.6 「ステップ4：入力の圧縮（"Input Compression"） 」（ページ185）
このステップでは、測定空間の各領域ごとに測定ポイントを圧縮することができます。
7.7 「ステップ5：ソート規則（"Sorting Rules"） 」（ページ186）
このステップでは、入力のソート規則を定義できます。これにより、対象システムの特性に
合わせた方法で実験計画を実行することができます。
7.8 「ステップ6：ブロック構成（"Block Configuration"）」（ページ188）
このステップでは、実験計画を、個別に測定できる複数のパーツ（「ブロック」）に分割で
きます。各ブロックは実験計画の要件に相当します。
7.9 「ステップ7：付加ポイント（"Additional Points"）」（ページ190）
このステップでは、必要に応じてポイント（実験計画のポイント以外の、特定の基準に
従って反復的にアプローチされて測定されるポイント）を定義します。
7.10 「ステップ8：演算入力（"Calculated Inputs"）」（ページ191）
チュートリアルではこのステップは省略します。
7.11 「ステップ9：エクスポート（"Export"） 」（ページ192）
このステップでは、プロジェクトおよび実験計画自体のプロパティが表示されます。データの
エクスポートは、いくつかのフォーマットで行えます。さらに、データを散布図や3Dプロット、
テーブルとして視覚化することもできます。詳しくは「実験計画の可視化」を参照してくださ
い。

7.2 ステップ1：一般設定 

ご注意ください！ 
誤った実験計画による損害
ASCMO-STATIC ExpeDesにおける誤ったエンジン設定は、エンジンやテストベンチの損傷
を招きます。例：ノッキングが多発するような点火角度設定などにより、動作ポイントがエンジ
ンに過大なストレスを与え、損傷の原因となります。

実験計画の一般設定は、システムと対象物に適合している必要があります。誤った設定
の例：最大6000rpmのエンジンに対して、実験計画内で10000rpmが設定されてい
る
動作ポイントは、許容値の範囲内に制限してください。ETAS ASCMOは、エンジンパラ
メータに関する情報を一切持っていません。
実験計画をエクスポートする前に、一般設定においてエンジン負荷の範囲を制限してくだ
さい。
実験計画を使用するには、その内容を検証する必要があります。
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7.2 「ステップ1：一般設定 」（前ページ）および7.11 「ステップ9：エクスポート
（"Export"） 」（ページ192）を参照してください。
最初のステップとして、実験計画の測定ポイント数、および入力の数とコンフィギュレーションを定
義します。

図 7-3: ASCMO-STATIC ExpeDes ステップ1：一般設定（"General Settings"）

7.2.1 入力の設定 
新しいASCMO-STATIC ExpeDesプロジェクトを作成すると、数個の入力が自動的に作成さ
れます。これらは適切な名前を付けて設定する必要があり、入力の追加が必要になる場合もあ
ります。
新しい入力を定義する

 1. 新しい入力を追加するには Add をクリックします。
新しい入力がリストの末尾に追加されます。
行番号をクリックして特定の行を選択してから Add をクリックした場合は、その行の下に
新しい入力が追加されます。

 2. 既存の入力の複製を作成するには、その行を選択して Clone をクリックします。
オリジナルの入力の下に<input_name>_2という名前の複製が作成されます。

入力を設定する
入力を設定するには、以下のように操作します。
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 1. 設定したいセルをクリックします。
セルが入力モードになります。

 2. 値を入力して <ENTER> を押します。
以下のパラメータを設定できます。
Input Name：測定する入力量の名前
Minimum / Maximum：入力の測定範囲の上下限値

注記 

入力の名前は一意である必要があります。

 3. 矢印ボタン h／i を使用して、リスト内の各入力の順番を変更することができます。

入力の名前をインポートする
 1. Import ボタンで、以下のいずれかのフォーマットのファイルから名前のリストをインポート

することができます。
 l ラベルファイル（*.lab）－ ETAS INCA用の変数ラベルファイルなど
 l MS Excel（*.xls、*.xlsx）
 l カンマ区切りのテキストファイル（*.csv）
 l コンフィギュレーションファイル（*.ini）－ ETAS ASCMOチャンネル設定ファイル

など
ウィンドウが開くので、実際にインポートする名前を選択します。

入力を削除する
 1. 削除したい行を選択して、Delete をクリックします。

7.2.2 測定量の設定 
実験計画における測定値の数は、手動設定するか、または "Expected System 
Complexity" 領域のオプションを使用して設定する必要があります。以下のオプションがありま
す。

Low：入力と出力がほぼ直線的な依存関係を持つシステム。
Medium：挙動が2次または3次の多項式にほぼ相当するシステム（例：エンジンの
ローカルな動作ポイント）
High：多項式では表現しきれないような複雑なシステム（例：操作域を超えたエン
ジンの挙動）

測定値の数を設定する
 1. "Actual Number of Measurements" フィールドに数を入力します。

または
"Expected System Complexity" 領域で、システムに適したオプションを選択しま
す。
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"Proposed Number of Measurements" フィールドに、選択したオプションに応じた
測定値の数が提示されます。

注記 

提示される測定値の数は、入力の数とシステムの複雑度に依存します。

 2. 提示された値を使用するには、Use Proposal オプションをオンにします。
測定値の数が多い場合は、測定値を小さなブロックに分割し（7.8 「ステップ6：ブロック構成
（"Block Configuration"）」（ページ188）を参照）、モデリング時において、所望のモデ
ル品質を実現するためにこのサイズのブロックがいくつ必要になるかを試してみることをお勧めしま
す。

注記 

ステップ1（"General Settings"）の設定内容から実験計画が作成されます。作成された
実験計画は、*.xls または *.csv フォーマットでエクスポートできます。実験計画をエクス
ポートする方法については、7.11 「ステップ9：エクスポート（"Export"） 」（ページ192）
を参照してください。

7.3 実験計画の可視化
計画データは、グラフやテーブルで表示して、いつでも評価することができます。

ASCMO-STATIC V5.11 | ユーザーガイド



7 チュートリアル：ASCMO-STATIC ExpeDesの操作 | 167

実験計画を可視化する
 1. 実験計画の2次元プロットを表示するには、ASCMO-STATIC ExpeDesメインウィンド

ウで View > Scatter Plot を選択します。

 2. "Experiment Scatter Plot" ウィンドウで、View > Select Axes を使用して、表
示する軸を選択します。

 3. 3次元プロットを表示するには、ASCMO-STATIC ExpeDesメインウィンドウで View 
> 3D View を選択します。
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表示する軸は、プロットウィンドウ内で直接選択できます。
 4. 測定計画のデータをテーブル形式で表示するには、ASCMO-STATIC ExpeDesウィン

ドウで View > Table View を選択します。

7.4 ステップ2：範囲制限（"Constraints"） 
このステップでは、ある変数の測定値の制限範囲を、他の1つまたは2つの変数の関数として定
義します。
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図 7-4: ASCMO-STATIC ExpeDesステップ2：範囲制限（"Curve" タイプ）

これらの制限条件について、追加や削除、インポート、可視化、設定が行えます。
制限を追加、削除、管理する

 1. 新しい制限を作成するには、Add をクリックします（図 7-4:  上記のAを参照）。
リストの末尾に新しい制限の行が追加されます。

 2. "Constraint Name" 列のセルをクリックして、制限の名前を入力します。
 3. "Constraint Type" 列のセルをクリックして、コンボボックスから制限のタイプを選択しま

す。
次のタイプから選択できます：Map、Curve、Formula
これらのタイプについての詳細は、7.4.1 「"Map"／"Curve" タイプの制限 」（次ペー
ジ）と7.4.2 「"Formula" タイプの制限 」（ページ172）を参照してください。

 4. "Active" 列で、使用したい制限をアクティブにします。
 5. 上下の矢印ボタン h i を使用して、リスト内の各制限の順番を変更することができます。

 6. Delete をクリックすると、選択されている行が削除されます。
Curve タイプと Map タイプの制限の設定方法は、7.4.1 「"Map"／"Curve" タイプの制限 」
（次ページ）を参照してください。
Formula タイプの制限の設定方法は、7.4.2 「"Formula" タイプの制限 」（ページ172）
を参照してください。
ウィンドウ下部に表示される情報（図 7-4のC、D、E）は、"Constraint Type" の設定に依
存します。
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7.4.1 "Map"／"Curve" タイプの制限 
変数を選択する

 1. "Show" 列で、編集したい制限をアクティブにします。
ウィンドウ下部にその制限の内容が表示されます。"x-Axis"／"y-Axis" コンボボックス
（マップの場合はさらに "z-Axis" コンボボックス）も表示されます。

 2. 各コンボボックスで、軸に割り当てる入力を選択します。
カーブの場合の依存関数は y(x) で、マップの場合は z(x,y) です。

測定ポイントと制限のグラフ表示
リスト内で選択された制限の内容が完全に定義されていると、現在の実験計画の測定ポイント
が2D（カーブ－ 図 7-4:  前ページを参照）または3D（マップ）でプロット表示されます。
どちらの入力も適切にクラスタ化（7.5 「ステップ3：入力タイプの設計（"Input Design 
Types"） 」（ページ179）を参照）されているので、結果は純粋なグリッドになります。
測定ポイントの表示／非表示は、Measurement オプション（図 7-4:  前ページ内のD）で
切り替えます。プロット内に表示される大きなサイズの点を動かして、領域の制限を変更すること
もできます（「グリッドノードの表示／編集用テーブル」（次ページ）を参照）。
測定範囲の制限を変更する

 1. "Show" 列で、編集したい制限をアクティブにします。
ウィンドウ下部にその制限の内容が表示されます。

 2. 制限プロット（図 7-4:  前ページのC）内で、制限ライン／領域の点にマウスポインタを
合わせ、マウスボタンを押し下げます。
マウスポインタが上下矢印に変わります。

 3. マウスボタンを押し下げたまま、その点を所望の位置にドラッグします。
以下の図は、低速域において負荷の制限をかけた例を示しています。
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 4. "Processing Method" 領域では、制限の外側に出るポイントをどのように扱うかを決
定するオプションを選択します。
このオプションについては、以下の "Processing Method" についての説明を参照してく
ださい。

プロット表示にはツールバーの各ボタン（Zoom In、Zoom Out、Pan、Rotate 3D）を
利用することもできます。

右側のテーブル（図 7-4:  ページ169のE）の "Upper" および "Lower" タブには、制限され
るポイントを表す値が表示され、この値を直接変更することもできます。「グリッドノードの表示／
編集用テーブル」（下記）を参照してください。
制限の表示と編集には以下のようなオプションも使用できます。

Display Options
 l Measurement：定義されたすべての制限によって算出される測定ポイントの表

示／非表示
 l Upper/Lower：制限によって定義される上下限の表示／非表示
 l Points Deleted：制限によって削除される測定ポイントの数
Processing Method：測定範囲が制限される場合、測定ポイントの数を処理する
ためのいくつかのオプションが利用できます。
 l Cutoff：測定範囲外になるポイントを除外します。これらのポイントの数はプロットの

下の "Points Deleted" に示されます。
 l Limit：測定範囲外のポイントを削除せずに、新しい制限範囲内に移動します。
 l Shrink：除外されてしまうポイントを、除外せずに測定範囲内に移動し、測定ポイ

ントを密集させます。
Global Limits：変数を制限するためのグローバルな上下限値（7.2 「ステップ1：
一般設定 」（ページ163）で定義）

グリッドノードの表示／編集用テーブル
ウィンドウ右端にあるテーブル（図 7-4:  ページ169のE）でもグリッドノードを編集することができ
ます。上限と下限の制限にそれぞれ専用のタブが用意されています。
グリッドノード数を変更する
制限に使用されるマップ／カーブを定義するポイントの数を変更するには、以下のように操作しま
す。

注記 

ポイントの数は2～20の範囲です。
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 1. Redefine Grid をクリックします。
"Constraint: Redefine Grid" ウィンドウが開きます。

 2. 制限軸のポイント数を変更するには、以下のように操作します。
 i. 制限軸のコンボボックスで、Count を選択します。

ポイント数は、それぞれの制限軸の入力フィールドに表示されます。
 ii. 新しい値を入力します。

 3. 制限軸のグリッドベクトルを直接指定するには、以下のように操作します。
 i. 制限軸のコンボボックスで、Vector を選択します。

ベクトルは、それぞれの制限軸の入力フィールドに表示されます。
 ii. ベクトルの値を編集します。

注記 

Count タイプの場合、各グリッドポイントは等間隔になります。Vector タイプの場
合は、各グリッドポイントを不均等に分散することができます。

 4. OK をクリックします。
設定に応じてポイントが変更されます。"Constraint: Redefine Grid" ウィンドウが閉
じます。

7.4.2 "Formula" タイプの制限 
各入力が機能的に相互依存している場合、測定対象となるシステムが設定不可能な状態に
なることを避ける必要があります。これは、式を用いた制限を定義することにより実現できます。
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図 7-5: ASCMO-STATIC ExpeDes ステップ2：範囲制限（"Formula" タイプの
例）

式の定義
"Low Limit" と "High Limit" フィールドで式の上限値と下限値を指定します。このフィールド
にはスカラの数値を入力します。
"Condition" コンボボックスでは比較演算子を選択します。選択できる演算子は、none（上
限値または下限値を指定しない場合）、<（小なり）、<=（小なりイコール）のいずれかで
す。
"Formula Expression" フィールドには式を入力します。ここには任意のMATLAB関係式を
入力できます。式に違反する測定ポイントが排除されます。変数として、"Inputs" 領域と 
"Parameters" 領域に表示された入力またはマップ／カーブ（2D／1D）を使用することがで
きます。演算子は、直接キー入力するか、またはボタン領域（図 7-5:  上記のB）を使用して
入力します。
例
噴射時刻 T_1 および T_2 において測定を行うマルチポイント噴射の場合、噴射間隔 
Delta_T について以下の関係が成り立っていることを確認する必要があります。

T_1 + Delta_T < T_2

入力 T_1 および T_2 だけでなく Delta_T も、他の入力の関数を表すマップ（または既存の
マップ）の形で定義できます。

入力とマップ（"Inputs"／"Parameters" フィールド）
Inputs："Inputs" リストには、実験計画のすべての入力が一覧表示されます。いず
れかを "Formula Expression" フィールドに挿入するには、名前をキー入力するか、ま
たは  ボタンを使用します。

Parameters："Parameters" リストには、実験計画のすべてのマップが一覧表示さ
れます。いずれかを "Formula Expression" フィールドに挿入するには、名前をキー入
力するか、または  ボタンを使用します。

"Parameters" リストの下にあるボタンで、マップ／カーブの作成、インポート、削除、編
集が行えます。
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7.4.3 マップ／カーブの管理
本項では、制限に使用されるマップ／カーブの管理方法（作成、編集、削除、インポート、エク
スポート）の方法について説明します。
マップ／カーブのデータをインポートする
制限に使用するマップやカーブのデータが所定のフォーマットのファイル（*.dcm、*.cdfx、
*.csv、*.xls、*.xlsx、*.xlsm、*.ascmo）に保存されている場合は、それをインポー
トして使用することができます。

 1. マップ／カーブをインポートしたい制限について、Show 列をオンにします。
 2. Parameter/Model > Import をクリックします。

ファイル選択ウィンドウが開きます。
 3. インポートしたいファイルを選択して、開く をクリックします。

"Import Maps or Models" ウィンドウが開きます。ファイルに保存されているマップ／
カーブの一覧が表示されます。

 4. コンボボックスで、カーブの場合はX軸、マップの場合はX軸とY軸に割り当てる入力を選
択します。
カーブの場合は、Y軸に入力を割り当てても無視されます。

 5. "Import" 列のチェックボックスで、インポートしたいアイテムを指定します。
 6. "Name" 列に、インポートするアイテムの一意の名前を入力します。
 7. OK をクリックします。

選択されたアイテムが、現在選択されている制限にインポートされます。
インポート後、Scale/Shift をクリックしてスケールとオフセットを加えることにより、上下
限値を変更して範囲を調整することができます。
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注記 

下側の境界を広げるには、負のオフセット値を入力します。

インポートしたマップ／カーブを制限に割り当てる方法は、「既存のマップ／カーブを制限に割り当
てる」（次ページ）を参照してください。
マップ／カーブのデータをエクスポートする
現在表示されている制限のマップ／カーブや、ASCMO-STATIC ExpeDesプロジェクト内で定
義されているマップ／カーブをエクスポートすることができます。使用できるエクスポートフォーマット
は、*.dcm と *.csv です。

 1. 現在表示されている制限のマップ／カーブをエクスポートする
 i. テーブル領域（図 7-4:  ページ169のE）で、Export をクリックします。

"Save Constraint Maps" ウィンドウが開きます。
 ii. ファイルタイプを選択します。
 iii. ファイルの場所と名前を指定して、保存 をクリックします。

"Specify label names" ウィンドウが開きます。
 iv. このウィンドウで、マップ／カーブの名前（ラベル）を入力します。
 v. OK をクリックします。

上限と下限に使用されるマップ／カーブがエクスポートされます。
 2. ASCMO-STATIC ExpeDesプロジェクト内のマップ／カーブをエクスポートする

 i. ASCMO-STATIC ExpeDesウィンドウで、Parameter/Model > Export を
選択します。
"Export Curve and Maps" ウィンドウが開きます。

 ii. "Export" 列で、エクスポートするマップ／カーブを選択します。
すべてのマップ／カーブを選択するには Select All、選択解除するには Unselect 
All をクリックします。

 iii. OK をクリックします。
"Save Constraint Maps" ウィンドウが開きます。
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 iv. ファイルタイプを選択します。
 v. ファイルの場所と名前を指定して、保存 をクリックします。

マップ／カーブがエクスポートされます。"Export Curve and Maps" ウィンドウが閉
じます。

既存のマップ／カーブを制限に割り当てる
マップ／カーブがASCMO-STATIC ExpeDesプロジェクト内に存在している場合は、Import 
ボタンで選択し、制限に割り当てることができます。

 1. マップ／カーブのデータを割り当てたい制限を表示します。
 2. 右下の Import ボタンをクリックします（図 7-4:  ページ169のE）。

"Select Map from imported Map(s)" または "Select Curve from imported 
Curve(s)" ウィンドウが開きます。

注記 

ASCMO-STATIC ExpeDesプロジェクト内に使用できるマップ／カーブが存在しない
場合は、上記ウィンドウの前にファイル選択ダイアログボックスが開くので、マップデータを
ファイル（*.dcm、*.csv）からインポートして使用します。

 3. 上限と下限にそれぞれ異なるマップ／カーブを使用するには、Use one map 
(/curve) for upper and lower constraint オプションをオフにします。
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 4. "List of Maps"/"List of Curves" 列で、上限と下限に使用するマップ／カーブを選
択します。

 5. OK をクリックします。
"Select Map from imported Map(s)" または "Select Curve from imported 
Curve(s)" ウィンドウが閉じます。上限と下限が制限に割り当てられ、表示されます。
インポート後、Scale/Shift をクリックしてスケールとオフセットを加えることにより、上下
限値を変更して範囲を調整することができます。

注記 

下側の境界を広げるには、負のオフセット値を入力します。

マップ／カーブを作成する
 1. 新しいマップ／カーブを作成するには、以下のいずれかを行います。

 l ASCMO-STATIC ExpeDesウィンドウで、Parameter/Model > New を選
択します。

 l 変換式タイプの制限の "Parameters" フィールド（図 7-5:  ページ173のA）で、
New をクリックします。

"Create new Map/Curve" ウィンドウが開きます。

 2. 名前を入力して、マップ／カーブの入力を選択し、上限値（"Max"）と下限値
（"Min"）を入力します。

 3. OK をクリックします。
"Editing Map/Curve" ウィンドウと "Map <name>" ／ "Curve <name>" ウィ
ンドウが開きます。ここでマップを編集することができます。

マップ／カーブを編集する
マップ／カーブは、テーブルとプロットのどちらででも編集することができます。
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 1. 既存のマップ／カーブを編集するには、以下のいずれかを行います。 
 l ASCMO-STATIC ExpeDesウィンドウで、Parameter/Model > Edit > 

<map/curve name> を選択します。
 l 変換式タイプの制限の "Parameters" フィールド（図 7-5:  ページ173のA）で、

Edit をクリックします。
"Editing Map/Curve" ウィンドウと "Map <name>" ／ "Curve <name>" ウィ
ンドウが開きます。

 2. グリッドポイントを再定義するには、Redefine Grid をクリックし、「グリッドノード数を変
更する」（ページ171）を参照してグリッドを編集します。

 3. マップ／カーブのスケールとオフセットを指定するには、以下のように操作します。
 i. Scale/Shift をクリックします。

"Scale and Shift Map" ウィンドウが開きます。

 ii. このウィンドウで、マップ／カーブのスケールファクタとオフセットを入力します。

注記 

下側の境界を広げるには、負のオフセット値を入力します。

 iii. OK をクリックします。
 4. "Smoothness" のツマミを左右に動かして、マップ／カーブを平滑化することができま

す。
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マップ／カーブの名前を変更する
 1. ASCMO-STATIC ExpeDesウィンドウで、Parameter/Model > Edit > 

<map/curve name> を選択します。
"Editing Map/Curve" ウィンドウと "Map <name>" ／ "Curve <name>" ウィ
ンドウが開きます。

 2. "Name" フィールドにマップ／カーブの名前を入力します。
 3. "Map <name>"／"Curve <name>" ウィンドウで OK をクリックして変更内容を

確定し、2つのウィンドウを閉じます。Apply をクリックすると、変更内容は確定されます
が、ウィンドウは閉じません。

マップ／カーブを削除する
 1. マップ／カーブを削除するには、以下のいずれかを行います。

 l ASCMO-STATIC ExpeDesウィンドウで、Parameter/Model > Delete を
選択します。

 l 変換式タイプの制限の "Parameters" フィールド（図 7-5:  ページ173のA）で、
Delete をクリックします。

"Delete Curve and Maps" ウィンドウが開きます。

 2. "Delete" 列で、削除したいマップ／カーブを選択します。
 3. Delete をクリックします。
 4. 選択したマップ／カーブの削除を実行するには、Yes をクリックします。

7.5 ステップ3：入力タイプの設計（"Input Design Types"） 
このステップでは、各入力の測定方法を定義します。
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図 7-6: ASCMO-STATIC ExpeDes ステップ3：入力タイプの設計（"Clustered" タ
イプ）

各入力について、以下の3つの測定タイプから1つを選択できます。
Space Filling：ASCMO-STATIC ExpeDesは、測定ポイントが空間充填的かつ
疑似ランダムに分布する実験計画を作成します。
Clustered：「クラスタポイント」という考え方により、所定のパラメータについて空間充
填アルゴリズムを無効化し、代わりに多くの測定値を空間内の数か所（クラスタ）に集
中的に分布させることができます。
これは、入力設定に非常に多くの工数がかかる場合（エンジン測定用の動作ポイントな
ど）や、一部のパラメータが離散値しかとらない場合（量産用プロトタイプ部品など）に
便利です。
あるパラメータを「クラスタ化された入力」（"Clustered"）として設定する場合、ユー
ザーはその測定ポイントも選択しなければなりません。ASCMO-STATIC ExpeDesに
は、測定ポイントをファイルからインポートする機能や測定ポイントの配置をグリッドとして
作成する機能が用意されているため、測定ポイントを容易に定義することができます
（「"Cluster Point Table" 領域（クラスタポイントテーブル）」（次ページ）を参
照）。

注記 

クラスタ化できる入力の数は3個までです。

Sweep：スイープ（"Sweep"）タイプの入力は、毎回の測定ごとに一部のポイントが
複数回使用されます。
Input_n が m 個のポイントからなる "Sweep" として定義されると、Input_1
 ...Input_n-1 についての実験計画が作成され、それら n-1 個の入力が毎回 
Input_n の m 個の値とともに測定されるように拡張されます。
ある入力を "Sweep" として設定する場合、ユーザーはその測定ポイントも選択する必
要があります。ASCMO-STATIC ExpeDesには、測定ポイントをファイルからインポート
する機能やグリッド配置を作成する機能が用意されているため、測定ポイントを容易に定
義することができます（ ページ184を参照）。
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注記 

"Constraints"（範囲制限）から "Input Compression"（入力の圧縮）まで
の設定内容も "Sweep" タイプの入力に影響を与えます。

"Cluster Point Table" 領域（クラスタポイントテーブル）
ここには現在定義されているクラスタポイントがテーブル表示されます。ポイントの選択、挿入、削
除が行えます。
ポイントの選択

 1. "Cluster Point Table" 領域（"Input Design Types" テーブルの左下）で、選
択したいポイントの行をクリックします。
<SHIFT> または <CTRL> キーで複数のポイントを選択することもできます。
テーブル内で選択されたポイントは、右側のプロット上に緑色で表示されます。

ポイントを追加する
 1. あるポイントの次にポイントを追加するには、クラスタポイントテーブルでその行を選択しま

す。
ポイントが選択されていない場合は、新しいポイントはリストの最後に追加されます。
複数行を選択すると、選択された各行の下にそれぞれ新しいポイントが追加されます。

 2. Add をクリックします。
新しいポイントが追加されます。新しいポイントの値は、2つのポイントの間に挿入された
場合は前後の行の値に依存します。リストの末尾に追加された場合は、両軸の平均値
が割り当てられます。

ポイントを削除する
 1. クラスタポイントテーブルで、削除したいポイント（1つまたは複数）を選択します。
 2. Delete をクリックします。

選択されたポイントが警告メッセージなしに削除されます。
クラスタポイントをインポートする
クラスタポイントのグリッドがファイル（*.dcm、*.csv、*.xls）に保存されている場合は、イ
ンポートして使用することができます。

 1. クラスタポイントテーブルの Import Grid をクリックします。
ファイル選択ウィンドウが開きます。

 2. インポートしたいファイルを選択して、開く をクリックします。
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"Import Grid" ウィンドウが開きます。内容は、インポートファイルのフォーマットに応じて
異なります。ファイルに含まれるすべてのマップが "<map name>" コンボボックスに表示
されます。

 3. インポートしたいマップを選択します。
 4. OK をクリックします。

カーブを選択した場合は、エラーメッセージが出力され、インポートは実行されません。
マップを選択した場合は、そのマップがインポートされ、クラスタポイントのグリッドとして使用
されます。

注記 

選択されたマップのいずれかの軸の値がクラスタ入力に定義された範囲を超えていて
も、警告は発行されません。このような値は、削除されます。

クラスタポイントを編集する
クラスタポイントの数を変更するには、以下のように操作します。
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 1. クラスタポイントテーブルの New Grid をクリックします。
"Creating Grid of Cluster Points" ウィンドウが開きます。

 2. 各軸のポイント数を変更するには、以下のように操作します。
 i. 軸のコンボボックスで、Count を選択します。

ポイント数は、それぞれの軸の入力フィールドに表示されます。
 ii. 新しい値を入力します。

 3. 各軸のグリッドベクトルを直接入力するには、以下のように操作します。
 i. 制限軸のコンボボックスで、Vector を選択します。

ベクトルは、それぞれの軸の入力フィールドに表示されます。
 ii. ベクトルの値を編集します。

注記 

Count タイプの場合、各グリッドポイントは等間隔になります。Vector タイプの場合
は、各グリッドポイントを不均等に分散することができます。

 4. "Staggering" のオプションをオンにすると、グリッドポイント数が削減され、測定時の速
度と負荷のバリエーションも削減されます。

 5. OK をクリックします。
設定に応じてポイントが変更されます。"Creating Grid of Cluster Points" ウィンドウ
が閉じます。

"Cluster Point View" 領域（クラスタポイントビュー）
テーブルに定義されている値がここに表示されます。グローバルな境界や制限により切り取られた
ポイントは赤で表示されます。テーブル内で選択されているポイント（「ポイントの選択」（ページ
181）を参照）は緑色の丸で囲んで表示されます。
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グローバル境界と制限の表示／非表示は、プロットの下のオプションで切り替えられます。

"Sweep Value Definition" 領域（スイープ値の定義）
"Sweep" プロパティを持つ入力を選択すると、その入力のテーブルがこの領域に表示されます。
ポイントの選択、挿入、削除が行えます。同時に、結果として得られた測定値の総数が "Total 
Number of Measurement" の値として表示されます。

図 7-7: ASCMO-STATIC ExpeDes ステップ3：入力タイプの設計（"Sweep" タイ
プ）

ポイントを選択する
 1. "Sweep Value Definition" 領域（"Input Design Types" テーブルの左下）

で、選択したいポイントの行をクリックします。
<SHIFT> または <CTRL> キーで複数のポイントを選択することもできます。
テーブル内で選択されたポイントは、右側のプロット上に緑色で表示されます。

ポイントを追加する
 1. "Number of Sweep Values" フィールドの値を大きくして、<ENTER> を押します。

値を n にすると、n 個の等間隔のポイントが作成されます。
または

あるポイントの次にポイントを追加するには、スイープ値テーブルでその行を選択します。
ポイントが選択されていない場合は、新しいポイントはリストの最後に追加されます。
複数行を選択すると、選択された各行の下にそれぞれ新しいポイントが追加されます。

 2. Add をクリックします。
新しいポイントが追加されます。新しいポイントの値は、2つのポイントの間に挿入された
場合は前後の行の値に依存します。リストの末尾に追加された場合は最大値が割り当
てられます。

ポイントを削除する
 1. "Number of Sweep Values" フィールドの値を少なくして、<ENTER> を押します。

値を m にすると、m 個の等間隔のポイントが作成されます。
または
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スイープ値テーブルで、削除したいポイント（1つまたは複数）を選択します。
 2. Delete をクリックします。

選択されたポイントが警告メッセージなしに削除されます。
ポイントをインポートする
スイープ値のリストがファイル（*.csv、*.xls、*.xlsx）に保存されている場合は、インポー
トして使用することができます。

 1. スイープ値テーブルの Import をクリックします。
ファイル選択ウィンドウが開きます。

 2. インポートしたいファイルを選択して、開く をクリックします。
"Import Grid" ウィンドウが開きます。ファイルに含まれるすべてのマップが "<map 
name>" コンボボックスに表示されます。

 3. インポートしたいリストを選択します。
 4. OK をクリックします。

リストがインポートされます。入力の許容範囲を超えている値があると、それらは破棄さ
れ、ログウィンドウに以下の警告メッセージが表示されます：
At least one value is outside the defined Min/Max range 

of this input and will be discarded!

7.6 ステップ4：入力の圧縮（"Input Compression"） 
このステップでは、測定空間の各領域ごとに測定ポイントを圧縮することができます。
各測定ポイント同士をより近くすることにより、モデル精度を向上できます。

図 7-8: ASCMO-STATIC ExpeDes ステップ4：入力の圧縮（"Edge 
Compression" タイプ）
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圧縮する入力を選択する
 1. ウィンドウ上部のリストの "Compression" 列で、圧縮したい入力を選択します（図 7-

8:  前ページのA）。
ウィンドウ下部に、選択された入力の内容が表示されます。

7.6.1 圧縮の設定
この領域（図 7-8:  前ページのB）で、圧縮のタイプと方向を指定します。圧縮のタイプは2種
類から選択できます。

Positioned Compression：このメソッドでは、自由に選択可能な1点に向けて圧
縮が行われます。
 l Gain："Position" で指定されている中心に向かう圧縮の度合い
 l Position：圧縮の中心位置
Edge Compression：測定範囲の一方または両方の端に向けて圧縮が行われま
す。
 l Gain：圧縮の度合い
 l Position：圧縮は、左端（Left Edge）、右端（Right Edge）、両端

（Both Edges）のいずれかの方向に行われます。

7.6.2 ビュー
この領域（図 7-8:  前ページのCとD）の上部には測定ポイントの位置がグラフィカルに表示さ
れ、設定された圧縮のようすがわかります。その下には、圧縮の結果得られた各区間の測定値
数（"Count"）が表示されます。

7.6.3 圧縮の適用例 
下図では、ex_cam の測定値が、測定範囲の両端に向けてゲイン81で圧縮されています。

7.7 ステップ5：ソート規則（"Sorting Rules"） 
このステップでは、入力のソート規則を定義できます。これにより、対象システムの特性に合わせ
た方法で実験計画を実行することができます。
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図 7-9: ASCMO-STATIC ExpeDes ステップ5：ソート規則

このウィンドウには2つの領域があります。  → ／←  ボタン（ ／ ）を使用し
て、測定する入力を両フィールド間で移動させることができます。

"Unsorted Inputs" 領域（ソートされない入力）
ソートされない入力が一覧表示されます。

"Sorted Inputs" 領域（ソートされる入力）
ソートされる入力が一覧表示されます。

Direction：入力の処理方向："Ascending" または "Descending"
Meander：このオプションをオンにすると、ソートされる入力のリストの先頭の入力が
（上図の例では昇順に）処理された後、ソートされる入力のリストの2番目の入力がリ
セットされることはありません。その代わり、値は保持され、逆方向に処理されます。
図 7-9:  上記の例では、最高負荷が測定されて回転数が高くなった後、負荷は最小負
荷にリセットされることなく保持され、この回転数において負荷が降順に処理されます。

注記 

"Meander" 条件は、ソートされる入力のリストの先頭エントリに対しては意味を持ち
ません。

ソートされる入力のリストにおける入力の順序は、↑／↓ ボタン（ ／ ）で変更でき
ます。
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"Cluster Point View" 領域（クラスタポイントビュー）
上部で設定された測定の挙動がグラフィカルに表示されます。

注記 

この領域は、「クラスタ化された入力」がソート対象として選択されている場合にのみ表示され
ます。

7.8 ステップ6：ブロック構成（"Block Configuration"）
このステップでは、実験計画を、個別に測定できる複数のパーツ（「ブロック」）に分割できます。
各ブロックは実験計画の要件に相当します。
ブロック構成を利用することのメリットは測定工数を削減できる点にあります。小数のブロックを測
定するだけで良好なモデル精度を実現できます。

図 7-10: ASCMO-STATIC ExpeDes ステップ6：ブロック構成

測定値の総数（"Current Number of Measurements"）とクラスタポイントの数
（"Number of Cluster Points"）が一番上に表示されます。後者の値は測定ブロックの最
小サイズを定義するために使用されるので、特に重要です。

"Block Size Table" 領域（ブロックサイズテーブル）
各ブロックのサイズを定義します。
定義済みの測定ブロックの合計サイズ（"Sum of Assigned Measurements"）が表示さ
れます。この値が現在の測定値の数（"Current Number of Measurements"）と異なる
場合は、その差（"Deviation"）が赤で表示されます。
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ブロックの作成と編集を行う
 1. "Number of Blocks" フィールドにブロック数を入力して、<ENTER> を押します。

nと入力すると、n個の同サイズのブロックが作成されます。
または

テーブルの最下行（Block ID = Add）の "Number of Measurement" 列に、新
しいブロックに割り当てる測定値の数を入力して、<ENTER> を押します。

新しいブロックが追加されます。
 2. 既存のブロックの測定値の数を調整して、割り当てられた測定値の総数が現在の測定

値の数と一致するようにします。

注記 

割り当てられた測定値の総数が現在の測定値の数と一致していない場合、実験計
画は無効になります。
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ブロックを削除する
 1. ブロックサイズテーブルで、削除したいブロックを選択します。
 2. Delete をクリックします。

ブロックが削除されます。削除されたブロックの測定値の数が "Deviation" として表示さ
れます。

 3. 各ブロックの測定値の数を調整して、すべての測定値がブロックに割り当てられるようにし
てください。

"Block Size View" 領域（ブロックサイズビュー）
ブロックのサイズ（"Block Size Table" 領域に定義されている内容）がグラフィカル表示されま
す。

7.9 ステップ7：付加ポイント（"Additional Points"）
このステップでは、必要に応じて付加ポイント（反復的に測定されるため「反復ポイント
（repetition points）」とも呼ばれます）を定義します。定義されたポイントは、実験計画の
ポイントに加えて、特定の目標に従って反復的にアプローチされて測定されます。
反復ポイントを定義する理由としては、以下のようなものがあげられます：

特定のポイントを複数回測定する必要がある場合（測定期間内のドリフト効果を評価
する場合など）
反復ポイントは、自動化テストの実施中に安定化ポイントとして使用することもでき、ま
た、常に特定の開始ポイントから測定を開始する必要がある場合（測定前の粒子フィ
ルタ再生など）にも使用できます。

反復ポイントは、空間内の位置とユニークなID、および反復特性により定義されます。
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図 7-11: ASCMO-STATIC ExpeDes ステップ7：付加ポイント

反復ポイントを追加／削除する
 1. 新しい反復ポイントをリストに追加するには、Add をクリックします。
 2. 新しい反復ポイントの行で、以下のように設定します。

 i. "Repetition Type" 列で、反復ポイントにアプローチする条件を選択します。
 ii. "Type <input>" 列で、<input> の値を決定する方法を選択します。
 iii. "Value <input>" 列で、Manual タイプの入力値を指定します。

 3. 反復ポイントを削除するには、削除したいポイントのIDを選択して Delete をクリックしま
す。

反復ポイントのリスト（"List of Repetition Points"）
反復ポイントは以下のパラメータで定義します。

Id：反復ポイントを識別するためのID
Repetition Type：どのような条件が満たされた時に反復ポイントにアプローチするか
を選択します。各タイプの詳細は、オンラインヘルプに記載されています。
Type <input>：入力のタイプを定義します。Manual、またはASCMO-STATIC 
ExpeDesプロジェクトに含まれるマップ／カーブを選択します。
Value <input>：反復ポイントにおける入力 <input> の値を定義します。この
フィールドは入力タイプが Manual の場合にのみ編集可能です。

7.10 ステップ8：演算入力（"Calculated Inputs"）
このステップでは、所定の式によって演算される入力を定義して追加することができます。
演算入力はすべてのビュー（散布図、スコープビュー、テーブルビューなど）に表示されます。それ
らは、実験計画とともにエクスポートされます。
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図 7-12: ASCMO-STATIC ExpeDes ステップ8：演算入力

チュートリアルではこのステップは省略します。詳細は、オンラインヘルプ（F1）を参照してくださ
い。

7.11 ステップ9：エクスポート（"Export"） 

ご注意ください！ 
誤った実験計画による損害
ASCMO-STATIC ExpeDesにおける誤ったエンジン設定は、エンジンやテストベンチの損傷
を招きます。例：ノッキングが多発するような点火角度設定などにより、動作ポイントがエンジ
ンに過大なストレスを与え、損傷の原因となります。

実験計画の一般設定は、システムと対象物に適合している必要があります。誤った設定
の例：最大6000rpmのエンジンに対して、実験計画内で10000rpmが設定されてい
る
動作ポイントは、許容値の範囲内に制限してください。ETAS ASCMOは、エンジンパラ
メータに関する情報を一切持っていません。
実験計画をエクスポートする前に、一般設定においてエンジン負荷の範囲を制限してくだ
さい。
実験計画を使用するには、その内容を検証する必要があります。

7.2 「ステップ1：一般設定 」（ページ163）および7.11 「ステップ9：エクスポート
（"Export"） 」（上記）を参照してください。
このステップでは、プロジェクトおよび実験計画自体のプロパティが表示されます。データを各種
フォーマット（*.xlsx、*.xls、*.csv）でエクスポートすることができます。さらに、データを
散布図や3Dプロット、テーブルとして視覚化することもできます。詳しくは7.3 「実験計画の可視
化」（ページ166）を参照してください。
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図 7-13: ASCMO-STATIC ExpeDes ステップ9：エクスポート

値の丸め条件を変更する
"Rounding of Values" 領域で、測定対象システム（エンジンベンチにおける速度など）が
設定する精度を指定することができます。

 1. "Rounding of Values" 領域で、編集したい入力の "Precision" 列をクリックします。
セルが入力モードになります。

 2. 精度の値を入力します。
計画をエクスポートする

 1. "Experiment Plan" 領域で、Export As をクリックします。
ファイル選択ウィンドウが開きます。

 2. エクスポートファイルのタイプを選択します。
使用できるフォーマットは、*.xlsx、*.xls、*.csv のいずれかです。

 3. エクスポートファイルのパスとファイル名を入力、または選択します。
既存のファイルを選択すると、そのファイルは警告なしに上書きされます。

 4. 保存 をクリックします。
または

 5. 前回選択されたファイルのパス、名前、フォーマットでエクスポートするには、Export をク
リックします。
設定に従って実験計画がエクスポートされます。

"Experiment Table" 領域（実験計画のプレビュー）
これまでのステップで定義された設定に基づいてASCMO-STATIC ExpeDesにより作成された
実験計画の全体が表示されます。

"Project Properties" 領域（プロジェクトプロパティ）
"Project Properties" 領域の左側には、プロジェクトと実験計画のプロパティが表示されます。
"Project Properties" 領域の右側には、実験計画のエクスポート履歴が表示されます。
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8 お問い合わせ先

テクニカルサポート

各国支社の営業やテクニカルサポートについての情報は、ETASウェブ
サイトをご覧ください。
www.etas.com/hotlines

ETAS本社
ETAS GmbH

Borsigstraße 24 電話： +49 711 3423-0

70469 Stuttgart Fax： +49 711 3423-2106

Germany インターネット： www.etas.com
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用語集

A
ACF

AutoCorrelation Function（自動相関関数）

ASC GP
ASCMO Gaussian Process

ASC GP-SCS
ASCMO Gaussian Process Sparse Constant Sigma

ASC GP-Spectrum
ASCMO Gaussian Process Spectrum

C
CCF

Cross-Correlation Function（相互相関関数）

CNN
Convolutional Neural Networks（畳み込みニューラルネットワーク）

D
DoE

Design of Experiment（実験計画）

G
GPU

Graphics Processing Unit（グラフィック処理ユニット）

GRU
Gated Recurrent Update（ゲート付き再帰型更新）

I
IACF

Inverse AutoCorrelation Function（逆自己相関関数）

ISP
InterSection Plot（インターセクションプロット）

L
LSTM

Long Short-Term Memory（長短期記憶）

用語集 | 195



ASCMO-STATIC V5.11 | ユーザーガイド

M
MOCA

与えられたデータを用いてファンクションのモデリング（MOdeling）と適合（CAlibration）を行うため
のツール

N
NaN

Not a Number（非数）

NARX
Nonlinear AutoRegression with eXogenous inputs（外生入力を伴う非線形自己回帰）

O
ODCM

Online DoE with Constraint Modeling（制限付きモデリングによるオンラインDoE）

OP
Operating Point（動作ポイント）

R
RDE

Real Driving Emissions（実路走行排気）

RNN
Recurrent Neural Network（再帰型ニューラルネットワーク）

T
TCN

Temporal Convolutional Network（時間畳み込みネットワーク）

は
ハウスドルフ距離

1つのデータセットの全データポイントから他の全データセットのデータポイントまでの最大ユークリッド距
離。
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