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1 Introduction to the Display App

The Drive Recorder Display App is a software application that is installed 
together with the Drive Recorder software from Drive Recorder V7.2.19. The 
Display App is designed to run on a USB monitor with a touch screen.

This section features information on the following topics:

1.1 Intended Use

1.2 Target Group

1.3 Further Information

1.4 Classification of Safety Messages

1.5 Safety Information

1.6 Hardware Requirements

For information on operation, see "Operating the Display App" on page 9.

1.1 Intended Use
The Display App is part of the Drive Recorder software from Drive Recorder 
V7.2.19.

The Display App gives the user access to the Drive Recorder via a monitor with 
a touch screen.  For this purpose, recording jobs must be preconfigured by an 
ES820/INCA expert using the Drive Recorder Configurator.

For recommended display types, see "Hardware Requirements" on page 8.

The Display App is designed for the following purposes:

 l Use in a vehicle for the purpose of test drives

 l Use in combination with the Drive Recorder Configurator and the ES820 
Drive Recorder

 l Starting and stopping recording jobs that are preconfigured by the Drive 
Recorder Configurator

 l Displaying status information on ongoing recording jobs

 l Displaying Drive Recorder system information, such as data storing 
capacity, power management, log file information, and diagnostic 
information

 l Displaying the data transfer status

The Display App must only be used by qualified personnel as defined in "Target 
Group" on the next page, under consideration of the "Safety Information" on 
page 7, and for the purposes that are described in this document. ETAS GmbH 
cannot be made liable for damage which is caused by incorrect use and not 
adhering to the safety instructions.
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1.2 Target Group
The Display App is designed for  engineers working in the field of measurement 
and calibration. Experience with the ETAS software tools INCA and Drive 
Recorder Configurator is necessary. Additionally, you need knowledge of the 
ES820 Drive Recorder hardware.

Test drivers may use the Display App after instruction and under supervision 
of a responsible calibration engineer.

1.3 Further Information
In the following documents, you can find further information on the con-
figuration of recording jobs and on the Drive Recorder hardware:

 l Drive Recorder Configurator - Online Help

 l INCA Online Help

 l ES800 Measurement, Calibration, and Prototyping System - User's 
Guide
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1.4 Classification of Safety Messages
The safety messages in this document warn of dangers that can lead to per-
sonal injury or damage to property:

             DANGER  

indicates a hazardous situation with a high risk of death or serious injury if 
not avoided.

 

             WARNING  

indicates a hazardous situation of medium risk which could result in death 
or serious injury if not avoided.

 

             CAUTION  

indicates a hazardous situation of low risk which may result in minor or mod-
erate injury if not avoided.

 

NOTICE 
indicates a situation which may result in damage to property if not avoided.
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1.5 Safety Information
It is important that you look at the USB monitor only when it is safe to do so. If 
you are the driver of the vehicle, ETAS recommends that you operate the touch 
screen and change recording jobs only when the vehicle is stationary.

After wake-up of the Drive Recorder, the Safety Advice window is displayed on 
the USB monitor.

 1. To select your preferred language, tap the flag button at the bot-
tom left.

 2. Scroll to read the complete Safety Advice.

 3. Tap I Agree.

The Recorder Status window is displayed.

Additionally, observe the following safety message:

             WARNING  

Risk of unexpected vehicle behavior
If the Drive Recorder is operated in combination with an ETK, an ECU reset is 
possible. An ECU reset can result in engine shutdown, which can cause unex-
pected vehicle behavior.

Only modify the test setup when the vehicle is stationary.

Only start recording jobs when the vehicle is stationary.

Before driving, always wait until the Recorder Status window of the Dis-
play App shows green side bars.
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1.6 Hardware Requirements
The Display App is designed for the ETAS ES820 Drive Recorder hardware. It is 
installed together with the Drive Recorder software from Drive Recorder 
V7.2.19.

To operate the DisplayApp, ETAS recommends the following XENARC® USB 
monitors and DIGITUS® adapter:

Recommended Hardware

Monitor Adapter

Xenarc 709CNH DIGITUS USB 3.0 to HDMI

Xenarc 1029CNH DIGITUS USB 3.0 to HDMI

The USB monitor and the adapter are not in the scope of delivery and have to 
be purchased by the customer.

Cables
Together with the respective Xenarc monitor, you can order the following 
power supply cables at XENARC:

Power Supply:

 l "AC Adapter (ACA-M12)" for use in the office or lab

 l "Cigarette Lighter Car Adapter (CLA-M12)" for use in the vehicle

Multi Interface Cable:

 l "5 Meter Cable": Cable with various connectors 
optionally: "5 Meter HDMI & USB Only"

Drivers
For the installation of the drivers for the monitors and the USB to HDMI 
adapter, refer to the following PDF documentation in the Manuals folder, that 
is installed together with the Drive Recorder Configurator installation files:

 l For Drive Recorder V7.2.19:

"ES820 V7.2.19 Display App: XENARC® Monitor Setup with DIGITUS® 
HDMI to USB Adapter - Installation Guide"

 l For Drive Recorder V7.3:

"ES820 V7.3 Display App: XENARC® Monitor Setup with DIGITUS® 
HDMI to USB Adapter - Installation Guide"
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2 Operating the Display App

The following sections describe the operation of the Display App by the touch 
screen of the USB monitor.

2.1 Using the USB Security Key

2.2 Installing the Drivers and Connecting the USB Monitor

2.3 Confirming the Safety Advice

2.4 Getting to Know the Different Views

2.5 Setting the View to Basic or Advanced and Selecting the Language

2.6 Starting and Stopping a Recording Job

2.7 Transferring Data

2.8 Handling Errors

2.1 Using the USB Security Key
To access the data of an encrypted Drive Recorder hard disk, you need the 
device-specific USB Security Key.

 l Connect the USB Security Key to an appropriate USB port of the 
Drive Recorder.

You can insert the USB Security Key either before you connect or 
after you have connected to the Drive Recorder from your local 
PC. Now you can access the data on the encrypted Drive 
Recorder hard disk.

         Note  

The USB Security Key unlocks the Drive Recorder hard disk for one power-up 
period after wake-up. After wake-up,  you can disconnect the USB Security 
Key. If the Drive Recorder is swiched off or falls into the standby mode, you 
must insert the USB Security Key again to make the Drive Recorder hard disk 
accessible after the next wake-up.

For more information on hard disc encryption, see "Managing Data Security" in 
the Drive Recorder Configurator Online Help.
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2.2 Installing the Drivers and Connecting the USB Monitor
For recommended USB monitors and adapters, see "Hardware Requirements" 
on page 8.

To install  monitor and  adapter drivers

         Note  

For a detailed description of the driver installations for the recommended 
hardware, follow the instructions in the respective installation guides, which 
are in the Manuals folder of the Drive Recorder Configurator installation 
files:

For Drive Recorder V7.2.19:

ES820 V7.2.19 Display App: XENARC® Monitor Setup with DIGITUS® HDMI 
to USB Adapter - Installation Guide

For Drive Recorder V7.3:

ES820 V7.3 Display App: XENARC® Monitor Setup with DIGITUS® HDMI to 
USB Adapter - Installation Guide

If you use the "Recommended Hardware" on page 8, use the documentation 
cited in the above note to install the drivers.

If you use monitors and drivers other than recommended, observe the fol-
lowing general steps for installation. These steps are valid for Drive Recorder 
V7.3 and Windows 10.

 1. Via the Drive Recorder Configurator, enter the service mode.

 2. On the Drive Recorder, disable the Intel graphics adapter as 
described in the "ES820 V7.3 Display App: XENARC® Monitor 
Setup with DIGITUS® HDMI to USB Adapter - Installation Guide".

 3. Install the monitor driver and/or adapter driver on the Drive 
Recorder.

 4. Connect the adapter and/or the monitor according to "To connect 
the monitor" on the next page.

 5. On the Drive Recorder, enable the Intel graphics adapter as 
described in the "ES820 V7.3 Display App: XENARC® Monitor 
Setup with DIGITUS® HDMI to USB Adapter - Installation Guide".

 6. Via the Drive Recorder Configurator, quit the service mode.

 7. Via the Drive Recorder Configurator Hardware Configuration win-
dow, enable the Display App according to "To enable the Display 
App" on the next page.

 8. In future, when connecting the monitor and/or adapter to the 
Drive Recorder, always use the USB ports that you used for driver 
installation and enabling.



ETAS 2 Operating the Display App

Drive Recorder Display App V7.3 - User Guide 11

To connect the monitor

If the driver installations are finished and the Drive Recorder is in the Active 
Idle state, you can connect the monitor to the Drive Recorder.

 1. Connect the appropriate power supply cable.

 2. To enable the touch function, insert the USB 2.0 connector of the 
monitor cable into any of the USB ports of your Drive Recorder.

 3. Connect the HDMI-to-USB 3.0 adapter to the HDMI connector of 
the monitor cable.

 4. Connect the USB 3.0 connector of the adapter to a USB 3.0 port 
of your Drive Recorder.

To enable the Display App

If the driver installations for the monitor and adapter are finished and the mon-
itor cables are connected to the Drive Recorder, you can enable the Display 
App.

         Note  

Remember the USB 2.0 and USB 3.0 ports that you use on your Drive 
Recorder when you first enable the Display App. You must always use the 
same USB ports for the monitor connection in future.

 1. In the Drive Recorder Configurator, click File > Open from Device 
> Open Hardware Configurtation from Device.

 2. Select Device Options.

 3. In the section Display App, select Enable Display App.

 4. Click Apply to Drive Recorder.

The Display App is now ready to use on the USB monitor.

 5. Select your desired language for the Display App. 

You can select the language  for the Display App independently 
from the language setting of the Drive Recorder Configurator. 
You can also change the language for the Display App  via the 
touch screen of the USB monitor.
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         Note  

If you want to use a different monitor, read the user documentation of the 
respective monitor and contact the manufacturer for advice. Some monitors 
need additional calibration, which is not necessary for the recommended 
XENARC types. 

To preserve the monitor settings, click Tools > Enter Service Mode before 
changing the monitor settings, and click Tools > Quit Service Mode after 
changing  the monitor settings.
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2.3 Confirming the Safety Advice
After wake-up of the Drive Recorder ,the Safety Advice window is displayed on 
the USB monitor.

To confirm the Safety Advice

 1. To select your preferred language, tap the flag button at the bot-
tom left.

 2. Scroll to read the complete Safety Advice.

 3. Tap I Agree.

The Recorder Status window is displayed.
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2.4  Getting to Know the Different Views
After confirming the Safety Advice, the Recorder Status window is displayed.

To display the main functions

 1. Tap  .

The Main Menu is displayed.

 2. To access a specific function, tap the respective square.

A new window for the respective function opens.

The Main Menu contains the following information:

 l Recorder Status

Displays information on the recording job and its progress. From this 
view, you can start and stop recordings. This is the preferable view dur-
ing driving.

 l System Information

Displays information about the operational state, the status of the exper-
iment, CPU load, and available RAM. 

To get information on Storage Capacity and Power Management, tap 
the corresponding button.

The Storage Capacity window displays all available hard disks and 
USB drives.

The Power Management window displays the settings as predifined 
by the Drive Recorder Configurator.

 l Log Details

Displays the information from the log files. You can use this information 
in case of an error.

 l Diagnostics

Displays diagnostic information. You can use this information in case of 
an error.
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 l App Settings

Allows changing the Recorder Status view between Basic and 
Advanced. You can also select the desired Language. See also " Setting 
the View to Basic or Advanced and Selecting the Language" below.

You can switch between the different functions without interrupting an ongo-
ing recording job.

2.5  Setting the View to Basic or Advanced and Selecting 
the Language
After confirming the Safety Advice, the Drive Recorder Display App displays the 
Recorder Status window.

To change the view between Basic and Advancedand to select the language

 1. Tap  .

The Main Menu window is displayed.

 2. Tap Settings.

The Settings window is displayed.

 3. To enable or disable the Advanced Mode, tap the respective 
checkbox.

 4. To select the language, tap the Language box and select your 
desired language from the drop-down menu.

 5. To return to the Recorder Status window, tap .

In the idle state, the USB monitor shows the following information:

Basic View
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Advanced View

Additionally to the recording job, the advanced view displays the following 
information:

 l CPU usage in [%]

 l RAM Usage in [GB]
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2.6  Starting and Stopping a Recording Job
After confirming the Safety Advice, the Drive Recorder Display App displays the 
Recorder Status window.

             WARNING  

Risk of unexpected vehicle behavior
If the Drive Recorder is operated in combination with an ETK, an ECU reset is 
possible. An ECU reset can result in engine shutdown, which can cause unex-
pected vehicle behavior.

Only modify the test setup when the vehicle is stationary.

Only start recording jobs when the vehicle is stationary.

Before driving, always wait until the Recorder Status window of the Dis-
play App shows green side bars.

In the idle state, you can select a recording job and start the selected recording 
job.

To select a recording job

 1. Tap Change Recording Job.

A list of the available recoding jobs is displayed.

 2. Tap the desired recording job.

The Recorder Status window displays the selected recording job.

To start the recording job

 1. To start the recording job that is displayed on the Recorder 
Status window, tap Start Recording.

The side bars of the Recorder Status window turn yellow.
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Depending on the progress, the status changes from preparing to 
loadingto initializing.

 2. When the side bars of the Recorder Status window turn green, 
the recording has started.

Now you can start driving.

Additionally to the name of the recording job, information on the 
estimated recording time and the remaining disk space is dis-
played.

To stop the recording job

 l In the Recorder Status window, tap Stop Recording.

The recording stops. The measurement data is automatically 
transferred to the pre-defined location.

See " Transferring Data" on the next page.
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2.7  Transferring Data
When the recorder job is finished and automatic data transfer is preconfigured 
by the Drive Recorder Configurator, the measurement data is automatically 
transferred according to the file transfer settings. The data transfer is indic-
ated by the following window:

When the data transfer is finished, the Recorder Status window displays the 
idle view.

You can now start a new recording job. To do this, start again from "To start 
the recording job" on page 17.
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2.8  Handling Errors
If an error occurs during recording, the Recorder Status window displays an 
error message.

To solve the error

Do one of the following:

 l Contact your local support or your supervisor.

From them, you get further advice.

or

 l Tap Show Details.

More information on the cause of the error is displayed.

 i. Solve the error by eliminating the cause.

 ii. Tap .

The Recoder Status window returns to the green state. 

Recording continues.

 iii. For more information, tap . Then, tap Log Details or Dia-
gnostics. 

You can look for Log Details, Diagnostics, and System Inform-
ation without interrupting the recording.

 iv. Tap .

The Recorder Status window displays green side bars and the 
status of the ongoing recording job.
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3 Supported Applications

Drive Recorder Remote Control Solution

From a remote site, the responsible engineer can make a request for remote 
calibration by using the Drive Recorder Remote Control Solution. In the vehicle 
at the driver's end, the Drive Recorder Remote Control Solution user interface 
is then displayed on the USB monitor instead of the Display App. The driver 
can respond to the request of the engineer. After the task of the Remote Con-
trol Solution is finished, the Display App is displayed again.

For more details and safety information, read the Drive Recorder 
Remote Control Solution - User Guide and use the "Contact Inform-
ation" on page 24 to ask ETAS for support.
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4 Limitations

It is not possible to use the recording functionality of the Drive Recorder while 
an INCA instance is open on any PC connected to the Drive Recorder.

If this case occurs, an error message is displayed on the USB monitor.

         Note  

As opposed to the limitations above, using the Drive Recorder Configurator 
and the Display App at the same time is supported.
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5 Contact Information

ETAS Headquarters
ETAS GmbH

Borsigstraße 24 Phone: +49 711 3423-0

70469 Stuttgart Fax: +49 711 3423-2106

Germany Internet: www.etas.com

ETAS Subsidiaries and Technical Support
For details of your local sales office as well as your local technical support 
team and product hotlines, take a look at the ETAS website:

ETAS subsidiaries Internet: www.etas.com/en/contact.php

ETAS technical support Internet: www.etas.com/en/hotlines.php

https://www.etas.com/
https://www.etas.com/en/contact.php
https://www.etas.com/en/hotlines.php
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